source: projects/specs/trunk/x/xorg-x11-apps/xorg-x11-apps-vl.spec @ 2642

Revision 2642, 10.3 KB checked in by Takemikaduchi, 13 years ago (diff)

new upstream release

Line 
1%define pkgname apps
2
3Summary: X.Org X11 applications
4Summary(ja): X.Org X11 アプリケーション
5Name: xorg-x11-%{pkgname}
6# NOTE: The package version should be set to the X11 major release from which
7# the OS release is based upon.
8Version: 7.6
9Release: 2%{?_dist_release}
10License: MIT/X11
11Group: User Interface/X
12URL: http://www.x.org
13
14# Clock apps
15Source0:  ftp://ftp.x.org/pub/individual/app/oclock-1.0.2.tar.bz2
16Source1:  ftp://ftp.x.org/pub/individual/app/xclock-1.0.5.tar.bz2
17# X Window Dump (xwd) utilities
18Source2:  ftp://ftp.x.org/pub/individual/app/xwd-1.0.4.tar.bz2
19Source3:  ftp://ftp.x.org/pub/individual/app/xwud-1.0.3.tar.bz2
20Source4:  ftp://ftp.x.org/pub/individual/app/xpr-1.0.3.tar.bz2
21# Miscellaneous other applications
22Source5:  ftp://ftp.x.org/pub/individual/app/luit-1.1.0.tar.bz2
23Source6:  ftp://ftp.x.org/pub/individual/app/x11perf-1.5.3.tar.bz2
24Source7:  ftp://ftp.x.org/pub/individual/app/xbiff-1.0.3.tar.bz2
25Source8:  ftp://ftp.x.org/pub/individual/app/xclipboard-1.1.1.tar.bz2
26Source9:  ftp://ftp.x.org/pub/individual/app/xconsole-1.0.4.tar.bz2
27Source10: ftp://ftp.x.org/pub/individual/app/xcursorgen-1.0.4.tar.bz2
28Source11: ftp://ftp.x.org/pub/individual/app/xeyes-1.1.1.tar.bz2
29Source12: ftp://ftp.x.org/pub/individual/app/xkill-1.0.3.tar.bz2
30Source13: ftp://ftp.x.org/pub/individual/app/xload-1.1.0.tar.bz2
31Source14: ftp://ftp.x.org/pub/individual/app/xlogo-1.0.3.tar.bz2
32Source15: ftp://ftp.x.org/pub/individual/app/xmag-1.0.4.tar.bz2
33Source16: ftp://ftp.x.org/pub/individual/app/xmessage-1.0.3.tar.bz2
34Source17: ftp://ftp.x.org/pub/individual/app/xinput-1.5.3.tar.bz2
35Source18: ftp://ftp.x.org/pub/individual/app/xcalc-1.0.4.tar.bz2
36
37Patch2: xconsole-1.0.3-streams-me-softer.patch
38
39BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
40BuildRequires: autoconf, automake
41BuildRequires: pkgconfig
42BuildRequires: xorg-x11-util-macros
43BuildRequires: xorg-x11-xbitmaps
44BuildRequires: zlib-devel
45BuildRequires: libfontenc-devel
46BuildRequires: libX11-devel
47BuildRequires: libXmu-devel
48BuildRequires: libXext-devel
49BuildRequires: libXt-devel
50BuildRequires: libXaw-devel
51BuildRequires: libXpm-devel
52BuildRequires: libXft-devel
53BuildRequires: libXrender-devel
54BuildRequires: libxkbfile-devel
55BuildRequires: libXcursor-devel
56BuildRequires: libpng-devel
57BuildRequires: libXfixes-devel
58BuildRequires: libXi-devel
59
60Requires(pre): xorg-x11-filesystem
61
62Provides: luit oclock x11perf xbiff xclipboard xclock xconsole xcursorgen
63Provides: xeyes xkill xload xlogo xmag xmessage xpr xwd xwud xinput xcalc
64
65# NOTE: xwd, xwud, luit used to be in these.
66Obsoletes: XFree86, XOrg
67# NOTE: x11perf, xclipboard used to be in these.
68Obsoletes: XFree86-tools, XOrg-tools
69
70
71%description
72A collection of common X Window System applications.
73
74%prep
75%setup -q -c %{name}-%{version} -a1 -a2 -a3 -a4 -a5 -a6 -a7 -a8 -a9 -a10 -a11 -a12 -a13 -a14 -a15 -a16 -a17 -a18
76## %patch2 -p0 -b .streams-me-softer
77
78%build
79# Build all apps
80{
81   for app in * ; do
82      pushd $app
83
84      case $app in
85         x11perf*)
86            aclocal ; automake ; autoconf
87         ;;
88         luit*)
89            autoconf
90         ;;
91      esac
92
93      %configure --disable-xprint
94      make
95      popd
96   done
97}
98
99%install
100rm -rf $RPM_BUILD_ROOT
101# Install all apps
102{
103   for app in * ; do
104      pushd $app
105      make install DESTDIR=$RPM_BUILD_ROOT
106      popd
107   done
108}
109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113%files
114%defattr(-,root,root,-)
115#%doc
116%{_bindir}/luit
117%{_bindir}/oclock
118%{_bindir}/x11perf
119%{_bindir}/x11perfcomp
120%{_bindir}/xbiff
121%{_bindir}/xcalc
122%{_bindir}/xclipboard
123%{_bindir}/xclock
124%{_bindir}/xconsole
125%{_bindir}/xcursorgen
126%{_bindir}/xcutsel
127%{_bindir}/xdpr
128%{_bindir}/xeyes
129%{_bindir}/xinput
130%{_bindir}/xkill
131%{_bindir}/xload
132%{_bindir}/xlogo
133%{_bindir}/xmag
134%{_bindir}/xmessage
135%{_bindir}/xpr
136%{_bindir}/xwd
137%{_bindir}/xwud
138%dir %{_datadir}/X11
139%{_datadir}/X11/app-defaults/Clock-color
140%{_datadir}/X11/app-defaults/XCalc
141%{_datadir}/X11/app-defaults/XCalc-color
142%{_datadir}/X11/app-defaults/XClipboard
143%{_datadir}/X11/app-defaults/XClock
144%{_datadir}/X11/app-defaults/XClock-color
145%{_datadir}/X11/app-defaults/XConsole
146%{_datadir}/X11/app-defaults/XLoad
147%{_datadir}/X11/app-defaults/XLogo
148%{_datadir}/X11/app-defaults/XLogo-color
149%{_datadir}/X11/app-defaults/Xmag
150%{_datadir}/X11/app-defaults/Xmessage
151%{_datadir}/X11/app-defaults/Xmessage-color
152%dir %{_libdir}/X11/x11perfcomp
153%{_libdir}/X11/x11perfcomp/Xmark
154%{_libdir}/X11/x11perfcomp/fillblnk
155%{_libdir}/X11/x11perfcomp/perfboth
156%{_libdir}/X11/x11perfcomp/perfratio
157#%dir %{_mandir}/man1x
158%{_mandir}/man1/xcursorgen.1*
159%{_mandir}/man1/Xmark.1*
160%{_mandir}/man1/luit.1*
161%{_mandir}/man1/oclock.1*
162%{_mandir}/man1/x11perf.1*
163%{_mandir}/man1/x11perfcomp.1*
164%{_mandir}/man1/xbiff.1*
165%{_mandir}/man1/xcalc.1*
166%{_mandir}/man1/xclipboard.1*
167%{_mandir}/man1/xclock.1*
168%{_mandir}/man1/xconsole.1*
169%{_mandir}/man1/xcutsel.1*
170%{_mandir}/man1/xdpr.1*
171%{_mandir}/man1/xeyes.1*
172%{_mandir}/man1/xinput.1*
173%{_mandir}/man1/xkill.1*
174%{_mandir}/man1/xload.1*
175%{_mandir}/man1/xlogo.1*
176%{_mandir}/man1/xmag.1*
177%{_mandir}/man1/xmessage.1*
178%{_mandir}/man1/xpr.1*
179%{_mandir}/man1/xwd.1*
180%{_mandir}/man1/xwud.1*
181
182%changelog
183* Sat Feb 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-2
184- xbiff-1.0.3
185
186* Sat Jan 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-1
187- x11perf-1.5.3
188
189* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-4
190- xwd-1.0.4
191- wud-1.0.3
192- xclipboard-1.1.1
193- xcursorgen-1.0.4
194- xeyes-1.1.1
195- xkill-1.0.3
196- xinput-1.5.3
197- xcalc-1.0.4
198
199* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-3
200- oclock-1.0.2
201- xlock-1.0.5
202- xconsole-1.0.4
203- luit-1.1.0
204- x11perf-1.5.2
205- xbiff-1.0.2
206- xlogo-1.0.3
207- xload-1.1.0
208- xmag-1.0.4
209- xinput-1.5.2
210- drop Patch2
211- add BuildRequires: libXi-devel
212
213* Fri Mar 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.5-2
214- luit-1.0.5
215- xeyes-1.1.0
216- xlogo-1.0.2
217- xmessage-1.0.3
218- xinput-1.5.1
219- added xcalc-1.0.3 <wishes:161>
220
221* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.5-1
222- xclock-1.0.4
223- xwd-1.0.3
224- xwud-1.0.2
225- xpr-1.0.3
226- luit-1.0.4
227- x11perf-1.5.1
228- xclipboard-1.1.0
229- xcursorgen-1.0.3
230- xeyes-1.0.991
231- xkill-1.0.2
232- xmag-1.0.3
233- xinput-1.5.0
234
235* Wed May 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-3
236- xinput-1.4.2
237
238* Mon Apr 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-2
239- xinput-1.4.1
240
241* Mon Nov 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-1
242- bump to 7.4 version
243- add xinput-1.3.0
244
245* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-2
246- xwd 1.0.2
247- luit 1.0.3
248- x11perf 1.5
249
250* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-1
251- new versioning policy
252
253* Thu Jan 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-0vl1
254- initial build for Vine Linux
255
256* Mon Sep 24 2007 Adam Jackson <ajax@redhat.com> 7.3-1
257- xconsole 1.0.3
258- xmessage 1.0.2
259- Bump to 7.3-1
260
261* Tue Aug 21 2007 Dave Airlie <airlied@redhat.com> 7.2-1
262- luit-1.0.2 xclock 1.0.3 xmag 1.0.2 xpr 1.0.2 xload 1.0.2 xcursorgen 1.0.2
263- bump to 7.2 version
264
265* Tue Jan 30 2007 Adam Jackson <ajax@redhat.com> 7.1-4
266- Fix man page globs and rebuild for FC7.
267
268* Mon Oct 2 2006 Soren Sandmann <sandmann@redhat.com> 7.1-3.fc6
269- Fix race condition in luit (Bug 197165).
270
271* Wed Jul 19 2006 Mike A. Harris <mharris@redhat.com> 7.1-2.fc6
272- Remove app-defaults dir from file manifest, as it is owned by libXt (#174021)
273- Add 'dist' tag to package release string.
274
275* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 7.1-1.1
276- rebuild
277
278* Tue Jun 20 2006 Mike A. Harris <mharris@redhat.com> 7.1-1
279- Added xload-1.0.1-setuid.diff to fix potential security issue (#196094)
280- Artificially inflate package version-release to 7.1 to match the X11R7.1
281  release that all of the tarballs are taken from.
282- Update to xconsole-1.0.2, xcursorgen-1.0.1 from X11R7.1
283- Add temporary dependency on autoconf, automake for brew builds.
284
285* Fri May 26 2006 Adam Jackson <ajackson@redhat.com> 1.0.3-2
286- Add more BuildRequires to fix mock builds.  (#191896)
287
288* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.3-1
289- Updated xclock and xconsole
290
291* Thu Mar 02 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-1
292- Bump x11perf to 1.4.1 from upstream.
293
294* Fri Feb 24 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-2
295- Added luit-1.0.1-locale.alias-datadir.patch to fix bug (#181785)
296
297* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
298- bump again for double-long bug on ppc(64)
299
300* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
301- rebuilt for new gcc4.1 snapshot and glibc changes
302
303* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
304- Upgraded all apps to version 1.0.1 from X11R7.0
305
306* Sat Dec 17 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
307- Upgraded all apps to version 1.0.0 from X11R7 RC4.
308- Changed manpage dir from man1x to man1 to match upstream default now.
309- Dropped all of the datadir-cleanups patches added in the previous build.
310- Added x11perf-1.0.0-x11perf-datadir-cleanups.patch as it is still needed
311  to put the helper scripts in datadir.
312- Added --disable-xprint to configure, as a great symbolic jesture.
313
314* Wed Nov 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-4
315- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3" to workaround
316  (#173384)
317- Added the following patches, and invoke aclocal/automake/autoconf on them
318  to force app-defaults and other datafiles into _datadir instead of _libdir:
319  - oclock-0.99.1-oclock-datadir-cleanups.patch
320  - x11perf-0.99.1-x11perf-datadir-cleanups.patch
321  - xclipboard-0.99.1-xclipboard-datadir-cleanups.patch
322  - xclock-0.99.1-xclock-datadir-cleanups.patch
323  - xconsole-0.99.2-xconsole-datadir-cleanups.patch
324  - xload-0.99.1-xload-datadir-cleanups.patch
325  - xlogo-0.99.1-xlogo-datadir-cleanups.patch
326  - xmag-0.99.1-xmag-datadir-cleanups.patch
327  - xmessage-0.99.1-xmessage-datadir-cleanups.patch
328- Added luit-0.99.1-luit-locale-dir-fix.patch to fix bug (#173702)
329
330* Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 0.99.2-3
331- add Requires(pre) on newer filesystem package (#172610)
332
333* Sun Nov 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-2
334- Add "Obsoletes: XFree86, XFree86-tools, xorg-x11, xorg-x11-tools", as
335  various utils have moved here from there in monolithic X packaging.
336- Add "BuildRequires: xbitmaps-devel" for xbiff.
337- Rebuild against new libXaw 0.99.2-2, which has fixed DT_SONAME. (#173027)
338
339* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
340- Initial build, with all apps taken from X11R7 RC2.
341- Use "make install DESTDIR=$RPM_BUILD_ROOT" as the makeinstall macro fails on
342  some packages.
343- Temporary hack to move xcursorgen manpage to 'man1' dir.
Note: See TracBrowser for help on using the repository browser.