source: projects/specs/trunk/x/xorg-x11-apps/xorg-x11-apps-vl.spec @ 6011

Revision 6011, 10.8 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1%define pkgname apps
2
3Summary: X.Org X11 applications
4Summary(ja): X.Org X11 アプリケーション
5Name: xorg-x11-%{pkgname}
6# NOTE: The package version should be set to the X11 major release from which
7# the OS release is based upon.
8Version: 7.6
9Release: 7%{?_dist_release}
10License: MIT/X11
11Group: User Interface/X
12URL: http://www.x.org
13
14# Clock apps
15Source0:  ftp://ftp.x.org/pub/individual/app/oclock-1.0.3.tar.bz2
16Source1:  ftp://ftp.x.org/pub/individual/app/xclock-1.0.6.tar.bz2
17# X Window Dump (xwd) utilities
18Source2:  ftp://ftp.x.org/pub/individual/app/xwd-1.0.5.tar.bz2
19Source3:  ftp://ftp.x.org/pub/individual/app/xwud-1.0.3.tar.bz2
20Source4:  ftp://ftp.x.org/pub/individual/app/xpr-1.0.3.tar.bz2
21# Miscellaneous other applications
22Source5:  ftp://ftp.x.org/pub/individual/app/luit-1.1.1.tar.bz2
23Source6:  ftp://ftp.x.org/pub/individual/app/x11perf-1.5.4.tar.bz2
24Source7:  ftp://ftp.x.org/pub/individual/app/xbiff-1.0.3.tar.bz2
25Source8:  ftp://ftp.x.org/pub/individual/app/xclipboard-1.1.2.tar.bz2
26Source9:  ftp://ftp.x.org/pub/individual/app/xconsole-1.0.4.tar.bz2
27Source10: ftp://ftp.x.org/pub/individual/app/xcursorgen-1.0.5.tar.bz2
28Source11: ftp://ftp.x.org/pub/individual/app/xeyes-1.1.1.tar.bz2
29Source12: ftp://ftp.x.org/pub/individual/app/xkill-1.0.3.tar.bz2
30Source13: ftp://ftp.x.org/pub/individual/app/xload-1.1.1.tar.bz2
31Source14: ftp://ftp.x.org/pub/individual/app/xlogo-1.0.4.tar.bz2
32Source15: ftp://ftp.x.org/pub/individual/app/xmag-1.0.4.tar.bz2
33Source16: ftp://ftp.x.org/pub/individual/app/xmessage-1.0.3.tar.bz2
34Source17: ftp://ftp.x.org/pub/individual/app/xinput-1.5.4.tar.bz2
35Source18: ftp://ftp.x.org/pub/individual/app/xcalc-1.0.4.1.tar.bz2
36
37Patch2: xconsole-1.0.3-streams-me-softer.patch
38
39BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
40BuildRequires: autoconf, automake
41BuildRequires: pkgconfig
42BuildRequires: xorg-x11-util-macros
43BuildRequires: xorg-x11-xbitmaps
44BuildRequires: zlib-devel
45BuildRequires: libfontenc-devel
46BuildRequires: libX11-devel
47BuildRequires: libXmu-devel
48BuildRequires: libXext-devel
49BuildRequires: libXt-devel
50BuildRequires: libXaw-devel
51BuildRequires: libXpm-devel
52BuildRequires: libXft-devel
53BuildRequires: libXrender-devel
54BuildRequires: libxkbfile-devel
55BuildRequires: libXcursor-devel
56BuildRequires: libpng-devel
57BuildRequires: libXfixes-devel
58BuildRequires: libXi-devel
59
60Requires(pre): xorg-x11-filesystem
61
62Provides: luit oclock x11perf xbiff xclipboard xclock xconsole xcursorgen
63Provides: xeyes xkill xload xlogo xmag xmessage xpr xwd xwud xinput xcalc
64
65# NOTE: xwd, xwud, luit used to be in these.
66Obsoletes: XFree86, XOrg
67# NOTE: x11perf, xclipboard used to be in these.
68Obsoletes: XFree86-tools, XOrg-tools
69
70Vendor: Project Vine
71Distribution: Vine Linux
72
73%description
74A collection of common X Window System applications.
75
76%prep
77%setup -q -c %{name}-%{version} -a1 -a2 -a3 -a4 -a5 -a6 -a7 -a8 -a9 -a10 -a11 -a12 -a13 -a14 -a15 -a16 -a17 -a18
78## %patch2 -p0 -b .streams-me-softer
79
80%build
81# Build all apps
82{
83   for app in * ; do
84      pushd $app
85
86      case $app in
87         x11perf*)
88            aclocal ; automake ; autoconf
89         ;;
90         luit*)
91            autoconf
92         ;;
93      esac
94
95      %configure --disable-xprint
96      make
97      popd
98   done
99}
100
101%install
102rm -rf $RPM_BUILD_ROOT
103# Install all apps
104{
105   for app in * ; do
106      pushd $app
107      make install DESTDIR=$RPM_BUILD_ROOT
108      popd
109   done
110}
111
112%clean
113rm -rf $RPM_BUILD_ROOT
114
115%files
116%defattr(-,root,root,-)
117#%doc
118%{_bindir}/luit
119%{_bindir}/oclock
120%{_bindir}/x11perf
121%{_bindir}/x11perfcomp
122%{_bindir}/xbiff
123%{_bindir}/xcalc
124%{_bindir}/xclipboard
125%{_bindir}/xclock
126%{_bindir}/xconsole
127%{_bindir}/xcursorgen
128%{_bindir}/xcutsel
129%{_bindir}/xdpr
130%{_bindir}/xeyes
131%{_bindir}/xinput
132%{_bindir}/xkill
133%{_bindir}/xload
134%{_bindir}/xlogo
135%{_bindir}/xmag
136%{_bindir}/xmessage
137%{_bindir}/xpr
138%{_bindir}/xwd
139%{_bindir}/xwud
140%dir %{_datadir}/X11
141%{_datadir}/X11/app-defaults/Clock-color
142%{_datadir}/X11/app-defaults/XCalc
143%{_datadir}/X11/app-defaults/XCalc-color
144%{_datadir}/X11/app-defaults/XClipboard
145%{_datadir}/X11/app-defaults/XClock
146%{_datadir}/X11/app-defaults/XClock-color
147%{_datadir}/X11/app-defaults/XConsole
148%{_datadir}/X11/app-defaults/XLoad
149%{_datadir}/X11/app-defaults/XLogo
150%{_datadir}/X11/app-defaults/XLogo-color
151%{_datadir}/X11/app-defaults/Xmag
152%{_datadir}/X11/app-defaults/Xmessage
153%{_datadir}/X11/app-defaults/Xmessage-color
154%dir %{_libdir}/X11/x11perfcomp
155%{_libdir}/X11/x11perfcomp/Xmark
156%{_libdir}/X11/x11perfcomp/fillblnk
157%{_libdir}/X11/x11perfcomp/perfboth
158%{_libdir}/X11/x11perfcomp/perfratio
159#%dir %{_mandir}/man1x
160%{_mandir}/man1/xcursorgen.1*
161%{_mandir}/man1/Xmark.1*
162%{_mandir}/man1/luit.1*
163%{_mandir}/man1/oclock.1*
164%{_mandir}/man1/x11perf.1*
165%{_mandir}/man1/x11perfcomp.1*
166%{_mandir}/man1/xbiff.1*
167%{_mandir}/man1/xcalc.1*
168%{_mandir}/man1/xclipboard.1*
169%{_mandir}/man1/xclock.1*
170%{_mandir}/man1/xconsole.1*
171%{_mandir}/man1/xcutsel.1*
172%{_mandir}/man1/xdpr.1*
173%{_mandir}/man1/xeyes.1*
174%{_mandir}/man1/xinput.1*
175%{_mandir}/man1/xkill.1*
176%{_mandir}/man1/xload.1*
177%{_mandir}/man1/xlogo.1*
178%{_mandir}/man1/xmag.1*
179%{_mandir}/man1/xmessage.1*
180%{_mandir}/man1/xpr.1*
181%{_mandir}/man1/xwd.1*
182%{_mandir}/man1/xwud.1*
183
184%changelog
185* Sat Mar 24 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-7
186- luit-1.1.1
187- xcursorgen-1.0.5
188- xload-1.1.1
189- xlogo-1.0.4
190
191* Sat Mar 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-6
192- oclock-1.0.3
193- xclipboard-1.1.2
194- xclock-1.0.6
195- xwd-1.0.5
196
197* Sun Jan 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-5
198- xinput-1.5.4
199
200* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-4
201- x11perf-1.5.4
202
203* Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-3
204- xcalc-1.0.4.1
205
206* Sat Feb 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-2
207- xbiff-1.0.3
208
209* Sat Jan 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-1
210- x11perf-1.5.3
211
212* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-4
213- xwd-1.0.4
214- wud-1.0.3
215- xclipboard-1.1.1
216- xcursorgen-1.0.4
217- xeyes-1.1.1
218- xkill-1.0.3
219- xinput-1.5.3
220- xcalc-1.0.4
221
222* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-3
223- oclock-1.0.2
224- xlock-1.0.5
225- xconsole-1.0.4
226- luit-1.1.0
227- x11perf-1.5.2
228- xbiff-1.0.2
229- xlogo-1.0.3
230- xload-1.1.0
231- xmag-1.0.4
232- xinput-1.5.2
233- drop Patch2
234- add BuildRequires: libXi-devel
235
236* Fri Mar 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.5-2
237- luit-1.0.5
238- xeyes-1.1.0
239- xlogo-1.0.2
240- xmessage-1.0.3
241- xinput-1.5.1
242- added xcalc-1.0.3 <wishes:161>
243
244* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.5-1
245- xclock-1.0.4
246- xwd-1.0.3
247- xwud-1.0.2
248- xpr-1.0.3
249- luit-1.0.4
250- x11perf-1.5.1
251- xclipboard-1.1.0
252- xcursorgen-1.0.3
253- xeyes-1.0.991
254- xkill-1.0.2
255- xmag-1.0.3
256- xinput-1.5.0
257
258* Wed May 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-3
259- xinput-1.4.2
260
261* Mon Apr 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-2
262- xinput-1.4.1
263
264* Mon Nov 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-1
265- bump to 7.4 version
266- add xinput-1.3.0
267
268* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-2
269- xwd 1.0.2
270- luit 1.0.3
271- x11perf 1.5
272
273* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-1
274- new versioning policy
275
276* Thu Jan 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-0vl1
277- initial build for Vine Linux
278
279* Mon Sep 24 2007 Adam Jackson <ajax@redhat.com> 7.3-1
280- xconsole 1.0.3
281- xmessage 1.0.2
282- Bump to 7.3-1
283
284* Tue Aug 21 2007 Dave Airlie <airlied@redhat.com> 7.2-1
285- luit-1.0.2 xclock 1.0.3 xmag 1.0.2 xpr 1.0.2 xload 1.0.2 xcursorgen 1.0.2
286- bump to 7.2 version
287
288* Tue Jan 30 2007 Adam Jackson <ajax@redhat.com> 7.1-4
289- Fix man page globs and rebuild for FC7.
290
291* Mon Oct 2 2006 Soren Sandmann <sandmann@redhat.com> 7.1-3.fc6
292- Fix race condition in luit (Bug 197165).
293
294* Wed Jul 19 2006 Mike A. Harris <mharris@redhat.com> 7.1-2.fc6
295- Remove app-defaults dir from file manifest, as it is owned by libXt (#174021)
296- Add 'dist' tag to package release string.
297
298* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 7.1-1.1
299- rebuild
300
301* Tue Jun 20 2006 Mike A. Harris <mharris@redhat.com> 7.1-1
302- Added xload-1.0.1-setuid.diff to fix potential security issue (#196094)
303- Artificially inflate package version-release to 7.1 to match the X11R7.1
304  release that all of the tarballs are taken from.
305- Update to xconsole-1.0.2, xcursorgen-1.0.1 from X11R7.1
306- Add temporary dependency on autoconf, automake for brew builds.
307
308* Fri May 26 2006 Adam Jackson <ajackson@redhat.com> 1.0.3-2
309- Add more BuildRequires to fix mock builds.  (#191896)
310
311* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.3-1
312- Updated xclock and xconsole
313
314* Thu Mar 02 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-1
315- Bump x11perf to 1.4.1 from upstream.
316
317* Fri Feb 24 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-2
318- Added luit-1.0.1-locale.alias-datadir.patch to fix bug (#181785)
319
320* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
321- bump again for double-long bug on ppc(64)
322
323* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
324- rebuilt for new gcc4.1 snapshot and glibc changes
325
326* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
327- Upgraded all apps to version 1.0.1 from X11R7.0
328
329* Sat Dec 17 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
330- Upgraded all apps to version 1.0.0 from X11R7 RC4.
331- Changed manpage dir from man1x to man1 to match upstream default now.
332- Dropped all of the datadir-cleanups patches added in the previous build.
333- Added x11perf-1.0.0-x11perf-datadir-cleanups.patch as it is still needed
334  to put the helper scripts in datadir.
335- Added --disable-xprint to configure, as a great symbolic jesture.
336
337* Wed Nov 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-4
338- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3" to workaround
339  (#173384)
340- Added the following patches, and invoke aclocal/automake/autoconf on them
341  to force app-defaults and other datafiles into _datadir instead of _libdir:
342  - oclock-0.99.1-oclock-datadir-cleanups.patch
343  - x11perf-0.99.1-x11perf-datadir-cleanups.patch
344  - xclipboard-0.99.1-xclipboard-datadir-cleanups.patch
345  - xclock-0.99.1-xclock-datadir-cleanups.patch
346  - xconsole-0.99.2-xconsole-datadir-cleanups.patch
347  - xload-0.99.1-xload-datadir-cleanups.patch
348  - xlogo-0.99.1-xlogo-datadir-cleanups.patch
349  - xmag-0.99.1-xmag-datadir-cleanups.patch
350  - xmessage-0.99.1-xmessage-datadir-cleanups.patch
351- Added luit-0.99.1-luit-locale-dir-fix.patch to fix bug (#173702)
352
353* Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 0.99.2-3
354- add Requires(pre) on newer filesystem package (#172610)
355
356* Sun Nov 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-2
357- Add "Obsoletes: XFree86, XFree86-tools, xorg-x11, xorg-x11-tools", as
358  various utils have moved here from there in monolithic X packaging.
359- Add "BuildRequires: xbitmaps-devel" for xbiff.
360- Rebuild against new libXaw 0.99.2-2, which has fixed DT_SONAME. (#173027)
361
362* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
363- Initial build, with all apps taken from X11R7 RC2.
364- Use "make install DESTDIR=$RPM_BUILD_ROOT" as the makeinstall macro fails on
365  some packages.
366- Temporary hack to move xcursorgen manpage to 'man1' dir.
Note: See TracBrowser for help on using the repository browser.