source: projects/specs/trunk/x/xnoise/xnoise-vl.spec @ 7444

Revision 7444, 6.4 KB checked in by kudoh, 11 years ago (diff)
Line 
1%define XNOISE_BIN %{_libexecdir}/%{name}
2
3Name: xnoise
4Version: 0.2.15
5Release: 1%{?_dist_release}
6Summary: Tracklist-centric Media Player
7Summary(ja): トラックリストを中心とするメディアプレーヤー
8
9Group: Applications/Multimedia
10License: GPLv2+ with exceptions
11URL: http://www.xnoise-media-player.com/
12
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14
15Source0: http://xnoise.googlecode.com/files/xnoise-%{version}.tar.bz2
16Source1: xnoise_ja.po
17Source10: xnoise.sh
18
19BuildRequires: pkgconfig
20BuildRequires: gettext
21BuildRequires: glib2-devel >= 2.30.0
22BuildRequires: gtk3-devel
23BuildRequires: gstreamer-plugins-base-devel >= 0.10.23
24BuildRequires: intltool
25BuildRequires: libxml2-devel >= 2.6.32
26#BuildRequires: libnotify-devel >= 0.7.0
27BuildRequires: libsoup-devel >= 2.26.0
28BuildRequires: perl-XML-Parser
29BuildRequires: sqlite3-devel >= 3.6
30BuildRequires: taglib-devel >= 1.6.0
31BuildRequires: unique-devel
32BuildRequires: vala-devel >= 0.16.0
33BuildRequires: desktop-file-utils gettext intltool
34Requires: hicolor-icon-theme
35# xnoise >= 0.1.14 bundles the plug-ins
36Provides: xnoise-plugins-core = %{version}-%{release}
37
38%description
39Xnoise is a Gtk+ media player with a tracklist-centric design. The
40tracklist is a list of video or music tracks that are played one by
41one without being removed (right side of window). This gives you the
42possibility to enqueue any track in any order, regardless if they are
43on the same album or not. The tracks can be reordered at any time by
44using drag and drop.
45
46
47%package devel
48Summary: Development files for %{name}
49Summary(ja): %{name} の開発ファイル
50Group: Development/Libraries
51Requires: %{name} = %{version}-%{release}
52
53%description    devel
54The %{name}-devel package contains libraries and header files for
55developing applications that use %{name}.
56
57
58%prep
59%setup -q
60%{__cp} -f %{SOURCE1} po/ja.po
61#sed -i s/hu/hu\\nja/g po/LINGUAS
62
63%build
64%configure --enable-soundmenu2=no --disable-ubuntuone
65make %{?_smp_mflags}
66
67
68%install
69rm -rf $RPM_BUILD_ROOT
70make install DESTDIR=$RPM_BUILD_ROOT
71
72find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
73
74# remove invalid locale file
75rm -rf $RPM_BUILD_ROOT%{_share}/locale/default
76
77## wrapper install
78%__mkdir_p $RPM_BUILD_ROOT%{_libexecdir}
79%__mv $RPM_BUILD_ROOT%{_bindir}/%{name} $RPM_BUILD_ROOT%{XNOISE_BIN}
80%{__install} -m 755 %{SOURCE10} $RPM_BUILD_ROOT%{_bindir}/%{name}
81
82%find_lang %{name}
83
84
85%check
86make check
87desktop-file-validate $RPM_BUILD_ROOT/%{_datadir}/applications/xnoise.desktop
88
89
90%post
91/sbin/ldconfig
92touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
93update-desktop-database &> /dev/null || :
94
95%postun
96/sbin/ldconfig
97if [ $1 -eq 0 ] ; then
98    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
99    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
100fi
101update-desktop-database &> /dev/null || :
102
103%posttrans
104gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
105
106
107%files -f %{name}.lang
108%defattr(-,root,root,-)
109%doc AUTHORS COPYING README
110%{XNOISE_BIN}
111%{_bindir}/xnoise
112# libxnoise.so *needs* to be in main package
113# otherwise plugins currently don't work
114%exclude %{_libdir}/xnoise/libxnoisetest.so
115%{_libdir}/xnoise
116%{_libdir}/libtaginfo*
117%{_libdir}/libxnoise.so*
118%{_mandir}/man1/xnoise.1*
119%{_datadir}/xnoise
120%{_datadir}/applications/xnoise.desktop
121%{_datadir}/icons/hicolor/*
122
123%files devel
124%defattr(-,root,root,-)
125%{_includedir}/xnoise
126%{_includedir}/taginfo/
127%{_libdir}/xnoise/libxnoise*.so*
128%{_libdir}/taginfo/include
129%{_libdir}/pkgconfig/xnoise-1.0.pc
130%{_libdir}/pkgconfig/taginfo.pc
131%{_libdir}/pkgconfig/taginfo_c.pc
132# make package own the vala API dir:
133# xnoise plugins don't have to be written in vala
134%dir %{_datadir}/vala
135%dir %{_datadir}/vala/vapi
136%{_datadir}/vala/vapi/xnoise-1.0.*
137%{_datadir}/vala/vapi/taginfo_c.*
138
139
140%changelog
141* Fri Feb 08 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.15-1
142- new upstream release
143- updated Source1
144
145* Fri Jan 11 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.14-1
146- new upstream release
147- updated Source1
148
149* Sat Nov 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.13-1
150- new upstream release
151- updated Source1
152
153* Thu Oct 04 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.12-1
154- new upstream release
155- updated Source1
156- deleted BuildRequires: libnotify-devel >= 0.7.0
157- changed BuildRequires: vala-devel >= 0.15.0 to 0.16.0
158
159* Sat Sep 22 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.11-1
160- new upstream release
161- updated Source1
162- deleted %%configure option: --disable-magnatune
163
164* Sat Sep 08 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.9-1
165- new upstream release
166- updated Source1
167
168* Sat Aug 25 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.8-1
169- new upstream release
170- updated Source1
171- added %%configure option: --disable-magnatune
172
173* Fri Aug 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.5-1
174- new upstream release
175- updated Source1
176- added %%configure option: --disable-ubuntuone
177
178* Thu Aug 02 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.4-1
179- initial build for VineSeed
180
181* Wed Oct  5 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.29-1
182- Update to 0.1.29
183
184* Wed Sep 21 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.28-1
185- Update to 0.1.28
186
187* Sat Sep 10 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.27-1
188- Update to 0.1.27
189
190* Thu Jul 28 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.26-1
191- Update to 0.1.26
192- Enable tests
193
194* Mon Apr  4 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.18-1
195- Update to 0.1.18
196
197* Sun Mar 13 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.16-1
198- Update to 0.1.16
199- Now bundles the plugins, obsoleting xnoise-plugins-core
200
201* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.12-4
202- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
203
204* Sat Nov  6 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.12-3
205- Own %%{_libdir}/xnoise for plugins
206
207* Sat Nov  6 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.12-2
208- invoke ldconfig on (un)install
209- remove %%clean section; only targeting F-14+
210- re-enable deletion of invalid locale dir
211
212* Sat Nov  6 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.12-1
213- Update to 0.1.12
214- Specify the correct location for Vala API files in *.pc
215
216* Fri Jun 25 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.6-2
217- Make xnoise-devel co-own Vala's VAPI dir
218- Remove invalid locale file
219
220* Wed Jun 23 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.6-1
221- Update to final 0.1.6 release
222
223* Sat Apr  3 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.2-0.1.331hg
224- Initial package
225
Note: See TracBrowser for help on using the repository browser.