source: projects/specs/trunk/x/xnoise/xnoise-vl.spec @ 6674

Revision 6674, 5.1 KB checked in by kudoh, 12 years ago (diff)

xnoise-vl.spec

Line 
1%define XNOISE_BIN %{_libexecdir}/%{name}
2
3Name: xnoise
4Version: 0.2.4
5Release: 1%{?_dist_release}
6Summary: Tracklist-centric Media Player
7Summary(ja): トラックリストを中心とするメディアプレーヤー
8
9Group: Applications/Multimedia
10License: GPLv2+ with exceptions
11URL: http://www.xnoise-media-player.com/
12
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14
15Source0: http://xnoise.googlecode.com/files/xnoise-%{version}.tar.bz2
16Source1: xnoise_ja.po
17Source10: xnoise.sh
18
19BuildRequires: pkgconfig
20BuildRequires: gettext
21BuildRequires: glib2-devel >= 2.30.0
22BuildRequires: gtk3-devel
23BuildRequires: gstreamer-plugins-base-devel >= 0.10.23
24BuildRequires: intltool
25BuildRequires: libxml2-devel >= 2.6.32
26BuildRequires: libnotify-devel >= 0.7.0
27BuildRequires: libsoup-devel >= 2.26.0
28BuildRequires: perl-XML-Parser
29BuildRequires: sqlite3-devel >= 3.6
30BuildRequires: taglib-devel >= 1.6.0
31BuildRequires: unique-devel
32BuildRequires: vala-devel >= 0.15.0
33BuildRequires: desktop-file-utils gettext intltool
34Requires: hicolor-icon-theme
35# xnoise >= 0.1.14 bundles the plug-ins
36Provides: xnoise-plugins-core = %{version}-%{release}
37
38%description
39Xnoise is a Gtk+ media player with a tracklist-centric design. The
40tracklist is a list of video or music tracks that are played one by
41one without being removed (right side of window). This gives you the
42possibility to enqueue any track in any order, regardless if they are
43on the same album or not. The tracks can be reordered at any time by
44using drag and drop.
45
46
47%package devel
48Summary: Development files for %{name}
49Summary(ja): %{name} の開発ファイル
50Group: Development/Libraries
51Requires: %{name} = %{version}-%{release}
52
53%description    devel
54The %{name}-devel package contains libraries and header files for
55developing applications that use %{name}.
56
57
58%prep
59%setup -q
60%{__cp} -f %{SOURCE1} po/ja.po
61sed -i s/hu/hu\\nja/g po/LINGUAS
62
63%build
64%configure --enable-soundmenu2=no
65make %{?_smp_mflags}
66
67
68%install
69rm -rf $RPM_BUILD_ROOT
70make install DESTDIR=$RPM_BUILD_ROOT
71
72find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
73
74# remove invalid locale file
75rm -rf $RPM_BUILD_ROOT%{_share}/locale/default
76
77## wrapper install
78%__mkdir_p $RPM_BUILD_ROOT%{_libexecdir}
79%__mv $RPM_BUILD_ROOT%{_bindir}/%{name} $RPM_BUILD_ROOT%{XNOISE_BIN}
80%{__install} -m 755 %{SOURCE10} $RPM_BUILD_ROOT%{_bindir}/%{name}
81
82%find_lang %{name}
83
84
85%check
86make check
87desktop-file-validate $RPM_BUILD_ROOT/%{_datadir}/applications/xnoise.desktop
88
89
90%post
91/sbin/ldconfig
92touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
93update-desktop-database &> /dev/null || :
94
95%postun
96/sbin/ldconfig
97if [ $1 -eq 0 ] ; then
98    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
99    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
100fi
101update-desktop-database &> /dev/null || :
102
103%posttrans
104gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
105
106
107%files -f %{name}.lang
108%defattr(-,root,root,-)
109%doc AUTHORS COPYING README
110%{XNOISE_BIN}
111%{_bindir}/xnoise
112# libxnoise.so *needs* to be in main package
113# otherwise plugins currently don't work
114%exclude %{_libdir}/xnoise/libxnoisetest.so
115%{_libdir}/xnoise
116%{_mandir}/man1/xnoise.1*
117%{_datadir}/xnoise
118%{_datadir}/applications/xnoise.desktop
119%{_datadir}/icons/hicolor/*
120
121%files devel
122%defattr(-,root,root,-)
123%{_includedir}/xnoise
124%{_libdir}/xnoise/libxnoisetest.so
125%{_libdir}/pkgconfig/xnoise-1.0.pc
126# make package own the vala API dir:
127# xnoise plugins don't have to be written in vala
128%dir %{_datadir}/vala
129%dir %{_datadir}/vala/vapi
130%{_datadir}/vala/vapi/xnoise-1.0.*
131
132
133%changelog
134* Thu Aug 02 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.4-1
135- initial build for VineSeed
136
137* Wed Oct  5 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.29-1
138- Update to 0.1.29
139
140* Wed Sep 21 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.28-1
141- Update to 0.1.28
142
143* Sat Sep 10 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.27-1
144- Update to 0.1.27
145
146* Thu Jul 28 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.26-1
147- Update to 0.1.26
148- Enable tests
149
150* Mon Apr  4 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.18-1
151- Update to 0.1.18
152
153* Sun Mar 13 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.16-1
154- Update to 0.1.16
155- Now bundles the plugins, obsoleting xnoise-plugins-core
156
157* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.12-4
158- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
159
160* Sat Nov  6 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.12-3
161- Own %%{_libdir}/xnoise for plugins
162
163* Sat Nov  6 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.12-2
164- invoke ldconfig on (un)install
165- remove %%clean section; only targeting F-14+
166- re-enable deletion of invalid locale dir
167
168* Sat Nov  6 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.12-1
169- Update to 0.1.12
170- Specify the correct location for Vala API files in *.pc
171
172* Fri Jun 25 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.6-2
173- Make xnoise-devel co-own Vala's VAPI dir
174- Remove invalid locale file
175
176* Wed Jun 23 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.6-1
177- Update to final 0.1.6 release
178
179* Sat Apr  3 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.2-0.1.331hg
180- Initial package
181
Note: See TracBrowser for help on using the repository browser.