source: projects/specs/trunk/x/xnoise/xnoise-vl.spec @ 8738

Revision 8738, 7.3 KB checked in by kudoh, 10 years ago (diff)

new up stream release & rebuilt

Line 
1%define XNOISE_BIN %{_libexecdir}/%{name}
2
3Name: xnoise
4Version: 0.2.21
5Release: 1%{?_dist_release}
6Summary: Tracklist-centric Media Player
7Summary(ja): トラックリストを中心とするメディアプレーヤー
8
9Group: Applications/Multimedia
10License: GPLv2+ with exceptions
11URL: http://www.xnoise-media-player.com/
12
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14
15Source0: http://xnoise.googlecode.com/files/xnoise-%{version}.tar.gz
16Source1: xnoise_ja.po
17Source10: xnoise.sh
18
19BuildRequires: pkgconfig
20BuildRequires: gettext
21BuildRequires: glib2-devel >= 2.30.0
22BuildRequires: gtk3-devel
23BuildRequires: gstreamer1-plugins-base-devel >= 1.0.1
24BuildRequires: intltool
25BuildRequires: libxml2-devel >= 2.6.32
26BuildRequires: libsoup-devel >= 2.26.0
27BuildRequires: libtaginfo-devel >= 0.1.6
28BuildRequires: perl-XML-Parser
29BuildRequires: sqlite3-devel >= 3.6
30BuildRequires: taglib-devel >= 1.6.0
31BuildRequires: unique-devel
32BuildRequires: vala-devel >= 0.16.0
33BuildRequires: desktop-file-utils gettext intltool
34Requires: hicolor-icon-theme
35Requires: libtaginfo >= 0.1.6
36# xnoise >= 0.1.14 bundles the plug-ins
37Provides: xnoise-plugins-core = %{version}-%{release}
38
39%description
40Xnoise is a Gtk+ media player with a tracklist-centric design. The
41tracklist is a list of video or music tracks that are played one by
42one without being removed (right side of window). This gives you the
43possibility to enqueue any track in any order, regardless if they are
44on the same album or not. The tracks can be reordered at any time by
45using drag and drop.
46
47
48%package devel
49Summary: Development files for %{name}
50Summary(ja): %{name} の開発ファイル
51Group: Development/Libraries
52Requires: %{name} = %{version}-%{release}
53
54%description    devel
55The %{name}-devel package contains libraries and header files for
56developing applications that use %{name}.
57
58
59%prep
60%setup -q
61%{__cp} -f %{SOURCE1} po/ja.po
62#sed -i s/hu/hu\\nja/g po/LINGUAS
63sed -i -e '16,$d' -e '13d' data/misc/xnoise.desktop*
64
65%build
66%configure --enable-soundmenu2=no
67make %{?_smp_mflags}
68
69
70%install
71rm -rf $RPM_BUILD_ROOT
72make install DESTDIR=$RPM_BUILD_ROOT
73
74find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
75
76# remove invalid locale file
77rm -rf $RPM_BUILD_ROOT%{_share}/locale/default
78
79## wrapper install
80%__mkdir_p $RPM_BUILD_ROOT%{_libexecdir}
81%__mv $RPM_BUILD_ROOT%{_bindir}/%{name} $RPM_BUILD_ROOT%{XNOISE_BIN}
82%{__install} -m 755 %{SOURCE10} $RPM_BUILD_ROOT%{_bindir}/%{name}
83
84%find_lang %{name}
85
86
87%check
88make check
89desktop-file-validate $RPM_BUILD_ROOT/%{_datadir}/applications/xnoise.desktop
90
91
92%post
93/sbin/ldconfig
94touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
95update-desktop-database &> /dev/null || :
96
97%postun
98/sbin/ldconfig
99if [ $1 -eq 0 ] ; then
100    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
101    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
102fi
103update-desktop-database &> /dev/null || :
104
105%posttrans
106gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
107
108
109%files -f %{name}.lang
110%defattr(-,root,root,-)
111%doc AUTHORS COPYING README
112%{XNOISE_BIN}
113%{_bindir}/xnoise
114%{_bindir}/xnoise_image_extractor_service
115# libxnoise.so *needs* to be in main package
116# otherwise plugins currently don't work
117#%exclude %{_libdir}/xnoise/libxnoisetest.so
118%{_libdir}/xnoise
119%{_libdir}/libxnoise.so*
120%{_mandir}/man1/xnoise.1*
121%{_datadir}/xnoise
122%{_datadir}/applications/xnoise.desktop
123%{_datadir}//dbus-1/services/org.gtk.xnoise.ImageExtractor.service
124%{_datadir}//dbus-1/services/org.gtk.xnoise.PlayerEngine.service
125%{_datadir}/icons/hicolor/*
126%{_datadir}/icons/ubuntu-mono-*/*
127
128%files devel
129%defattr(-,root,root,-)
130%{_includedir}/xnoise
131#%{_libdir}/libxnoise*.so*
132%{_libdir}/pkgconfig/xnoise-1.0.pc
133# make package own the vala API dir:
134# xnoise plugins don't have to be written in vala
135%dir %{_datadir}/vala
136%dir %{_datadir}/vala/vapi
137%{_datadir}/vala/vapi/xnoise-1.0.*
138
139%changelog
140* Sat Jul 05 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.21-1
141- new upstream release
142
143* Sat Oct 12 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.19-1
144- new upstream release
145- updated Source1
146
147* Sun May 12 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.18-1
148- new upstream release
149- updated Source1
150- changed BuildRequires: libtaginfo-devel >= 0.1.6
151- changed Rquires: libtaginfo >= 0.1.6
152- fixed desktop error
153- deleted unrecognize option: --disable-ubuntuone
154
155* Mon Apr 29 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.17-1
156- new upstream release
157- updated Source1
158- changed BuildRequires: gstreamer-plugins-base-devel >= 0.10.23 to
159  gstreamer1-plugins-base-devel >= 1.0.1
160- added BuildRequires: libtaginfo-devel
161- added Requires: libtaginfo
162- fixed Source10
163
164* Fri Feb 08 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.15-1
165- new upstream release
166- updated Source1
167
168* Fri Jan 11 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.14-1
169- new upstream release
170- updated Source1
171
172* Sat Nov 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.13-1
173- new upstream release
174- updated Source1
175
176* Thu Oct 04 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.12-1
177- new upstream release
178- updated Source1
179- deleted BuildRequires: libnotify-devel >= 0.7.0
180- changed BuildRequires: vala-devel >= 0.15.0 to 0.16.0
181
182* Sat Sep 22 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.11-1
183- new upstream release
184- updated Source1
185- deleted %%configure option: --disable-magnatune
186
187* Sat Sep 08 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.9-1
188- new upstream release
189- updated Source1
190
191* Sat Aug 25 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.8-1
192- new upstream release
193- updated Source1
194- added %%configure option: --disable-magnatune
195
196* Fri Aug 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.5-1
197- new upstream release
198- updated Source1
199- added %%configure option: --disable-ubuntuone
200
201* Thu Aug 02 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.4-1
202- initial build for VineSeed
203
204* Wed Oct  5 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.29-1
205- Update to 0.1.29
206
207* Wed Sep 21 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.28-1
208- Update to 0.1.28
209
210* Sat Sep 10 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.27-1
211- Update to 0.1.27
212
213* Thu Jul 28 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.26-1
214- Update to 0.1.26
215- Enable tests
216
217* Mon Apr  4 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.18-1
218- Update to 0.1.18
219
220* Sun Mar 13 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.16-1
221- Update to 0.1.16
222- Now bundles the plugins, obsoleting xnoise-plugins-core
223
224* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.12-4
225- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
226
227* Sat Nov  6 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.12-3
228- Own %%{_libdir}/xnoise for plugins
229
230* Sat Nov  6 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.12-2
231- invoke ldconfig on (un)install
232- remove %%clean section; only targeting F-14+
233- re-enable deletion of invalid locale dir
234
235* Sat Nov  6 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.12-1
236- Update to 0.1.12
237- Specify the correct location for Vala API files in *.pc
238
239* Fri Jun 25 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.6-2
240- Make xnoise-devel co-own Vala's VAPI dir
241- Remove invalid locale file
242
243* Wed Jun 23 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.6-1
244- Update to final 0.1.6 release
245
246* Sat Apr  3 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.2-0.1.331hg
247- Initial package
248
Note: See TracBrowser for help on using the repository browser.