source: projects/specs/trunk/x/xmonad-utils/xmonad-utils-vl.spec @ 11992

Revision 11992, 2.5 KB checked in by ara_t, 5 years ago (diff)

xmobar/xmonad: update/build with ghc-8.6.3

Line 
1%define pkg_name    xmonad-utils
2%define pkg_version 0.1.3.3
3%define pkg_release 10%{?_dist_release}
4
5Summary:     a small collection of X utilities when running XMonad
6Summary(ja): XMonadのためのXユーティリティ集
7Name:    %{pkg_name}
8Version: %{pkg_version}
9Release: %{pkg_release}
10
11License: BSD3
12Group:   User Interface/Desktops
13URL:     http://hackage.haskell.org
14
15Source0: packages
16
17Source11: xmonad-utils-0.1.3.3.tar.gz
18Source12: xmonad-utils.cabal
19
20
21BuildRoot: %{_tmppath}/%{name}-%{version}-root
22
23BuildRequires: ghc haskell-platform
24BuildRequires: xmonad
25
26BuildRequires: libffi-devel gmp-devel zlib-devel
27BuildRequires: xorg-x11-devel
28BuildRequires: ncurses-devel
29
30Requires: haskell-platform-dep
31Requires: xmonad
32
33
34Vendor: Project Vine
35Distribution: Vine Linux
36Packager: ara_t
37
38
39%description
40A small collection of X utilities useful when running XMonad. It includes:
41- hxsel: which returns the text currently in the X selection;
42- hxput: sets the value of the X paste buffer;
43- hslock: a simple X screen lock;
44- hmanage: an utility to toggle the override-redirect property of any window;
45- hhp: a simple utility to hide the pointer, similar to unclutter.
46
47
48%prep
49%{__rm} -rf ${RPM_BUILD_ROOT}
50
51%build
52%ghc_pkg_init
53
54cd %{_builddir}
55for pkg in `cat %{SOURCE0}`; do
56    %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
57    pushd ${pkg}
58        %ghc_fix_dependencies ${pkg}
59        %cabal_configure2 %{name} ${pkg}
60        %cabal_build
61        %cabal_haddock
62        %cabal_copy_resister %{name}_${pkg}
63    popd
64done
65
66
67%clean
68%{__rm} -rf ${RPM_BUILD_ROOT}
69
70%post
71%ghc_pkg_recache
72
73%postun
74%ghc_pkg_recache
75
76
77%files
78%defattr(-, root, root)
79%{_bindir}/
80%{_docdir}/%{name}
81
82
83%changelog
84* Mon Dec 17 2018 Toshiaki Ara <ara_t@384.jp> 0.1.3.3-10
85- build using ghc-8.6.3
86
87* Wed Aug 08 2018 Toshiaki Ara <ara_t@384.jp> 0.1.3.3-9
88- build using ghc-8.4.3-2
89
90* Fri Jul 20 2018 Toshiaki Ara <ara_t@384.jp> 0.1.3.3-8
91- build using ghc-8.4.3
92
93* Fri May 18 2018 Toshiaki Ara <ara_t@384.jp> 0.1.3.3-7
94- rebuild using ghc-8.4.2
95- rewrite using macro
96
97* Tue Jan 09 2018 Toshiaki Ara <ara_t@384.jp> 0.1.3.3-6
98- rebuild using ghc-8.2.2
99
100* Thu Feb 02 2017 Toshiaki Ara <ara_t@384.jp> 0.1.3.3-5
101- rebuild using ghc-8.0.1
102
103* Wed May 04 2016 Toshiaki Ara <ara_t@384.jp> 0.1.3.3-4
104- rebuilt
105
106* Tue Apr 12 2016 Toshiaki Ara <ara_t@384.jp> 0.1.3.3-3
107- correct SPEC file
108- rebuild under xmonad-0.12-3
109
110* Sun Mar 06 2016 Toshiaki Ara <ara_t@384.jp> 0.1.3.3-2
111- rebuild under xmonad-0.12-2
112
113* Sun Feb 28 2016 Toshiaki Ara <ara_t@384.jp> 0.1.3.3-1
114- new package
Note: See TracBrowser for help on using the repository browser.