source: projects/specs/trunk/x/xmonad-extras/xmonad-extras-vl.spec @ 11995

Revision 11995, 3.5 KB checked in by ara_t, 5 years ago (diff)

xmonad-extras: update/build with ghc-8.6.3

Line 
1%define pkg_name    xmonad-extras
2%define pkg_version 0.15
3%define pkg_release 1%{?_dist_release}
4
5Summary:     Various modules for xmonad
6Summary(ja): xmonadのための様々なモジュール
7Name:    %{pkg_name}
8Version: %{pkg_version}
9Release: %{pkg_release}
10
11License: BSD3
12Group:   User Interface/Desktops
13URL:     http://hackage.haskell.org
14
15Source0: packages
16
17Source11: ghc-paths-0.1.0.9.tar.gz
18Source12: ghc-paths.cabal
19Source13: libmpd-0.9.0.9.tar.gz
20Source14: libmpd.cabal
21Source15: transformers-compat-0.6.2.tar.gz
22Source16: transformers-compat.cabal
23Source17: exceptions-0.10.0.tar.gz
24Source18: exceptions.cabal
25Source19: temporary-1.3.tar.gz
26Source20: temporary.cabal
27Source21: hint-0.9.0.tar.gz
28Source22: hint.cabal
29Source23: xmonad-extras-0.15.tar.gz
30Source24: xmonad-extras.cabal
31
32BuildRoot: %{_tmppath}/%{name}-%{version}-root
33
34BuildRequires: ghc haskell-platform
35BuildRequires: xmonad xmonad-contrib
36BuildRequires: libffi-devel gmp-devel zlib-devel
37BuildRequires: xorg-x11-devel
38# BuildRequires: alsa-lib-devel
39BuildRequires: libXScrnSaver-devel
40BuildRequires: ncurses-devel
41BuildRequires: docbook-utils docbook-utils-pdf docbook-style-xsl
42
43Requires: haskell-platform-dep
44Requires: xmonad xmonad-contrib
45Requires: libXScrnSaver-devel
46
47
48Vendor: Project Vine
49Distribution: Vine Linux
50Packager: ara_t
51
52
53%description
54Various modules for xmonad that cannot be added to xmonad-contrib
55 because of additional dependencies.
56
57%description -l ja
58サードパーティーによるxmonad拡張であり、依存パッケージの追加のために
59xmonad-contribに含まれなかったモジュールを含みます。
60
61
62%prep
63%{__rm} -rf ${RPM_BUILD_ROOT}
64
65%build
66export PATH=${RPM_BUILD_ROOT}%{_bindir}:${PATH}
67%ghc_pkg_init
68
69cd %{_builddir}
70for pkg in `cat %{SOURCE0}`; do
71    %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
72    pushd ${pkg}
73        %ghc_fix_dependencies ${pkg}
74        %cabal_configure2 %{name} ${pkg}
75        %cabal_build
76        %cabal_haddock
77        %cabal_copy_resister %{name}_${pkg}
78    popd
79done
80
81%install
82# copy documents
83pushd %{_builddir}/%{name}-%{version}
84    %{__cp} CHANGELOG.md LICENSE README.md \
85     ${RPM_BUILD_ROOT}%{_docdir}/%{name}/%{name}-%{version}
86popd
87
88
89%clean
90%{__rm} -rf ${RPM_BUILD_ROOT}
91
92%post
93%ghc_pkg_recache
94
95%postun
96%ghc_pkg_recache
97
98
99%files
100%defattr(-, root, root)
101# %{_bindir}/
102%{_libdir}/ghc-%{ghc_version}/
103%{_libdir}/ghc-lib/
104# %{_datadir}/%{name}/
105%{_docdir}/%{name}/
106
107
108%changelog
109* Mon Dec 17 2018 Toshiaki Ara <ara_t@384.jp> 0.15-1
110- update to 0.15
111- build using ghc-8.6.3
112- disabled sound support due to build error of alsa-mixer
113
114* Wed Aug 08 2018 Toshiaki Ara <ara_t@384.jp> 0.14-1
115- update to 0.14
116- add BuildRequires: libXScrnSaver-devel
117
118* Fri Jul 20 2018 Toshiaki Ara <ara_t@384.jp> 0.13.3-3
119- build using ghc-8.4.3
120
121* Fri May 18 2018 Toshiaki Ara <ara_t@384.jp> 0.13.3-1
122- update to 0.13.3
123- rebuild using ghc-8.4.2
124- rewrite using macro
125
126* Tue Jan 09 2018 Toshiaki Ara <ara_t@384.jp> 0.13.2-1
127- update to 0.13.2
128- build using ghc-8.2.2
129
130* Fri Feb 03 2017 Toshiaki Ara <ara_t@384.jp> 0.12.1-6
131- rebuild using ghc-8.0.1
132
133* Wed May 04 2016 Toshiaki Ara <ara_t@384.jp> 0.12.1-5
134- rebuilt
135
136* Tue Apr 12 2016 Toshiaki Ara <ara_t@384.jp> 0.12.1-4
137- rebuild under xmonad-0.12-3 and xmonad-contrib-0.12-4
138- correct SPEC file
139
140* Tue Mar 01 2016 Toshiaki Ara <ara_t@384.jp> 0.12.1-3
141- rebuild under xmonad-0.12-2 and xmonad-contrib-0.12-3
142
143* Sat Feb 27 2016 Toshiaki Ara <ara_t@384.jp> 0.12.1-2
144- recompile
145
146* Sat Feb 27 2016 Toshiaki Ara <ara_t@384.jp> 0.12.1-1
147- new package
Note: See TracBrowser for help on using the repository browser.