source: projects/specs/trunk/x/xmonad-contrib/xmonad-contrib-vl.spec @ 11632

Revision 11632, 2.9 KB checked in by ara_t, 6 years ago (diff)

xmonad/xmobar: rebuild with ghc-8.4.2

Line 
1%define pkg_name    xmonad-contrib
2%define pkg_version 0.13
3%define pkg_release 3%{?_dist_release}
4
5Summary:     Third party extensions for xmonad
6Summary(ja): サードパーティーによるxmonad拡張
7Name:    %{pkg_name}
8Version: %{pkg_version}
9Release: %{pkg_release}
10
11License: BSD3
12Group:   User Interface/Desktops
13URL:     http://hackage.haskell.org
14
15Source0: packages
16
17# Patch for building ghc-8.4
18Source1: xmonad-contrib-0.13_using_ghc-8.4.patch
19
20Source11: X11-xft-0.3.1.tar.gz
21Source12: X11-xft.cabal
22Source13: old-time-1.1.0.3.tar.gz
23Source14: old-time.cabal
24Source15: random-1.1.tar.gz
25Source16: random.cabal
26Source17: xmonad-contrib-0.13.tar.gz
27Source18: xmonad-contrib.cabal
28
29BuildRoot: %{_tmppath}/%{name}-%{version}-root
30
31BuildRequires: ghc haskell-platform
32BuildRequires: xmonad
33
34BuildRequires: libffi-devel gmp-devel zlib-devel
35BuildRequires: xorg-x11-devel
36BuildRequires: docbook-utils docbook-utils-pdf docbook-style-xsl
37
38Requires: haskell-platform-dep
39Requires: xmonad
40
41Vendor: Project Vine
42Distribution: Vine Linux
43Packager: ara_t
44
45
46%description
47Third party tiling algorithms, configurations and scripts to xmonad,
48 a tiling window manager for X.
49
50%description -l ja
51サードパーティーによるxmonad拡張であり、
52タイル化のためのアルゴリズム、設定およびスクリプトを含みます。
53
54
55%prep
56%{__rm} -rf ${RPM_BUILD_ROOT}
57
58%build
59%ghc_pkg_init
60
61cd %{_builddir}
62for pkg in `cat %{SOURCE0}`; do
63    %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
64    pushd ${pkg}
65        %ghc_fix_dependencies ${pkg}
66
67        case ${pkg} in
68            "%{name}-%{version}") %{__patch} -p1 < %{SOURCE1} ;;
69            *) ;;
70        esac
71
72        %cabal_configure2 %{name} ${pkg}
73        %cabal_build
74        %cabal_haddock
75        %cabal_copy_resister %{name}_${pkg}
76    popd
77done
78
79
80%install
81# copy documents
82pushd %{_builddir}/%{name}-%{version}
83    %{__cp} CHANGES.md LICENSE README.md \
84     ${RPM_BUILD_ROOT}%{_docdir}/%{name}/%{name}-%{version}
85popd
86
87
88%clean
89%{__rm} -rf ${RPM_BUILD_ROOT}
90
91%post
92%ghc_pkg_recache
93
94%postun
95%ghc_pkg_recache
96
97
98%files
99%defattr(-, root, root)
100%{_libdir}/ghc-%{ghc_version}/
101%{_libdir}/ghc-lib/
102%{_docdir}/%{name}/
103
104
105%changelog
106* Fri May 18 2018 Toshiaki Ara <ara_t@384.jp> 0.13-3
107- rebuild using ghc-8.4.2
108- add Patch for building with ghc-8.4 (Source1)
109- rewrite using macro
110
111* Thu May 10 2018 Toshiaki Ara <ara_t@384.jp> 0.13-2
112- rebuild using ghc-8.4.2
113
114* Tue Jan 09 2018 Toshiaki Ara <ara_t@384.jp> 0.13-1
115- update to 0.13
116- rebuild using ghc-8.0.2
117
118* Fri Feb 03 2017 Toshiaki Ara <ara_t@384.jp> 0.12-6
119- rebuild using ghc-8.0.1
120
121* Wed May 04 2016 Toshiaki Ara <ara_t@384.jp> 0.12-5
122- rebuilt
123
124* Tue Apr 12 2016 Toshiaki Ara <ara_t@384.jp> 0.12-4
125- rebuild under xmonad-0.12-3
126- correct SPEC file
127
128* Tue Mar 01 2016 Toshiaki Ara <ara_t@384.jp> 0.12-3
129- rebuild under xmonad-0.12-2
130
131* Sat Feb 27 2016 Toshiaki Ara <ara_t@384.jp> 0.12-2
132- recompile
133
134* Sat Feb 27 2016 Toshiaki Ara <ara_t@384.jp> 0.12-1
135- new package
Note: See TracBrowser for help on using the repository browser.