source: projects/specs/trunk/x/xmobar/xmobar-vl.spec @ 11992

Revision 11992, 4.0 KB checked in by ara_t, 5 years ago (diff)

xmobar/xmonad: update/build with ghc-8.6.3

Line 
1%define pkg_name    xmobar
2%define pkg_version 0.29.3
3%define pkg_release 1%{?_dist_release}
4
5Summary:     a minimalistic text based status bar
6Summary(ja): テキストを基礎とした最小のステータスバー
7Name:    %{pkg_name}
8Version: %{pkg_version}
9Release: %{pkg_release}
10
11License: BSD3
12Group:   User Interface/Desktops
13URL:     http://hackage.haskell.org
14
15Source0: packages
16
17# # Patch for building with hinotify-3.10
18# Source2: xmobar-0.26_with_hinotify-3.10.patch
19
20Source11: hinotify-0.4.tar.gz
21Source12: hinotify.cabal
22Source13: parsec-numbers-0.1.0.tar.gz
23Source14: parsec-numbers.cabal
24Source15: timezone-series-0.1.9.tar.gz
25Source16: timezone-series.cabal
26Source17: timezone-olson-0.1.9.tar.gz
27Source18: timezone-olson.cabal
28Source19: xmobar-0.29.3.tar.gz
29Source20: xmobar.cabal
30
31BuildRoot: %{_tmppath}/%{name}-%{version}-root
32
33BuildRequires: ghc haskell-platform
34BuildRequires: xmonad xmonad-contrib
35BuildRequires: libXScrnSaver-devel
36BuildRequires: libffi-devel gmp-devel zlib-devel
37BuildRequires: xorg-x11-devel
38BuildRequires: libXpm-devel
39
40Requires: haskell-platform-dep
41Requires: xmonad xmonad-contrib
42Requires: libXpm
43
44Vendor: Project Vine
45Distribution: Vine Linux
46Packager: ara_t
47
48
49%description
50Xmobar is a minimalistic text based status bar.
51
52Inspired by the Ion3 status bar, it supports similar features,
53like dynamic color management, output templates, and extensibility
54through plugins.
55
56%description -l ja
57Xmobarはテキストを基礎とした最小のステータスバーです。
58
59
60%prep
61%{__rm} -rf ${RPM_BUILD_ROOT}
62
63%build
64%ghc_pkg_init
65
66cd %{_builddir}
67for pkg in `sed '$d' %{SOURCE0}`; do
68    %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
69    pushd ${pkg}
70        %ghc_fix_dependencies ${pkg}
71        %cabal_configure2 %{name} ${pkg}
72        %cabal_build
73        %cabal_haddock
74        %cabal_copy_resister %{name}_${pkg}
75    popd
76done
77
78cd %{_builddir}
79for pkg in `tail -n 1 %{SOURCE0}`; do
80    %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
81    pushd ${pkg}
82        %ghc_fix_dependencies ${pkg}
83
84        # # Patch for building with hinotify-3.10
85        # %{__patch} -p1 < %{SOURCE2}
86
87        %cabal_configure2 %{name} ${pkg} \
88            --flags="with_utf8" --flags="with_xft" \
89            --flags="with_threaded" --flags="with_inotify" \
90            --flags="with_datazone" --flags="with_xpm"
91        %cabal_build
92        %cabal_haddock
93        %cabal_copy_resister %{name}_${pkg}
94    popd
95done
96
97
98%install
99# copy documents
100pushd %{_builddir}/%{name}-%{version}
101    %{__cp} readme.md \
102     ${RPM_BUILD_ROOT}%{_docdir}/%{name}/%{name}-%{version}
103popd
104
105
106%clean
107%{__rm} -rf ${RPM_BUILD_ROOT}
108
109%post
110%ghc_pkg_recache
111
112%postun
113%ghc_pkg_recache
114
115
116%files
117%defattr(-, root, root)
118%{_bindir}/
119%{_libdir}/ghc-%{ghc_version}/
120%{_libdir}/ghc-lib/
121%{_docdir}/%{name}/
122
123
124%changelog
125* Mon Dec 17 2018 Toshiaki Ara <ara_t@384.jp> 0.29.3-1
126- update to 0.29.3
127- build using ghc-8.6.3
128
129* Wed Aug 08 2018 Toshiaki Ara <ara_t@384.jp> 0.27-2
130- build using ghc-8.4.3-2
131- add BuildRequires: libXScrnSaver-devel
132- correct BuildRequires
133
134* Fri Jul 20 2018 Toshiaki Ara <ara_t@384.jp> 0.27-1
135- update to 0.27
136- drop Patch2 (fixed at upstream)
137- build using ghc-8.4.3
138
139* Fri May 18 2018 Toshiaki Ara <ara_t@384.jp> 0.26-1
140- update to 0.26
141- rebuild using ghc-8.4.2
142- add Patch for building with hinotify-3.10 (Source2)
143- rewrite using macro
144
145* Tue Jan 09 2018 Toshiaki Ara <ara_t@384.jp> 0.24.5-2
146- update to 0.24.5
147- rebuild using ghc-8.2.2
148
149* Fri Feb 03 2017 Toshiaki Ara <ara_t@384.jp> 0.24.3-1
150- update to 0.24.3
151- build using ghc-8.0.1
152
153* Wed May 04 2016 Toshiaki Ara <ara_t@384.jp> 0.23.1-6
154- rebuilt
155
156* Tue Apr 12 2016 Toshiaki Ara <ara_t@384.jp> 0.23.1-5
157- rebuild under xmonad-0.12-3 and xmonad-contrib-0.12-4
158- correct SPEC file
159
160* Sun Mar 06 2016 Toshiaki Ara <ara_t@384.jp> 0.23.1-4
161- correct SPEC file
162
163* Tue Mar 01 2016 Toshiaki Ara <ara_t@384.jp> 0.23.1-3
164- rebuild under xmonad-0.12-2 and xmonad-contrib-0.12-3
165
166* Sun Feb 28 2016 Toshiaki Ara <ara_t@384.jp> 0.23.1-2
167- add configure option and required libraries
168
169* Sat Feb 27 2016 Toshiaki Ara <ara_t@384.jp> 0.23.1-1
170- new package
Note: See TracBrowser for help on using the repository browser.