source: projects/specs/trunk/x/xmobar/xmobar-vl.spec @ 11746

Revision 11746, 3.7 KB checked in by ara_t, 6 years ago (diff)

xmobar/xmonad*: rebuild with ghc-8.4.3

Line 
1%define pkg_name    xmobar
2%define pkg_version 0.27
3%define pkg_release 1%{?_dist_release}
4
5Summary:     a minimalistic text based status bar
6Summary(ja): テキストを基礎とした最小のステータスバー
7Name:    %{pkg_name}
8Version: %{pkg_version}
9Release: %{pkg_release}
10
11License: BSD3
12Group:   User Interface/Desktops
13URL:     http://hackage.haskell.org
14
15Source0: packages
16
17# # Patch for building with hinotify-3.10
18# Source2: xmobar-0.26_with_hinotify-3.10.patch
19
20Source11: hinotify-0.3.10.tar.gz
21Source12: hinotify.cabal
22Source13: timezone-series-0.1.9.tar.gz
23Source14: timezone-series.cabal
24Source15: timezone-olson-0.1.9.tar.gz
25Source16: timezone-olson.cabal
26Source17: parsec-numbers-0.1.0.tar.gz
27Source18: parsec-numbers.cabal
28Source19: xmobar-0.27.tar.gz
29Source20: xmobar.cabal
30
31BuildRoot: %{_tmppath}/%{name}-%{version}-root
32
33BuildRequires: ghc haskell-platform
34BuildRequires: xmonad-contrib
35BuildRequires: libffi-devel gmp-devel zlib-devel
36BuildRequires: xorg-x11-devel
37BuildRequires: libXpm-devel
38
39Requires: haskell-platform-dep
40Requires: xmonad-contrib
41Requires: libXpm
42
43Vendor: Project Vine
44Distribution: Vine Linux
45Packager: ara_t
46
47
48%description
49Xmobar is a minimalistic text based status bar.
50
51Inspired by the Ion3 status bar, it supports similar features,
52like dynamic color management, output templates, and extensibility
53through plugins.
54
55%description -l ja
56Xmobarはテキストを基礎とした最小のステータスバーです。
57
58
59%prep
60%{__rm} -rf ${RPM_BUILD_ROOT}
61
62%build
63%ghc_pkg_init
64
65cd %{_builddir}
66for pkg in `sed '$d' %{SOURCE0}`; do
67    %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
68    pushd ${pkg}
69        %ghc_fix_dependencies ${pkg}
70        %cabal_configure2 %{name} ${pkg}
71        %cabal_build
72        %cabal_haddock
73        %cabal_copy_resister %{name}_${pkg}
74    popd
75done
76
77cd %{_builddir}
78for pkg in `tail -n 1 %{SOURCE0}`; do
79    %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
80    pushd ${pkg}
81        %ghc_fix_dependencies ${pkg}
82
83        # # Patch for building with hinotify-3.10
84        # %{__patch} -p1 < %{SOURCE2}
85
86        %cabal_configure2 %{name} ${pkg} \
87            --flags="with_utf8" --flags="with_xft" \
88            --flags="with_threaded" --flags="with_inotify" \
89            --flags="with_datazone" --flags="with_xpm"
90        %cabal_build
91        %cabal_haddock
92        %cabal_copy_resister %{name}_${pkg}
93    popd
94done
95
96
97%install
98# copy documents
99pushd %{_builddir}/%{name}-%{version}
100    %{__cp} readme.md \
101     ${RPM_BUILD_ROOT}%{_docdir}/%{name}/%{name}-%{version}
102popd
103
104
105%clean
106%{__rm} -rf ${RPM_BUILD_ROOT}
107
108%post
109%ghc_pkg_recache
110
111%postun
112%ghc_pkg_recache
113
114
115%files
116%defattr(-, root, root)
117%{_bindir}/
118%{_libdir}/ghc-%{ghc_version}/
119%{_libdir}/ghc-lib/
120%{_docdir}/%{name}/
121
122
123%changelog
124* Fri Jul 20 2018 Toshiaki Ara <ara_t@384.jp> 0.27-1
125- update to 0.27
126- drop Patch2 (fixed at upstream)
127- build using ghc-8.4.3
128
129* Fri May 18 2018 Toshiaki Ara <ara_t@384.jp> 0.26-1
130- update to 0.26
131- rebuild using ghc-8.4.2
132- add Patch for building with hinotify-3.10 (Source2)
133- rewrite using macro
134
135* Tue Jan 09 2018 Toshiaki Ara <ara_t@384.jp> 0.24.5-2
136- update to 0.24.5
137- rebuild using ghc-8.2.2
138
139* Fri Feb 03 2017 Toshiaki Ara <ara_t@384.jp> 0.24.3-1
140- update to 0.24.3
141- build using ghc-8.0.1
142
143* Wed May 04 2016 Toshiaki Ara <ara_t@384.jp> 0.23.1-6
144- rebuilt
145
146* Tue Apr 12 2016 Toshiaki Ara <ara_t@384.jp> 0.23.1-5
147- rebuild under xmonad-0.12-3 and xmonad-contrib-0.12-4
148- correct SPEC file
149
150* Sun Mar 06 2016 Toshiaki Ara <ara_t@384.jp> 0.23.1-4
151- correct SPEC file
152
153* Tue Mar 01 2016 Toshiaki Ara <ara_t@384.jp> 0.23.1-3
154- rebuild under xmonad-0.12-2 and xmonad-contrib-0.12-3
155
156* Sun Feb 28 2016 Toshiaki Ara <ara_t@384.jp> 0.23.1-2
157- add configure option and required libraries
158
159* Sat Feb 27 2016 Toshiaki Ara <ara_t@384.jp> 0.23.1-1
160- new package
Note: See TracBrowser for help on using the repository browser.