source: projects/specs/trunk/x/xmobar/xmobar-vl.spec @ 11632

Revision 11632, 3.5 KB checked in by ara_t, 6 years ago (diff)

xmonad/xmobar: rebuild with ghc-8.4.2

RevLine 
[10168]1%define pkg_name    xmobar
[11632]2%define pkg_version 0.26
[10916]3%define pkg_release 1%{?_dist_release}
[10168]4
5Summary:     a minimalistic text based status bar
6Summary(ja): テキストを基礎とした最小のステータスバー
7Name:    %{pkg_name}
8Version: %{pkg_version}
9Release: %{pkg_release}
10
11License: BSD3
12Group:   User Interface/Desktops
13URL:     http://hackage.haskell.org
14
[11632]15Source0: packages
[10168]16
[11632]17# Patch for building with hinotify-3.10
18Source2: xmobar-0.26_with_hinotify-3.10.patch
[10168]19
[11632]20Source11: hinotify-0.3.10.tar.gz
21Source12: hinotify.cabal
22Source13: timezone-series-0.1.9.tar.gz
23Source14: timezone-series.cabal
24Source15: timezone-olson-0.1.9.tar.gz
25Source16: timezone-olson.cabal
26Source17: xmobar-0.26.tar.gz
27Source18: xmobar.cabal
[10168]28
29BuildRoot: %{_tmppath}/%{name}-%{version}-root
30
[10916]31BuildRequires: ghc haskell-platform
[10168]32BuildRequires: xmonad-contrib
33BuildRequires: libffi-devel gmp-devel zlib-devel
34BuildRequires: xorg-x11-devel
35BuildRequires: libXpm-devel
36
[11632]37Requires: haskell-platform-dep
[10168]38Requires: xmonad-contrib
39Requires: libXpm
40
41Vendor: Project Vine
42Distribution: Vine Linux
43Packager: ara_t
44
[11632]45
[10168]46%description
47Xmobar is a minimalistic text based status bar.
48
49Inspired by the Ion3 status bar, it supports similar features,
50like dynamic color management, output templates, and extensibility
51through plugins.
52
53%description -l ja
54Xmobarはテキストを基礎とした最小のステータスバーです。
55
56
57%prep
58%{__rm} -rf ${RPM_BUILD_ROOT}
59
60%build
[11632]61%ghc_pkg_init
[10168]62
63cd %{_builddir}
[11632]64for pkg in `sed '$d' %{SOURCE0}`; do
65    %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
66    pushd ${pkg}
67        %ghc_fix_dependencies ${pkg}
68        %cabal_configure2 %{name} ${pkg}
69        %cabal_build
70        %cabal_haddock
71        %cabal_copy_resister %{name}_${pkg}
72    popd
[10168]73done
74
[11632]75cd %{_builddir}
76for pkg in `tail -n 1 %{SOURCE0}`; do
77    %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
78    pushd ${pkg}
79        %ghc_fix_dependencies ${pkg}
[10168]80
[11632]81        # Patch for building with hinotify-3.10
82        %{__patch} -p1 < %{SOURCE2}
[10168]83
[11632]84        %cabal_configure2 %{name} ${pkg} \
85            --flags="with_utf8" --flags="with_xft" \
86            --flags="with_threaded" --flags="with_inotify" \
87            --flags="with_datazone" --flags="with_xpm"
88        %cabal_build
89        %cabal_haddock
90        %cabal_copy_resister %{name}_${pkg}
91    popd
92done
93
94
[10168]95%install
[11632]96# copy documents
97pushd %{_builddir}/%{name}-%{version}
98    %{__cp} readme.md \
99     ${RPM_BUILD_ROOT}%{_docdir}/%{name}/%{name}-%{version}
100popd
[10168]101
102
103%clean
104%{__rm} -rf ${RPM_BUILD_ROOT}
105
106%post
[11632]107%ghc_pkg_recache
[10168]108
109%postun
[11632]110%ghc_pkg_recache
[10168]111
112
113%files
114%defattr(-, root, root)
115%{_bindir}/
[10236]116%{_libdir}/ghc-%{ghc_version}/
117%{_libdir}/ghc-lib/
118%{_docdir}/%{name}/
[10168]119
120
121%changelog
[11632]122* Fri May 18 2018 Toshiaki Ara <ara_t@384.jp> 0.26-1
123- update to 0.26
124- rebuild using ghc-8.4.2
125- add Patch for building with hinotify-3.10 (Source2)
126- rewrite using macro
127
[11384]128* Tue Jan 09 2018 Toshiaki Ara <ara_t@384.jp> 0.24.5-2
129- update to 0.24.5
130- rebuild using ghc-8.2.2
131
[10916]132* Fri Feb 03 2017 Toshiaki Ara <ara_t@384.jp> 0.24.3-1
133- update to 0.24.3
134- build using ghc-8.0.1
135
[10236]136* Wed May 04 2016 Toshiaki Ara <ara_t@384.jp> 0.23.1-6
137- rebuilt
138
[10168]139* Tue Apr 12 2016 Toshiaki Ara <ara_t@384.jp> 0.23.1-5
140- rebuild under xmonad-0.12-3 and xmonad-contrib-0.12-4
141- correct SPEC file
142
143* Sun Mar 06 2016 Toshiaki Ara <ara_t@384.jp> 0.23.1-4
144- correct SPEC file
145
146* Tue Mar 01 2016 Toshiaki Ara <ara_t@384.jp> 0.23.1-3
147- rebuild under xmonad-0.12-2 and xmonad-contrib-0.12-3
148
149* Sun Feb 28 2016 Toshiaki Ara <ara_t@384.jp> 0.23.1-2
150- add configure option and required libraries
151
152* Sat Feb 27 2016 Toshiaki Ara <ara_t@384.jp> 0.23.1-1
153- new package
Note: See TracBrowser for help on using the repository browser.