source: projects/specs/trunk/x/xmms/xmms-vl.spec @ 521

Revision 521, 14.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1##define __libtoolize /bin/true
2
3# 3dnow feature can be enabled by '--define _3dnow 1' from command line
4# underscore _ is just set to avoid numeric beginning
5
6# if you want to make vorbis input plugin,
7# uncomment below line, or rpm --define with_vorbis:1
8%define with_vorbis 1
9
10# if you want to make alsa output plugin,
11# uncomment below line, or rpm --define with_alsa:1
12%define with_alsa 1
13
14Summary: An MP3 player for X which resembles Winamp.
15Summary(ja): WinAMPに似たX11 MP3プレーヤー
16Name: xmms
17Version: 1.2.11
18Release: 2%{?_3dnow:.3dnow}%{?_dist_release}
19License: GPL
20Group: Applications/Multimedia
21URL: http://www.xmms.org/
22Source0: ftp://ftp.xmms.org/%{name}/1.2.x/%{name}-%{version}.tar.gz
23Source1: xmms.desktop
24Source2: mp3license
25Source3: README.ESD
26Source6: xmms.xpm
27Patch1: xmms-1.2.10-audio.patch
28#Patch2: xmms-workaround.patch
29# source/patch for Vine
30#Patch100: http://www3.big.or.jp/~sian/linux/products/xmms/files/patches/xmms-1.2.7j_20020305.diff.bz2
31#Patch100: xmms-1.2.10j_20040415.diff.bz2
32Patch100: xmms-1.2.11j_20071118.diff.bz2
33Patch101: xmms-1.2.11-vine-fontset.patch
34Patch103: http://www.scn-net.ne.jp/~garakuta/file/xmms-1.2.10j_20040415-shadefont-20040617.patch
35Patch200: xmms-1.2.10-except-flac.patch
36
37Buildroot: %{_tmppath}/%{name}-%{version}-root
38BuildRequires: esound-devel, audiofile-devel, gtk+-devel, bison
39%{?with_vorbis:BuildRequires: libogg-devel, libvorbis-devel}
40%{?with_alsa:BuildRequires: alsa-lib-devel >= 0.9.0}
41Requires: gtk+ >= 1.2.2, esound, audiofile
42Requires: xmms-libs = %{version}-%{release}
43Requires(post): desktop-file-utils
44Requires(postun): desktop-file-utils
45Obsoletes: x11amp0.7-1-1 x11amp
46
47Vendor: Project Vine
48Distribution: Vine Linux
49
50%description
51Xmms is a multimedia (MP3s, CDs) player for the X Window System with
52an interface similar to Winamp's.  Xmms supports playlists and
53streaming content and has a configurable interface.
54
55%description -l ja
56X MultiMedia System は、スクラッチから作成されたサウンド再生ツールです。
57WinAmpのGUIを参考にして作られているので、WinAmpのスキンをそのまま使う
58ことができます。mp3, mod, s3m 等他の形式も再生することが可能です。
59入力、出力、一般、およびビジュアルプラグインもサポートしています。
60
61%package libs
62Summary: XMMS engine and core plugins
63Group: System Environment/Libraries
64
65%description libs
66The X MultiMedia System player engine and core plugins.
67
68%package devel
69Summary: Static libraries and header files for Xmms plug-in development.
70Summary(ja): XMMS - 静的ライブラリおよびヘッダファイル.
71Group: Development/Libraries
72Requires: xmms-libs = %{version}-%{release}
73Obsoletes: x11amp-devel
74
75%description devel
76The static libraries and header files needed for building plug-ins for
77the Xmms multimedia player.
78
79%description devel -l ja
80XMMS プラグインのコンパイルに必要な, 静的ライブラリおよびヘッダファイルです。
81
82%{?with_vorbis:%package vorbis}
83%{?with_vorbis:Summary: XMMS - Input plugin to play OGGs}
84%{?with_vorbis:Summary(ja): XMMS - OGG を再生するための入力プラグイン}
85%{?with_vorbis:Group: System Environment/Libraries}
86%{?with_vorbis:Requires: xmms-libs = %{version}-%{release}, libogg, libvorbis}
87
88%{?with_vorbis:%description vorbis}
89%{?with_vorbis:Input plugin for XMMS to play Ogg Vorbis files (.ogg).}
90
91%{?with_vorbis:%description vorbis -l ja}
92%{?with_vorbis:XMMS で Ogg Vorbis のファイル (.ogg) を再生するための入力プラグインです。}
93
94%{?with_alsa:%package alsa}
95%{?with_alsa:Summary: XMMS - ALSA output plugin}
96%{?with_alsa:Summary(ja): XMMS - ALSA 出力プラグイン}
97%{?with_alsa:Group: System Environment/Libraries}
98%{?with_alsa:Requires: xmms-libs = %{version}-%{release}, alsa-lib >= 0.9.0}
99
100%{?with_alsa:%description vorbis}
101%{?with_alsa:Output plugin for XMMS to use with the Advanced Linux Sound Architecture}
102%{?with_alsa:(ALSA).}
103
104%{?with_alsa:%description alsa -l ja}
105%{?with_alsa:XMMS で Advanced Linux Sound Architecture (ALSA) を用いて出力するための}
106%{?with_alsa:入力プラグインです。}
107
108%prep
109%setup -q
110%patch1 -p1 -b .audio
111#%patch2 -p1 -b .blarg
112# patch added by Vine
113%patch100 -p1 -b .ja
114#%patch103 -p1 -b .shade
115%patch101 -p1 -b .fontset
116
117%patch200 -p1 -b .ex-flac
118
119%build
120autoconf
121
122#  --enable-simd build with x86 SIMD (MMX/3DNow!) instructions support
123%configure \
124  --disable-dependency-tracking \
125  --enable-kanji \
126  --disable-static \
127  --disable-mikmod --disable-opengl --disable-oggtest \
128%{!?with_alsa:  --disable-alsa --disable-alsatest} \
129%{!?with_vorbis: --disable-vorbis} \
130%{?_3dnow: --enable-simd}
131
132find . -name Makefile | xargs sed -i -e s/-lpthread//g # old libtool, x86_64
133
134# Now, make target!
135make
136
137%install
138rm -rf %{buildroot}
139mkdir -p %{buildroot}
140make DESTDIR=%{buildroot} \
141        sysconfdir=%{buildroot}%{_sysconfdir} \
142        gnulocaledir=%{buildroot}%{_localedir} \
143        GNOME_SYSCONFDIR=%{_sysconfdir} \
144        GNOME_DATADIR=%{_datadir} \
145        mandir=%{_mandir} \
146        install
147
148mkdir -p %{buildroot}%{_datadir}/applications
149install -m 644 %{SOURCE1} %{buildroot}%{_datadir}/applications
150
151mkdir -p %{buildroot}%{_datadir}/pixmaps/mini
152install -p -m 644 xmms/xmms_logo.xpm %{buildroot}%{_datadir}/pixmaps
153install -p -m 644 xmms/xmms_mini.xpm %{buildroot}%{_datadir}/pixmaps/mini
154install -p -m 644 %{SOURCE6} %{buildroot}%{_datadir}/pixmaps
155
156find %{buildroot} -name "*.la" | xargs rm -f
157
158%find_lang %{name}
159
160%post
161/sbin/ldconfig
162%{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
163
164%postun
165/sbin/ldconfig
166%{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
167
168%clean
169rm -rf %{buildroot}
170
171%files -f %{name}.lang
172%defattr(-,root,root)
173%doc AUTHORS COPYING ChangeLog FAQ INSTALL NEWS TODO README README.jp
174%doc $RPM_SOURCE_DIR/README.ESD
175%{_bindir}/xmms
176%{_bindir}/wmxmms
177%config (missingok) %{_datadir}/applications/xmms.desktop
178%{_datadir}/pixmaps/xmms_logo.xpm
179%{_datadir}/pixmaps/mini/xmms_mini.xpm
180%{_datadir}/pixmaps/xmms.xpm
181%{_datadir}/xmms/wmxmms.xpm
182%{_mandir}/man1/xmms.1*
183%{_mandir}/man1/wmxmms.1*
184
185%files libs
186%defattr(-,root,root)
187%{_libdir}/libxmms.so.*
188%dir %{_libdir}/xmms
189%{_libdir}/xmms/Effect
190%{_libdir}/xmms/General
191%dir %{_libdir}/xmms/Input
192%{_libdir}/xmms/Input/libcdaudio.*
193#%{_libdir}/xmms/Input/libidcin.*
194%{_libdir}/xmms/Input/libmpg123.*
195%{_libdir}/xmms/Input/libtonegen.*
196%{_libdir}/xmms/Input/libwav.*
197%{_libdir}/xmms/Output
198%{_libdir}/xmms/Visualization
199
200%files devel
201%defattr(-,root,root)
202%{_includedir}/xmms
203%{_bindir}/xmms-config
204%{_datadir}/aclocal/xmms.m4
205#{_libdir}/lib*.a
206%{_libdir}/lib*.so
207
208%{?with_vorbis:%files vorbis}
209%{?with_vorbis:%defattr(-,root,root)}
210%{?with_vorbis:%{_libdir}/xmms/Input/libvorbis.*}
211
212%{?with_alsa:%files alsa}
213%{?with_alsa:%defattr(-,root,root)}
214%{?with_alsa:%{_libdir}/xmms/Output/libALSA.*}
215
216
217%changelog
218* Fri Jun 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.11-2
219- split libs sub-package
220- added --disbale-static, --disable-dependency-tracking option
221
222* Wed Oct 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.2.11-1vl5
223- applied new versioning policy, spec in utf-8
224
225* Sun Dec 30 2007 Satoshi MACHINO <machino@vinelinux.org> 1.2.11-0vl1
226- new upstream release
227- updated patch100 and patch101
228- dropped patch103
229
230* Mon Aug 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.10-0vl8
231- use %%configure
232
233* Sun Aug 14 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.10-0vl7
234- use --enable-simd instead of --enable-3dnow
235  - thanks, K. Moriyama [VinePlus:02628]
236- build with alsa-lib
237
238* Sun May 29 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.10-0vl6
239- update desktop file
240  - merge xmms.desktop.patch (patch102)
241  - add application/ogg to MimeType
242  - add Encoding=UTF-8
243  - add Categories=Application;AudioVideo;Player;
244  - dtop deprecated keys
245- install xmms.desktop to %%{_datadir}/applications
246- run update-desktop-database at %%post, %%postun
247- add PreReq: desktop-file-utils
248- add PreReq: ldconfig instead of /sbin/ldconfig
249- not strip at %%install, it should be done by %%__install_spec_post
250
251* Thu Feb 10 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.10-0vl5
252- add except-flac.patch (patch200)
253      to prevent mpg123 plugin's hijacking FLAC stream
254  (ref. http://bugs.xmms.org/show_bug.cgi?id=2038)
255- add BuildPrereq: automake17
256
257* Fri Oct 01 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.10-0vl4
258- add shade-font.patch (patch103)
259  - update vine-fontset.patch (patch101)
260- add BuildPrereq: gtk+-devel, bison
261- run configure with --disable-alsatest
262
263* Fri Sep 10 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.10-0vl3
264- rebuilt without alsa-lib (sorry, ppc.rpm had dependencies with alsa-lib)
265
266* Tue May 04 2004 Tomoya TAKA <taka@vinelinux.org> 1.2.10-0vl2
267- fix typo in spec file
268
269* Fri Apr 30 2004 Tomoya TAKA <taka@vinelinux.org> 1.2.10-0vl1
270- new upstream release
271- drop obsoleted patch2
272- update patch1 and patch101
273- update patch100, it was made from xmms-1.2.10j_20040415.tar.bz2
274  by Hiroshi Takekawa <sian@big.or.jp>
275  cf. http://www3.big.or.jp/~sian/linux/products/xmms/
276- delete xmms-gnome subpackage
277- add macro to enable alsa plugin (disabled by default)
278
279* Sat Mar 22 2003 IWAI Masaharu <iwai@alib.jp> 1.2.7-0vl6
280- rebuild with new toolchain
281- add BuildRequires: gnome-core-devel
282
283* Fri Jul 26 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.7-0vl5
284- %define with_vorbis 1 (rebuild with libvorbis-1.0-0vl1)
285
286* Wed May 08 2002 Satoshi MACHINO <machino@vinelinux.org> 1.2.7-0vl4
287- fixed changelog
288        -- don't expand macros in changelog ;P
289               
290* Wed May 01 2002 Satoshi MACHINO <machino@vinelinux.org> 1.2.7-0vl3
291- changed to use configure in build section
292        (can't build on sparc)
293
294* Thu Apr  4 2002 Hironobu MORIGUCHI <moriguti@luna.email.ne.jp> 1.2.7-0vl2
295- removed %%F from desktop menu (xmms.desktop.patch)
296
297* Fri Mar 08 2002 Toru Sagami <sagami@vinelinux.org> 1.2.7-0vl1
298- updated to current stable release 1.2.7
299
300* Wed Jan 31 2002 UECHI Yasumasa <uh@u.dhis.portside.net> 1.2.6-0vl2
301- add xmms-vorbis subpackage
302
303* Fri Jan 11 2002 Toru Sagami <sagami@vinelinux.org> 1.2.6-0vl1
304- updated to current stable release 1.2.6 and regenerate patches
305- Requires: %%{name} = %%{version} for subpackages
306- just run autoheader at libxmms/ and ./
307- disable mikmod vorbis opengl oggtest
308
309* Wed Aug 22 2001 Jun Nishii <jun@vinelinux.org> 1.2.5-0vl2
310- set default fontset (xmms-1.2.5-vine-fontset.patch)
311- libtoolize libxmms/ and ./, in which make process failed because of libtool version dependency...
312
313* Tue Jul 10 2001 <sagami@vinelinux.org>
314- 1.2.5-0vl1: was partially based upon RH's 1.2.5-2
315- added macro to enable 3dnow option by '--define _3dnow 1' from command line
316- added man pages
317- added Prereq: /sbin/ldconfig line
318
319* Fri Sep 15 2000 Jun Nishii <jun@vinelinux.org>
320- 1.2.2-0v3
321- without gl again...
322
323* Mon Sep 11 2000 Jun Nishii <jun@vinelinux.org>
324- 1.2.2-0v2
325- requires esound, audiofile
326- without gl
327
328* Tue Jul 18 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
329- updated 1.2.2
330- added bmp32depth patch and lha patch.
331- fixed SPEC to install locale, gnome data.
332
333* Thu Jul  3 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
334- modified i18n patch to support 8bpp and clean up.
335
336* Thu Jun 29 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
337- modified i18n patch to fix the textbackground transparent.
338
339* Wed Jun 28 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
340- modified i18n patch to make the textbackground transparent.
341
342* Mon Jun 19 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
343- Vine's first release for 1.2.1
344- added xmms.xpm
345- remake spec from rawhide.
346- added my poor i18n_mb and libjcode patches.
347- modified ja.po for i18n_mb patch.
348
349* Mon Jun 12 2000 Preston Brown <pbrown@redhat.com>
350- 1.2.0
351- use rpm macros
352- fix gnomexmms buildroot breakage
353
354* Sun Jun 11 2000 Bill Nottingham <notting@redhat.com>
355- rebuild in new environment
356- work around some toolchain madness
357
358* Mon Mar 27 2000 Bill Nottingham <notting@redhat.com>
359- include /usr/share/xmmms/wmxmms.xpm
360
361* Tue Feb 22 2000 Bill Nottingham <notting@redhat.com>
362- use /usr prefix to be consistent with xmms.org (why not?)
363- find something more appropriate than the disk writer to use
364  as output plugin if configured one doesn't exist
365
366* Wed Feb 16 2000 Matt Wilson <msw@redhat.com>
367- include /usr/X11R6/bin/wmxmms
368
369* Thu Feb  3 2000 Bill Nottingham <notting@redhat.com>
370- some cleanups
371
372* Mon Jan 31 2000 Bill Nottingham <notting@redhat.com>
373- update to 1.0.1
374
375* Fri Jan 28 2000 Bill Nottingham <notting@redhat.com>
376- update to 1.0.0
377
378* Tue Sep 28 1999 Bill Nottingham <notting@redhat.com>
379- update to 0.9.5.1
380
381* Wed Sep 23 1999 Preston Brown <pbrown@redhat.com>
382- latest stable release (0.9.5)
383
384* Wed Sep 22 1999 Bill Nottingham <notting@redhat.com>
385- open in non-blocking mode, then reset
386- make esd the default
387
388* Mon Sep 13 1999 Bill Nottingham <notting@redhat.com>
389- fix binaries
390
391* Thu Sep  9 1999 Bill Nottingham <notting@redhat.com>
392- fix gtk+ requirements
393
394* Wed Aug 18 1999 Bill Nottingham <notting@redhat.com>
395- fix a /0 in the disk writer
396
397* Tue Jul 20 1999 Bill Nottingham <notting@redhat.com>
398- 0.9.1
399
400* Mon Jun 21 1999 Bill Nottingham <notting@redhat.com>
401- use other fallback patch
402- obsolete x11amp-devel
403
404* Fri Jun 11 1999 Matt Wilson <msw@redhat.com>
405- updated to xmms 0.9 final
406
407* Thu Apr 8 1999 The Rasterman <raster@redhat.com>
408- patched to have plugin fallback to other plugins for output if plugin fails.
409
410* Mon Mar 29 1999 Michael Maher <mike@redhat.com>
411- added desktop entry.
412
413* Mon Mar 22 1999 Michael Maher <mike@redhat.com>
414- made some changes to the spec file.
415- has 'esd' support now.
416- stripped executables.
417
418* Mon Feb 15 1999 Michael Maher <mike@redhat.com>
419- built pacakge for 6.0
420- changed spec file, added mp3 licenses.
421
422* Mon Feb 15 1999 Ryan Weaver <ryanw@infohwy.com>
423  [x11amp-0.9-alpha3-1]
424- Updated to alpha3 see ChangLog for changes.
425
426* Wed Jan 13 1999 Ryan Weaver <ryanw@infohwy.com>
427  [x11amp-0.9-alpha2-1]
428- fixed close button in PL/EQ windows
429- fixed shuffel/randomize functions
430- removed imlib, no need for imlib anymore
431- mpg123 plugin now works on SMP machines, also reduced cpu usage
432- fixed so mainwindow will be positioned correct at startup in some windowmanagers
433- fixed the playlistwindow buttons that ended up behind the window
434- added mikmod plugin into the source tree
435- now you can configure the OSS drivers and mpg123 plugin
436- SKINSDIR variable can be used again
437- added bars as analyzer mode
438- in playlistwindow the player control buttons now work, also time window works
Note: See TracBrowser for help on using the repository browser.