source: projects/specs/trunk/x/xmlsec1/xmlsec1-vl.spec @ 521

Revision 521, 9.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Library providing support for "XML Signature" and "XML Encryption" standards
2Name: xmlsec1
3Version: 1.2.12
4Release: 1%{?_dist_release}
5License: MIT
6Group: System Environment/Libraries
7Source: ftp://ftp.aleksey.com/pub/xmlsec/releases/xmlsec1-%{version}.tar.gz
8BuildRoot: %{_tmppath}/%{name}-%{version}-root
9URL: http://www.aleksey.com/xmlsec/
10Requires: libxml2 >= 2.6.0
11Requires: libxslt >= 1.1.0
12BuildRequires: libxml2-devel >= 2.6.0
13BuildRequires: libxslt-devel >= 1.1.0
14Prefix: %{_prefix}
15Docdir: %{_docdir}
16
17%description
18XML Security Library is a C library based on LibXML2  and OpenSSL.
19The library was created with a goal to support major XML security
20standards "XML Digital Signature" and "XML Encryption".
21
22%package devel
23Summary: Libraries, includes, etc. to develop applications with XML Digital Signatures and XML Encryption support.
24Group: Development/Libraries
25Requires: xmlsec1 = %{version}
26Requires: libxml2-devel >= 2.6.0
27Requires: libxslt-devel >= 1.1.0
28Requires: openssl-devel >= 0.9.6
29Requires: zlib-devel
30Requires: pkgconfig
31
32%description devel
33Libraries, includes, etc. you can use to develop applications with XML Digital
34Signatures and XML Encryption support.
35
36%package openssl
37Summary: OpenSSL crypto plugin for XML Security Library
38Group: System Environment/Libraries
39Requires: xmlsec1 = %{version}
40Requires: libxml2 >= 2.6.0
41Requires: libxslt >= 1.1.0
42Requires: openssl >= 0.9.6
43BuildRequires: openssl-devel >= 0.9.6
44
45%description openssl
46OpenSSL plugin for XML Security Library provides OpenSSL based crypto services
47for the xmlsec library
48
49%package openssl-devel
50Summary: OpenSSL crypto plugin for XML Security Library
51Group: Development/Libraries
52Requires: xmlsec1 = %{version}
53Requires: xmlsec1-devel = %{version}
54Requires: xmlsec1-openssl = %{version}
55Requires: libxml2-devel >= 2.6.0
56Requires: libxslt-devel >= 1.1.0
57Requires: openssl >= 0.9.6
58Requires: openssl-devel >= 0.9.6
59
60%description openssl-devel
61Libraries, includes, etc. for developing XML Security applications with OpenSSL
62
63%package gnutls
64Summary: GNUTls crypto plugin for XML Security Library
65Group: System Environment/Libraries
66Requires: xmlsec1 = %{version}
67Requires: libxml2 >= 2.6.0
68Requires: libxslt >= 1.1.0
69Requires: libgcrypt >= 1.2.0
70Requires: gnutls >= 1.0.20
71BuildRequires: libgcrypt-devel >= 1.2.0
72BuildRequires: gnutls-devel >= 1.0.20
73
74%description gnutls
75GNUTls plugin for XML Security Library provides GNUTls based crypto services
76for the xmlsec library
77
78%package gnutls-devel
79Summary: GNUTls crypto plugin for XML Security Library
80Group: Development/Libraries
81Requires: xmlsec1 = %{version}
82Requires: xmlsec1-devel = %{version}
83Requires: xmlsec1-openssl = %{version}
84Requires: libxml2-devel >= 2.6.0
85Requires: libxslt-devel >= 1.1.0
86Requires: libgcrypt >= 1.2.0
87Requires: gnutls >= 1.0.20
88Requires: libgcrypt-devel >= 1.2.0
89Requires: gnutls-devel >= 1.0.20
90
91%description gnutls-devel
92Libraries, includes, etc. for developing XML Security applications with GNUTls
93
94%package nss
95Summary: NSS crypto plugin for XML Security Library
96Group: System Environment/Libraries
97Requires: xmlsec1 = %{version}
98Requires: libxml2 >= 2.4.24
99Requires: libxslt >= 1.0.20
100Requires: nss >= 3.2
101Requires: nspr
102BuildRequires: nss-devel >= 3.2
103BuildRequires: nspr-devel
104
105%description nss
106NSS plugin for XML Security Library provides NSS based crypto services
107for the xmlsec library
108
109%package nss-devel
110Summary: NSS crypto plugin for XML Security Library
111Group: Development/Libraries
112Requires: xmlsec1 = %{version}
113Requires: xmlsec1-devel = %{version}
114Requires: xmlsec1-nss = %{version}
115Requires: libxml2-devel >= 2.4.24
116Requires: libxslt-devel >= 1.0.20
117Requires: nss-devel >= 3.2
118Requires: nspr-devel
119
120%description nss-devel
121Libraries, includes, etc. for developing XML Security applications with NSS
122
123%prep
124%setup -q
125
126%build
127%configure
128#
129# Note: it seems that this may break on older version of Red Hat,
130#       and that replacing the following line with just "make" can
131#       fix the problem
132#
133make
134
135# positively ugly but only sane way to get around #192756
136sed 's+/lib64+/$archlib+g' < xmlsec1-config | sed 's+/lib+/$archlib+g' | sed 's+ -DXMLSEC_NO_SIZE_T++' > xmlsec1-config.$$ && mv xmlsec1-config.$$ xmlsec1-config
137
138%install
139rm -rf $RPM_BUILD_ROOT
140mkdir -p $RPM_BUILD_ROOT/usr/bin
141mkdir -p $RPM_BUILD_ROOT/usr/include/xmlsec1
142mkdir -p $RPM_BUILD_ROOT/usr/lib
143mkdir -p $RPM_BUILD_ROOT/usr/man/man1
144
145%makeinstall
146#make prefix=$RPM_BUILD_ROOT%{prefix} mandir=$RPM_BUILD_ROOT%{_mandir} install
147rm -fv $RPM_BUILD_ROOT%{_libdir}/*.la
148rm -fv $RPM_BUILD_ROOT%{_libdir}/*.a
149
150rm -rf docs-to-install
151mkdir -p docs-to-install
152cp -pr $RPM_BUILD_ROOT%{_datadir}/doc/xmlsec1/* docs-to-install
153rm -rf $RPM_BUILD_ROOT%{_datadir}/doc/xmlsec1
154
155%clean
156rm -fr %{buildroot}
157
158%post -p /sbin/ldconfig
159
160%postun -p /sbin/ldconfig
161
162%post openssl -p /sbin/ldconfig
163
164%postun openssl -p /sbin/ldconfig
165
166%post gnutls -p /sbin/ldconfig
167
168%postun gnutls -p /sbin/ldconfig
169
170%post nss -p /sbin/ldconfig
171
172%postun nss -p /sbin/ldconfig
173
174
175%files
176%defattr(-, root, root)
177%doc AUTHORS ChangeLog NEWS README Copyright
178%doc %{_mandir}/man1/xmlsec1.1*
179%{prefix}/lib*/libxmlsec1.so.*
180%{prefix}/bin/xmlsec1
181
182%files devel
183%defattr(-, root, root) 
184%{prefix}/bin/xmlsec1-config
185%{prefix}/include/xmlsec1/xmlsec/*.h
186%{prefix}/include/xmlsec1/xmlsec/private/*.h
187%{prefix}/lib*/libxmlsec1.so
188# %{prefix}/lib*/libxmlsec1.*a
189%{prefix}/lib*/pkgconfig/xmlsec1.pc
190%{prefix}/lib*/xmlsec1Conf.sh
191%{_datadir}/aclocal/*.m4
192%doc AUTHORS HACKING ChangeLog NEWS README Copyright
193%doc docs-to-install/*
194%doc %{_mandir}/man1/xmlsec1-config.1*
195
196%files openssl
197%defattr(-, root, root) 
198%{prefix}/lib*/libxmlsec1-openssl.so.*
199
200%files openssl-devel
201%defattr(-, root, root) 
202%{prefix}/include/xmlsec1/xmlsec/openssl/*.h
203# %{prefix}/lib*/libxmlsec1-openssl.*a
204%{prefix}/lib*/libxmlsec1-openssl.so
205%{prefix}/lib*/pkgconfig/xmlsec1-openssl.pc
206
207%files gnutls
208%defattr(-, root, root) 
209%{prefix}/lib*/libxmlsec1-gnutls.so.*
210
211%files gnutls-devel
212%defattr(-, root, root) 
213%{prefix}/include/xmlsec1/xmlsec/gnutls/*.h
214# %{prefix}/lib*/libxmlsec1-gnutls.*a
215%{prefix}/lib*/libxmlsec1-gnutls.so
216%{prefix}/lib*/pkgconfig/xmlsec1-gnutls.pc
217
218%files nss
219%defattr(-, root, root) 
220%{prefix}/lib*/libxmlsec1-nss.so.*
221
222%files nss-devel
223%defattr(-, root, root) 
224%{prefix}/include/xmlsec1/xmlsec/nss/*.h
225# %{prefix}/lib*/libxmlsec1-nss.*a
226%{prefix}/lib*/libxmlsec1-nss.so
227%{prefix}/lib*/pkgconfig/xmlsec1-nss.pc
228
229%changelog
230* Fri Jul 24 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.12-1
231- new upstream release with security fix (CVE-2009-0217)
232- remove *.a files
233
234* Sat Jan 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.11-2
235- rebuilt with gnutls-2.6.3
236
237* Wed Jul 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.11-1
238- new upstream release
239
240* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.9-0vl1
241- initial build for Vine Linux
242
243* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.2.9-8.1
244- rebuild
245
246* Wed Jun 14 2006 Tomas Mraz <tmraz@redhat.com> - 1.2.9-8
247- rebuilt with new gnutls
248
249* Thu Jun  8 2006 Daniel Veillard <veillard@redhat.com> - 1.2.9-7
250- oops libxmlsec1.la was still there, should fix #171410 and #154142
251
252* Thu Jun  8 2006 Daniel Veillard <veillard@redhat.com> - 1.2.9-6
253- Ugly patch and sed based changes to work around #192756 xmlsec1-config
254  multilib problem
255
256* Wed Jun  7 2006 Jeremy Katz <katzj@redhat.com> - 1.2.9-5
257- move .so symlinks to -devel subpackage
258
259* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.2.9-4.2
260- bump again for double-long bug on ppc(64)
261
262* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.2.9-4.1
263- rebuilt for new gcc4.1 snapshot and glibc changes
264
265* Thu Dec 15 2005 Christopher Aillon <caillon@redhat.com> 1.2.9-4
266- NSS has been split out of the mozilla package, so require that now
267  and update separate_nspr.patch to account for the new NSS as well
268
269* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
270- rebuilt
271
272* Wed Nov 23 2005 Tomas Mraz <tmraz@redhat.com> 1.2.9-3
273- rebuilt due to gnutls library revision
274* Wed Nov  9 2005 <veillard@redhat.com> 1.2.9-2
275- rebuilt due to openssl library revision
276* Tue Sep 20 2005 <veillard@redhat.com> 1.2.9-1
277- update from upstream, release done in July
278- apparently nss is now available on ppc64
279* Mon Aug  8 2005 <veillard@redhat.com> 1.2.8-3
280- rebuilt with new gnutls
281- nspr has been split to a separate package
282* Fri Jul  8 2005 Daniel Veillard <veillard@redhat.com> 1.2.8-2
283- Enabling the mozilla-nss crypto backend
284* Fri Jul  8 2005 Daniel Veillard <veillard@redhat.com> 1.2.8-1
285- update from upstream, needed for openoffice
286* Tue Mar  8 2005 Daniel Veillard <veillard@redhat.com> 1.2.7-4
287- rebuilt with gcc4
288* Wed Feb 23 2005 Daniel Veillard <veillard@redhat.com> 1.2.7-1
289- Upstream release of 1.2.7, mostly bug fixes plus new functions
290  to GetKeys from simple store and X509 handling.
291* Wed Feb  9 2005 Daniel Veillard <veillard@redhat.com> 1.2.6-4
292- Adding support for GNUTls crypto backend
293* Wed Sep  1 2004 Daniel Veillard <veillard@redhat.com> 1.2.6-3
294- adding missing ldconfig calls
295* Thu Aug 26 2004 Daniel Veillard <veillard@redhat.com> 1.2.6-2
296- updated with upstream release from Aleksey
297* Mon Jun 21 2004 Daniel Veillard <veillard@redhat.com> 1.2.5-2
298- rebuilt
299* Mon Apr 19 2004 Daniel Veillard <veillard@redhat.com> 1.2.5-1
300- updated with upstream release from Aleksey
301* Wed Feb 11 2004 Daniel Veillard <veillard@redhat.com> 1.2.4-1
302- updated with upstream release from Aleksey
303* Tue Jan  6 2004 Daniel Veillard <veillard@redhat.com> 1.2.3-1
304- updated with upstream release from Aleksey
305* Wed Nov 12 2003 Daniel Veillard <veillard@redhat.com> 1.2.2-1
306- updated with upstream release from Aleksey, specific patches should
307  have been integrated now.
308* Thu Nov  6 2003 Daniel Veillard <veillard@redhat.com> 1.2.1-1
309- initial packaging based on the upstream one and libxml2 one.
310- desactivated mozilla-nss due to detection/architecture problems
Note: See TracBrowser for help on using the repository browser.