source: projects/specs/trunk/x/xmlsec1/xmlsec1-vl.spec @ 10258

Revision 10258, 10.6 KB checked in by tomop, 8 years ago (diff)

xmlsec1-1.2.22-1

Line 
1Summary: Library providing support for "XML Signature" and "XML Encryption" standards
2Name: xmlsec1
3Version: 1.2.22
4Release: 1%{?_dist_release}
5License: MIT
6Group: System Environment/Libraries
7URL: http://www.aleksey.com/xmlsec/
8Source: ftp://ftp.aleksey.com/pub/xmlsec/releases/xmlsec1-%{version}.tar.gz
9Vendor: Project Vine
10Distribution: Vine Linux
11
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13BuildRequires: libxml2-devel >= 2.6.0
14BuildRequires: libxslt-devel >= 1.1.0
15BuildRequires: openssl-devel >= 0.9.6
16BuildRequires: libgcrypt-devel >= 1.4.0
17BuildRequires: gnutls-devel >= 1.0.20
18BuildRequires: nss-devel >= 3.2
19BuildRequires: nspr-devel
20BuildRequires: libtool-ltdl-devel
21# extra build deps needed for autoreconf after above patch
22BuildRequires: autoconf
23BuildRequires: automake
24BuildRequires: gettext-devel
25BuildRequires: libtool
26
27%description
28XML Security Library is a C library based on LibXML2  and OpenSSL.
29The library was created with a goal to support major XML security
30standards "XML Digital Signature" and "XML Encryption".
31
32%package devel
33Summary: Libraries, includes, etc. to develop applications with XML Digital Signatures and XML Encryption support.
34Group: Development/Libraries
35Requires: xmlsec1 = %{version}-%{release}
36Requires: libxml2-devel >= 2.6.0
37Requires: libxslt-devel >= 1.1.0
38Requires: openssl-devel >= 0.9.6
39Requires: zlib-devel
40Requires: pkgconfig
41
42%description devel
43Libraries, includes, etc. you can use to develop applications with XML Digital
44Signatures and XML Encryption support.
45
46%package openssl
47Summary: OpenSSL crypto plugin for XML Security Library
48Group: System Environment/Libraries
49Requires: xmlsec1 = %{version}-%{release}
50
51%description openssl
52OpenSSL plugin for XML Security Library provides OpenSSL based crypto services
53for the xmlsec library
54
55%package openssl-devel
56Summary: OpenSSL crypto plugin for XML Security Library
57Group: Development/Libraries
58Requires: xmlsec1-devel = %{version}-%{release}
59Requires: xmlsec1-openssl = %{version}-%{release}
60
61%description openssl-devel
62Libraries, includes, etc. for developing XML Security applications with OpenSSL
63
64%package gcrypt
65Summary: GCrypt crypto plugin for XML Security Library
66Group: System Environment/Libraries
67Requires: xmlsec1 = %{version}-%{release}
68
69%description gcrypt
70GCrypt plugin for XML Security Library provides GCrypt based crypto services
71for the xmlsec library.
72
73%package gcrypt-devel
74Summary: GCrypt crypto plugin for XML Security Library
75Group: Development/Libraries
76Requires: xmlsec1-devel = %{version}-%{release}
77Requires: xmlsec1-gnutls-devel = %{version}-%{release}
78
79%description gcrypt-devel
80Libraries, includes, etc. for developing XML Security applications with GCrypt.
81
82%package gnutls
83Summary: GNUTls crypto plugin for XML Security Library
84Group: System Environment/Libraries
85Requires: xmlsec1 = %{version}-%{release}
86
87%description gnutls
88GNUTls plugin for XML Security Library provides GNUTls based crypto services
89for the xmlsec library
90
91%package gnutls-devel
92Summary: GNUTls crypto plugin for XML Security Library
93Group: Development/Libraries
94Requires: xmlsec1 = %{version}
95Requires: xmlsec1-devel = %{version}
96Requires: xmlsec1-openssl = %{version}
97Requires: libgcrypt-devel >= 1.2.0
98Requires: gnutls-devel >= 1.0.20
99
100%description gnutls-devel
101Libraries, includes, etc. for developing XML Security applications with GNUTls
102
103%package nss
104Summary: NSS crypto plugin for XML Security Library
105Group: System Environment/Libraries
106Requires: xmlsec1 = %{version}-%{release}
107
108%description nss
109NSS plugin for XML Security Library provides NSS based crypto services
110for the xmlsec library
111
112%package nss-devel
113Summary: NSS crypto plugin for XML Security Library
114Group: Development/Libraries
115Requires: xmlsec1-devel = %{version}-%{release}
116Requires: xmlsec1-nss = %{version}-%{release}
117Requires: nss-devel >= 3.2
118Requires: nspr-devel
119
120%description nss-devel
121Libraries, includes, etc. for developing XML Security applications with NSS
122
123%prep
124%setup -q
125
126%build
127autoreconf -if
128%configure --enable-silent-rules --disable-static
129
130sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
131sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
132make
133
134# positively ugly but only sane way to get around #192756
135sed 's+/lib64+/$archlib+g' < xmlsec1-config | sed 's+/lib+/$archlib+g' | sed 's+ -DXMLSEC_NO_SIZE_T++' > xmlsec1-config.$$ && mv xmlsec1-config.$$ xmlsec1-config
136
137%install
138rm -rf $RPM_BUILD_ROOT
139mkdir -p $RPM_BUILD_ROOT/usr/bin
140mkdir -p $RPM_BUILD_ROOT/usr/include/xmlsec1
141mkdir -p $RPM_BUILD_ROOT%{_libdir}
142mkdir -p $RPM_BUILD_ROOT/usr/man/man1
143
144make install DESTDIR=$RPM_BUILD_ROOT
145#make prefix=$RPM_BUILD_ROOT%{prefix} mandir=$RPM_BUILD_ROOT%{_mandir} install
146rm -fv $RPM_BUILD_ROOT%{_libdir}/*.la
147#rm -fv $RPM_BUILD_ROOT%{_libdir}/*.a
148
149rm -rf docs-to-install
150mkdir -p docs-to-install
151cp -pr $RPM_BUILD_ROOT%{_datadir}/doc/xmlsec1/* docs-to-install
152rm -rf $RPM_BUILD_ROOT%{_datadir}/doc/xmlsec1
153
154%clean
155rm -fr %{buildroot}
156
157%post -p /sbin/ldconfig
158
159%postun -p /sbin/ldconfig
160
161%post openssl -p /sbin/ldconfig
162
163%postun openssl -p /sbin/ldconfig
164
165%post gcrypt -p /sbin/ldconfig
166
167%postun gcrypt -p /sbin/ldconfig
168
169%post gnutls -p /sbin/ldconfig
170
171%postun gnutls -p /sbin/ldconfig
172
173%post nss -p /sbin/ldconfig
174
175%postun nss -p /sbin/ldconfig
176
177
178%files
179%defattr(-, root, root)
180%doc AUTHORS ChangeLog NEWS README Copyright
181%doc %{_mandir}/man1/xmlsec1.1*
182%{_libdir}/libxmlsec1.so.*
183%{_bindir}/xmlsec1
184
185%files devel
186%defattr(-, root, root) 
187%{_bindir}/xmlsec1-config
188%{_includedir}/xmlsec1/xmlsec/*.h
189%{_includedir}/xmlsec1/xmlsec/private/*.h
190%{_libdir}/libxmlsec1.so
191%{_libdir}/pkgconfig/xmlsec1.pc
192%{_libdir}/xmlsec1Conf.sh
193%{_datadir}/aclocal/*.m4
194%doc AUTHORS HACKING ChangeLog NEWS README Copyright
195%doc docs-to-install/*
196%doc %{_mandir}/man1/xmlsec1-config.1*
197
198%files openssl
199%defattr(-, root, root) 
200%{_libdir}/libxmlsec1-openssl.so
201%{_libdir}/libxmlsec1-openssl.so.*
202
203%files openssl-devel
204%defattr(-, root, root) 
205%{_includedir}/xmlsec1/xmlsec/openssl/*.h
206%{_libdir}/pkgconfig/xmlsec1-openssl.pc
207
208%files gcrypt
209%defattr(-, root, root, -)
210%{_libdir}/libxmlsec1-gcrypt.so
211%{_libdir}/libxmlsec1-gcrypt.so.*
212
213%files gcrypt-devel
214%defattr(-, root, root, -)
215%{_includedir}/xmlsec1/xmlsec/gcrypt/
216%{_libdir}/pkgconfig/xmlsec1-gcrypt.pc
217
218%files gnutls
219%defattr(-, root, root) 
220%{_libdir}/libxmlsec1-gnutls.so
221%{_libdir}/libxmlsec1-gnutls.so.*
222
223%files gnutls-devel
224%defattr(-, root, root) 
225%{_includedir}/xmlsec1/xmlsec/gnutls/*.h
226%{_libdir}/pkgconfig/xmlsec1-gnutls.pc
227
228%files nss
229%defattr(-, root, root) 
230%{_libdir}/libxmlsec1-nss.so
231%{_libdir}/libxmlsec1-nss.so.*
232
233%files nss-devel
234%defattr(-, root, root) 
235%{_includedir}/xmlsec1/xmlsec/nss/*.h
236%{_libdir}/pkgconfig/xmlsec1-nss.pc
237
238%changelog
239* Mon May  9 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.22-1
240- new upstream release.
241
242* Wed Dec 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.20-3
243- rebuilt with gnutls-3.4.x.
244
245* Fri Jul  3 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.20-2
246- fixed %%files.
247
248* Sat Nov  1 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.2.20-1
249- new upstream release
250- moved gcrypt to System Environment/Libraries Group
251
252* Sat Jan 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.16-1
253- new upstream release
254- add BuildRequires: libtool-ltdl-devel
255- add -gcrypt,-gcrypt-devel package
256
257* Fri Jul 24 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.12-1
258- new upstream release with security fix (CVE-2009-0217)
259- remove *.a files
260
261* Sat Jan 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.11-2
262- rebuilt with gnutls-2.6.3
263
264* Wed Jul 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.11-1
265- new upstream release
266
267* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.9-0vl1
268- initial build for Vine Linux
269
270* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.2.9-8.1
271- rebuild
272
273* Wed Jun 14 2006 Tomas Mraz <tmraz@redhat.com> - 1.2.9-8
274- rebuilt with new gnutls
275
276* Thu Jun  8 2006 Daniel Veillard <veillard@redhat.com> - 1.2.9-7
277- oops libxmlsec1.la was still there, should fix #171410 and #154142
278
279* Thu Jun  8 2006 Daniel Veillard <veillard@redhat.com> - 1.2.9-6
280- Ugly patch and sed based changes to work around #192756 xmlsec1-config
281  multilib problem
282
283* Wed Jun  7 2006 Jeremy Katz <katzj@redhat.com> - 1.2.9-5
284- move .so symlinks to -devel subpackage
285
286* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.2.9-4.2
287- bump again for double-long bug on ppc(64)
288
289* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.2.9-4.1
290- rebuilt for new gcc4.1 snapshot and glibc changes
291
292* Thu Dec 15 2005 Christopher Aillon <caillon@redhat.com> 1.2.9-4
293- NSS has been split out of the mozilla package, so require that now
294  and update separate_nspr.patch to account for the new NSS as well
295
296* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
297- rebuilt
298
299* Wed Nov 23 2005 Tomas Mraz <tmraz@redhat.com> 1.2.9-3
300- rebuilt due to gnutls library revision
301* Wed Nov  9 2005 <veillard@redhat.com> 1.2.9-2
302- rebuilt due to openssl library revision
303* Tue Sep 20 2005 <veillard@redhat.com> 1.2.9-1
304- update from upstream, release done in July
305- apparently nss is now available on ppc64
306* Mon Aug  8 2005 <veillard@redhat.com> 1.2.8-3
307- rebuilt with new gnutls
308- nspr has been split to a separate package
309* Fri Jul  8 2005 Daniel Veillard <veillard@redhat.com> 1.2.8-2
310- Enabling the mozilla-nss crypto backend
311* Fri Jul  8 2005 Daniel Veillard <veillard@redhat.com> 1.2.8-1
312- update from upstream, needed for openoffice
313* Tue Mar  8 2005 Daniel Veillard <veillard@redhat.com> 1.2.7-4
314- rebuilt with gcc4
315* Wed Feb 23 2005 Daniel Veillard <veillard@redhat.com> 1.2.7-1
316- Upstream release of 1.2.7, mostly bug fixes plus new functions
317  to GetKeys from simple store and X509 handling.
318* Wed Feb  9 2005 Daniel Veillard <veillard@redhat.com> 1.2.6-4
319- Adding support for GNUTls crypto backend
320* Wed Sep  1 2004 Daniel Veillard <veillard@redhat.com> 1.2.6-3
321- adding missing ldconfig calls
322* Thu Aug 26 2004 Daniel Veillard <veillard@redhat.com> 1.2.6-2
323- updated with upstream release from Aleksey
324* Mon Jun 21 2004 Daniel Veillard <veillard@redhat.com> 1.2.5-2
325- rebuilt
326* Mon Apr 19 2004 Daniel Veillard <veillard@redhat.com> 1.2.5-1
327- updated with upstream release from Aleksey
328* Wed Feb 11 2004 Daniel Veillard <veillard@redhat.com> 1.2.4-1
329- updated with upstream release from Aleksey
330* Tue Jan  6 2004 Daniel Veillard <veillard@redhat.com> 1.2.3-1
331- updated with upstream release from Aleksey
332* Wed Nov 12 2003 Daniel Veillard <veillard@redhat.com> 1.2.2-1
333- updated with upstream release from Aleksey, specific patches should
334  have been integrated now.
335* Thu Nov  6 2003 Daniel Veillard <veillard@redhat.com> 1.2.1-1
336- initial packaging based on the upstream one and libxml2 one.
337- desactivated mozilla-nss due to detection/architecture problems
Note: See TracBrowser for help on using the repository browser.