source: projects/specs/trunk/x/xmlsec1/xmlsec1-vl.spec @ 9908

Revision 9908, 10.5 KB checked in by tomop, 8 years ago (diff)

xmlsec1-1.2.20-3

Line 
1Summary: Library providing support for "XML Signature" and "XML Encryption" standards
2Name: xmlsec1
3Version: 1.2.20
4Release: 3%{?_dist_release}
5License: MIT
6Group: System Environment/Libraries
7URL: http://www.aleksey.com/xmlsec/
8Source: ftp://ftp.aleksey.com/pub/xmlsec/releases/xmlsec1-%{version}.tar.gz
9
10BuildRoot: %{_tmppath}/%{name}-%{version}-root
11BuildRequires: libxml2-devel >= 2.6.0
12BuildRequires: libxslt-devel >= 1.1.0
13BuildRequires: openssl-devel >= 0.9.6
14BuildRequires: libgcrypt-devel >= 1.4.0
15BuildRequires: gnutls-devel >= 1.0.20
16BuildRequires: nss-devel >= 3.2
17BuildRequires: nspr-devel
18BuildRequires: libtool-ltdl-devel
19# extra build deps needed for autoreconf after above patch
20BuildRequires: autoconf
21BuildRequires: automake
22BuildRequires: gettext-devel
23BuildRequires: libtool
24
25%description
26XML Security Library is a C library based on LibXML2  and OpenSSL.
27The library was created with a goal to support major XML security
28standards "XML Digital Signature" and "XML Encryption".
29
30%package devel
31Summary: Libraries, includes, etc. to develop applications with XML Digital Signatures and XML Encryption support.
32Group: Development/Libraries
33Requires: xmlsec1 = %{version}-%{release}
34Requires: libxml2-devel >= 2.6.0
35Requires: libxslt-devel >= 1.1.0
36Requires: openssl-devel >= 0.9.6
37Requires: zlib-devel
38Requires: pkgconfig
39
40%description devel
41Libraries, includes, etc. you can use to develop applications with XML Digital
42Signatures and XML Encryption support.
43
44%package openssl
45Summary: OpenSSL crypto plugin for XML Security Library
46Group: System Environment/Libraries
47Requires: xmlsec1 = %{version}-%{release}
48
49%description openssl
50OpenSSL plugin for XML Security Library provides OpenSSL based crypto services
51for the xmlsec library
52
53%package openssl-devel
54Summary: OpenSSL crypto plugin for XML Security Library
55Group: Development/Libraries
56Requires: xmlsec1-devel = %{version}-%{release}
57Requires: xmlsec1-openssl = %{version}-%{release}
58
59%description openssl-devel
60Libraries, includes, etc. for developing XML Security applications with OpenSSL
61
62%package gcrypt
63Summary: GCrypt crypto plugin for XML Security Library
64Group: System Environment/Libraries
65Requires: xmlsec1 = %{version}-%{release}
66
67%description gcrypt
68GCrypt plugin for XML Security Library provides GCrypt based crypto services
69for the xmlsec library.
70
71%package gcrypt-devel
72Summary: GCrypt crypto plugin for XML Security Library
73Group: Development/Libraries
74Requires: xmlsec1-devel = %{version}-%{release}
75Requires: xmlsec1-gnutls-devel = %{version}-%{release}
76
77%description gcrypt-devel
78Libraries, includes, etc. for developing XML Security applications with GCrypt.
79
80%package gnutls
81Summary: GNUTls crypto plugin for XML Security Library
82Group: System Environment/Libraries
83Requires: xmlsec1 = %{version}-%{release}
84
85%description gnutls
86GNUTls plugin for XML Security Library provides GNUTls based crypto services
87for the xmlsec library
88
89%package gnutls-devel
90Summary: GNUTls crypto plugin for XML Security Library
91Group: Development/Libraries
92Requires: xmlsec1 = %{version}
93Requires: xmlsec1-devel = %{version}
94Requires: xmlsec1-openssl = %{version}
95Requires: libgcrypt-devel >= 1.2.0
96Requires: gnutls-devel >= 1.0.20
97
98%description gnutls-devel
99Libraries, includes, etc. for developing XML Security applications with GNUTls
100
101%package nss
102Summary: NSS crypto plugin for XML Security Library
103Group: System Environment/Libraries
104Requires: xmlsec1 = %{version}-%{release}
105
106%description nss
107NSS plugin for XML Security Library provides NSS based crypto services
108for the xmlsec library
109
110%package nss-devel
111Summary: NSS crypto plugin for XML Security Library
112Group: Development/Libraries
113Requires: xmlsec1-devel = %{version}-%{release}
114Requires: xmlsec1-nss = %{version}-%{release}
115Requires: nss-devel >= 3.2
116Requires: nspr-devel
117
118%description nss-devel
119Libraries, includes, etc. for developing XML Security applications with NSS
120
121%prep
122%setup -q
123
124%build
125autoreconf -if
126%configure --enable-silent-rules --disable-static
127
128sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
129sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
130make
131
132# positively ugly but only sane way to get around #192756
133sed 's+/lib64+/$archlib+g' < xmlsec1-config | sed 's+/lib+/$archlib+g' | sed 's+ -DXMLSEC_NO_SIZE_T++' > xmlsec1-config.$$ && mv xmlsec1-config.$$ xmlsec1-config
134
135%install
136rm -rf $RPM_BUILD_ROOT
137mkdir -p $RPM_BUILD_ROOT/usr/bin
138mkdir -p $RPM_BUILD_ROOT/usr/include/xmlsec1
139mkdir -p $RPM_BUILD_ROOT%{_libdir}
140mkdir -p $RPM_BUILD_ROOT/usr/man/man1
141
142make install DESTDIR=$RPM_BUILD_ROOT
143#make prefix=$RPM_BUILD_ROOT%{prefix} mandir=$RPM_BUILD_ROOT%{_mandir} install
144rm -fv $RPM_BUILD_ROOT%{_libdir}/*.la
145#rm -fv $RPM_BUILD_ROOT%{_libdir}/*.a
146
147rm -rf docs-to-install
148mkdir -p docs-to-install
149cp -pr $RPM_BUILD_ROOT%{_datadir}/doc/xmlsec1/* docs-to-install
150rm -rf $RPM_BUILD_ROOT%{_datadir}/doc/xmlsec1
151
152%clean
153rm -fr %{buildroot}
154
155%post -p /sbin/ldconfig
156
157%postun -p /sbin/ldconfig
158
159%post openssl -p /sbin/ldconfig
160
161%postun openssl -p /sbin/ldconfig
162
163%post gcrypt -p /sbin/ldconfig
164
165%postun gcrypt -p /sbin/ldconfig
166
167%post gnutls -p /sbin/ldconfig
168
169%postun gnutls -p /sbin/ldconfig
170
171%post nss -p /sbin/ldconfig
172
173%postun nss -p /sbin/ldconfig
174
175
176%files
177%defattr(-, root, root)
178%doc AUTHORS ChangeLog NEWS README Copyright
179%doc %{_mandir}/man1/xmlsec1.1*
180%{_libdir}/libxmlsec1.so.*
181%{_bindir}/xmlsec1
182
183%files devel
184%defattr(-, root, root) 
185%{_bindir}/xmlsec1-config
186%{_includedir}/xmlsec1/xmlsec/*.h
187%{_includedir}/xmlsec1/xmlsec/private/*.h
188%{_libdir}/libxmlsec1.so
189%{_libdir}/pkgconfig/xmlsec1.pc
190%{_libdir}/xmlsec1Conf.sh
191%{_datadir}/aclocal/*.m4
192%doc AUTHORS HACKING ChangeLog NEWS README Copyright
193%doc docs-to-install/*
194%doc %{_mandir}/man1/xmlsec1-config.1*
195
196%files openssl
197%defattr(-, root, root) 
198%{_libdir}/libxmlsec1-openssl.so
199%{_libdir}/libxmlsec1-openssl.so.*
200
201%files openssl-devel
202%defattr(-, root, root) 
203%{_includedir}/xmlsec1/xmlsec/openssl/*.h
204%{_libdir}/pkgconfig/xmlsec1-openssl.pc
205
206%files gcrypt
207%defattr(-, root, root, -)
208%{_libdir}/libxmlsec1-gcrypt.so
209%{_libdir}/libxmlsec1-gcrypt.so.*
210
211%files gcrypt-devel
212%defattr(-, root, root, -)
213%{_includedir}/xmlsec1/xmlsec/gcrypt/
214%{_libdir}/pkgconfig/xmlsec1-gcrypt.pc
215
216%files gnutls
217%defattr(-, root, root) 
218%{_libdir}/libxmlsec1-gnutls.so
219%{_libdir}/libxmlsec1-gnutls.so.*
220
221%files gnutls-devel
222%defattr(-, root, root) 
223%{_includedir}/xmlsec1/xmlsec/gnutls/*.h
224%{_libdir}/pkgconfig/xmlsec1-gnutls.pc
225
226%files nss
227%defattr(-, root, root) 
228%{_libdir}/libxmlsec1-nss.so
229%{_libdir}/libxmlsec1-nss.so.*
230
231%files nss-devel
232%defattr(-, root, root) 
233%{_includedir}/xmlsec1/xmlsec/nss/*.h
234%{_libdir}/pkgconfig/xmlsec1-nss.pc
235
236%changelog
237* Wed Dec 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.20-3
238- rebuilt with gnutls-3.4.x.
239
240* Fri Jul  3 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.20-2
241- fixed %%files.
242
243* Sat Nov  1 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.2.20-1
244- new upstream release
245- moved gcrypt to System Environment/Libraries Group
246
247* Sat Jan 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.16-1
248- new upstream release
249- add BuildRequires: libtool-ltdl-devel
250- add -gcrypt,-gcrypt-devel package
251
252* Fri Jul 24 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.12-1
253- new upstream release with security fix (CVE-2009-0217)
254- remove *.a files
255
256* Sat Jan 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.11-2
257- rebuilt with gnutls-2.6.3
258
259* Wed Jul 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.11-1
260- new upstream release
261
262* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.9-0vl1
263- initial build for Vine Linux
264
265* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.2.9-8.1
266- rebuild
267
268* Wed Jun 14 2006 Tomas Mraz <tmraz@redhat.com> - 1.2.9-8
269- rebuilt with new gnutls
270
271* Thu Jun  8 2006 Daniel Veillard <veillard@redhat.com> - 1.2.9-7
272- oops libxmlsec1.la was still there, should fix #171410 and #154142
273
274* Thu Jun  8 2006 Daniel Veillard <veillard@redhat.com> - 1.2.9-6
275- Ugly patch and sed based changes to work around #192756 xmlsec1-config
276  multilib problem
277
278* Wed Jun  7 2006 Jeremy Katz <katzj@redhat.com> - 1.2.9-5
279- move .so symlinks to -devel subpackage
280
281* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.2.9-4.2
282- bump again for double-long bug on ppc(64)
283
284* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.2.9-4.1
285- rebuilt for new gcc4.1 snapshot and glibc changes
286
287* Thu Dec 15 2005 Christopher Aillon <caillon@redhat.com> 1.2.9-4
288- NSS has been split out of the mozilla package, so require that now
289  and update separate_nspr.patch to account for the new NSS as well
290
291* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
292- rebuilt
293
294* Wed Nov 23 2005 Tomas Mraz <tmraz@redhat.com> 1.2.9-3
295- rebuilt due to gnutls library revision
296* Wed Nov  9 2005 <veillard@redhat.com> 1.2.9-2
297- rebuilt due to openssl library revision
298* Tue Sep 20 2005 <veillard@redhat.com> 1.2.9-1
299- update from upstream, release done in July
300- apparently nss is now available on ppc64
301* Mon Aug  8 2005 <veillard@redhat.com> 1.2.8-3
302- rebuilt with new gnutls
303- nspr has been split to a separate package
304* Fri Jul  8 2005 Daniel Veillard <veillard@redhat.com> 1.2.8-2
305- Enabling the mozilla-nss crypto backend
306* Fri Jul  8 2005 Daniel Veillard <veillard@redhat.com> 1.2.8-1
307- update from upstream, needed for openoffice
308* Tue Mar  8 2005 Daniel Veillard <veillard@redhat.com> 1.2.7-4
309- rebuilt with gcc4
310* Wed Feb 23 2005 Daniel Veillard <veillard@redhat.com> 1.2.7-1
311- Upstream release of 1.2.7, mostly bug fixes plus new functions
312  to GetKeys from simple store and X509 handling.
313* Wed Feb  9 2005 Daniel Veillard <veillard@redhat.com> 1.2.6-4
314- Adding support for GNUTls crypto backend
315* Wed Sep  1 2004 Daniel Veillard <veillard@redhat.com> 1.2.6-3
316- adding missing ldconfig calls
317* Thu Aug 26 2004 Daniel Veillard <veillard@redhat.com> 1.2.6-2
318- updated with upstream release from Aleksey
319* Mon Jun 21 2004 Daniel Veillard <veillard@redhat.com> 1.2.5-2
320- rebuilt
321* Mon Apr 19 2004 Daniel Veillard <veillard@redhat.com> 1.2.5-1
322- updated with upstream release from Aleksey
323* Wed Feb 11 2004 Daniel Veillard <veillard@redhat.com> 1.2.4-1
324- updated with upstream release from Aleksey
325* Tue Jan  6 2004 Daniel Veillard <veillard@redhat.com> 1.2.3-1
326- updated with upstream release from Aleksey
327* Wed Nov 12 2003 Daniel Veillard <veillard@redhat.com> 1.2.2-1
328- updated with upstream release from Aleksey, specific patches should
329  have been integrated now.
330* Thu Nov  6 2003 Daniel Veillard <veillard@redhat.com> 1.2.1-1
331- initial packaging based on the upstream one and libxml2 one.
332- desactivated mozilla-nss due to detection/architecture problems
Note: See TracBrowser for help on using the repository browser.