source: projects/specs/trunk/x/xmlsec1/xmlsec1-vl.spec @ 12328

Revision 12328, 10.9 KB checked in by tomop, 4 years ago (diff)

updated 6 packages

libmodsecurity-3.0.4-1

nginx-1.16.1-5

pcre-8.44-1

pcre2-10.34-1

sysstat-12.2.1-1

xmlsec1-1.2.29-1

Line 
1Summary: Library providing support for "XML Signature" and "XML Encryption" standards
2Name: xmlsec1
3Version: 1.2.29
4Release: 1%{?_dist_release}
5License: MIT
6Group: System Environment/Libraries
7URL: https://www.aleksey.com/xmlsec/
8Source: https://www.aleksey.com/xmlsec/download/xmlsec1-%{version}.tar.gz
9Vendor: Project Vine
10Distribution: Vine Linux
11
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13BuildRequires: libxml2-devel >= 2.6.0
14BuildRequires: libxslt-devel >= 1.1.0
15BuildRequires: openssl-devel >= 0.9.6
16BuildRequires: libgcrypt-devel >= 1.4.0
17BuildRequires: gnutls-devel >= 1.0.20
18BuildRequires: nss-devel >= 3.2
19BuildRequires: nspr-devel
20BuildRequires: libtool-ltdl-devel
21# extra build deps needed for autoreconf after above patch
22BuildRequires: autoconf
23BuildRequires: automake
24BuildRequires: gettext-devel
25BuildRequires: libtool
26
27%description
28XML Security Library is a C library based on LibXML2  and OpenSSL.
29The library was created with a goal to support major XML security
30standards "XML Digital Signature" and "XML Encryption".
31
32%package devel
33Summary: Libraries, includes, etc. to develop applications with XML Digital Signatures and XML Encryption support.
34Group: Development/Libraries
35Requires: xmlsec1 = %{version}-%{release}
36Requires: libxml2-devel >= 2.6.0
37Requires: libxslt-devel >= 1.1.0
38Requires: openssl-devel >= 0.9.6
39Requires: zlib-devel
40Requires: pkgconfig
41
42%description devel
43Libraries, includes, etc. you can use to develop applications with XML Digital
44Signatures and XML Encryption support.
45
46%package openssl
47Summary: OpenSSL crypto plugin for XML Security Library
48Group: System Environment/Libraries
49Requires: xmlsec1 = %{version}-%{release}
50
51%description openssl
52OpenSSL plugin for XML Security Library provides OpenSSL based crypto services
53for the xmlsec library
54
55%package openssl-devel
56Summary: OpenSSL crypto plugin for XML Security Library
57Group: Development/Libraries
58Requires: xmlsec1-devel = %{version}-%{release}
59Requires: xmlsec1-openssl = %{version}-%{release}
60
61%description openssl-devel
62Libraries, includes, etc. for developing XML Security applications with OpenSSL
63
64%package gcrypt
65Summary: GCrypt crypto plugin for XML Security Library
66Group: System Environment/Libraries
67Requires: xmlsec1 = %{version}-%{release}
68
69%description gcrypt
70GCrypt plugin for XML Security Library provides GCrypt based crypto services
71for the xmlsec library.
72
73%package gcrypt-devel
74Summary: GCrypt crypto plugin for XML Security Library
75Group: Development/Libraries
76Requires: xmlsec1-devel = %{version}-%{release}
77Requires: xmlsec1-gnutls-devel = %{version}-%{release}
78
79%description gcrypt-devel
80Libraries, includes, etc. for developing XML Security applications with GCrypt.
81
82%package gnutls
83Summary: GNUTls crypto plugin for XML Security Library
84Group: System Environment/Libraries
85Requires: xmlsec1 = %{version}-%{release}
86
87%description gnutls
88GNUTls plugin for XML Security Library provides GNUTls based crypto services
89for the xmlsec library
90
91%package gnutls-devel
92Summary: GNUTls crypto plugin for XML Security Library
93Group: Development/Libraries
94Requires: xmlsec1 = %{version}
95Requires: xmlsec1-devel = %{version}
96Requires: xmlsec1-openssl = %{version}
97Requires: libgcrypt-devel >= 1.2.0
98Requires: gnutls-devel >= 1.0.20
99
100%description gnutls-devel
101Libraries, includes, etc. for developing XML Security applications with GNUTls
102
103%package nss
104Summary: NSS crypto plugin for XML Security Library
105Group: System Environment/Libraries
106Requires: xmlsec1 = %{version}-%{release}
107
108%description nss
109NSS plugin for XML Security Library provides NSS based crypto services
110for the xmlsec library
111
112%package nss-devel
113Summary: NSS crypto plugin for XML Security Library
114Group: Development/Libraries
115Requires: xmlsec1-devel = %{version}-%{release}
116Requires: xmlsec1-nss = %{version}-%{release}
117Requires: nss-devel >= 3.2
118Requires: nspr-devel
119
120%description nss-devel
121Libraries, includes, etc. for developing XML Security applications with NSS
122
123%prep
124%setup -q
125
126%build
127autoreconf -if
128%configure --enable-silent-rules --disable-static
129
130sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
131sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
132make
133
134# positively ugly but only sane way to get around #192756
135sed 's+/lib64+/$archlib+g' < xmlsec1-config | sed 's+/lib+/$archlib+g' | sed 's+ -DXMLSEC_NO_SIZE_T++' > xmlsec1-config.$$ && mv xmlsec1-config.$$ xmlsec1-config
136
137%install
138rm -rf $RPM_BUILD_ROOT
139mkdir -p $RPM_BUILD_ROOT/usr/bin
140mkdir -p $RPM_BUILD_ROOT/usr/include/xmlsec1
141mkdir -p $RPM_BUILD_ROOT%{_libdir}
142mkdir -p $RPM_BUILD_ROOT/usr/man/man1
143
144make install DESTDIR=$RPM_BUILD_ROOT
145#make prefix=$RPM_BUILD_ROOT%{prefix} mandir=$RPM_BUILD_ROOT%{_mandir} install
146rm -fv $RPM_BUILD_ROOT%{_libdir}/*.la
147#rm -fv $RPM_BUILD_ROOT%{_libdir}/*.a
148
149rm -rf docs-to-install
150mkdir -p docs-to-install
151cp -pr $RPM_BUILD_ROOT%{_datadir}/doc/xmlsec1/* docs-to-install
152rm -rf $RPM_BUILD_ROOT%{_datadir}/doc/xmlsec1
153
154%clean
155rm -fr %{buildroot}
156
157%post -p /sbin/ldconfig
158
159%postun -p /sbin/ldconfig
160
161%post openssl -p /sbin/ldconfig
162
163%postun openssl -p /sbin/ldconfig
164
165%post gcrypt -p /sbin/ldconfig
166
167%postun gcrypt -p /sbin/ldconfig
168
169%post gnutls -p /sbin/ldconfig
170
171%postun gnutls -p /sbin/ldconfig
172
173%post nss -p /sbin/ldconfig
174
175%postun nss -p /sbin/ldconfig
176
177
178%files
179%defattr(-, root, root)
180%license Copyright
181%doc AUTHORS ChangeLog NEWS README
182%doc %{_mandir}/man1/xmlsec1.1*
183%{_libdir}/libxmlsec1.so.*
184%{_bindir}/xmlsec1
185
186%files devel
187%defattr(-, root, root) 
188%{_bindir}/xmlsec1-config
189%{_includedir}/xmlsec1
190%exclude %{_includedir}/xmlsec1/xmlsec/gcrypt
191%exclude %{_includedir}/xmlsec1/xmlsec/gnutls
192%exclude %{_includedir}/xmlsec1/xmlsec/nss
193%exclude %{_includedir}/xmlsec1/xmlsec/openssl
194%{_libdir}/libxmlsec1.so
195%{_libdir}/pkgconfig/xmlsec1.pc
196%{_libdir}/xmlsec1Conf.sh
197%{_datadir}/aclocal/*.m4
198%license Copyright
199%doc AUTHORS HACKING ChangeLog NEWS README
200%doc docs-to-install/*
201%doc %{_mandir}/man1/xmlsec1-config.1*
202
203%files openssl
204%defattr(-, root, root) 
205%{_libdir}/libxmlsec1-openssl.so
206%{_libdir}/libxmlsec1-openssl.so.*
207
208%files openssl-devel
209%defattr(-, root, root) 
210%{_includedir}/xmlsec1/xmlsec/openssl
211%{_libdir}/pkgconfig/xmlsec1-openssl.pc
212
213%files gcrypt
214%defattr(-, root, root, -)
215%{_libdir}/libxmlsec1-gcrypt.so
216%{_libdir}/libxmlsec1-gcrypt.so.*
217
218%files gcrypt-devel
219%defattr(-, root, root, -)
220%{_includedir}/xmlsec1/xmlsec/gcrypt
221%{_libdir}/pkgconfig/xmlsec1-gcrypt.pc
222
223%files gnutls
224%defattr(-, root, root) 
225%{_libdir}/libxmlsec1-gnutls.so
226%{_libdir}/libxmlsec1-gnutls.so.*
227
228%files gnutls-devel
229%defattr(-, root, root) 
230%{_includedir}/xmlsec1/xmlsec/gnutls
231%{_libdir}/pkgconfig/xmlsec1-gnutls.pc
232
233%files nss
234%defattr(-, root, root) 
235%{_libdir}/libxmlsec1-nss.so
236%{_libdir}/libxmlsec1-nss.so.*
237
238%files nss-devel
239%defattr(-, root, root) 
240%{_includedir}/xmlsec1/xmlsec/nss
241%{_libdir}/pkgconfig/xmlsec1-nss.pc
242
243%changelog
244* Mon Mar 09 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.29-1
245- new upstream release.
246
247* Wed Dec 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.27-1
248- new upstream release.
249
250* Mon May  9 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.22-1
251- new upstream release.
252
253* Wed Dec 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.20-3
254- rebuilt with gnutls-3.4.x.
255
256* Fri Jul  3 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.20-2
257- fixed %%files.
258
259* Sat Nov  1 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.2.20-1
260- new upstream release
261- moved gcrypt to System Environment/Libraries Group
262
263* Sat Jan 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.16-1
264- new upstream release
265- add BuildRequires: libtool-ltdl-devel
266- add -gcrypt,-gcrypt-devel package
267
268* Fri Jul 24 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.12-1
269- new upstream release with security fix (CVE-2009-0217)
270- remove *.a files
271
272* Sat Jan 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.11-2
273- rebuilt with gnutls-2.6.3
274
275* Wed Jul 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.11-1
276- new upstream release
277
278* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.9-0vl1
279- initial build for Vine Linux
280
281* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.2.9-8.1
282- rebuild
283
284* Wed Jun 14 2006 Tomas Mraz <tmraz@redhat.com> - 1.2.9-8
285- rebuilt with new gnutls
286
287* Thu Jun  8 2006 Daniel Veillard <veillard@redhat.com> - 1.2.9-7
288- oops libxmlsec1.la was still there, should fix #171410 and #154142
289
290* Thu Jun  8 2006 Daniel Veillard <veillard@redhat.com> - 1.2.9-6
291- Ugly patch and sed based changes to work around #192756 xmlsec1-config
292  multilib problem
293
294* Wed Jun  7 2006 Jeremy Katz <katzj@redhat.com> - 1.2.9-5
295- move .so symlinks to -devel subpackage
296
297* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.2.9-4.2
298- bump again for double-long bug on ppc(64)
299
300* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.2.9-4.1
301- rebuilt for new gcc4.1 snapshot and glibc changes
302
303* Thu Dec 15 2005 Christopher Aillon <caillon@redhat.com> 1.2.9-4
304- NSS has been split out of the mozilla package, so require that now
305  and update separate_nspr.patch to account for the new NSS as well
306
307* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
308- rebuilt
309
310* Wed Nov 23 2005 Tomas Mraz <tmraz@redhat.com> 1.2.9-3
311- rebuilt due to gnutls library revision
312* Wed Nov  9 2005 <veillard@redhat.com> 1.2.9-2
313- rebuilt due to openssl library revision
314* Tue Sep 20 2005 <veillard@redhat.com> 1.2.9-1
315- update from upstream, release done in July
316- apparently nss is now available on ppc64
317* Mon Aug  8 2005 <veillard@redhat.com> 1.2.8-3
318- rebuilt with new gnutls
319- nspr has been split to a separate package
320* Fri Jul  8 2005 Daniel Veillard <veillard@redhat.com> 1.2.8-2
321- Enabling the mozilla-nss crypto backend
322* Fri Jul  8 2005 Daniel Veillard <veillard@redhat.com> 1.2.8-1
323- update from upstream, needed for openoffice
324* Tue Mar  8 2005 Daniel Veillard <veillard@redhat.com> 1.2.7-4
325- rebuilt with gcc4
326* Wed Feb 23 2005 Daniel Veillard <veillard@redhat.com> 1.2.7-1
327- Upstream release of 1.2.7, mostly bug fixes plus new functions
328  to GetKeys from simple store and X509 handling.
329* Wed Feb  9 2005 Daniel Veillard <veillard@redhat.com> 1.2.6-4
330- Adding support for GNUTls crypto backend
331* Wed Sep  1 2004 Daniel Veillard <veillard@redhat.com> 1.2.6-3
332- adding missing ldconfig calls
333* Thu Aug 26 2004 Daniel Veillard <veillard@redhat.com> 1.2.6-2
334- updated with upstream release from Aleksey
335* Mon Jun 21 2004 Daniel Veillard <veillard@redhat.com> 1.2.5-2
336- rebuilt
337* Mon Apr 19 2004 Daniel Veillard <veillard@redhat.com> 1.2.5-1
338- updated with upstream release from Aleksey
339* Wed Feb 11 2004 Daniel Veillard <veillard@redhat.com> 1.2.4-1
340- updated with upstream release from Aleksey
341* Tue Jan  6 2004 Daniel Veillard <veillard@redhat.com> 1.2.3-1
342- updated with upstream release from Aleksey
343* Wed Nov 12 2003 Daniel Veillard <veillard@redhat.com> 1.2.2-1
344- updated with upstream release from Aleksey, specific patches should
345  have been integrated now.
346* Thu Nov  6 2003 Daniel Veillard <veillard@redhat.com> 1.2.1-1
347- initial packaging based on the upstream one and libxml2 one.
348- desactivated mozilla-nss due to detection/architecture problems
Note: See TracBrowser for help on using the repository browser.