source: projects/specs/trunk/x/xmlrpc-epi/xmlrpc-epi-vl.spec @ 521

Revision 521, 2.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: An implementation of the xmlrpc protocol in C
2Summary(ja): xmlrpc プロトコルの C による実装
3Name:    xmlrpc-epi
4Version: 0.51
5Release: 1%{?_dist_release}
6Group:     Development/Libraries
7License:   BSD
8URL:       http://xmlrpc-epi.sourceforge.net/
9BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
10
11Source0: http://dl.sf.net/sourceforge/xmlrpc-epi/xmlrpc-epi-%{version}.tar.gz
12
13Patch0: xmlrpc-epi-0.51-gcc4.1.patch
14Patch1: xmlrpc-epi-0.51-use-system-expat.patch
15Patch2: xmlrpc-epi-0.51-rename.patch
16
17BuildRequires: expat-devel
18BuildRequires: libtool
19
20%description
21An implementation of the xmlrpc protocol in C.
22
23%package  devel
24Summary:  Development files for xmlrpc-epi
25Group:    Development/Libraries
26Requires: xmlrpc-epi = %{version}-%{release}
27
28%description devel
29The xmlrpc-epi-devel package contains libraries and header files for
30developing applications that use xmlrpc-epi.
31
32%package  examples
33Summary:  Example xmlrpc-epi applications
34Group:    Development/Libraries
35Requires: xmlrpc-epi = %{version}-%{release}
36
37%description examples
38Example xmlrpc-epi applications.
39
40%prep
41%setup -q
42%patch0 -p1
43%patch1 -p1
44%patch2 -p1
45# Previous two patches require we regenerate all autotools
46# As an extra bonus this also fixes the usual x86_64 libtool rpath problems
47libtoolize -c -f
48aclocal
49automake -c -a -f
50autoconf
51
52%build
53%configure --disable-static --includedir=%{_includedir}/xmlrpc-epi
54make %{?_smp_mflags}
55
56%install
57rm -rf %{buildroot}
58make install DESTDIR=%{buildroot}
59find %{buildroot}%{_libdir} -name '*.la' -exec rm -f {} ';'
60
61# compat links
62ln -sf libxmlrpc-epi.so %{buildroot}%{_libdir}/libxmlrpc.so
63
64%clean
65rm -rf %{buildroot}
66
67%post -p /sbin/ldconfig
68
69%postun -p /sbin/ldconfig
70
71%files
72%defattr(-,root,root,-)
73%doc AUTHORS COPYING README
74%{_libdir}/libxmlrpc-epi.so.*
75
76%files devel
77%defattr(-,root,root,-)
78%doc NEWS
79%{_includedir}/xmlrpc-epi
80%{_libdir}/libxmlrpc-epi.so
81%{_libdir}/libxmlrpc.so
82
83%files examples
84%defattr(-,root,root,-)
85%doc
86%{_bindir}/client
87%{_bindir}/hello_client
88%{_bindir}/hello_server
89%{_bindir}/memtest
90%{_bindir}/sample
91%{_bindir}/server
92%{_bindir}/server_compliance_test
93
94%changelog
95* Wed Oct 15 2008 Shu KONNO <owa@bg.wakwak.com> 0.51-1vl5
96- applied new versioning policy, spec in utf-8
97
98* Thu Feb 28 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.51-0vl2
99- rebuild with expat-2.0.1
100
101* Fri Jun 08 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.51-0vl1
102- initial build for Vine Linux
103
104* Sat May 26 2007 Callum Lerwick <seg@haxxed.com> 0.51-3
105- Rename the library so we don't conflict with xmlrpc-c.
106
107* Tue Mar 13 2007 Callum Lerwick <seg@haxxed.com> 0.51-2
108- Ooops, the use-system-expat patch was completely broken. Fixed.
109
110* Sun Feb 04 2007 Callum Lerwick <seg@haxxed.com> 0.51-1
111- Initial packaging.
Note: See TracBrowser for help on using the repository browser.