source: projects/specs/trunk/x/xml-stylebook/xml-stylebook-vl.spec @ 9447

Revision 9447, 5.7 KB checked in by inagaki, 9 years ago (diff)

2015-03-21 Ryoichi INAGAKi <ryo1@…>

  • antlr, junit, xalan-j2: updated
  • bcel, xml-stylebook: new


Line 
1Name:          xml-stylebook
2Version:       1.0
3Release:       1%{?_dist_release}
4Summary:       Apache XML Stylebook
5Summary(ja):   Apache XML スタイルブック
6
7Group:         Development/Libraries
8License:       ASL 1.1
9URL:           http://xml.apache.org/
10
11# How to generate this tarball:
12#  $ svn export http://svn.apache.org/repos/asf/xml/stylebook/trunk/@313293 xml-stylebook-1.0
13#  $ tar zcf xml-stylebook-1.0.tar.gz xml-stylebook-1.0
14Source0:       %{name}-%{version}.tar.gz
15
16# Patch to fix an NPE in Xalan-J2's docs generation (from JPackage)
17Patch0:        %{name}-image-printer.patch
18# Patch the build script to build javadocs
19Patch1:        %{name}-build-javadoc.patch
20
21BuildRoot:     %{_tmppath}/%{name}-%{version}-root
22BuildArch:     noarch
23BuildRequires: java-devel >= 1.6.0
24BuildRequires: java-javadoc
25BuildRequires: jpackage-utils
26BuildRequires: ant
27BuildRequires: xml-commons-apis
28BuildRequires: xerces-j2
29BuildRequires: TrueType-dejavu-sans
30#BuildRequires: dejavu-sans-fonts
31Requires:      java-headless
32Requires:      jpackage-utils
33Requires:      xml-commons-apis
34Requires:      xerces-j2
35
36%description
37Apache XML Stylebook is a HTML documentation generator.
38
39%package       javadoc
40Summary:       API documentation for %{name}
41Summary(ja):   %{name} の API ドキュメント
42Group:         Documentation
43Requires:      java-javadoc
44
45%description   javadoc
46%{summary}.
47
48%package       demo
49Summary:       Examples for %{name}
50Summary(ja):   %{name} のデモ集
51Group:         Development/Libraries
52Requires:      %{name} = %{version}-%{release}
53
54%description   demo
55Examples demonstrating the use of %{name}.
56
57%prep
58%setup -q
59%patch0 -p0
60%patch1 -p0
61
62# Remove bundled binaries
63rm -r bin/*.jar
64
65# Don't include this sample theme because it contains an errant font
66rm -r styles/christmas/
67
68# Make sure upstream hasn't sneaked in any jars we don't know about
69JARS=""
70for j in `find -name "*.jar"`; do
71    if [ ! -L $j ]; then
72        JARS="$JARS $j"
73    fi
74done
75if [ ! -z "$JARS" ]; then
76    echo "These jars should be deleted and symlinked to system jars: $JARS"
77    exit 1
78fi
79
80%build
81ant
82
83# Build the examples (this serves as a good test suite)
84pushd docs
85rm run.bat
86java -classpath "$(build-classpath xml-commons-apis):$(build-classpath jaxp_parser_impl):../bin/stylebook-%{version}-b3_xalan-2.jar" \
87     org.apache.stylebook.StyleBook "targetDirectory=../results" book.xml ../styles/apachexml
88popd
89
90%install
91rm -rf %{buildroot}
92# jars
93install -pD -T bin/stylebook-%{version}-b3_xalan-2.jar \
94  %{buildroot}%{_javadir}/%{name}.jar
95
96# javadoc
97install -d %{buildroot}%{_javadocdir}/%{name}
98cp -pr build/javadoc/* %{buildroot}%{_javadocdir}/%{name}
99
100# examples
101install -d %{buildroot}%{_datadir}/%{name}
102cp -pr docs %{buildroot}%{_datadir}/%{name}
103cp -pr styles %{buildroot}%{_datadir}/%{name}
104cp -pr results %{buildroot}%{_datadir}/%{name}
105
106%clean
107rm -rf %{buildroot}
108
109
110%files
111%doc LICENSE.txt
112%{_javadir}/*
113
114%files javadoc
115%doc LICENSE.txt
116%{_javadocdir}/%{name}
117
118%files demo
119%{_datadir}/%{name}
120
121%changelog
122* Fri Mar 20 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.0-1
123- Initial build for Vine Linux
124
125* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-0.16.b3_xalan2.svn313293
126- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
127
128* Tue Mar 04 2014 Stanislav Ochotnicky <sochotnicky@redhat.com> - 1.0-0.15.b3_xalan2.svn313293
129- Use Requires: java-headless rebuild (#1067528)
130
131* Mon Aug 12 2013 Mat Booth <fedora@matbooth.co.uk> - 1.0-0.14.b3_xalan2.svn313293
132- Prefer xerces-j2 instead of gcj for providing jaxp_parser_impl
133
134* Sat Aug 10 2013 Mat Booth <fedora@matbooth.co.uk> - 1.0-0.13.b3_xalan2.svn313293
135- Update for newer guidelines
136
137* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-0.12.b3_xalan2.svn313293
138- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
139
140* Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-0.11.b3_xalan2.svn313293
141- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
142
143* Sun Jul 22 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-0.10.b3_xalan2.svn313293
144- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
145
146* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-0.9.b3_xalan2.svn313293
147- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
148
149* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-0.8.b3_xalan2.svn313293
150- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
151
152* Sun Dec 12 2010 Mat Booth <fedora@matbooth.co.uk> - 1.0-0.7.b3_xalan2.svn313293
153- Really fix FTBFS this time.
154
155* Sun Dec 12 2010 Mat Booth <fedora@matbooth.co.uk> - 1.0-0.6.b3_xalan2.svn313293
156- Fix FTBFS due to ant upgrade.
157
158* Sat Jun 12 2010 Mat Booth <fedora@matbooth.co.uk> - 1.0-0.5.b3_xalan2.svn313293
159- Link to local java API docs properly and fix requires on javadoc package.
160- Build with source and target levels of 1.5 so we don't have to require 1.6.
161
162* Thu Apr 22 2010 Mat Booth <fedora@matbooth.co.uk> - 1.0-0.4.b3_xalan2.svn313293
163- Remove font from demo package to comply with guidelines. RHBZ #567912
164
165* Mon Jan 11 2010 Mat Booth <fedora@matbooth.co.uk> - 1.0-0.3.b3_xalan2.svn313293
166- Build the examples (this serves as a good test suite.)
167- Patch the build script to build javadocs.
168- Add a build dep on a font package because the JDK is missing a dependency
169  to function correctly in headless mode. See RHBZ #478480 and #521523.
170
171* Tue Jan 5 2010 Mat Booth <fedora@matbooth.co.uk> - 1.0-0.2.b3_xalan2.svn313293
172- Add patch from JPackage to fix NPE in Xalan-J2 doc generation.
173
174* Tue Jan 5 2010 Mat Booth <fedora@matbooth.co.uk> - 1.0-0.1.b3_xalan2.svn313293
175- Initial stab at packaging trunk version of stylebook.
176
Note: See TracBrowser for help on using the repository browser.