source: projects/specs/trunk/x/xml-commons-apis/xml-commons-apis-vl.spec @ 9288

Revision 9288, 9.6 KB checked in by inagaki, 9 years ago (diff)

2015-01-24 Ryoichi INAGAKI <ryo1@…>

  • java_cup: added Patch
  • rhino, xerces-c, xml-common-apis, xmlcopyeditor: updated


Line 
1Name:           xml-commons-apis
2Version:        1.4.01
3Release:        1%{?_dist_release}
4Summary:        APIs for DOM, SAX, and JAXP
5Summary(ja):    DOX, SAX, JAXP 用 API
6
7Group:          Development/Libraries
8License:        ASL 2.0 and W3C and Public Domain
9URL:            http://xml.apache.org/commons/
10
11# From source control because the published tarball doesn't include some docs:
12#   svn export http://svn.apache.org/repos/asf/xml/commons/tags/xml-commons-external-1_4_01/java/external/
13#   tar czf xml-commons-external-1.4.01-src.tar.gz external
14Source0:       xml-commons-external-%{version}-src.tar.gz
15Source1:       %{name}-MANIFEST.MF
16Source2:       %{name}-ext-MANIFEST.MF
17Source3:       http://repo1.maven.org/maven2/xml-apis/xml-apis/2.0.2/xml-apis-2.0.2.pom
18Source4:       http://repo1.maven.org/maven2/xml-apis/xml-apis-ext/1.3.04/xml-apis-ext-1.3.04.pom
19
20BuildRoot:      %{_tmppath}/%{name}-%{version}-root
21BuildArch:      noarch
22BuildRequires:  java-devel
23BuildRequires:  jpackage-utils
24BuildRequires:  ant
25BuildRequires:  zip
26Requires:       java-headless
27Requires:       jpackage-utils
28
29Obsoletes:      xml-commons < %{version}-%{release}
30Provides:       xml-commons = %{version}-%{release}
31
32# TODO: Ugh, this next line should be dropped since it actually provides JAXP 1.4 now...
33Provides:       xml-commons-jaxp-1.3-apis = %{version}-%{release}
34
35%description
36xml-commons-apis is designed to organize and have common packaging for
37the various externally-defined standard interfaces for XML. This
38includes the DOM, SAX, and JAXP.
39
40%package manual
41Summary: Manual for %{name}
42Summary(ja): %{name} のマニュアル
43Group: Documentation
44
45%description manual
46Manual for %{name}.
47
48%package javadoc
49Summary: Javadoc for %{name}
50Summary(ja): %{name} の Javadoc
51Group: Documentation
52
53%description javadoc
54%{summary}.
55
56# -----------------------------------------------------------------------------
57
58%prep
59%setup -q -n external
60# Make sure upstream hasn't sneaked in any jars we don't know about
61find -name '*.class' -exec rm -f '{}' \;
62find -name '*.jar' -exec rm -f '{}' \;
63
64# Fix file encodings
65iconv -f iso8859-1 -t utf-8 LICENSE.dom-documentation.txt > \
66  LICENSE.dom-doc.temp && mv -f LICENSE.dom-doc.temp LICENSE.dom-documentation.txt
67iconv -f iso8859-1 -t utf-8 LICENSE.dom-software.txt > \
68  LICENSE.dom-sof.temp && mv -f LICENSE.dom-sof.temp LICENSE.dom-software.txt
69
70# remove bogus section from poms
71cp %{SOURCE3} %{SOURCE4} .
72sed -i '/distributionManagement/,/\/distributionManagement/ {d}' *.pom
73
74%build
75ant -Dant.build.javac.source=1.5 -Dant.build.javac.target=1.5 jar javadoc
76
77
78%install
79rm -rf $RPM_BUILD_ROOT
80
81mkdir -p META-INF
82cp -p %{SOURCE1} META-INF/MANIFEST.MF
83touch META-INF/MANIFEST.MF
84zip -u build/xml-apis.jar META-INF/MANIFEST.MF
85cp -p %{SOURCE2} META-INF/MANIFEST.MF
86touch META-INF/MANIFEST.MF
87zip -u build/xml-apis-ext.jar META-INF/MANIFEST.MF
88
89# Jars
90install -pD -T build/xml-apis.jar $RPM_BUILD_ROOT%{_javadir}/%{name}.jar
91#install -pDm 644 xml-apis-[0-9]*.pom $RPM_BUILD_ROOT/%{_mavenpomdir}/JPP-%{name}.po
92#add_maven_depmap -a xerces:dom3-xml-apis
93
94install -pD -T build/xml-apis-ext.jar $RPM_BUILD_ROOT%{_javadir}/%{name}-ext.jar
95#install -pDm 644 xml-apis-ext*.pom $RPM_BUILD_ROOT/%{_mavenpomdir}/JPP-%{name}-ext.pom
96#add_maven_depmap JPP-%{name}-ext.pom %{name}-ext.jar
97
98# for better interoperability with the jpp apis packages
99ln -sf %{name}.jar $RPM_BUILD_ROOT%{_javadir}/jaxp13.jar
100ln -sf %{name}.jar $RPM_BUILD_ROOT%{_javadir}/jaxp.jar
101ln -sf %{name}.jar $RPM_BUILD_ROOT%{_javadir}/xml-commons-jaxp-1.3-apis.jar
102
103# Javadocs
104mkdir -p $RPM_BUILD_ROOT%{_javadocdir}/%{name}
105cp -pr build/docs/javadoc/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}
106
107# prevent apis javadoc from being included in doc
108rm -rf build/docs/javadoc
109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113
114%files
115%defattr(-,root,root,-)
116%doc LICENSE NOTICE
117%doc LICENSE.dom-documentation.txt README.dom.txt
118%doc LICENSE.dom-software.txt LICENSE.sac.html
119%doc LICENSE.sax.txt README-sax  README.sax.txt
120%{_javadir}/*
121
122%files manual
123%defattr(-,root,root,-)
124%doc build/docs/*
125
126%files javadoc
127%defattr(-,root,root,-)
128%{_javadocdir}/*
129
130
131%changelog
132* Fri Jan 23 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.4.01-1
133- updated to 1.4.01
134
135* Sat Feb 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.04-2
136- rebuild with Vine6 environment
137
138* Fri Aug 27 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.04-1
139- Initial build for Vine Linux
140- used version 1.3.04
141
142* Sat Jan 9 2010 Alexander Kurtakov <akurtako@redhat.com> 0:1.4.01-1
143- Update to 1.4.01.
144
145* Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:1.3.04-3.5
146- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
147
148* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:1.3.04-2.5
149- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
150
151* Fri Feb 6 2009 Alexander Kurtakov <akurtako@redhat.com> 0:1.3.04-1.5
152- Add osgi metadata to the ext jar too.
153
154* Fri Jan 30 2009 Alexander Kurtakov <akurtako@redhat.com> 0:1.3.04-1.4
155- Add osgi metadata.
156
157* Fri Sep 19 2008 Matt Wringe <mwringe@redhat.com> - 0:1.3.04-1.3
158- Remove natively compiled bits from the javadoc package (462809)
159
160* Thu Jul 10 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0:1.3.04-1.2
161- drop repotag
162- fix license tag
163
164* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0:1.3.04-1jpp.1
165- Autorebuild for GCC 4.3
166
167* Tue Mar 06 2007 Matt Wringe <mwringe@redhat.com> - 0:1.3.04-0jpp.1
168- Update to 1.3.04
169
170* Tue Mar 06 2007 Matt Wringe <mwringe@redhat.com> - 0:1.3.03-0jpp.1
171- Split xml-commons package up into 2 separate package: xml-commons-apis
172  and xml-commons-which.
173
174* Mon Aug 21 2006 Fernando Nasser <fnasser@redhat.com> - 0:1.3.02-0.b2.7jpp.10
175- Add missing Requires for post and postun javadoc sections
176
177* Sat Jul 22 2006 Jakub Jelinek <jakub@redhat.com> - 0:1.3.02-0.b2.7jpp_9fc
178- Rebuilt
179
180* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0:1.3.02-0.b2.7jpp_8fc
181- rebuild
182
183* Mon Mar  6 2006 Jeremy Katz <katzj@redhat.com> - 0:1.3.02-0.b2.7jpp_7fc
184- stop scriptlet spew
185
186* Wed Feb 22 2006 Rafael Schloming <rafaels@redhat.com> - 0:1.3.02-0.b2.7jpp_6fc
187- Updated to 1.3
188
189* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0:1.0-0.b2.7jpp_5fc
190- bump again for double-long bug on ppc(64)
191
192* Wed Dec 21 2005 Jesse Keating <jkeating@redhat.com> 0:1.0-0.b2.7jpp_4fc
193- rebuilt again
194
195* Tue Dec 13 2005 Jesse Keating <jkeating@redhat.com>
196- rebuilt for new gcj
197
198* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
199- rebuilt
200
201* Fri Jul 15 2005 Gary Benson <gbenson@redhat.com> - 0:1.0-0.b2.7jpp_3fc
202- Build on ia64, ppc64, s390 and s390x.
203- Switch to aot-compile-rpm (also BC-compiles the which jar).
204
205* Wed Jun 15 2005 Gary Benson <gbenson@redhat.com> - 0:1.0-0.b2.7jpp_2fc
206- Remove all prebuilt stuff from the tarball.
207
208* Thu May 26 2005 Gary Benson <gbenson@redhat.com> - 0:1.0-0.b2.7jpp_1fc
209- Upgrade to 1.0-0.b2.7jpp.
210- Remove now-unnecessary workaround for #130162.
211- Rearrange how BC-compiled stuff is built and installed.
212
213* Mon May 23 2005 Gary Benson <gbenson@redhat.com> - 0:1.0-0.b2.6jpp_13fc
214- Add alpha to the list of build architectures (#157522).
215- Use absolute paths for rebuild-gcj-db.
216
217* Thu May  5 2005 Gary Benson <gbenson@redhat.com> - 0:1.0-0.b2.6jpp_12fc
218- Add dependencies for %%post and %%postun scriptlets (#156901).
219
220* Tue May  3 2005 Gary Benson <gbenson@redhat.com> - 0:1.0-0.b2.6jpp_11fc
221- BC-compile the API jar.
222
223* Tue Apr 26 2005 Gary Benson <gbenson@redhat.com> - 0:1.0-0.b2.6jpp_10fc
224- Remove gcj endorsed dir support (#155693).
225
226* Mon Apr 25 2005 Gary Benson <gbenson@redhat.com> - 0:1.0-0.b2.6jpp_9fc
227- Provide a default transformer when running under libgcj.
228
229* Mon Apr 25 2005 Gary Benson <gbenson@redhat.com> - 0:1.0-0.b2.6jpp_8fc
230- Provide a default DOM builder when running under libgcj (#155693).
231
232* Fri Apr 22 2005 Gary Benson <gbenson@redhat.com> - 0:1.0-0.b2.6jpp_7fc
233- Provide a default SAX parser when running under libgcj (#155693).
234
235* Thu Apr 21 2005 Gary Benson <gbenson@redhat.com> - 0:1.0-0.b2.6jpp_6fc
236- Add gcj endorsed dir support.
237
238* Tue Jan 11 2005 Gary Benson <gbenson@redhat.com> - 0:1.0-0.b2.6jpp_5fc
239- Sync with RHAPS.
240
241* Thu Nov  4 2004 Gary Benson <gbenson@redhat.com> - 0:1.0-0.b2.6jpp_4fc
242- Build into Fedora.
243
244* Thu Oct 28 2004 Gary Benson <gbenson@redhat.com> - 0:1.0-0.b2.6jpp_3fc
245- Bootstrap into Fedora.
246
247* Fri Oct 1 2004 Andrew Overholt <overholt@redhat.com> - 0:1.0-0.b2.6jpp_3rh
248- add coreutils BuildRequires
249
250* Thu Mar  4 2004 Frank Ch. Eigler <fche@redhat.com> - 0:1.0-0.b2.6jpp_2rh
251- RH vacuuming part II
252
253* Tue Mar  2 2004 Frank Ch. Eigler <fche@redhat.com> - 0:1.0-0.b2.6jpp_1rh
254- RH vacuuming
255
256* Thu Aug 26 2003 Ralph Apel <r.apel at r-apel.de> - 0:1.0-0.b2.7jpp
257- Build with ant-1.6.2
258
259* Mon May  5 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.0-0.b2.6jpp
260- Fix non-versioned javadoc symlinking.
261
262* Mon Apr 21 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.0-0.b2.5jpp
263- Fix xml-which script.
264- Include non-versioned javadoc symlinks.
265- Add Epoch: 0.
266- Fix jpackage-utils dependency versions.
267
268* Thu Mar 13 2003 Nicolas Mailhot <Nicolas.Mailhot at jpackage.org> - 1.0-0.b2.4jpp
269- For jpackage-utils 1.5
270
271* Wed Nov 13 2002 Ville Skyttä <ville.skytta at iki.fi> - 1.0-0.b2.3jpp
272- Following upstream changes, resolver is now built from its own package.
273
274* Sun Nov  3 2002 Ville Skyttä <ville.skytta at iki.fi> 1.0-0.b2.2jpp
275- Split resolver into its own subpackage.
276- Fix Group, Vendor and Distribution tags.
277- Use sed instead of bash 2 extension when symlinking jars.
278- Add resolver and which shell scripts.
279
280* Thu Jul 11 2002 Henri Gomez <hgomez@users.sourceforge.net> 1.0-0.b2.1jpp
281- 1.0.b2
282- get tarball from xml.apache.org
283- add macro section
284
285* Fri Jan 18 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 1.0-0.b1.1jpp
286- first jpp release
Note: See TracBrowser for help on using the repository browser.