source: projects/specs/trunk/x/xlogical/xlogical-vl.spec @ 521

Revision 521, 4.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:     xlogical - parallel thinking puzzle game
2Summary(ja): xlogical - ¥¢¥¯¥·¥ç¥ó¥Ñ¥º¥ë¥²¡¼¥à
3
4%define rel     7
5
6Name:           xlogical
7Version:        1.0
8Release:        %{rel}vl2
9License:        GPL
10Group:          Applications/Games
11Source: http://changeling.dynip.com/xlogical/downloads/%{name}-%{version}-%{rel}.tar.gz
12## Vine Patch
13Patch10:        %{name}-%{version}-scoredir.patch
14
15URL:            http://changeling.dynip.com/xlogical/
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17Requires:       SDL >= 1.1.0, SDL_image, SDL_mixer
18BuildRequires:  SDL-devel, SDL_image-devel, SDL_mixer-devel
19BuildPrereq:    automake14, gcc295-c++
20
21%description
22This is a puzzle game based on a game by Rainbow Arts called Logical! which
23was released on the Commodore Amiga in 1980's.  It requires parallel thinking
24and quick reflexes.
25
26#'
27
28%description -l ja
29xlogical ¤Ï Rainbow Arts ¤Î Logical! (¸µ¡¹ Commodore Amiga ÍѤË
301980ǯÂå¤Ëºî¤é¤ì¤¿¤â¤Î) ¤ò»²¹Í¤Ë¤·¤¿¥Ñ¥º¥ë¥²¡¼¥à¤Ç¤¹¡¥
31Ʊ»þ¤Ë¤«¤ÄÈ¿¼ÍŪ¤Ë»×¹Í/Áàºî¤¹¤ë¤³¤È¤¬Í׵ᤵ¤ì¤Þ¤¹¡¥
32
33
34%prep
35%setup -q
36%patch10 -p1 -b .scoredir
37
38
39%build
40# Workaround for legacy auto* tools
41#[ -x /usr/bin/autoconf-2.13 ] && ln -s /usr/bin/autoconf-2.13 autoconf
42#[ -x /usr/bin/autoheader-2.13 ] && ln -s /usr/bin/autoheader-2.13 autoheader
43[ -x /usr/bin/aclocal-1.4 ] && ln -s /usr/bin/aclocal-1.4 aclocal
44[ -x /usr/bin/automake-1.4 ] && ln -s /usr/bin/automake-1.4 automake
45export PATH=`pwd`:$PATH
46# End workaround
47
48%configure --localstatedir=/var/lib/games
49make prefix=/usr localstatedir=/var/lib/games CXX=g++-2.95.3
50
51
52%install
53[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
54
55%makeinstall \
56        localstatedir="$RPM_BUILD_ROOT/var/lib/games" \
57#make prefix="$RPM_BUILD_ROOT/usr" \
58#       install-strip
59
60
61%clean
62[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
63
64
65%files
66%defattr(-,root,root)
67%doc README COPYING ChangeLog AUTHORS NEWS TODO LICENSE
68%attr(2755, root, root) %{_bindir}/xlogical
69%{_datadir}/xlogical
70/var/lib/games/xlogical.scores
71
72
73%changelog
74* Mon Sep 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0-7vl2
75- using autoconf-2.59
76- changed Group to Applications/Games
77
78* Mon Sep 13 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0-7vl1
79- based on 1.0-7 at xlogical offical web site
80- rebuild with new toolchains
81- added BuildPrereq: automake14, autoconf213, gcc295-c++
82- updated scoredir patch
83- used better macros
84- s/Copytright/License/
85- Changed Group: to Amusements/Games
86
87* Tue Nov 28 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
88- 1.0-4vl1
89- based on 1.0-4 at xlogical offical web site
90- rebuild for Vine Linux
91- added Japanese summary and description
92- spec modified for rebuilding by non-root user
93- score file stored in /var/lib/games (same as many gnome-games apps)
94
95* Sat Nov 18 2000 Tom Warkentin <tom@changeling.dynip.com>
96- fixed infinite loop when calculating time bonus after finishing "DIMLIGHTS"
97  level
98  (reported by <wuff@writeme.com>
99- fixed disappearing ball bug when balls were bouncing back and forth between
100  full spinners
101  (reported by <wuff@writeme.com>
102- fixed compiler errors/warnings from RedHat 7.0 C++ compiler
103  (reported by <Nat.Pryce@quokka.com>)
104- implemented and tested 'make uninstall'
105  (reported by <Nat.Pryce@quokka.com>)
106- changed install target to install data files into ${prefix}/share/xlogical
107  (reported by <Nat.Pryce@quokka.com>)
108- changed install target to install high score file into
109  ${localstatedir}/var/xlogical
110  (reported by <Nat.Pryce@quokka.com>)
111
112* Fri Oct 13 2000 Tom Warkentin <tom@changeling.dynip.com>
113- added usage information if invalid command line arguments are supplied
114  (reported by <Daniel_Burrows@brown.edu>)
115- fixed core dump when no module info is available (only shows up with audio
116  disabled)
117  (reported by <Daniel_Burrows@brown.edu>)
118- changed generation of xlogical.properties file to be a build dependency
119  instead of an install dependency.  "make install prefix=/usr/foobar" will
120  not modify any configuration files now - they are all generated as needed
121  during the build.
122  (reported by <Daniel_Burrows@brown.edu>)
123
124* Mon Oct 9 2000 Tom Warkentin <tom@changeling.dynip.com>
125- fixed a large memory leak in graphics routines that were called constantly
126- fix is in xlogical-1.0-2
127
128* Sat Oct 7 2000 Tom Warkentin <tom@changeling.dynip.com>
129- initial release
130
Note: See TracBrowser for help on using the repository browser.