source: projects/specs/trunk/x/xlockmore_gl/xlockmore_gl-vl.spec @ 521

Revision 521, 6.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define orgname xlockmore
2
3# if you want to make kterm_plus version,
4# uncomment below line, or rpm --define withgl:1
5# % define withgl 1
6
7%define name %{orgname}%{?withgl:_gl}
8%define version 5.03
9%define release 0vl1
10
11Summary: An X terminal locking program.
12Name: %{name}
13Version: %{version}
14Release: %{release}
15License: MIT
16Group: Amusements/Graphics
17Url: http://www.tux.org/~bagleyd/xlockmore.html
18Source0: ftp://ftp.tux.org/pub/tux/bagleyd/xlockmore/xlockmore-%{version}.tar.bz2
19Source1: m-redhat.xpm
20Source2: m-redhat.xbm
21Source3: s-redhat.xpm
22Source4: s-redhat.xbm
23Source5: xlock.pamd
24Patch0: xlockmore-5.02-sounddir.patch
25BuildPrereq: esound-devel, audiofile-devel
26Requires: pam >= 0.59, esound, audiofile, fortune-mod
27%{?withgl:Requires: Mesa, gle}
28%{?withgl:BuildPreReq: Mesa-devel, gle-devel}
29%{?withgl:Provides: xlockmore}
30Conflicts: %{orgname}%{!?withgl:_gl}
31Buildroot: %{_tmppath}/%{name}-%{version}-root
32
33Vendor: Project Vine
34Distribution: Vine Linux
35
36%define gldesc %{?withgl:This package has MesaGL feature.}
37
38%define gldescja %{?withgl:¤³¤Î¥Ñ¥Ã¥±¡¼¥¸¤Ï MesaGL Âбþ¤Ë¤Ê¤Ã¤Æ¤¤¤Þ¤¹.}
39
40%description
41The xlockmore utility is an enhanced version of the standard xlock
42program, which allows you to lock an X session so that other users
43can't access it.  Xlockmore runs a provided screensaver until you type
44in your password.
45
46Install the xlockmore package if you need a locking program to secure
47X sessions.
48
49%{gldesc}
50
51%description
52xlockmore ¤Ï ɸ½àŪ¤Ê xlock ¤Îµ¡Ç½³ÈÄ¥ÈǤǤ¹¡¥¤¢¤Ê¤¿¤¬Àʤò¤Ï¤º¤¹¤È¤­¤Ë
53X ¥»¥Ã¥·¥ç¥ó¤ò¥í¥Ã¥¯¤·¡¤¤¢¤Ê¤¿¤¬¥Ñ¥¹¥ï¡¼¥É¤òÆþÎϤ¹¤ë¤Þ¤Ç¾¤Î¿Í¤¬¥¢¥¯
54¥»¥¹¤Ç¤­¤Ê¤¤¤è¤¦¤Ë¤·¤Þ¤¹¡¥
55
56%{gldescja}
57
58%prep
59%setup -q -n %{orgname}-%{version}
60%patch0 -p1 -b .sounddir
61
62cp %{_sourcedir}/m-redhat.xpm pixmaps/m-redhat.xpm
63cp %{_sourcedir}/m-redhat.xbm bitmaps/m-redhat.xbm
64cp %{_sourcedir}/m-redhat.xpm pixmaps/l-redhat.xpm
65cp %{_sourcedir}/m-redhat.xbm bitmaps/l-redhat.xbm
66cp %{_sourcedir}/s-redhat.xpm pixmaps/s-redhat.xpm
67cp %{_sourcedir}/s-redhat.xbm bitmaps/s-redhat.xbm
68
69%build
70autoconf
71
72%define nglflag %{!?withgl:--without-opengl --without-mesa --without-gltt}
73%define glflag %{?withgl:--with-mesa --with-gltt}
74
75%configure --prefix=/usr --exec-prefix=/usr/X11R6/ --bindir=/usr/X11R6/bin \
76    --mandir=/usr/X11R6/man/man1  --without-motif --without-gtk --enable-pam \
77    --with-esound %{glflag} %{nglflag}
78make
79
80# recompile xlockgen for each architecture
81make -C etc/genlauncher xlockgen
82
83%install
84rm -rf %{buildroot}
85mkdir -p %{buildroot}/etc/pam.d
86%makeinstall exec_prefix=%{buildroot}/usr/X11R6/ bindir=%{buildroot}/usr/X11R6/bin mandir=%{buildroot}/usr/X11R6/man/man1 xapploaddir=%{buildroot}/usr/X11R6/lib/X11/app-defaults/  INSTPGMFLAGS="-m 755"
87install -m 644 %{_sourcedir}/xlock.pamd %{buildroot}/etc/pam.d/xlock
88
89mkdir -p %{buildroot}%{_datadir}/sounds/xlockmore/
90install -m 644 -p sounds/*.au %{buildroot}%{_datadir}/sounds/xlockmore/
91
92(cd etc
93sed -e 's|/usr/X11/bin/wish|/usr/bin/wish|g' xlock.tcl > xlock.tcl.new
94mv xlock.tcl.new xlock.tcl
95# chmod +x xlock.tcl
96)
97
98# eliminate executable bit in %doc
99find etc/ -type f -perm +111 | xargs -r chmod -x
100
101%clean
102rm -rf %{buildroot}
103
104%files
105%defattr(-,root,root)
106%doc README docs/ etc/
107%config /etc/pam.d/xlock
108%attr(4111,root,root)/usr/X11R6/bin/xlock
109/usr/X11R6/man/man1/xlock.*
110%config /usr/X11R6/lib/X11/app-defaults/XLock
111%{_datadir}/sounds/xlockmore/
112
113%changelog
114* Tue Jan 30 2002 Toru Sagami <sagami@vinelinux.org> 5.03-0vl1
115- updated to current stable release 5.03
116- use %%configure, %%makeinstall
117- added patch for DEFALUT_SOUND_DIR
118
119* Tue Sep 04 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.01.2-0vl3
120- typo fixed: --without-mesagl -> --without-mesa
121
122* Sun Aug 18 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
123- add Conflicts tag
124
125* Fri Aug 17 2001 <sagami@vinelinux.org>
126- 5.01.2-0vl1: bump up release
127
128* Wed Jul 18 2001 <sagami@vinelinux.org>
129- 5.01.2-0vl0: updated to current stable release 5.01.2
130
131* Mon Apr  2 2001 Jun Nishii <jun@vinelinux.org> 4.17.2-0vl8
132- bug fix for withgl option
133
134* Wed Mar 28 2001 Jun Nishii <jun@vinelinux.org> 4.17.2-0vl7
135- bug fix in Provides for withgl
136- build with gle
137
138* Tue Mar 27 2001 Jun Nishii <jun@vinelinux.org> 4.17.2-0vl6
139- added switch withgl
140
141* Mon Jan 22 2001 Tomoya TAKA <tomoya@olive.plala.or.jp> 4.17.2-0vl5
142- recompile %%{_docdir}/xlockmore-%{version}/etc/genlauncher/xlockgen
143  for each architecture (to resolve unmet dependency)
144
145* Sat Jan 20 2001 Toru Sagami <czs14350@mb.infoweb.ne.jp>
146- 4.17.2-0vl4
147- eliminate executable bit in %doc (requierment for /bin/ksh etc.)
148
149* Sun Nov 12 2000 MACHINO, Satoshi <machino@vinelinux.org> 4.17.2-0vl3
150- build on gcc-2.95.3
151- partialy used rpmmacros
152
153* Tue Nov  7 2000 Kazuhisa TAKEI <takei@vinelinux.org> 4.17.2-0vl2
154- change filedepend to package name depend
155
156* Sat Sep  2 2000 Jun Nishii <jun@vinelinux.org>
157- 4.17.2-0vl1
158
159* Fri Sep  1 2000 Jun Nishii <jun@vinelinux.org>
160- 4.17.1-0vl1
161- upgrade and build without GL
162- added docs etc
163
164* Wed Feb 09 2000 Preston Brown <pbrown@redhat.com>
165- wmconfig gone.
166
167* Thu Feb  3 2000 Bill Nottingham <notting@redhat.com>
168- handle compressed man pages
169
170* Fri Jan 14 2000 Bill Nottingham <notting@redhat.com>
171- fun with GL
172
173* Tue Nov  9 1999 Bill Nottingham <notting@redhat.com>
174- update to 4.15
175
176* Mon Jun 14 1999 Bill Nottingham <notting@redhat.com>
177- update to 4.13.1
178
179* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
180- auto rebuild in the new build environment (release 2)
181
182* Fri Dec 18 1998 Bill Nottingham <notting@redhat.com>
183- update to 4.12
184
185* Tue Oct 13 1998 Cristian Gafton <gafton@redhat.com>
186- take out some modules to avoid TMv
187
188* Fri Sep 18 1998 Bill Nottingham <notting@redhat.com>
189- turned PAM support on in ./configure
190
191* Fri Sep 11 1998 Preston Brown <pbrown@redhat.com>
192- Upgraded to 4.11
193
194* Fri Apr 24 1998 Prospector System <bugs@redhat.com>
195- translations modified for de, fr, tr
196
197* Sat Apr 11 1998 Donnie Barnes <djb@redhat.com>
198- upgraded to 4.09
199- removed Michael's PAM patch (it's now available in the sources)
200
201* Thu Oct 23 1997 Marc Ewing <marc@redhat.com>
202- upgrade to 4.05
203- add wmconfig
204
205* Mon Oct 13 1997 Michael K. Johnson <johnsonm@redhat.com>
206- Upgraded to 4.04
207- Changed pam to new conventions
208- Use configure instead of imake
209- buildroot
210
211* Mon Jul 21 1997 Erik Troan <ewt@redhat.com>
212- built against glibc
213
214* Mon Mar 03 1997 Michael K. Johnson <johnsonm@redhat.com>
215- moved from pam.conf to pam.d
216
Note: See TracBrowser for help on using the repository browser.