source: projects/specs/trunk/x/xl2tpd/xl2tpd-vl.spec @ 12056

Revision 12056, 14.7 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

Line 
1%define src_dir_name xl2tpd-%{version}
2
3Summary: Layer 2 Tunnelling Protocol Daemon (RFC 2661)
4Name: xl2tpd
5Version: 1.3.13
6Release: 1%{?_dist_release}
7# No version specified.
8License: GPL+
9Url: http://www.xelerance.com/software/xl2tpd/
10Group: System Environment/Daemons
11Source0: https://github.com/xelerance/xl2tpd/archive/v%{version}.tar.gz#/xl2tpd-%{version}.tar.gz
12
13Patch1: 0001-fix-ppp-options.patch
14Patch2: 0002-fix-initscript.patch
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17Requires: ppp
18BuildRequires: libpcap-devel
19BuildRequires: openssl-devel
20Requires(post): /sbin/chkconfig
21Requires(preun): /sbin/chkconfig
22Requires(preun): /sbin/service
23
24Vendor: Project Vine
25Distribution: Vine Linux
26Packager: tomop
27
28%description
29xl2tpd is an implementation of the Layer 2 Tunnelling Protocol (RFC 2661).
30L2TP allows you to tunnel PPP over UDP. Some ISPs use L2TP to tunnel user
31sessions from dial-in servers (modem banks, ADSL DSLAMs) to back-end PPP
32servers. Another important application is Virtual Private Networks where
33the IPsec protocol is used to secure the L2TP connection (L2TP/IPsec,
34RFC 3193). The L2TP/IPsec protocol is mainly used by Windows and
35Mac OS X clients. On Linux, xl2tpd can be used in combination with IPsec
36implementations such as Openswan.
37Example configuration files for such a setup are included in this RPM.
38
39xl2tpd works by opening a pseudo-tty for communicating with pppd.
40It runs completely in userspace.
41
42xl2tpd supports IPsec SA Reference tracking to enable overlapping internak
43NAT'ed IP's by different clients (eg all clients connecting from their
44linksys internal IP 192.168.1.101) as well as multiple clients behind
45the same NAT router.
46
47xl2tpd supports the pppol2tp kernel mode operations on 2.6.23 or higher,
48or via a patch in contrib for 2.4.x kernels.
49
50Xl2tpd is based on the 0.69 L2TP by Jeff McAdams <jeffm@iglou.com>
51It was de-facto maintained by Jacco de Leeuw <jacco2@dds.nl> in 2002 and 2003.
52
53%prep
54%autosetup -p1 -n %{src_dir_name}
55
56%build
57make DFLAGS="$RPM_OPT_FLAGS -g -DDEBUG_HELLO -DDEBUG_CLOSE -DDEBUG_FLOW -DDEBUG_PAYLOAD -DDEBUG_CONTROL -DDEBUG_CONTROL_XMIT -DDEBUG_FLOW_MORE -DDEBUG_MAGIC -DDEBUG_ENTROPY -DDEBUG_HIDDEN -DDEBUG_PPPD -DDEBUG_AAA -DDEBUG_FILE -DDEBUG_FLOW -DDEBUG_HELLO -DDEBUG_CLOSE -DDEBUG_ZLB -DDEBUG_AUTH"
58
59%install
60rm -rf %{buildroot}
61make DESTDIR=%{buildroot} PREFIX=%{_prefix} install
62install -p -D -m644 examples/xl2tpd.conf %{buildroot}%{_sysconfdir}/xl2tpd/xl2tpd.conf
63install -p -D -m644 examples/ppp-options.xl2tpd %{buildroot}%{_sysconfdir}/ppp/options.xl2tpd
64install -p -D -m600 doc/l2tp-secrets.sample %{buildroot}%{_sysconfdir}/xl2tpd/l2tp-secrets
65install -p -D -m600 examples/chapsecrets.sample %{buildroot}%{_sysconfdir}/ppp/chap-secrets.sample
66install -p -D -m755 packaging/fedora/xl2tpd.init %{buildroot}%{_initrddir}/xl2tpd
67install -p -D -m755 -d %{buildroot}%{_localstatedir}/run/xl2tpd
68
69
70%clean
71rm -rf %{buildroot}
72
73%post
74/sbin/chkconfig --add xl2tpd
75
76%preun
77if [ $1 -eq 0 ]; then
78  /sbin/service xl2tpd stop > /dev/null 2>&1
79  /sbin/chkconfig --del xl2tpd
80fi
81
82%postun
83if [ $1 -ge 1 ]; then
84  /sbin/service xl2tpd condrestart 2>&1 >/dev/null
85fi
86
87%files
88%defattr(-,root,root)
89%license LICENSE
90%doc BUGS CHANGES CREDITS README* TODO
91%doc doc/README.patents examples/chapsecrets.sample
92%{_sbindir}/xl2tpd
93%{_sbindir}/xl2tpd-control
94%{_bindir}/pfc
95%{_mandir}/*/*
96%dir %{_sysconfdir}/xl2tpd
97%config(noreplace) %{_sysconfdir}/xl2tpd/*
98%config(noreplace) %{_sysconfdir}/ppp/*
99%attr(0755,root,root)  %{_initrddir}/xl2tpd
100%dir %{_localstatedir}/run/xl2tpd
101%ghost %attr(0600,root,root) %{_localstatedir}/run/xl2tpd/l2tp-control
102
103%changelog
104* Sat Jan 26 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.13-1
105- new upstream release.
106
107* Tue Dec 19 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.10.1-1
108- new upstream release.
109
110* Tue Mar 21 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.9-1
111- new upstream release.
112
113* Wed Apr  2 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.6-1
114- new upstream release.
115
116* Sun Jan 05 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.3-1
117- new upstream release.
118
119* Sat Sep 29 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.1-1
120- new upstream release.
121
122* Fri Sep 16 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.0-1
123- new upstream release.
124
125* Fri Apr 22 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.8-2
126- built for Vine Linux.
127
128* Wed Feb 23 2011 Paul Wouters <paul@xelerance.com> - 1.2.8-1
129- Updated to 1.2.8
130- Add ghosting for l2tp pipe (bz#656725)
131
132* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.7-3
133- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
134
135* Tue Nov 30 2010 Paul Wouters <paul@xelerance.com> - 1.2.7-2
136- fix md5 of init script in sources
137
138* Tue Nov 30 2010 Paul Wouters <paul@xelerance.com> - 1.2.7-1
139- Updated to 1.2.7
140- Added more DEBUG build options to the make command
141- Minor cleanups
142
143* Sat Jan 09 2010 Paul Wouters <paul@xelerance.com> - 1.2.5-2
144- Bump for EVR
145
146* Sat Jan 09 2010 Paul Wouters <paul@xelerance.com> - 1.2.5-1
147- Upgraded to 1.2.5. (fixes interop with two Windows machines behind same NAT)
148- Fix mix space/tab in spec file
149- Added missing keyword Default-Stop
150
151* Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.4-4
152- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
153
154* Sun Mar 08 2009 Paul Wouters <paul@xelerance.com> - 1.2.4-3
155- Bump version for tagging mistake
156
157* Sun Mar 08 2009 Paul Wouters <paul@xelerance.com> - 1.2.4-2
158-Fix initscript for https://bugzilla.redhat.com/show_bug.cgi?id=247100
159
160* Sun Mar 08 2009 Paul Wouters <paul@xelerance.com> - 1.2.4-1
161- Upgraded to 1.2.4
162- Merged spec file with upstream
163
164* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0-2
165- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
166
167* Thu Oct  9 2008 Paul Wouters <paul@xelerance.com> - 1.2.0-1
168- Updated to new upstream release
169
170* Sat Sep  6 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.1.12-3
171- fix license tag
172
173* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.1.12-2
174- Autorebuild for GCC 4.3
175
176* Fri Oct 26 2007 Paul Wouters <paul@xelerance.com> 1.1.12-1
177- Upgraded to new release upstream
178- Removed l2tpd to xl2tpd migration in post
179
180* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 1.1.11-3
181- Rebuild for selinux ppc32 issue.
182
183* Sat Jul 28 2007 Paul Wouters <paul@xelerance.com> 1.1.11-2
184- Upgraded to 1.1.11
185- Include new split README.*
186
187* Mon Mar 19 2007 Paul Wouters <paul@xelerance.com> 1.1.09-1
188- Upgraded to 1.1.09
189
190* Fri Feb 23 2007 Paul Wouters <paul@xelerance.com> 1.1.08-2
191- Bump for EVR
192
193* Fri Feb 23 2007 Paul Wouters <paul@xelerance.com> 1.1.08-1
194- Upgraded to 1.1.08
195- This works around the ppp-2.4.2-6.4 issue of not dying on SIGTERM
196
197* Tue Feb 20 2007 Paul Wouters <paul@xelerance.com> 1.1.07-2
198- Fixed version usage in source macro
199
200* Tue Feb 20 2007 Paul Wouters <paul@xelerance.com> 1.1.07-1
201- Upgraded to 1.1.07
202- Added /var/run/xl2tpd to the spec file so this pacakge
203  owns /var/run/xl2tpd
204 
205* Thu Dec  7 2006 Paul Wouters <paul@xelerance.com> 1.1.06-5
206- Changed space/tab replacing method
207
208* Wed Dec  6 2006 Paul Wouters <paul@xelerance.com> 1.1.06-4
209- Added -p to keep original timestamps
210- Added temporary hack to change space/tab in init file.
211- Added /sbin/service dependancy
212
213* Tue Dec  5 2006 Paul Wouters <paul@xelerance.com> 1.1.06-3
214- Added Requires(post) / Requires(preun)
215- changed init file to create /var/run/xl2tpd fixed a tab/space
216- changed control file to be within /var/run/xl2tpd/
217
218* Tue Dec  5 2006 Paul Wouters <paul@xelerance.com> 1.1.06-2
219- Changed Mr. Karlsen's name to not be a utf8 problem
220- Fixed Obosoletes/Provides to be more specific wrt l2tpd.
221- Added dist tag which accidentally got deleted.
222
223* Mon Dec  4 2006 Paul Wouters <paul@xelerance.com> 1.1.06-1
224- Rebased spec file on Fedora Extras copy, but using xl2tpd as package name
225
226* Sun Nov 27 2005 Paul Wouters <paul@xelerance.com> 0.69.20051030
227- Pulled up sourceforget.net CVS fixes.
228- various debugging added, but debugging should not be on by default.
229- async/sync conversion routines must be ready for possibility that the read
230  will block due to routing loops.
231- refactor control socket handling.
232- move all logic about pty usage to pty.c. Try ptmx first, if it fails try
233  legacy ptys
234- rename log() to l2tp_log(), as "log" is a math function.
235- if we aren't deamonized, then log to stderr.
236- added install: and DESTDIR support.
237
238* Thu Oct 20 2005 Paul Wouters <paul@xelerance.com> 0.69-13
239- Removed suse/mandrake specifics. Comply for Fedora Extras guidelines
240
241* Tue Jun 21 2005 Jacco de Leeuw <jacco2@dds.nl> 0.69-12jdl
242- Added log() patch by Paul Wouters so that l2tpd compiles on FC4.
243
244* Sat Jun 4 2005 Jacco de Leeuw <jacco2@dds.nl>
245- l2tpd.org has been hijacked. Project moved back to SourceForge:
246  http://l2tpd.sourceforge.net
247
248* Tue May 3 2005 Jacco de Leeuw <jacco2@dds.nl>
249- Small Makefile fixes. Explicitly use gcc instead of cc.
250  Network services library was not linked on Solaris due to typo.
251
252* Thu Mar 17 2005 Jacco de Leeuw <jacco2@dds.nl> 0.69-11jdl
253- Choosing between SysV or BSD style ptys is now configurable through
254  a compile-time boolean "unix98pty".
255
256* Fri Feb 4 2005 Jacco de Leeuw <jacco2@dds.nl>
257- Added code from Roaring Penguin (rp-l2tp) to support SysV-style ptys.
258  Requires the N_HDLC kernel module.
259
260* Fri Nov 26 2004 Jacco de Leeuw <jacco2@dds.nl>
261- Updated the README.
262
263* Wed Nov 10 2004 Jacco de Leeuw <jacco2@dds.nl> 0.69-10jdl
264- Patch by Marald Klein and Roger Luethi. Fixes writing PID file.
265  (http://l2tpd.graffl.net/msg01790.html)
266  Long overdue. Rereleasing 10jdl.
267
268* Tue Nov 9 2004 Jacco de Leeuw <jacco2@dds.nl> 0.69-10jdl
269- [SECURITY FIX] Added fix from Debian because of a bss-based
270  buffer overflow.
271  (http://www.mail-archive.com/l2tpd-devel@l2tpd.org/msg01071.html)
272- Mandrake's FreeS/WAN, Openswan and Strongswan RPMS use configuration
273  directories /etc/{freeswan,openswan,strongswan}. Install our
274  configuration files to /etc/ipsec.d and create symbolic links in
275  those directories.
276
277* Wed Aug 18 2004 Jacco de Leeuw <jacco2@dds.nl>
278- Removed 'leftnexthop=' lines. Not relevant for recent versions
279  of FreeS/WAN and derivates.
280
281* Tue Jan 20 2004 Jacco de Leeuw <jacco2@dds.nl>  0.69-9jdl
282- Added "noccp" because of too much MPPE/CCP messages sometimes.
283
284* Wed Dec 31 2003 Jacco de Leeuw <jacco2@dds.nl>
285- Added patch in order to prevent StopCCN messages.
286
287* Sat Aug 23 2003 Jacco de Leeuw <jacco2@dds.nl>
288- MTU/MRU 1410 seems to be the lowest possible for MSL2TP.
289  For Windows 2000/XP it doesn't seem to matter.
290- Typo in l2tpd.conf (192.168.128/25).
291
292* Fri Aug 8 2003 Jacco de Leeuw <jacco2@dds.nl>  0.69-8jdl
293- Added MTU/MRU 1400 to options.l2tpd. I don't know the optimal
294  value but some apps had problems with the default value.
295
296* Fri Aug 1 2003 Jacco de Leeuw <jacco2@dds.nl>
297- Added workaround for the missing hostname bug in the MSL2TP client
298  ('Specify your hostname', error 629: "You have been disconnected
299  from the computer you are dialing").
300
301* Sun Jul 20 2003 Jacco de Leeuw <jacco2@dds.nl>  0.69-7jdl
302- Added the "listen-addr" global parameter for l2tpd.conf. By
303  default, the daemon listens on *all* interfaces. Use
304  "listen-addr" if you want it to bind to one specific
305  IP address (interface), for security reasons. (See also:
306  http://www.jacco2.dds.nl/networking/freeswan-l2tp.html#Firewallwarning)
307- Explained in l2tpd.conf that two different IP addresses should be
308  used for 'listen-addr' and 'local ip'.
309- Modified init script. Upgrades should work better now. You
310  still need to start/chkconfig l2tpd manually.
311- Renamed the example Openswan .conf files to better reflect
312  the situation. There are two variants using different portselectors.
313  Previously I thought Windows 2000/XP used portselector 17/0
314  and the rest used 17/1701. But with the release of an updated
315  IPsec client by Microsoft, it turns out that 17/0 must have
316  been a mistake: the updated client now also uses 17/1701.
317
318* Thu Apr 10 2003 Jacco de Leeuw <jacco2@dds.nl>  0.69-6jdl
319- Changed sample chap-secrets to be valid only for specific
320  IP addresses.
321
322* Thu Mar 13 2003 Bernhard Thoni <tech-role@tronicplanet.de>
323- Adjustments for SuSE8.x (thanks, Bernhard!)
324- Added sample chap-secrets.
325
326* Thu Mar 6 2003 Jacco de Leeuw <jacco2@dds.nl> 0.69-5jdl
327- Replaced Dominique's patch by Damion de Soto's, which does not
328  depend on the N_HDLC kernel module.
329
330* Wed Feb 26 2003 Jacco de Leeuw <jacco2@dds.nl> 0.69-4jdl
331- Seperate example config files for Win9x (MSL2TP) and Win2K/XP
332  due to left/rightprotoport differences.
333  Fixing preun for Red Hat.
334
335* Mon Feb 3 2003 Jacco de Leeuw <jacco2@dds.nl> 0.69-3jdl
336- Mandrake uses /etc/freeswan/ instead of /etc/ipsec.d/
337  Error fixed: source6 was used for both PSK and CERT.
338
339* Wed Jan 29 2003 Jacco de Leeuw <jacco2@dds.nl> 0.69-3jdl
340- Added Dominique Cressatti's pty patch in another attempt to
341  prevent the Windows 2000 Professional "loopback detected" error.
342  Seems to work!
343
344* Wed Dec 25 2002 Jacco de Leeuw <jacco2@dds.nl> 0.69-2jdl
345- Added 'connect-delay' to PPP parameters in an attempt to
346  prevent the Windows 2000 Professional "loopback detected" error.
347  Didn't seem to work.
348
349* Fri Dec 13 2002 Jacco de Leeuw <jacco2@dds.nl> 0.69-1jdl
350- Did not build on Red Hat 8.0. Solved by adding comments(?!).
351  Bug detected in spec file: chkconfig --list l2tpd does not work
352  on Red Hat 8.0. Not important enough to look into yet.
353
354* Sun Nov 17 2002 Jacco de Leeuw <jacco2@dds.nl> 0.69-1jdl
355- Tested on Red Hat, required some changes. No gprintf. Used different
356  pty patch, otherwise wouldn't run. Added buildroot sanity check.
357
358* Sun Nov 10 2002 Jacco de Leeuw <jacco2@dds.nl>
359- Specfile adapted from Mandrake Cooker. The original RPM can be
360  retrieved through:
361  http://www.rpmfind.net/linux/rpm2html/search.php?query=l2tpd
362- Config path changed from /etc/l2tp/ to /etc/l2tpd/
363  (Seems more logical and rp-l2tp already uses /etc/l2tp/).
364- Do not run at boot or install. The original RPM uses a config file
365  which is completely commented out, but it still starts l2tpd on all
366  interfaces. Could be a security risk. This RPM does not start l2tpd,
367  the sysadmin has to edit the config file and start l2tpd explicitly.
368- Renamed patches to start with l2tpd-
369- Added dependencies for pppd, glibc-devel.
370- Use %%{name} as much as possible.
371- l2tp-secrets contains passwords, thus should not be world readable.
372- Removed dependency on rpm-helper.
373
374* Mon Oct 21 2002 Lenny Cartier <lenny@mandrakesoft.com> 0.69-3mdk
375- from Per 0yvind Karlsen <peroyvind@delonic.no> :
376 - PreReq and Requires
377 - Fix preun_service
378
379* Thu Oct 17 2002 Per 0yvind Karlsen <peroyvind@delonic.no> 0.69-2mdk
380- Move l2tpd from /usr/bin to /usr/sbin
381- Added SysV initscript
382- Patch0
383- Patch1
384
385* Thu Oct 17 2002 Per 0yvind Karlsen <peroyvind@delonic.no> 0.69-1mdk
386- Initial release
Note: See TracBrowser for help on using the repository browser.