source: projects/specs/trunk/x/xkeyboard-config/xkeyboard-config-vl.spec @ 521

Revision 521, 6.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: xkeyboard-config alternative xkb data files
2Name: xkeyboard-config
3Version: 1.6
4Release: 1%{?_dist_release}
5License: MIT
6Group: User Interface/X
7URL: http://www.x.org
8
9Source0: http://xlibs.freedesktop.org/xkbdesc/%{name}-%{version}.tar.bz2
10
11# upstream patch
12Patch1: xkeyboard-config-1.6-caps-super.patch
13Patch2: xkeyboard-config-1.6-caps-hyper.patch
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
16BuildArch: noarch
17BuildRequires: pkgconfig
18BuildRequires: xorg-x11-util-macros
19BuildRequires: xkbcomp
20BuildRequires: perl(XML::Parser)
21Provides: xkbdata
22
23%description
24xkeyboard-config alternative xkb data files
25
26%prep
27%setup -q
28
29%build
30%configure \
31    --enable-compat-rules \
32    --with-xkb-base=%{_datadir}/X11/xkb \
33    --disable-xkbcomp-symlink \
34    --with-xkb-rules-symlink=xorg
35
36make
37
38%install
39rm -rf $RPM_BUILD_ROOT
40
41make install DESTDIR=$RPM_BUILD_ROOT
42# Remove unnecessary symlink
43rm -f $RPM_BUILD_ROOT%{_datadir}/X11/xkb/compiled
44
45rm -rf $RPM_BUILD_ROOT%{_datadir}/locale
46
47# Create filelist
48{
49   FILESLIST=${PWD}/files.list
50   pushd $RPM_BUILD_ROOT
51   find ./usr/share/X11 -type d | sed -e "s/^\./%dir /g" > $FILESLIST
52   find ./usr/share/X11 -type f | sed -e "s/^\.//g" >> $FILESLIST
53   popd
54}
55
56%clean
57rm -rf $RPM_BUILD_ROOT
58
59%files -f files.list
60%defattr(-,root,root,-)
61%{_datadir}/X11/xkb/rules/xorg
62%{_datadir}/X11/xkb/rules/xorg.lst
63%{_datadir}/X11/xkb/rules/xorg.xml
64
65%changelog
66* Mon Sep 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16-1
67- new upstream release
68- drop upstreamed patch
69- add Patch1,2 from upstream
70
71* Thu Oct 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14-1
72- new upstream release
73
74* Mon May 19 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12-1
75- new upstream release
76
77* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1-1
78- new versioning policy
79
80* Mon Jan 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1-0vl1
81- initial build for Vine Linux
82
83* Sat Oct  6 2007 Matthias Clasen <mclasen@redhat.com> - 1.1-3
84- Somehow the Dell M65 model lost its vendor
85
86* Wed Sep 26 2007 Matthias Clasen <mclasen@redhat.com> - 1.1-2
87- Pick up the respun 1.1 release
88
89* Wed Sep 26 2007 Matthias Clasen <mclasen@redhat.com> - 1.1-1
90- Update to 1.1
91- Drop upstreamed patches
92
93* Wed Sep  5 2007 Matthias Clasen <mclasen@redhat.com> - 1.0-1
94- Update to 1.0
95- Drop upstreamed patches
96- Update remaining patches
97
98* Fri Sep  1 2006 Alexander Larsson <alexl@redhat.com> - 0.8-7
99- Update macbook patch to be closer to what got in upstream
100- (kp enter is ralt, not the option key)
101
102* Fri Sep  1 2006 Matthias Clasen <mclasen@redhat.com> - 0.8-6
103- Add support for Korean 106 key keyboards (204158)
104
105* Tue Aug 29 2006 Alexander Larsson <alexl@redhat.com> - 0.8-5
106- Add MacBook model and geometry, plus alt_win option
107
108* Thu Aug 22 2006 Matthias Clasen <mclasen@redhat.com> 0.8-4
109- Fix geometry description for Thinkpads
110- Add a Kinesis model
111- Add Dell Precision M65 geometry and model
112
113* Tue Aug 22 2006 Adam Jackson <ajackson@redhat.com> 0.8-3
114- Add Compose semantics to right Alt when that's ISO_Level3_Shift (#193922)
115
116* Fri Jul 07 2006 Mike A. Harris <mharris@redhat.com> 0.8-2
117- Rename spec file from xorg-x11-xkbdata to xkeyboard-config.spec
118
119* Fri Jul 07 2006 Mike A. Harris <mharris@redhat.com> 0.8-1
120- Renamed package from 'xorg-x11-xkbdata' to 'xkeyboard-config' to match the
121  upstream project name and tarball.  I kept the rpm changelog intact however
122  to preserve history, so all entries older than today, are from the
123  prior 'xorg-x11-xkbdata' package.  (#196229,197939)
124- Added "Obsoletes: xorg-x11-xkbdata"
125- Removed 'pre' script from spec file, as that was a temporary hack to help
126  transition from modular X.Org xkbdata to modular xkeyboard-config during
127  FC5 development.  The issue it resolved is not present in any officially
128  released distribution release or updates, so the hack is no longer needed.
129
130* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-8.xkbc0.8.0
131- Embed xkeyboard-config version in Release field so we can tell from the
132  filename what is really in this package without having to look in the
133  spec file.  We should rename the package to xkeyboard-config and restart
134  the versioning.
135
136* Tue Jun 06 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-8
137- Added "BuildRequires: perl(XML::Parser)" for (#194188)
138
139* Sat Mar 04 2006 Ray Strode <rstrode@redhat.com> 1.0.1-7
140- Update to 0.8.
141
142* Wed Mar 01 2006 Ray Strode <rstrode@redhat.com> 1.0.1-6
143- Turn on compat symlink (bug 183521)
144
145* Tue Feb 28 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-5
146- Fixed rpm pre script upgrade/install testing
147- Rebuild package as 1.0.1-5 in rawhide, completing the transition to
148  xkeyboard-config.
149
150* Tue Feb 28 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-4.0.7.xkbcfg.5
151- Added rpm pre script, to pre-remove the symbols/pc during package upgrades,
152  to avoid an rpm cpio error if the X11R7.0 modular xkbdata package is already
153  installed, because rpm can not replace a directory with a file. 
154
155* Fri Feb 24 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-4.0.7.xkbcfg.1
156- Package renamed to xorg-x11-xkbdata and version/release tweaked since it
157  is too late to add new package names to Fedora Core 5 development.
158- Added "Provides: xkeyboard-config" virtual provide.
159
160* Fri Feb 24 2006 Mike A. Harris <mharris@redhat.com> 0.7-1
161- Initial package created with xkeyboard-config-0.7.
162
163* Tue Feb 21 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-3
164- Added xkbdata-1.0.1-greek-fix-bug181313.patch to fix (#181313,181313)
165- Added xkbdata-1.0.1-cz-fix-bug177362.patch to fix (#177362,178892)
166
167* Thu Feb 09 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-2
168- Added xkbdata-1.0.1-sysreq-fix-bug175661.patch to fix (#175661)
169
170* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
171- Updated to xbitmaps 1.0.1 from X11R7.0
172
173* Sat Dec 17 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
174- Updated to xbitmaps 1.0.0 from X11R7 RC4.
175
176* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-2
177- Add a few missing rpm 'dir' directives to file manifest.
178- Bump release, and build as a 'noarch' package.
179
180* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
181- Updated to xkbdata 0.99.1 from X11R7 RC2.
Note: See TracBrowser for help on using the repository browser.