source: projects/specs/trunk/x/xhtml-dtd10/xhtml-dtd10-vl.spec @ 521

Revision 521, 2.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define catalog_name    %{name}-%{version}-%{release}.cat
2
3Name: xhtml-dtd10
4Version: 1.0
5Release: 2%{?_dist_release}
6Group: Applications/Text
7
8Summary: XML document type definition for XHTML 1.0
9
10License: Distributable
11
12#Provides: html-dtd
13Requires: sgml-common >= 0.5
14BuildRequires: unzip
15BuildRoot: %{_tmppath}/%{name}-%{version}
16
17BuildArch: noarch
18Source0: http://www.w3.org/TR/xhtml1/xhtml1.zip
19Source1: http://www.w3.org/Consortium/Legal/copyright-documents-19990405.html
20Url: http://www.w3.org/TR/xhtml1/
21
22%description
23XML document type definition for XHTML 1.0
24
25%prep
26[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
27rm -rf ${RPM_BUILD_DIR}/%{name}-%{version}
28
29%setup -c -T
30unzip %{SOURCE0}
31cp -a %{SOURCE1} .
32
33%build
34
35%install
36[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
37[ "${RPM_BUILD_ROOT}" != "/" ] && \
38            mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/sgml/xhtml/xhtml-dtd-1.0
39
40pushd xhtml1/DTD
41install -m0644 *.ent ${RPM_BUILD_ROOT}%{_datadir}/sgml/xhtml/xhtml-dtd-1.0
42install -m0644 *.dtd ${RPM_BUILD_ROOT}%{_datadir}/sgml/xhtml/xhtml-dtd-1.0
43install -m0644 *.dcl ${RPM_BUILD_ROOT}%{_datadir}/sgml/xhtml/xhtml-dtd-1.0
44install -m0644 *.soc ${RPM_BUILD_ROOT}%{_datadir}/sgml/xhtml/xhtml-dtd-1.0
45ln -s  xhtml.soc ${RPM_BUILD_ROOT}%{_datadir}/sgml/xhtml/xhtml-dtd-1.0/catalog
46popd
47
48%clean
49[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
50rm -rf ${RPM_BUILD_DIR}/%{name}-%{version}
51
52%files
53%defattr (-,root,root)
54%doc copyright-documents-19990405.html xhtml1/*.*
55%{_datadir}/sgml/xhtml/xhtml-dtd-1.0
56
57
58%post
59# Update the centralized catalog corresponding to this version of the DTD
60/usr/bin/install-catalog --add /etc/sgml/%{catalog_name} %{_datadir}/sgml/xhtml/xhtml-dtd-1.0/catalog > /dev/null
61
62# Update the link to the current version of the DTD
63ln -s -f /etc/sgml/%{catalog_name} /etc/sgml/xhtml.cat
64
65%postun
66# Update the centralized catalog corresponding to this version of the DTD
67/usr/bin/install-catalog --remove /etc/sgml/%{catalog_name} %{_datadir}/sgml/xhtml/xhtml-dtd-1.0/catalog > /dev/null
68
69# Update the link to the current version of the DTD
70if [ ! -e /etc/sgml/%{catalog_name} ]; then
71    rm -f /etc/sgml/xhtml.cat
72    OTHERCAT=`ls /etc/sgml/xhtml-?.*.cat 2> /dev/null | head --lines 1`
73    if [ -n "$OTHERCAT" ]; then ln -s $OTHERCAT /etc/sgml/xhtml.cat; fi
74fi
75
76%changelog
77* Wed Oct 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.0-2vl5
78- applied new versioning policy
79
80* Mon Mar 24 2003 IWAI Masaharu <iwai@alib.jp> 1.0-1vl2
81- rename catalog file
82
83* Sun Jan  6 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp>
84- first release
85
Note: See TracBrowser for help on using the repository browser.