source: projects/specs/trunk/x/xfsprogs/xfsprogs-vl.spec @ 8735

Revision 8735, 8.8 KB checked in by tomop, 10 years ago (diff)

filesystem tools.

Line 
1Summary:        Utilities for managing the XFS filesystem
2Summary(ja):    XFSファイルシステムを管理するためのユーティリティ
3Name:           xfsprogs
4Version:        3.2.0
5Release:        1%{?_dist_release}
6# Licensing based on generic "GNU GENERAL PUBLIC LICENSE"
7# in source, with no mention of version.
8# doc/COPYING file specifies what is GPL and what is LGPL
9# but no mention of versions in the source.
10License:        GPL+ and LGPLv2+
11Group:          System Environment/Base
12URL:            http://oss.sgi.com/projects/xfs/
13Source0:        ftp://oss.sgi.com/projects/xfs/download/cmd_tars/%{name}-%{version}.tar.gz
14Source1:        xfsprogs-wrapper.h
15BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
16BuildRequires:  libtool, gettext
17BuildRequires:  libuuid-devel
18BuildRequires:  readline-devel
19BuildRequires:  libblkid-devel
20
21%description
22A set of commands to use the XFS filesystem, including mkfs.xfs.
23
24XFS is a high performance journaling filesystem which originated
25on the SGI IRIX platform.  It is completely multi-threaded, can
26support large files and large filesystems, extended attributes,
27variable block sizes, is extent based, and makes extensive use of
28Btrees (directories, extents, free space) to aid both performance
29and scalability.
30
31Refer to the documentation at http://oss.sgi.com/projects/xfs/
32for complete details.  This implementation is on-disk compatible
33with the IRIX version of XFS.
34
35%package devel
36Summary: XFS filesystem-specific static libraries and headers
37Summary(ja): XFS filesystem-specific static libraries and headers
38Group: Development/Libraries
39Requires: xfsprogs = %{version}-%{release}
40
41%description devel
42xfsprogs-devel contains the libraries and header files needed to
43develop XFS filesystem-specific programs.
44
45You should install xfsprogs-devel if you want to develop XFS
46filesystem-specific programs,  If you install xfsprogs-devel, you'll
47also want to install xfsprogs.
48
49%prep
50%setup -q
51
52%build
53# xfsprogs abuses libexecdir
54export tagname=CC DEBUG=-DNDEBUG
55
56%configure \
57        --enable-readline=yes   \
58        --enable-blkid=yes
59
60# Kill rpaths
61sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
62sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
63
64make V=1 %{?_smp_mflags}
65
66%install
67rm -rf $RPM_BUILD_ROOT
68make V=1 DIST_ROOT=$RPM_BUILD_ROOT install install-dev install-qa
69
70# nuke .la files, etc
71rm -f $RPM_BUILD_ROOT/{%{_lib}/*.{la,a,so},%{_libdir}/*.{la,a}}
72
73# fix up symlink to be correct
74rm -f $RPM_BUILD_ROOT/%{_libdir}/libhandle.so
75ln -s ../../%{_lib}/libhandle.so.1 $RPM_BUILD_ROOT/%{_libdir}/libhandle.so
76
77# remove non-versioned docs location
78rm -rf $RPM_BUILD_ROOT/%{_datadir}/doc/xfsprogs/
79
80# ugly hack to allow parallel install of 32-bit and 64-bit -devel packages:
81%define multilib_arches %{ix86} x86_64 ppc ppc64 s390 s390x sparcv9 sparc64
82
83%ifarch %{multilib_arches}
84mv -f $RPM_BUILD_ROOT%{_includedir}/xfs/platform_defs.h \
85      $RPM_BUILD_ROOT%{_includedir}/xfs/platform_defs-%{_arch}.h
86install -m 644 %{SOURCE1} $RPM_BUILD_ROOT%{_includedir}/xfs/platform_defs.h
87%endif
88
89%find_lang %{name}
90
91%clean
92rm -rf $RPM_BUILD_ROOT
93
94%post -p /sbin/ldconfig
95
96%postun -p /sbin/ldconfig
97
98%files -f %{name}.lang
99%defattr(-,root,root)
100%doc doc/CHANGES doc/COPYING doc/CREDITS README
101/sbin/*
102/%{_lib}/*.so.*
103%{_mandir}/man8/*
104%{_mandir}/man5/*
105%{_sbindir}/*
106
107%files devel
108%defattr(-,root,root)
109%{_mandir}/man3/*
110%{_includedir}/xfs
111%{_libdir}/*.so
112
113%changelog
114* Fri Jul  4 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.2.0-1
115- new upstream release.
116
117* Thu Dec 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.10-1
118- new upstream release
119
120* Sat Dec 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
121- new upstream release
122- add BuildRequires: libuuid-devel
123- remove all configure options
124- fix %%install and %%files
125
126* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp>  2.10.1-1
127- initial build for Vine Linux
128
129* Wed Apr 23 2008 Dennis Gilmore <dennis@ausil.us> 2.9.8-3
130- sparc32 is built using the sparcv9 variant
131
132* Wed Apr 23 2008 Eric Sandeen <sandeen@redhat.com> 2.9.8-2
133- Tidy up multilib hack for non-multilib arches & add sparc (#448452)
134
135* Wed Apr 23 2008 Eric Sandeen <sandeen@redhat.com> 2.9.8-1
136- Update to xfsprogs 2.9.8
137- Add support for sb_features2 in wrong location
138- Add -c option to xfs_admin to turn lazy-counters on/off
139- Added support for mdp in libdisk/mkfs.xfs
140
141* Sun Mar 02 2008 Eric Sandeen <sandeen@redhat.com> 2.9.7-1
142- Update to xfsprogs 2.9.7
143- Lazy sb counters back off by default; other misc fixes
144
145* Wed Feb 06 2008 Eric Sandeen <sandeen@redhat.com> 2.9.6-1
146- Update to xfsprogs 2.9.6 - fixes mkfs sizing problem.
147- Trim down BuildRequires to what's actually required now
148
149* Mon Jan 21 2008 Eric Sandeen <sandeen@redhat.com> 2.9.5-1
150- Update to xfsprogs 2.9.5
151- Contains more optimal mkfs defaults
152- specfile cleanup, & don't restate config defaults
153
154* Tue Oct 23 2007 Eric Sandeen <sandeen@redhat.com> 2.9.4-4
155- Add arm to multilib header wrapper
156
157* Tue Oct 02 2007 Eric Sandeen <sandeen@redhat.com> 2.9.4-3
158- mkfs.xfs: Fix wiping old AG headers and purge whack buffers
159
160* Mon Oct 01 2007 Eric Sandeen <sandeen@redhat.com> 2.9.4-2
161- Add alpha to the multilib wrapper (#310411)
162
163* Mon Sep 10 2007 Eric Sandeen <sandeen@redhat.com> 2.9.4-1
164- Update to xfsprogs 2.9.4
165
166* Fri Aug 24 2007 Eric Sandeen <sandeen@redhat.com> 2.9.3-3
167- Add gawk to buildrequires
168
169* Thu Aug 16 2007 Eric Sandeen <sandeen@redhat.com> 2.9.3-2
170- Update license tag
171
172* Thu Jul 26 2007 Eric Sandeen <sandeen@redhat.com> 2.9.3-1
173- Upgrade to xfsprogs 2.9.2, quota, xfs_repair, and filestreams changes
174
175* Fri Jul  6 2007 Eric Sandeen <sandeen@redhat.com> 2.8.21-1
176- Upgrade to xfsprogs 2.8.21, lazy sb counters enabled,
177  xfs_quota fix (#236746)
178
179* Thu May 31 2007 Eric Sandeen <sandeen@redhat.com> 2.8.20-2
180- Fix ppc64 build... again
181
182* Fri May 25 2007 Eric Sandeen <sandeen@redhat.com> 2.8.20-1
183- Upgrade to xfsprogs 2.8.20, several xfs_repair fixes
184
185* Tue Mar 06 2007 Miroslav Lichvar <mlichvar@redhat.com> 2.8.18-3
186- Remove libtermcap-devel from BuildRequires
187
188* Wed Feb 14 2007 Miroslav Lichvar <mlichvar@redhat.com> 2.8.18-2
189- Disable readline support for now (#223781)
190
191* Sun Feb 04 2007 Jarod Wilson <jwilson@redhat.com> 2.8.18-1
192- Post-facto changelog addition to note bump to 2.8.18
193
194* Wed Sep 27 2006 Russell Cattelan <cattelan@thebarn.com> 2.8.11-3
195- bump build version to 3 for a new brew build
196
197* Tue Sep 26 2006 Russell Cattelan <cattelan@thebarn.com> 2.8.11-2
198- add ppc64 build patch
199
200* Thu Sep 21 2006 Russell Cattelan <cattelan@redhat.com> 2.8.11-1
201- Upgrade to xfsprogs 2.8.11 Need to pick up important repair fixes
202
203* Tue Jul 18 2006 Jeremy Katz <katzj@redhat.com> - 2.8.4-3
204- exclude arch ppc64 for now (#199315)
205
206* Mon Jul 17 2006 Jesse Keating <jkeating@redhat.com> - 2.8.4-2
207- rebuild
208
209* Tue Jul 04 2006 Robert Scheck <redhat@linuxnetz.de> 2.8.4-1
210- Upgrade to 2.8.4 (#196599 #c2)
211
212* Sun Jun 25 2006 Robert Scheck <redhat@linuxnetz.de> 2.8.3-1
213- Upgrade to 2.8.3 (#196599)
214- Applied Russell Coker's suggested patch to improve the
215  performance for SELinux machines significantly (#120622)
216
217* Sun Jun 25 2006 Robert Scheck <redhat@linuxnetz.de> 2.7.11-2
218- Fixed multilib conflict of xfs/platform_defs.h (#192755)
219
220* Sun Mar 12 2006 Robert Scheck <redhat@linuxnetz.de> 2.7.11-1
221- Upgrade to 2.7.11 and spec file cleanup (#185234)
222
223* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.7.3-1.2.1
224- bump again for double-long bug on ppc(64)
225
226* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.7.3-1.2
227- rebuilt for new gcc4.1 snapshot and glibc changes
228
229* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
230- rebuilt
231
232* Mon Oct 31 2005 Robert Scheck <redhat@linuxnetz.de> 2.7.3-1
233- Upgrade to 2.7.3 and enabled termcap support (#154323)
234
235* Wed Sep 28 2005 Florian La Roche <laroche@redhat.com>
236- fixup building with current rpm
237
238* Wed Apr 20 2005 Dave Jones <davej@redhat.com>
239- Disable debug. (#151438)
240- Rebuild with gcc4
241
242* Wed Jan 12 2005 Tim Waugh <twaugh@redhat.com> - 2.6.13-3
243- Rebuilt for new readline.
244
245* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
246- rebuilt
247
248* Wed May  5 2004 Jeremy Katz <katzj@redhat.com> - 2.6.13-1
249- update to 2.6.13 per request of upstream
250- fixes mount by label of xfs on former raid partition (#122043)
251
252* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
253- rebuilt
254
255* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
256- rebuilt
257
258* Thu Jan  8 2004 Jeremy Katz <katzj@redhat.com> 2.6.0-2
259- add defattr (reported by Matthias)
260
261* Tue Dec 23 2003 Elliot Lee <sopwith@redhat.com> 2.6.0-3
262- Fix tyops in dependencies
263
264* Mon Dec 22 2003 Jeremy Katz <katzj@redhat.com> 2.6.0-1
265- build for Fedora Core
266- switch to more explicit file lists, nuke .la files
267
268* Tue Dec 16 2003 Axel Thimm <Axel.Thimm@physik.fu-berlin.de> 2.6.0
269- Update to 2.6.0.
270
271* Sat Sep 13 2003 Axel Thimm <Axel.Thimm@physik.fu-berlin.de>
272- Sync with XFS 1.3.0.
273- Update to 2.5.6.
274
275* Thu Apr 10 2003 Axel Thimm <Axel.Thimm@physik.fu-berlin.de> 2.3.9-0_2.90at
276- Rebuilt for Red Hat 9.
Note: See TracBrowser for help on using the repository browser.