source: projects/specs/trunk/x/xfsprogs/xfsprogs-vl.spec @ 521

Revision 521, 8.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:        Utilities for managing the XFS filesystem
2Summary(ja):    XFSファイルシステムを管理するためのユーティリティ
3Name:           xfsprogs
4Version:        2.10.1
5Release:        1%{?_dist_release}
6# Licensing based on generic "GNU GENERAL PUBLIC LICENSE"
7# in source, with no mention of version.
8# doc/COPYING file specifies what is GPL and what is LGPL
9# but no mention of versions in the source.
10License:        GPL+ and LGPLv2+
11Group:          System Environment/Base
12URL:            http://oss.sgi.com/projects/xfs/
13Source0:        ftp://oss.sgi.com/projects/xfs/download/cmd_tars/%{name}_%{version}-1.tar.gz
14Source1:        xfsprogs-wrapper.h
15BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
16BuildRequires:  libtool, gettext
17BuildRequires:  e2fsprogs-devel
18
19%description
20A set of commands to use the XFS filesystem, including mkfs.xfs.
21
22XFS is a high performance journaling filesystem which originated
23on the SGI IRIX platform.  It is completely multi-threaded, can
24support large files and large filesystems, extended attributes,
25variable block sizes, is extent based, and makes extensive use of
26Btrees (directories, extents, free space) to aid both performance
27and scalability.
28
29Refer to the documentation at http://oss.sgi.com/projects/xfs/
30for complete details.  This implementation is on-disk compatible
31with the IRIX version of XFS.
32
33%package devel
34Summary: XFS filesystem-specific static libraries and headers
35Summary(ja): XFS filesystem-specific static libraries and headers
36Group: Development/Libraries
37Requires: xfsprogs = %{version}-%{release}
38
39%description devel
40xfsprogs-devel contains the libraries and header files needed to
41develop XFS filesystem-specific programs.
42
43You should install xfsprogs-devel if you want to develop XFS
44filesystem-specific programs,  If you install xfsprogs-devel, you'll
45also want to install xfsprogs.
46
47%prep
48%setup -q
49
50%build
51# xfsprogs abuses libexecdir
52export tagname=CC DEBUG=-DNDEBUG
53
54%configure \
55        --sbindir=/sbin         \
56        --libdir=/%{_lib}       \
57        --libexecdir=%{_libdir} \
58        --bindir=%{_sbindir}
59
60make %{?_smp_mflags}
61
62%install
63rm -rf $RPM_BUILD_ROOT
64make DIST_ROOT=$RPM_BUILD_ROOT install install-dev
65
66# nuke .la files, etc
67rm -f $RPM_BUILD_ROOT/{%{_lib}/*.{la,a,so},%{_libdir}/*.la}
68# fix up symlink to be correct
69rm -f $RPM_BUILD_ROOT/%{_libdir}/libhandle.so
70ln -s ../../%{_lib}/libhandle.so.1 $RPM_BUILD_ROOT/%{_libdir}/libhandle.so
71# remove non-versioned docs location
72rm -rf $RPM_BUILD_ROOT/%{_datadir}/doc/xfsprogs/
73
74# ugly hack to allow parallel install of 32-bit and 64-bit -devel packages:
75%define multilib_arches %{ix86} x86_64 ppc ppc64 s390 s390x sparcv9 sparc64
76
77%ifarch %{multilib_arches}
78mv -f $RPM_BUILD_ROOT%{_includedir}/xfs/platform_defs.h \
79      $RPM_BUILD_ROOT%{_includedir}/xfs/platform_defs-%{_arch}.h
80install -m 644 %{SOURCE1} $RPM_BUILD_ROOT%{_includedir}/xfs/platform_defs.h
81%endif
82
83%find_lang %{name}
84
85%clean
86rm -rf $RPM_BUILD_ROOT
87
88%post -p /sbin/ldconfig
89
90%postun -p /sbin/ldconfig
91
92%files -f %{name}.lang
93%defattr(-,root,root)
94%doc doc/CHANGES doc/COPYING doc/CREDITS doc/PORTING README
95/sbin/fsck.xfs
96/sbin/mkfs.xfs
97/sbin/xfs_repair
98/%{_lib}/*.so.*
99%{_mandir}/man8/*
100%{_mandir}/man5/*
101%{_sbindir}/*
102
103%files devel
104%defattr(-,root,root)
105%{_mandir}/man3/*
106%{_includedir}/disk
107%{_includedir}/xfs
108%{_libdir}/*.a
109%{_libdir}/*.so
110
111%changelog
112* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp>  2.10.1-1
113- initial build for Vine Linux
114
115* Wed Apr 23 2008 Dennis Gilmore <dennis@ausil.us> 2.9.8-3
116- sparc32 is built using the sparcv9 variant
117
118* Wed Apr 23 2008 Eric Sandeen <sandeen@redhat.com> 2.9.8-2
119- Tidy up multilib hack for non-multilib arches & add sparc (#448452)
120
121* Wed Apr 23 2008 Eric Sandeen <sandeen@redhat.com> 2.9.8-1
122- Update to xfsprogs 2.9.8
123- Add support for sb_features2 in wrong location
124- Add -c option to xfs_admin to turn lazy-counters on/off
125- Added support for mdp in libdisk/mkfs.xfs
126
127* Sun Mar 02 2008 Eric Sandeen <sandeen@redhat.com> 2.9.7-1
128- Update to xfsprogs 2.9.7
129- Lazy sb counters back off by default; other misc fixes
130
131* Wed Feb 06 2008 Eric Sandeen <sandeen@redhat.com> 2.9.6-1
132- Update to xfsprogs 2.9.6 - fixes mkfs sizing problem.
133- Trim down BuildRequires to what's actually required now
134
135* Mon Jan 21 2008 Eric Sandeen <sandeen@redhat.com> 2.9.5-1
136- Update to xfsprogs 2.9.5
137- Contains more optimal mkfs defaults
138- specfile cleanup, & don't restate config defaults
139
140* Tue Oct 23 2007 Eric Sandeen <sandeen@redhat.com> 2.9.4-4
141- Add arm to multilib header wrapper
142
143* Tue Oct 02 2007 Eric Sandeen <sandeen@redhat.com> 2.9.4-3
144- mkfs.xfs: Fix wiping old AG headers and purge whack buffers
145
146* Mon Oct 01 2007 Eric Sandeen <sandeen@redhat.com> 2.9.4-2
147- Add alpha to the multilib wrapper (#310411)
148
149* Mon Sep 10 2007 Eric Sandeen <sandeen@redhat.com> 2.9.4-1
150- Update to xfsprogs 2.9.4
151
152* Fri Aug 24 2007 Eric Sandeen <sandeen@redhat.com> 2.9.3-3
153- Add gawk to buildrequires
154
155* Thu Aug 16 2007 Eric Sandeen <sandeen@redhat.com> 2.9.3-2
156- Update license tag
157
158* Thu Jul 26 2007 Eric Sandeen <sandeen@redhat.com> 2.9.3-1
159- Upgrade to xfsprogs 2.9.2, quota, xfs_repair, and filestreams changes
160
161* Thu Jul  6 2007 Eric Sandeen <sandeen@redhat.com> 2.8.21-1
162- Upgrade to xfsprogs 2.8.21, lazy sb counters enabled,
163  xfs_quota fix (#236746)
164
165* Thu May 31 2007 Eric Sandeen <sandeen@redhat.com> 2.8.20-2
166- Fix ppc64 build... again
167
168* Fri May 25 2007 Eric Sandeen <sandeen@redhat.com> 2.8.20-1
169- Upgrade to xfsprogs 2.8.20, several xfs_repair fixes
170
171* Tue Mar 06 2007 Miroslav Lichvar <mlichvar@redhat.com> 2.8.18-3
172- Remove libtermcap-devel from BuildRequires
173
174* Wed Feb 14 2007 Miroslav Lichvar <mlichvar@redhat.com> 2.8.18-2
175- Disable readline support for now (#223781)
176
177* Sun Feb 04 2007 Jarod Wilson <jwilson@redhat.com> 2.8.18-1
178- Post-facto changelog addition to note bump to 2.8.18
179
180* Wed Sep 27 2006 Russell Cattelan <cattelan@thebarn.com> 2.8.11-3
181- bump build version to 3 for a new brew build
182
183* Tue Sep 26 2006 Russell Cattelan <cattelan@thebarn.com> 2.8.11-2
184- add ppc64 build patch
185
186* Thu Sep 21 2006 Russell Cattelan <cattelan@redhat.com> 2.8.11-1
187- Upgrade to xfsprogs 2.8.11 Need to pick up important repair fixes
188
189* Tue Jul 18 2006 Jeremy Katz <katzj@redhat.com> - 2.8.4-3
190- exclude arch ppc64 for now (#199315)
191
192* Mon Jul 17 2006 Jesse Keating <jkeating@redhat.com> - 2.8.4-2
193- rebuild
194
195* Tue Jul 04 2006 Robert Scheck <redhat@linuxnetz.de> 2.8.4-1
196- Upgrade to 2.8.4 (#196599 #c2)
197
198* Sun Jun 25 2006 Robert Scheck <redhat@linuxnetz.de> 2.8.3-1
199- Upgrade to 2.8.3 (#196599)
200- Applied Russell Coker's suggested patch to improve the
201  performance for SELinux machines significantly (#120622)
202
203* Sun Jun 25 2006 Robert Scheck <redhat@linuxnetz.de> 2.7.11-2
204- Fixed multilib conflict of xfs/platform_defs.h (#192755)
205
206* Sun Mar 12 2006 Robert Scheck <redhat@linuxnetz.de> 2.7.11-1
207- Upgrade to 2.7.11 and spec file cleanup (#185234)
208
209* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.7.3-1.2.1
210- bump again for double-long bug on ppc(64)
211
212* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.7.3-1.2
213- rebuilt for new gcc4.1 snapshot and glibc changes
214
215* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
216- rebuilt
217
218* Mon Oct 31 2005 Robert Scheck <redhat@linuxnetz.de> 2.7.3-1
219- Upgrade to 2.7.3 and enabled termcap support (#154323)
220
221* Wed Sep 28 2005 Florian La Roche <laroche@redhat.com>
222- fixup building with current rpm
223
224* Wed Apr 20 2005 Dave Jones <davej@redhat.com>
225- Disable debug. (#151438)
226- Rebuild with gcc4
227
228* Wed Jan 12 2005 Tim Waugh <twaugh@redhat.com> - 2.6.13-3
229- Rebuilt for new readline.
230
231* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
232- rebuilt
233
234* Wed May  5 2004 Jeremy Katz <katzj@redhat.com> - 2.6.13-1
235- update to 2.6.13 per request of upstream
236- fixes mount by label of xfs on former raid partition (#122043)
237
238* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
239- rebuilt
240
241* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
242- rebuilt
243
244* Thu Jan  8 2004 Jeremy Katz <katzj@redhat.com> 2.6.0-2
245- add defattr (reported by Matthias)
246
247* Tue Dec 23 2003 Elliot Lee <sopwith@redhat.com> 2.6.0-3
248- Fix tyops in dependencies
249
250* Mon Dec 22 2003 Jeremy Katz <katzj@redhat.com> 2.6.0-1
251- build for Fedora Core
252- switch to more explicit file lists, nuke .la files
253
254* Tue Dec 16 2003 Axel Thimm <Axel.Thimm@physik.fu-berlin.de> 2.6.0
255- Update to 2.6.0.
256
257* Sat Sep 13 2003 Axel Thimm <Axel.Thimm@physik.fu-berlin.de>
258- Sync with XFS 1.3.0.
259- Update to 2.5.6.
260
261* Thu Apr 10 2003 Axel Thimm <Axel.Thimm@physik.fu-berlin.de> 2.3.9-0_2.90at
262- Rebuilt for Red Hat 9.
Note: See TracBrowser for help on using the repository browser.