source: projects/specs/trunk/x/xfig/xfig-vl.spec @ 9003

Revision 9003, 6.6 KB checked in by inagaki, 10 years ago (diff)

2014-10-11 Ryoichi INAGAKI <ryo1@…>

  • transfig, xfig: update


Line 
1%define desktop_file 1
2%define desktop_file_utils_version 0.2.90
3
4Summary: An X Window System tool for drawing basic vector graphics.
5Name: xfig
6Version: 3.2.5c
7Release: 1%{?_dist_release}
8License: MIT
9Group: Applications/Graphics
10URL: http://www.xfig.org/
11Source0: http://www.xfig.org/xfigdist/xfig.%{version}.full.tar.gz
12Source1: xfig-icons.tar.gz
13Source2: xfig.desktop
14Source3: xfig.sh
15Source4: Fig.ad.ja
16
17Patch0: xfig-3.2.5a-default-apps.patch
18Patch1: xfig-3.2.5-Imakefile.patch
19Patch3: xfig-3.2.5-urwfonts.patch
20Patch4: 31_spelling.patch
21Patch5: 33_pdfimport_mediabox.patch
22# xfig_man.html is not in 3.2.5c tarball from some reason,
23# but makefile still tries to install it
24Patch6: 38_formatstring.patch
25Patch7: 39_add_xfig_man_html.patch
26Patch8: 40_fix_dash_list_for_different_styles.patch
27Patch9: xfig-3.2.5-rhbz1046102.patch
28
29Buildroot: %{_tmppath}/%{name}-%{version}-root
30BuildRequires: desktop-file-utils
31BuildRequires: freetype2-devel
32BuildRequires: imake
33BuildRequires: libICE-devel
34BuildRequires: libSM-devel
35BuildRequires: libX11-devel
36BuildRequires: libXaw3dXft-devel
37BuildRequires: libXmu-devel
38BuildRequires: libXpm-devel
39BuildRequires: libXt-devel
40BuildRequires: libjpeg-devel
41BuildRequires: libpng-devel
42BuildRequires: zlib-devel
43
44Requires: hicolor-icon-theme
45Requires: transfig >= 3.2.5
46Requires: urw-fonts
47Requires: xdg-utils
48
49Vendor: Project Vine
50Distribution: Vine Linux
51
52%description
53Xfig is an X Window System tool for creating basic vector graphics,
54including bezier curves, lines, rulers and more.  The resulting
55graphics can be saved, printed on PostScript printers or converted to
56a variety of other formats (e.g., X11 bitmaps, Encapsulated
57PostScript, LaTeX).
58
59%prep
60%setup -q -n xfig.%{version} -a 1
61%patch0 -p1 -b .redhat
62%patch1 -p1 -b .Imakefile
63#patch7 -p1 -b .modularX
64#patch9 -p1 -b .Xaw3d
65#patch10 -p1 -b .no-Xaw3d
66#patch13 -p1 -b .urw
67#patch19 -p1
68%patch3 -p1 -b .urw
69%patch4 -p1
70%patch5 -p1
71%patch6 -p1
72%patch7 -p1
73%patch8 -p1
74%patch9 -p1
75
76iconv -f ISO-8859-1 -t UTF8 CHANGES > tmp; touch -r CHANGES tmp; mv tmp CHANGES
77rm Doc/html/images/sav1a0.tmp
78chmod -x `find -type f`
79
80# fix for building libXaw3dXft
81sed -i 's/X11\/Xaw3d\//X11\/Xaw3dxft\//' *.h *.c
82sed -i 's/-lXaw3d/-lXaw3dxft/' Imakefile
83
84
85%build
86xmkmf
87make XFIGDOCDIR=%{_docdir}/%{name}-%{version} \
88     INCLUDES=`pkg-config --cflags freetype2`  \
89     CDEBUGFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE -fno-strength-reduce -fno-strict-aliasing"
90
91%install
92rm -rf $RPM_BUILD_ROOT
93
94make DESTDIR=%{buildroot} XFIGDOCDIR=%{_docdir}/%{name}-%{version} \
95     INSTALL="install -p" install.all
96install -p -m 644 CHANGES README LATEX.AND.XFIG* FIGAPPS \
97  %{buildroot}%{_docdir}/%{name}-%{version}
98
99# remove the map generation scripts, these are for xfig developers only
100rm %{buildroot}%{_datadir}/%{name}/Libraries/Maps/{USA,Canada}/assemble
101# remove app-defaults symlink which gets installed
102rm $RPM_BUILD_ROOT%{_prefix}/lib*/X11/app-defaults
103
104install -D -p -m 644 %{name}16x16.xpm \
105  $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps/%{name}.xpm
106install -D -p -m 644 %{name}32x32.xpm \
107  $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/%{name}.xpm
108install -D -p -m 644 %{name}64x64.xpm \
109  $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/%{name}.xpm
110
111mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
112desktop-file-install          \
113  --dir $RPM_BUILD_ROOT%{_datadir}/applications %{SOURCE2}
114
115
116%clean
117rm -rf $RPM_BUILD_ROOT
118
119%post
120update-desktop-database &> /dev/null || :
121touch --no-create %{_datadir}/icons/hicolor || :
122if [ -x %{_bindir}/gtk-update-icon-cache ]; then
123   %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
124fi
125
126%postun
127update-desktop-database &> /dev/null || :
128touch --no-create %{_datadir}/icons/hicolor || :
129if [ -x %{_bindir}/gtk-update-icon-cache ]; then
130   %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
131fi
132
133
134%files
135%defattr(-,root,root)
136%doc %{_docdir}/%{name}-%{version}
137%{_bindir}/%{name}
138%{_datadir}/%{name}
139%{_mandir}/*/*
140%{_datadir}/X11/app-defaults/*
141%{_datadir}/applications/%{name}.desktop
142%{_datadir}/icons/hicolor/??x??/apps/%{name}.xpm
143
144
145%changelog
146* Sat Oct 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.2.5c-1
147- updated to 3.2.5c
148- updated Source1
149- added Patch 4-9 from Fedora and dropt Patch7, 9, 10 and 19
150- build with libXaw3dXft
151
152* Thu Sep 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.5-1
153- new usptream release
154- build with modular X
155- import patched from fedora package.
156- drop jp patch
157
158* Sat Jul 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2.4-2vl5
159- rebuilt with Xaw3d-1.5-17vl3
160
161* Fri Sep 10 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2.4-2vl4
162- Requires transfig >= 3.2.4, ghostscript
163- build with -march=i386
164- changed Group
165- fixed .desktop file
166
167* Wed Sep  8 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2.4-2vl3
168- rebuild with gcc-3.3.2
169- added BuildPrereq: Xaw3d-devel
170
171* Sun Aug 31 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2.4-2vl2
172- based on Rawhide 3.2.4-2
173  * Tue May  6 2003 Than Ngo <than@redhat.com> 3.2.4-1
174  - 3.2.4
175  * Wed Jul 24 2002 Than Ngo <than@redhat.com> 3.2.3d-8
176  - desktop file issue (bug #69543)
177  * Tue Jun 25 2002 Than Ngo <than@redhat.com> 3.2.3d-7
178  - add patch file using mkstemp (bug #67351)
179  * Tue Jul 03 2001 Than Ngo <than@redhat.com>
180  - fix export to eps when i18n set (bug #45114)
181
182- update Source3
183- previous Patch0 moved to Patch10
184- rebuild with new toolchains
185
186* Sun Aug 20 2000 Jun Nishii <jun@vinelinux.org>
187- 3.2.3c-0vl1
188- use brp
189
190* Mon Jan 24 2000 Atsushi Saito <saito4@slb.com>
191- update to 3.2.3a
192
193* Tue Dec 21 1999 Atsushi Saito <saito4@slb.com>
194- update to 3.2.3-beta-1
195- i18n
196
197* Thu Sep 23 1999 Preston Brown <pbrown@redhat.com>
198- add icon
199- don't compile with optimization on alpha
200
201* Mon Aug 30 1999 Preston Brown <pbrown@redhat.com>
202- converted to use a .desktop file
203
204* Fri Mar 26 1999 Michael Maher <mike@redhat.com>
205- added files that were missing.
206
207* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
208- auto rebuild in the new build environment (release 4)
209- varargs fix
210
211* Thu Feb 18 1999 Jeff Johnson <jbj@redhat.com>
212- correct DESTDIRR typo (#962)
213
214* Wed Dec 30 1998 Cristian Gafton <gafton@redhat.com>
215- build for glibc 2.1
216
217* Tue Jul  7 1998 Jeff Johnson <jbj@redhat.com>
218- updated to 3.2.2.
219
220* Wed Jun 10 1998 Prospector System <bugs@redhat.com>
221- translations modified for de
222
223* Fri May 08 1998 Prospector System <bugs@redhat.com>
224- translations modified for de, fr, tr
225
226* Sat Apr 11 1998 Cristian Gafton <gafton@redhat.com>
227- updated for manhattan
228- buildroot
229
230* Thu Oct 23 1997 Marc Ewing <marc@redhat.com>
231- new version
232- messed with config for 5.0
233- updated Requires and Copyright
234- added wmconfig
235
236* Mon Jul 21 1997 Erik Troan <ewt@redhat.com>
237- built against glibc
Note: See TracBrowser for help on using the repository browser.