source: projects/specs/trunk/x/xfig/xfig-vl.spec @ 521

Revision 521, 5.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define desktop_file 1
2%define desktop_file_utils_version 0.2.90
3
4Summary: An X Window System tool for drawing basic vector graphics.
5Name: xfig
6Version: 3.2.5b
7Release: 1%{?_dist_release}
8License: Freeware
9Group: Applications/Graphics
10Url: http://www.xfig.org/
11Source0: http://www.xfig.org/xfigdist/xfig.%{version}.full.tar.gz
12Source1: xfig.png
13Source2: xfig.desktop
14Source3: xfig.sh
15Source4: Fig.ad.ja
16
17Patch0: xfig-3.2.5a-default-apps.patch
18Patch1: xfig-3.2.5-fhs.patch
19Patch7: xfig.3.2.5-modularX.patch
20Patch9: xfig.3.2.5-Xaw3d.patch
21Patch10: xfig-3.2.5-enable-Xaw3d.patch
22Patch13: xfig-3.2.5-urwfonts.patch
23Patch19: xfig-3.2.5-debian.patch
24
25BuildRequires: libjpeg-devel
26BuildRequires: libpng-devel
27BuildRequires: imake
28BuildRequires: libICE-devel
29BuildRequires: libSM-devel
30BuildRequires: libX11-devel
31BuildRequires: libXaw-devel
32BuildRequires: libXext-devel
33BuildRequires: libXi-devel
34BuildRequires: libXmu-devel
35BuildRequires: libXpm-devel
36BuildRequires: libXt-devel
37BuildRequires: Xaw3d-devel
38BuildRequires: desktop-file-utils
39
40Buildroot: %{_tmppath}/%{name}-root
41Requires: transfig >= 3.2.5
42Requires: xdg-utils, enchant, urw-fonts
43Requires: hicolor-icon-theme
44
45Vendor: Project Vine
46Distribution: Vine Linux
47
48%description
49Xfig is an X Window System tool for creating basic vector graphics,
50including bezier curves, lines, rulers and more.  The resulting
51graphics can be saved, printed on PostScript printers or converted to
52a variety of other formats (e.g., X11 bitmaps, Encapsulated
53PostScript, LaTeX).
54
55%prep
56%setup -q -n xfig.%{version}
57%patch0 -p1 -b .redhat
58%patch1 -p1 -b .fhs
59%patch7 -p1 -b .modularX
60%patch9 -p1 -b .Xaw3d
61%patch10 -p1 -b .no-Xaw3d
62%patch13 -p1 -b .urw
63%patch19 -p1
64rm Doc/html/images/sav1a0.tmp
65
66%build
67xmkmf
68make XFIGDOCDIR=%{_docdir}/%{name}-%{version} \
69     CDEBUGFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE -fno-strength-reduce -fno-strict-aliasing"
70
71%install
72rm -rf $RPM_BUILD_ROOT
73
74make DESTDIR=%{buildroot} XFIGDOCDIR=%{_docdir}/%{name}-%{version} \
75     INSTALL="install -p" install.all
76install -p -m 644 CHANGES README LATEX.AND.XFIG* FIGAPPS \
77  %{buildroot}%{_docdir}/%{name}-%{version}
78
79# remove the map generation scripts, these are for xfig developers only
80rm %{buildroot}%{_datadir}/%{name}/Libraries/Maps/{USA,Canada}/assemble
81
82mkdir -p %{buildroot}%{_datadir}/icons/hicolor/32x32/apps \
83         %{buildroot}%{_datadir}/applications
84
85install -p -m 644 %{SOURCE1} %{buildroot}%{_datadir}/icons/hicolor/32x32/apps
86
87desktop-file-install --vendor ""         \
88  --dir %{buildroot}%{_datadir}/applications \
89  %{SOURCE2}
90
91# remove app-defaults symlink which gets installed
92rm %{buildroot}%{_prefix}/lib*/X11/app-defaults
93
94
95%clean
96rm -rf $RPM_BUILD_ROOT
97
98%post
99update-desktop-database &> /dev/null || :
100touch --no-create %{_datadir}/icons/hicolor || :
101if [ -x %{_bindir}/gtk-update-icon-cache ]; then
102   %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
103fi
104
105%postun
106update-desktop-database &> /dev/null || :
107touch --no-create %{_datadir}/icons/hicolor || :
108if [ -x %{_bindir}/gtk-update-icon-cache ]; then
109   %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
110fi
111
112
113%files
114%defattr(-,root,root)
115%doc %{_docdir}/%{name}-%{version}
116%{_bindir}/%{name}
117%{_datadir}/%{name}
118%{_mandir}/*/*
119%{_datadir}/X11/app-defaults/*
120%{_datadir}/applications/%{name}.desktop
121%{_datadir}/icons/hicolor/32x32/apps/%{name}.png
122
123
124%changelog
125* Thu Sep 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.5-1
126- new usptream release
127- build with modular X
128- import patched from fedora package.
129- drop jp patch
130
131* Sat Jul 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2.4-2vl5
132- rebuilt with Xaw3d-1.5-17vl3
133
134* Fri Sep 10 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2.4-2vl4
135- Requires transfig >= 3.2.4, ghostscript
136- build with -march=i386
137- changed Group
138- fixed .desktop file
139
140* Wed Sep  8 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2.4-2vl3
141- rebuild with gcc-3.3.2
142- added BuildPrereq: Xaw3d-devel
143
144* Sun Aug 31 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2.4-2vl2
145- based on Rawhide 3.2.4-2
146  * Tue May  6 2003 Than Ngo <than@redhat.com> 3.2.4-1
147  - 3.2.4
148  * Wed Jul 24 2002 Than Ngo <than@redhat.com> 3.2.3d-8
149  - desktop file issue (bug #69543)
150  * Tue Jun 25 2002 Than Ngo <than@redhat.com> 3.2.3d-7
151  - add patch file using mkstemp (bug #67351)
152  * Tue Jul 03 2001 Than Ngo <than@redhat.com>
153  - fix export to eps when i18n set (bug #45114)
154
155- update Source3
156- previous Patch0 moved to Patch10
157- rebuild with new toolchains
158
159* Sun Aug 20 2000 Jun Nishii <jun@vinelinux.org>
160- 3.2.3c-0vl1
161- use brp
162
163* Mon Jan 24 2000 Atsushi Saito <saito4@slb.com>
164- update to 3.2.3a
165
166* Tue Dec 21 1999 Atsushi Saito <saito4@slb.com>
167- update to 3.2.3-beta-1
168- i18n
169
170* Thu Sep 23 1999 Preston Brown <pbrown@redhat.com>
171- add icon
172- don't compile with optimization on alpha
173
174* Mon Aug 30 1999 Preston Brown <pbrown@redhat.com>
175- converted to use a .desktop file
176
177* Fri Mar 26 1999 Michael Maher <mike@redhat.com>
178- added files that were missing.
179
180* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
181- auto rebuild in the new build environment (release 4)
182- varargs fix
183
184* Thu Feb 18 1999 Jeff Johnson <jbj@redhat.com>
185- correct DESTDIRR typo (#962)
186
187* Wed Dec 30 1998 Cristian Gafton <gafton@redhat.com>
188- build for glibc 2.1
189
190* Tue Jul  7 1998 Jeff Johnson <jbj@redhat.com>
191- updated to 3.2.2.
192
193* Wed Jun 10 1998 Prospector System <bugs@redhat.com>
194- translations modified for de
195
196* Fri May 08 1998 Prospector System <bugs@redhat.com>
197- translations modified for de, fr, tr
198
199* Sat Apr 11 1998 Cristian Gafton <gafton@redhat.com>
200- updated for manhattan
201- buildroot
202
203* Thu Oct 23 1997 Marc Ewing <marc@redhat.com>
204- new version
205- messed with config for 5.0
206- updated Requires and Copyright
207- added wmconfig
208
209* Mon Jul 21 1997 Erik Troan <ewt@redhat.com>
210- built against glibc
Note: See TracBrowser for help on using the repository browser.