source: projects/specs/trunk/x/xfig/xfig-vl.spec @ 9247

Revision 9247, 6.8 KB checked in by inagaki, 9 years ago (diff)

2015-01-11 Ryoichi INAGAKI <ryo1@…>

  • libXaw3dXft: updated
  • xbill: built with libXaw3dXft
  • xfig: added xft patch


Line 
1%define desktop_file 1
2%define desktop_file_utils_version 0.2.90
3
4Summary: An X Window System tool for drawing basic vector graphics.
5Name: xfig
6Version: 3.2.5c
7Release: 2%{?_dist_release}
8License: MIT
9Group: Applications/Graphics
10URL: http://www.xfig.org/
11Source0: http://www.xfig.org/xfigdist/xfig.%{version}.full.tar.gz
12Source1: xfig-icons.tar.gz
13Source2: xfig.desktop
14Source3: xfig.sh
15Source4: Fig.ad.ja
16
17Patch0: xfig-3.2.5a-default-apps.patch
18Patch1: xfig-3.2.5-Imakefile.patch
19Patch3: xfig-3.2.5-urwfonts.patch
20Patch4: 31_spelling.patch
21Patch5: 33_pdfimport_mediabox.patch
22# xfig_man.html is not in 3.2.5c tarball from some reason,
23# but makefile still tries to install it
24Patch6: 38_formatstring.patch
25Patch7: 39_add_xfig_man_html.patch
26Patch8: 40_fix_dash_list_for_different_styles.patch
27Patch9: xfig-3.2.5-rhbz1046102.patch
28
29# patches for libXaw3dxft from http://sourceforge.net/projects/sf-xpaint/files/xaw3dxft-progs/
30# modified by deleting debian-related patch
31Patch100: xfig-xft.patch.bz2
32
33Buildroot: %{_tmppath}/%{name}-%{version}-root
34BuildRequires: desktop-file-utils
35BuildRequires: freetype2-devel
36BuildRequires: imake
37BuildRequires: libICE-devel
38BuildRequires: libSM-devel
39BuildRequires: libX11-devel
40BuildRequires: libXaw3dXft-devel
41BuildRequires: libXmu-devel
42BuildRequires: libXpm-devel
43BuildRequires: libXt-devel
44BuildRequires: libjpeg-devel
45BuildRequires: libpng-devel
46BuildRequires: zlib-devel
47
48Requires: hicolor-icon-theme
49Requires: transfig >= 3.2.5
50Requires: urw-fonts
51Requires: xdg-utils
52
53Vendor: Project Vine
54Distribution: Vine Linux
55
56%description
57Xfig is an X Window System tool for creating basic vector graphics,
58including bezier curves, lines, rulers and more.  The resulting
59graphics can be saved, printed on PostScript printers or converted to
60a variety of other formats (e.g., X11 bitmaps, Encapsulated
61PostScript, LaTeX).
62
63%prep
64%setup -q -n xfig.%{version} -a 1
65%patch0 -p1 -b .redhat
66%patch1 -p1 -b .Imakefile
67%patch3 -p1 -b .urw
68%patch4 -p1
69%patch5 -p1
70%patch6 -p1
71%patch7 -p1
72%patch8 -p1
73%patch9 -p1
74
75%patch100 -p1 -b .xft
76# above patch is not enough
77sed -i -e 's|X11/Xaw3d/|X11/Xaw3dxft/|g' w_listwidget.c
78sed -i -e 's|X11/Xaw3d/|X11/Xaw3dxft/|g' SmeCascade.h
79
80iconv -f ISO-8859-1 -t UTF8 CHANGES > tmp; touch -r CHANGES tmp; mv tmp CHANGES
81rm Doc/html/images/sav1a0.tmp
82chmod -x `find -type f`
83
84%build
85xmkmf
86make XFIGDOCDIR=%{_docdir}/%{name}-%{version} \
87     INCLUDES=`pkg-config --cflags freetype2`  \
88     CDEBUGFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE -fno-strength-reduce -fno-strict-aliasing"
89
90%install
91rm -rf $RPM_BUILD_ROOT
92
93make DESTDIR=%{buildroot} XFIGDOCDIR=%{_docdir}/%{name}-%{version} \
94     INSTALL="install -p" install.all
95install -p -m 644 CHANGES README LATEX.AND.XFIG* FIGAPPS \
96  %{buildroot}%{_docdir}/%{name}-%{version}
97
98# remove the map generation scripts, these are for xfig developers only
99rm %{buildroot}%{_datadir}/%{name}/Libraries/Maps/{USA,Canada}/assemble
100# remove app-defaults symlink which gets installed
101rm $RPM_BUILD_ROOT%{_prefix}/lib*/X11/app-defaults
102
103install -D -p -m 644 %{name}16x16.xpm \
104  $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps/%{name}.xpm
105install -D -p -m 644 %{name}32x32.xpm \
106  $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/%{name}.xpm
107install -D -p -m 644 %{name}64x64.xpm \
108  $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/%{name}.xpm
109
110mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
111desktop-file-install          \
112  --dir $RPM_BUILD_ROOT%{_datadir}/applications %{SOURCE2}
113
114
115%clean
116rm -rf $RPM_BUILD_ROOT
117
118%post
119update-desktop-database &> /dev/null || :
120touch --no-create %{_datadir}/icons/hicolor || :
121if [ -x %{_bindir}/gtk-update-icon-cache ]; then
122   %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
123fi
124
125%postun
126update-desktop-database &> /dev/null || :
127touch --no-create %{_datadir}/icons/hicolor || :
128if [ -x %{_bindir}/gtk-update-icon-cache ]; then
129   %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
130fi
131
132
133%files
134%defattr(-,root,root)
135%doc %{_docdir}/%{name}-%{version}
136%{_bindir}/%{name}
137%{_datadir}/%{name}
138%{_mandir}/*/*
139%{_datadir}/X11/app-defaults/*
140%{_datadir}/applications/%{name}.desktop
141%{_datadir}/icons/hicolor/??x??/apps/%{name}.xpm
142
143
144%changelog
145* Sun Jan 11 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.2.5c-2
146- added Patch100
147
148* Sat Oct 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.2.5c-1
149- updated to 3.2.5c
150- updated Source1
151- added Patch 4-9 from Fedora and dropt Patch7, 9, 10 and 19
152- build with libXaw3dXft
153
154* Thu Sep 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.5-1
155- new usptream release
156- build with modular X
157- import patched from fedora package.
158- drop jp patch
159
160* Sat Jul 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2.4-2vl5
161- rebuilt with Xaw3d-1.5-17vl3
162
163* Fri Sep 10 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2.4-2vl4
164- Requires transfig >= 3.2.4, ghostscript
165- build with -march=i386
166- changed Group
167- fixed .desktop file
168
169* Wed Sep  8 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2.4-2vl3
170- rebuild with gcc-3.3.2
171- added BuildPrereq: Xaw3d-devel
172
173* Sun Aug 31 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2.4-2vl2
174- based on Rawhide 3.2.4-2
175  * Tue May  6 2003 Than Ngo <than@redhat.com> 3.2.4-1
176  - 3.2.4
177  * Wed Jul 24 2002 Than Ngo <than@redhat.com> 3.2.3d-8
178  - desktop file issue (bug #69543)
179  * Tue Jun 25 2002 Than Ngo <than@redhat.com> 3.2.3d-7
180  - add patch file using mkstemp (bug #67351)
181  * Tue Jul 03 2001 Than Ngo <than@redhat.com>
182  - fix export to eps when i18n set (bug #45114)
183
184- update Source3
185- previous Patch0 moved to Patch10
186- rebuild with new toolchains
187
188* Sun Aug 20 2000 Jun Nishii <jun@vinelinux.org>
189- 3.2.3c-0vl1
190- use brp
191
192* Mon Jan 24 2000 Atsushi Saito <saito4@slb.com>
193- update to 3.2.3a
194
195* Tue Dec 21 1999 Atsushi Saito <saito4@slb.com>
196- update to 3.2.3-beta-1
197- i18n
198
199* Thu Sep 23 1999 Preston Brown <pbrown@redhat.com>
200- add icon
201- don't compile with optimization on alpha
202
203* Mon Aug 30 1999 Preston Brown <pbrown@redhat.com>
204- converted to use a .desktop file
205
206* Fri Mar 26 1999 Michael Maher <mike@redhat.com>
207- added files that were missing.
208
209* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
210- auto rebuild in the new build environment (release 4)
211- varargs fix
212
213* Thu Feb 18 1999 Jeff Johnson <jbj@redhat.com>
214- correct DESTDIRR typo (#962)
215
216* Wed Dec 30 1998 Cristian Gafton <gafton@redhat.com>
217- build for glibc 2.1
218
219* Tue Jul  7 1998 Jeff Johnson <jbj@redhat.com>
220- updated to 3.2.2.
221
222* Wed Jun 10 1998 Prospector System <bugs@redhat.com>
223- translations modified for de
224
225* Fri May 08 1998 Prospector System <bugs@redhat.com>
226- translations modified for de, fr, tr
227
228* Sat Apr 11 1998 Cristian Gafton <gafton@redhat.com>
229- updated for manhattan
230- buildroot
231
232* Thu Oct 23 1997 Marc Ewing <marc@redhat.com>
233- new version
234- messed with config for 5.0
235- updated Requires and Copyright
236- added wmconfig
237
238* Mon Jul 21 1997 Erik Troan <ewt@redhat.com>
239- built against glibc
Note: See TracBrowser for help on using the repository browser.