source: projects/specs/trunk/x/xfconf/xfconf-vl.spec @ 521

Revision 521, 4.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Name:           xfconf
2Version:        4.6.1
3Release:        2%{?_dist_release}
4Summary:        Hierarchical configuration system for Xfce
5
6Group:          System Environment/Base
7License:        GPLv2
8URL:            http://www.xfce.org/
9Source0:        http://www.xfce.org/archive/xfce-%{version}/src/xfconf-%{version}.tar.bz2
10BuildRoot:      %{_tmppath}/%{name}-%{version}-root
11
12BuildRequires:  glib2-devel
13BuildRequires:  libxfce4util-devel = %{version}
14BuildRequires:  dbus-devel
15BuildRequires:  dbus-glib-devel
16BuildRequires:  perl-ExtUtils-Depends
17BuildRequires:  perl-ExtUtils-PkgConfig
18BuildRequires:  perl-Glib
19BuildRequires:  gettext
20
21Obsoletes: libxfce4mcs < 4.4.3-3
22
23%description
24Xfconf is a hierarchical (tree-like) configuration system where the
25immediate child nodes of the root are called "channels".  All settings
26beneath the channel nodes are called "properties."
27
28%package devel
29Summary: Development tools for xfconf
30Group: Development/Libraries
31Requires: %{name} = %{version}-%{release}
32Requires: pkgconfig
33Requires: gtk-doc
34Requires: dbus-devel
35Requires: dbus-glib-devel
36Requires: glib2-devel
37Obsoletes: libxfce4mcs-devel < 4.4.3-3
38Obsoletes: xfce-mcs-manager-devel < 4.4.3-3
39
40%description devel
41This package includes the libraries and header files you will need
42to compile applications for xfconf.
43
44%package perl
45Summary: Perl modules for xfconf
46Group: Development/Libraries
47Requires: %{name} = %{version}-%{release}
48Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
49
50%description perl
51This package includes the perl modules and files you will need to
52interact with xfconf using perl.
53
54%prep
55%setup -q
56
57%build
58%configure --disable-static --with-perl-options=INSTALLDIRS="vendor"
59sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
60sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
61
62make %{?_smp_mflags}
63
64%install
65rm -rf $RPM_BUILD_ROOT
66make install DESTDIR=$RPM_BUILD_ROOT
67
68# remove unneeded la files.
69rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
70# remove perl temp file
71rm -f $RPM_BUILD_ROOT/%{perl_archlib}/perllocal.pod
72# remove unneeded dynloader bootstrap file
73rm -f $RPM_BUILD_ROOT/%{perl_vendorarch}/auto/Xfce4/Xfconf/Xfconf.bs
74# remove .packlist files.
75find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} \;
76# fix permissions on the .so file
77chmod 755 $RPM_BUILD_ROOT/%{perl_vendorarch}/auto/Xfce4/Xfconf/Xfconf.so
78
79%find_lang %{name}
80
81# we need to own
82mkdir -p ${RPM_BUILD_ROOT}%{_libdir}/xfce4/
83mkdir -p ${RPM_BUILD_ROOT}%{_libexecdir}/xfce4/
84
85%clean
86rm -rf $RPM_BUILD_ROOT
87
88%post -p /sbin/ldconfig
89
90%postun -p /sbin/ldconfig
91
92%files -f %{name}.lang
93%defattr(-,root,root,-)
94%doc AUTHORS ChangeLog NEWS TODO COPYING
95%{_libdir}/lib*.so.*
96%{_bindir}/xfconf-query
97%{_libexecdir}/xfconfd
98%{_datadir}/dbus-1/services/org.xfce.Xfconf.service
99%ghost %dir %{_libdir}/xfce4/
100%ghost %dir %{_libexecdir}/xfce4/
101
102%files devel
103%defattr(-,root,root,-)
104%doc %{_datadir}/gtk-doc/html/xfconf
105%{_libdir}/lib*.so
106%{_libdir}/pkgconfig/*.pc
107%{_includedir}/xfce4/xfconf-0
108
109%files perl
110%defattr(-,root,root,-)
111%{perl_vendorarch}/auto/*
112%{perl_vendorarch}/Xfce4
113%{_mandir}/man3/*.3*
114
115%changelog
116* Fri May 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.1-2
117- initial build for Vine
118
119* Sun Apr 19 2009 Kevin Fenzi <kevin@tummy.com> - 4.6.1-1
120- Update to 4.6.1
121
122* Mon Mar 02 2009 Christoph Wickert <cwickert@fedoraproject.org> - 4.6.0-2
123- Fix directory ownership problems
124- Move gtk-doc into devel package and mark it %%doc
125- Make devel package require gtk-doc
126
127* Thu Feb 26 2009 Kevin Fenzi <kevin@tummy.com> - 4.6.0-1
128- Update to 4.6.0
129
130* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.5.99.1-2
131- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
132
133* Mon Jan 26 2009 Kevin Fenzi <kevin@tummy.com> - 4.5.99.1-1
134- Update to 4.5.99.1
135
136* Thu Jan 22 2009 Christoph Wickert <cwickert@fedoraproject.org> - 4.5.93-3
137- Let xfce4-settings Obsolete mcs manager and plugin packages
138
139* Thu Jan 22 2009 Christoph Wickert <cwickert@fedoraproject.org> - 4.5.93-2
140- Add Obsoletes for mcs devel package
141
142* Tue Jan 13 2009 Kevin Fenzi <kevin@tummy.com> - 4.5.93-1
143- Update to 4.5.93
144
145* Fri Jan 02 2009 Kevin Fenzi <kevin@tummy.com> - 4.5.92-4
146- Add Obsoletes for mcs packages
147
148* Mon Dec 22 2008 Kevin Fenzi <kevin@tummy.com> - 4.5.92-3
149- Fixes for review ( bug 477732 )
150
151* Mon Dec 22 2008 Kevin Fenzi <kevin@tummy.com> - 4.5.92-2
152- Add gettext BuildRequires
153
154* Sun Dec 21 2008 Kevin Fenzi <kevin@tummy.com> - 4.5.92-1
155- Initial version for Fedora
Note: See TracBrowser for help on using the repository browser.