source: projects/specs/trunk/x/xfce4-power-manager/xfce4-power-manager-vl.spec @ 4634

Revision 4634, 6.6 KB checked in by inagaki, 13 years ago (diff)

update: Thunar, orage, xfce4-power-manager, xfce4-settings, xfdesktop

Line 
1%global minorversion 1.0
2%global xfceversion 4.7
3
4Name:           xfce4-power-manager
5Summary:        Power management for the Xfce desktop environment
6Summary(ja):    Xfce デスクトップ環境用電源管理ツール
7Version:        1.0.10
8Release:        3%{?_dist_release}
9
10Group:          User Interface/Desktops
11License:        GPLv2+
12URL:            http://goodies.xfce.org/projects/applications/%{name}
13
14Source0:        http://archive.xfce.org/src/apps/%{name}/%{minorversion}/%{name}-%{version}.tar.bz2
15Patch0:         xfce4-power-manager-1.0.1-dsofix.patch
16Patch1:         xfce4-power-manager-1.0.10-libnotify-0.7.0.patch
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-root
19
20BuildRequires:  xfconf-devel >= %{xfceversion}
21BuildRequires:  xfce4-panel-devel >= %{xfceversion}
22BuildRequires:  dbus-devel >= 0.60
23BuildRequires:  dbus-glib-devel >= 0.70
24BuildRequires:  libnotify-devel >= 0.4.1
25BuildRequires:  libxfce4ui-devel >= %{xfceversion}
26BuildRequires:  libXrandr-devel >= 1.2.0
27BuildRequires:  xorg-x11-proto-devel
28BuildRequires:  gettext intltool desktop-file-utils
29Requires:       xfce4-panel >= %{xfceversion}
30#Requires:       xfce4-doc
31Requires:       polkit
32
33%description
34Xfce Power Manager uses the information and facilities provided by HAL to
35display icons and handle user callbacks in an interactive Xfce session.
36Xfce Power Preferences allows authorised users to set policy and change
37preferences.
38
39
40%prep
41%setup -q
42%patch0 -p1 -b .dsofix
43%patch1 -p1 -b .libnotify-0.7.0
44
45
46%build
47%configure
48make %{?_smp_mflags} V=1
49
50
51%install
52rm -rf $RPM_BUILD_ROOT
53make install DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p'
54%find_lang %{name}
55desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/%{name}-settings.desktop     
56
57
58%clean
59rm -rf $RPM_BUILD_ROOT
60
61
62%post
63touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
64
65
66%postun
67if [ $1 -eq 0 ] ; then
68    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
69    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
70fi
71
72
73%posttrans
74gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
75
76
77%files -f %{name}.lang
78%defattr(-,root,root,-)
79%doc AUTHORS COPYING ChangeLog NEWS README TODO
80%{_bindir}/%{name}
81%{_bindir}/%{name}-settings
82%{_bindir}/xfce4-power-information
83%{_sbindir}/xfpm-power-backlight-helper
84%config %{_sysconfdir}/xdg/autostart/%{name}.desktop
85%{_libdir}/xfce4/panel-plugins/xfce4-brightness-plugin
86%{_datadir}/applications/%{name}-settings.desktop
87%{_datadir}/icons/hicolor/*/*/*.*
88%{_datadir}/xfce4/panel-plugins/xfce4-brightness-plugin.desktop
89%{_datadir}/polkit-1/actions/org.xfce.power.policy
90%doc %{_datadir}/xfce4/doc/C/images/*.png
91%doc %{_datadir}/xfce4/doc/C/%{name}.html
92%{_mandir}/man1/%{name}-settings.1.*
93%{_mandir}/man1/%{name}.1.*
94
95
96%changelog
97* Sun Aug 21 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.10-3
98- rebuilt with libnotify-0.7.3
99- added Patch1
100
101* Mon May 23 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.10-2
102- Initial build for Vine Linux
103
104* Sun Feb 20 2011 Christoph Wickert <cwickert@fedoraproject.org> - 1.0.10-1
105- Update to 1.0.10
106
107* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.3-2
108- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
109
110* Tue Jan 04 2011 Christoph Wickert <cwickert@fedoraproject.org> - 1.0.3-1
111- Update to 1.0.3
112- No longer require hal because the brightness backend was removed
113- Require polkit
114
115* Sun Dec 19 2010 Christoph Wickert <cwickert@fedoraproject.org> - 1.0.2-1
116- Update to 1.0.2
117
118* Thu Dec 16 2010 Christoph Wickert <cwickert@fedoraproject.org> - 1-0.1-1
119- Update to 1.0.1 on Xfce 4.8 pre2
120
121* Sat Nov 06 2010 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.5-1
122- Update to 0.8.5
123- Fix for libnotify 0.7.0
124- Make build verbose
125
126* Sat Nov 21 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.4.2-1
127- Update to 0.8.4.2
128
129* Mon Nov 02 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.4.1-1
130- Update to 0.8.4.1
131
132* Tue Sep 29 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.4-1
133- Update to 0.8.4
134- Drop xfpm_session_set_client_id patch, fixed upstream
135
136* Wed Sep 09 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.3.1-2
137- Fix segfault in xfpm_session_set_client_id
138
139* Sun Aug 09 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.3.1-1
140- Update to 0.8.3.1
141
142* Sat Aug 01 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.3-1
143- Update to 0.8.3
144
145* Thu Jul 30 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.2-3
146- Patch to include dpmsconst.h instead of dpms.h
147
148* Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.2-2
149- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
150
151* Thu Jul 09 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.2-1
152- Update to 0.8.2
153
154* Mon Jul 06 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.1.1-1
155- Update to 0.8.1.1
156
157* Fri Jul 03 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.1-1
158- Update to 0.8.1
159- Drop libglade2 requirement
160
161* Wed Jun 10 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.0-1
162- Update to 0.8.0 final
163- Update gtk-icon-cache scriptlets
164
165* Wed May 20 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.0-0.3.RC2
166- Update to 0.8.0RC2
167
168* Tue Apr 28 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.0-0.3.RC1
169- Update to 0.8.0RC1
170
171* Mon Apr 13 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.0-0.2.beta2
172- Update to 0.8.0beta2
173- Drop xfpm-button-hal.patch, no longer necessary
174
175* Mon Apr 13 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.0-0.2.beta1
176- Add xfpm-button-hal.patch by Mike Massonnet
177
178* Sun Apr 12 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.0-0.1.beta1
179- Update to 0.8.0beta1
180
181* Thu Apr 09 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.0-0.1.alpha2
182- Update to 0.8.0alpha2
183
184* Thu Apr 02 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.0-0.1.alpha
185- Update to 0.8.0alpha
186
187* Tue Mar 24 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.6.5-1
188- Update to 0.6.5
189- Remove custom autostart file
190
191* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.2-2
192- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
193
194* Thu Feb 19 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.6.2-1
195- Update to 0.6.2
196
197* Sat Feb  7 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.6.1-1
198- Update to 0.6.1
199- Include additional desktop file for autostarting the app
200
201* Mon Nov 10 2008 Christoph Wickert <cwickert@fedoraproject.org> - 0.6.0-0.1.RC1
202- Update to 0.6.0 RC1
203
204* Fri Oct 31 2008 Christoph Wickert <cwickert@fedoraproject.org> - 0.6.0-0.1.0.beta1
205- Initial Fedora package
Note: See TracBrowser for help on using the repository browser.