source: projects/specs/trunk/x/xerces-j2/xerces-j2-vl.spec @ 1678

Revision 1678, 16.5 KB checked in by inagaki, 14 years ago (diff)

NEW: ant, xml-common-apis, xerces-j2

Line 
1%global cvs_version 2_9_0
2
3Name:          xerces-j2
4Summary:       Java XML parser
5Summary(ja):   Java XML パーサ
6Version:       2.9.0
7Release:       5%{?_dist_release}
8
9Group:         Development/Libraries
10License:       ASL 2.0
11URL:           http://xerces.apache.org/xerces2-j/
12
13# using binary for bootstrap
14Source0:       http://archive.apache.org/dist/xml/xerces-j/Xerces-J-bin.%{version}.tar.gz
15#Source0:       http://archive.apache.org/dist/xml/xerces-j/source/Xerces-J-src.%{version}.tar.gz
16Source1:       %{name}-version.sh
17Source2:       %{name}-constants.sh
18
19
20BuildRoot:     %{_tmppath}/%{name}-%{version}-root
21BuildArch:     noarch
22
23#BuildRequires: java-devel >= 1:1.6.0
24#BuildRequires: jpackage-utils
25#BuildRequires: xml-commons-apis >= 1.3
26#BuildRequires: xml-commons-resolver >= 1.1
27#BuildRequires: ant
28#BuildRequires: xalan-j2
29#BuildRequires: xml-stylebook
30#BuildRequires: jaxp_parser_impl
31#BuildRequires: dejavu-sans-fonts
32Requires:      java
33Requires:      jpackage-utils
34Requires:      xml-commons-apis >= 1.3
35#Requires:      xml-commons-resolver >= 1.1
36
37Provides:      jaxp_parser_impl = 1.3
38Requires(post):  alternatives jaxp_parser_impl
39Requires(preun): alternatives jaxp_parser_impl
40
41# This documentation is provided by xml-commons-apis
42#Obsoletes:     %{name}-javadoc-apis < %{version}-%{release}
43
44%description
45Welcome to the future! Xerces2 is the next generation of high performance,
46fully compliant XML parsers in the Apache Xerces family. This new version of
47Xerces introduces the Xerces Native Interface (XNI), a complete framework for
48building parser components and configurations that is extremely modular and
49easy to program.
50
51The Apache Xerces2 parser is the reference implementation of XNI but other
52parser components, configurations, and parsers can be written using the Xerces
53Native Interface. For complete design and implementation documents, refer to
54the XNI Manual.
55
56Xerces2 is a fully conforming XML Schema processor. For more information,
57refer to the XML Schema page.
58
59Xerces2 also provides a complete implementation of the Document Object Model
60Level 3 Core and Load/Save W3C Recommendations and provides a complete
61implementation of the XML Inclusions (XInclude) W3C Recommendation. It also
62provides support for OASIS XML Catalogs v1.1.
63
64Xerces2 is able to parse documents written according to the XML 1.1
65Recommendation, except that it does not yet provide an option to enable
66normalization checking as described in section 2.13 of this specification. It
67also handles namespaces according to the XML Namespaces 1.1 Recommendation,
68and will correctly serialize XML 1.1 documents if the DOM level 3 load/save
69APIs are in use.
70
71#%package        javadoc-impl
72#Summary:        Javadoc for %{name} implementation
73#Group:          Documentation
74#
75#%description    javadoc-impl
76#%{summary}.
77
78#%package        javadoc-xs
79#Summary:        Javadoc for %{name} XML schema API
80#Group:          Documentation
81#
82#%description    javadoc-xs
83#%{summary}.
84
85#%package        javadoc-xni
86#Summary:        Javadoc for %{name} XNI
87#Group:          Documentation
88#
89#%description    javadoc-xni
90#%{summary}.
91
92#%package        javadoc-other
93#Summary:        Javadoc for other %{name} components
94#Group:          Documentation
95#
96#%description    javadoc-other
97#%{summary}.
98
99#%package        manual
100#Summary:        Manual for %{name}
101#Group:          Documentation
102#Requires:       xml-commons-apis-javadoc
103#Requires:       %{name}-javadoc-impl = %{version}-%{release}
104#Requires:       %{name}-javadoc-xs = %{version}-%{release}
105#Requires:       %{name}-javadoc-xni = %{version}-%{release}
106#Requires:       %{name}-javadoc-other = %{version}-%{release}
107#
108#%description    manual
109#%{summary}.
110
111#%package        demo
112#Summary:        Demonstrations and samples for %{name}
113#Group:          Development/Libraries
114#Requires:       %{name} = %{version}-%{release}
115#
116#%description    demo
117#%{summary}.
118
119#%package        scripts
120#Summary:        Additional utility scripts for %{name}
121#Group:          Development/Libraries
122#Requires:       %{name} = %{version}-%{release}
123#
124#%description    scripts
125#%{summary}.
126
127%prep
128%setup -q -n xerces-2_9_0
129#patch0 -p0 -b .orig
130
131%build
132
133%install
134rm -rf $RPM_BUILD_ROOT
135
136# jars
137install -pD -T xercesImpl.jar $RPM_BUILD_ROOT%{_javadir}/%{name}-%{version}.jar
138(cd $RPM_BUILD_ROOT%{_javadir} && for jar in *-%{version}.jar; do ln -sf ${jar} `echo $jar| sed "s|-%{version}||g"`; done)
139
140# scripts
141install -pD -m755 -T %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/%{name}-version
142install -pD -m755 -T %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}-constants
143
144# demo
145#install -pD -T xercesSamples.jar $RPM_BUILD_ROOT%{_datadir}/%{name}/%{name}-samples.jar
146#cp -pr data $RPM_BUILD_ROOT%{_datadir}/%{name}
147
148# jaxp_parser_impl ghost symlink
149#ln -s %{_sysconfdir}/alternatives \
150#  $RPM_BUILD_ROOT%{_javadir}/jaxp_parser_impl.jar
151
152%clean
153rm -rf $RPM_BUILD_ROOT
154
155%post
156/sbin/update-alternatives --install %{_javadir}/jaxp_parser_impl.jar \
157    jaxp_parser_impl %{_javadir}/%{name}.jar 40
158
159%preun
160if [ $1 = 0 ]; then
161    /sbin/update-alternatives --remove jaxp_parser_impl \
162        %{_javadir}/%{name}.jar
163fi
164
165%files
166%defattr(-,root,root,-)
167%doc LICENSE NOTICE
168%{_javadir}/%{name}*
169#ghost %{_javadir}/jaxp_parser_impl.jar
170
171#%files javadoc-impl
172#%defattr(-,root,root,-)
173#%{_javadocdir}/%{name}-impl-%{version}
174#%{_javadocdir}/%{name}-impl
175
176#%files javadoc-xs
177#%defattr(-,root,root,-)
178#%{_javadocdir}/%{name}-xs-%{version}
179#%{_javadocdir}/%{name}-xs
180
181#%files javadoc-other
182#%defattr(-,root,root,-)
183#%{_javadocdir}/%{name}-other-%{version}
184#%{_javadocdir}/%{name}-other
185
186#%files javadoc-xni
187#%defattr(-,root,root,-)
188#%{_javadocdir}/%{name}-xni-%{version}
189#%{_javadocdir}/%{name}-xni
190
191#%files manual
192#%defattr(-,root,root,-)
193#%dir %{_docdir}/%{name}-%{version}
194#%{_docdir}/%{name}-%{version}/manual
195
196#%files demo
197#%defattr(-,root,root,-)
198#%{_datadir}/%{name}
199
200#%files scripts
201#%defattr(-,root,root,-)
202%{_bindir}/*
203
204%changelog
205* Fri Aug 27 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.9.0-5
206- Initial build for Vine Linux
207
208* Sat Jun 12 2010 Mat Booth <fedora@matbooth.co.uk> - 2.9.0-4
209- Fix broken links in manual and fix javadoc requires.
210- Build 1.5 bytecode instead of 1.6, for compatibility.
211
212* Fri Jan 22 2010 Andrew Overholt <overholt@redhat.com> - 2.9.0-3
213- Fix unversioned Provides for jaxp_parser_impl (make it 1.3).
214
215* Thu Jan 14 2010 Mat Booth <fedora@matbooth.co.uk> - 2.9.0-2
216- Add a build dep on a font package because the JDK is missing a dependency
217  to function correctly in headless mode. See RHBZ #478480 and #521523.
218- Fix groups.
219
220* Tue Jan 5 2010 Mat Booth <fedora@matbooth.co.uk> - 2.9.0-1
221- Update to 2.9.0: This is the version Eclipse expects, previously the OSGi
222  manifest was lying about its version :-o
223- Enable manual sub-package now xml-stylebook is in Fedora.
224- Drop GCJ support.
225- Minor changes to spec to make it more conforming to the guidelines.
226- Drop the libgcj patch, we don't seem to need it anymore.
227- Add the OSGi manifest as part of the build instead of the install.
228- Fix packaging bug RHBZ #472646.
229
230* Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:2.7.1-12.3
231- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
232
233* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:2.7.1-11.3
234- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
235
236* Fri Jan 30 2009 Alexander Kurtakov <akurtako@redhat.com> 0:2.7.1-10.3
237- Add osgi manifest.
238
239* Thu Jul 10 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0:2.7.1-10.2
240- drop repotag
241- fix license tag
242
243* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0:2.7.1-10jpp.1
244- Autorebuild for GCC 4.3
245
246* Wed Mar 28 2007 Matt Wringe <mwringe@redhat.com> 0:2.7.1-9jpp.1
247- Update with newest jpp version
248- Clean up spec file for Fedora Review
249
250* Sun Aug 13 2006 Warren Togami <wtogami@redhat.com> 0:2.7.1-7jpp.2
251- fix typo in preun req
252
253* Sat Aug 12 2006 Matt Wringe <mwringe at redhat.com> 0:2.7.1-7jpp.1
254- Merge with upstream version
255
256* Sat Aug 12 2006 Matt Wringe <mwringe at redhat.com> 0:2.7.1-7jpp
257- Add conditional native compiling
258- Add missing requires for javadocs
259- Add missing requires for post and preun
260- Update version to 7jpp at Fedora's request
261
262* Sat Jul 22 2006 Jakub Jelinek <jakub@redhat.com> - 0:2.7.1-6jpp_9fc
263- Rebuilt
264
265* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0:2.7.1-6jpp_8fc
266- rebuild
267
268* Thu Mar 30 2006 Fernando Nasser <fnasser@redhat.com> 0:2.7.1-3jpp
269- Add missing BR for xml-stylebook
270
271* Wed Mar 22 2006 Ralph Apel <r.apel at r-apel.de> 0:2.7.1-2jpp
272- First JPP-1.7 release
273- use tools subdir and give it as java.endorsed.dirs (for java-1.4.2-bea e.g.)
274
275* Mon Mar  6 2006 Jeremy Katz <katzj@redhat.com> - 0:2.7.1-6jpp_7fc
276- stop scriptlet spew
277
278* Wed Feb 22 2006 Rafael Schloming <rafaels@redhat.com> - 0:2.7.1-6jpp_6fc
279- Updated to 2.7.1
280
281* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0:2.6.2-6jpp_5fc
282- bump again for double-long bug on ppc(64)
283
284* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0:2.6.2-6jpp_4fc
285- rebuilt for new gcc4.1 snapshot and glibc changes
286
287* Thu Feb  2 2006 Archit Shah <ashah@redhat.com> 0:2.6.2-6jpp_3fc
288- build xerces without using native code
289
290* Mon Jan  9 2006 Archit Shah <ashah@redhat.com> 0:2.6.2-6jpp_2fc
291- rebuilt for new gcj
292
293* Wed Dec 21 2005 Jesse Keating <jkeating@redhat.com> 0:2.6.2-6jpp_1fc
294- rebuilt for new gcj
295
296* Tue Dec 13 2005 Jesse Keating <jkeating@redhat.com>
297- rebuilt for new gcj
298
299* Fri Oct 07 2005 Ralph Apel <r.apel at r-apel.de> 0:2.7.1-1jpp
300- Upgrade to 2.7.1
301
302* Thu Jul 21 2005 Ralph Apel <r.apel at r-apel.de> 0:2.6.2-7jpp
303- Include target jars-dom3
304- Create new subpackage dom3
305
306* Mon Jul 18 2005 Gary Benson <gbenson at redhat.com> 0:2.6.2-5jpp_2fc
307- Build on ia64, ppc64, s390 and s390x.
308- Switch to aot-compile-rpm (also BC-compiles samples).
309
310* Wed Jul 13 2005 Gary Benson <gbenson at redhat.com> 0:2.6.2-6jpp
311- Build with Sun JDK (from <gareth.armstrong at hp.com>).
312
313* Wed Jun 15 2005 Gary Benson <gbenson at redhat.com> 0:2.6.2-5jpp_1fc
314- Upgrade to 2.6.2-5jpp.
315
316* Tue Jun 14 2005 Gary Benson <gbenson at redhat.com> 0:2.6.2-5jpp
317- Remove the tools tarball, and build xjavac from source.
318- Patch xjavac to fix the classpath under libgcj too.
319
320* Fri Jun 10 2005 Gary Benson <gbenson@redhat.com> 0:2.6.2-4jpp_8fc
321- Remove the tools tarball, and build xjavac from source.
322- Replace classpath workaround to xjavac task and use
323  xml-commons classes again (#152255).
324
325* Thu May 26 2005 Gary Benson <gbenson@redhat.com> 0:2.6.2-4jpp_7fc
326- Rearrange how BC-compiled stuff is built and installed.
327
328* Mon May 23 2005 Gary Benson <gbenson@redhat.com> 0:2.6.2-4jpp_6fc
329- Add alpha to the list of build architectures (#157522).
330- Use absolute paths for rebuild-gcj-db.
331
332* Thu May  5 2005 Gary Benson <gbenson@redhat.com> 0:2.6.2-4jpp_5fc
333- Add dependencies for %%post and %%postun scriptlets (#156901).
334
335* Fri Apr 29 2005 Gary Benson <gbenson@redhat.com> 0:2.6.2-4jpp_4fc
336- BC-compile.
337
338* Thu Apr 28 2005 Gary Benson <gbenson@redhat.com> 0:2.6.2-4jpp_3fc
339- Revert xjavac classpath workaround, and patch to use libgcj's
340  classes instead of those in xml-commons (#152255).
341
342* Thu Apr 21 2005 Gary Benson <gbenson@redhat.com> 0:2.6.2-4jpp_2fc
343- Add classpath workaround to xjavac task (#152255).
344
345* Wed Jan 12 2005 Gary Benson <gbenson@redhat.com> 0:2.6.2-4jpp_1fc
346- Reenable building of classes that require javax.swing (#130006).
347- Sync with RHAPS.
348
349* Mon Nov 15 2004 Fernando Nasser <fnasser@redhat.com>  0:2.6.2-4jpp_1rh
350- Merge with upstream for 2.6.2 upgrade
351
352* Thu Nov  4 2004 Gary Benson <gbenson@redhat.com> 0:2.6.2-2jpp_5fc
353- Build into Fedora.
354
355* Thu Oct 28 2004 Gary Benson <gbenson@redhat.com> 0:2.6.2-2jpp_4fc
356- Bootstrap into Fedora.
357
358* Fri Oct 1 2004 Andrew Overholt <overholt@redhat.com> 0:2.6.2-2jpp_4rh
359- add coreutils BuildRequires
360
361* Thu Sep 30 2004 Andrew Overholt <overholt@redhat.com> 0:2.6.2-2jpp_3rh
362- Remove xml-commons-resolver as a Requires
363
364* Thu Aug 26 2004 Ralph Apel <r.apel at r-apel.de> 0:2.6.2-4jpp
365- Build with ant-1.6.2
366- Dropped jikes requirement, built for 1.4.2
367
368* Wed Jun 23 2004 Kaj J. Niemi <kajtzu@fi.basen.net> 0:2.6.2-3jpp
369- Updated Patch #0 to fix breakage using BEA 1.4.2 SDK, new patch
370  from <mwringe@redhat.com> and <vivekl@redhat.com>.
371
372* Mon Jun 21 2004 Vivek Lakshmanan <vivekl@redhat.com> 0:2.6.2-2jpp_2rh
373- Added new Source1 URL and added new %%setup to expand it under the
374  expanded result of Source0.
375- Updated Patch0 to fix version discrepancies.
376- Added build requirement for xml-commons-apis
377 
378* Mon Jun 14 2004 Matt Wringe <mwringe@redhat.com> 0:2.6.2-2jpp_1rh
379- Update to 2.6.2
380- made patch names comformant
381
382* Mon Mar 29 2004 Kaj J. Niemi <kajtzu@fi.basen.net> 0:2.6.2-2jpp
383- Rebuilt with jikes 1.18 for java 1.3.1_11
384
385* Fri Mar 26 2004 Frank Ch. Eigler <fche@redhat.com> 0:2.6.1-1jpp_2rh
386- add RHUG upgrade cleanup
387
388* Tue Mar 23 2004 Kaj J. Niemi <kajtzu@fi.basen.net> 0:2.6.2-1jpp
389- 2.6.2
390
391* Thu Mar 11 2004 Frank Ch. Eigler <fche@redhat.com> 0:2.6.1-1jpp_1rh
392- RH vacuuming
393- remove jikes dependency
394- add nonjikes-cast.patch
395
396* Sun Feb 08 2004 David Walluck <david@anti-microsoft.org> 0:2.6.1-1jpp
397- 2.6.1
398- update Source0 URL
399- now requires xml-commons-resolver
400
401* Fri Jan  9 2004 Kaj J. Niemi <kajtzu@fi.basen.net> - 0:2.6.0-1jpp
402- Update to 2.6.0
403- Patch #1 (xerces-j2-manifest.patch) is unnecessary (upstream)
404
405* Tue Oct 21 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:2.5.0-1jpp
406- Update to 2.5.0.
407- Clean up versionless javadoc dir symlinking, own (ghost) the symlinks.
408- Mark javadocs as %%doc.
409
410* Wed Jun  4 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:2.4.0-3jpp
411- Own (ghost) %%{_javadir}/jaxp_parser_impl.jar.
412- Remove alternatives in preun instead of postun.
413
414* Mon May 12 2003 David Walluck <david@anti-microsoft.org> 0:2.4.0-2jpp
415- bug #17325 fixed upstream
416
417* Mon May 12 2003 David Walluck <david@anti-microsoft.org> 0:2.4.0-1jpp
418- 2.4.0
419- BuildRequires: jikes
420- update for JPackage 1.5
421- re-diff'ed build patch for 2.4.0
422- bug #17325 handled by perl now
423- scripts: s|find-jar|build-classpath| and don't test for java-functions
424
425* Wed Mar 26 2003 Nicolas Mailhot <Nicolas.Mailhot (at) JPackage.org> - 2.3.0-2jpp
426- For jpackage-utils 1.5
427- zapped manual, since it doesn't want to build
428- as a consequence, removed uneeded dependencies
429
430* Mon Feb 24 2003 Ville Skyttä <ville.skytta at iki.fi> - 2.3.0-1jpp
431- Update to 2.3.0.
432- Add a crude patch to work around invalid XML in doc sources, see
433  <http://nagoya.apache.org/bugzilla/show_bug.cgi?id=17325>.
434- Built with IBM's 1.3.1 SR3.
435
436* Sat Dec 28 2002 Ville Skyttä <ville.skytta at iki.fi> - 2.2.1-2jpp
437- Add upstream patch which fixes problems with Tomcat's webapps.
438  <http://nagoya.apache.org/bugzilla/show_bug.cgi?id=13282>
439  <http://marc.theaimsgroup.com/?l=xerces-cvs&m=103791990130308>
440- Separate scripts subpackage.
441
442* Fri Nov 15 2002 Ville Skyttä <ville.skytta at iki.fi> - 2.2.1-1jpp
443- Update to 2.2.1.
444- Change alternative to point to non-versioned jar.
445- Don't remove alternative on upgrade.
446- Fix Group tag for demo, javadoc and manual subpackages.
447- Add version and constants scripts.
448- Some spec file cleanup.
449
450* Sun Oct  6 2002 Ville Skyttä <ville.skytta at iki.fi> 2.2.0-2jpp
451- Fix bad permissions for main jar.
452
453* Sun Sep 29 2002 Ville Skyttä <ville.skytta at iki.fi> 2.1.0-1jpp
454- Update to 2.2.0.
455
456* Tue Sep 10 2002 Ville Skyttä <ville.skytta at iki.fi> 2.1.0-2jpp
457- Rebuild with -Dcompiler=modern, not a Jikes bug this time, but sloppy code
458  that is tolerated by javac.  See <http://www-124.ibm.com/developerworks/bugs/?func=detailbug&bug_id=3218&group_id=10> for details.
459
460* Tue Sep 10 2002 Ville Skyttä <ville.skytta at iki.fi> 2.1.0-1jpp
461- 2.1.0.
462- Updated description.
463- Changed javadoc and manual group to Documentation.
464- Spec file cleanups.
465
466* Fri Jul 12 2002 Henri Gomez <hgomez@users.sourceforge.net> 2.0.2-4jpp
467- add BuildRequires xerces-j1 and xalan-j2
468- removed BuildRequires xml-commons-api since ant require jaxp_parser_impl
469  which in turn require xml-commons-api ;)
470
471* Mon Jul 01 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.0.2-3jpp
472- vendor, distribution, group tags
473- provides jaxp_parser_impl
474- dropped api jar
475- renamed lone jar to %%{name}.jar
476- priority bumped to 40
477- fixed stylebook build (add xerces-j1 in classpath)
478
479* Wed Jun 26 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.0.2-2jpp
480- rebuild for missing symlinks
481- use sed instead of bash 2.x extension in link area to make spec compatible with distro using bash 1.1x
482
483* Mon Jun 24 2002 Henri Gomez <hgomez@users.sourceforge.net> 2.0.2-1jpp
484- 2.0.2
485
486* Sun Mar 10 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.0.1-1jpp
487- 2.0.1
488- provides jaxp_parser2 virtual resource
489- drop wrapper
490
491* Sun Feb 03 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.0.0-1jpp
492- first JPackage release
Note: See TracBrowser for help on using the repository browser.