source: projects/specs/trunk/x/xerces-j2/xerces-j2-vl.spec @ 9289

Revision 9289, 18.6 KB checked in by inagaki, 9 years ago (diff)

2015-01-24 Ryoichi INAGAKI <ryo1@…>

  • javapackages-tools: fixed spec
  • regexp, xml-commons-resolver: NEW
  • xalan-c, xerces-j2: updated


Line 
1%global cvs_version 2_11_0
2
3Name:          xerces-j2
4Summary:       Java XML parser
5Summary(ja):   Java XML パーサ
6Version:       2.11.0
7Release:       1%{?_dist_release}
8
9Group:         Development/Libraries
10License:       ASL 2.0
11URL:           http://xerces.apache.org/xerces2-j/
12
13Source0:       http://mirror.ox.ac.uk/sites/rsync.apache.org/xerces/j/source/Xerces-J-src.%{version}.tar.gz
14Source1:       %{name}-version.sh
15Source2:       %{name}-constants.sh
16Source11:      %{name}-version.1
17Source12:      %{name}-constants.1
18
19# Custom javac ant task used by the build
20Source3:       https://svn.apache.org/repos/asf/xerces/java/tags/Xerces-J_%{cvs_version}/tools/src/XJavac.java
21
22# Custom doclet tags used in javadocs
23Source5:       https://svn.apache.org/repos/asf/xerces/java/tags/Xerces-J_%{cvs_version}/tools/src/ExperimentalTaglet.java
24Source6:       https://svn.apache.org/repos/asf/xerces/java/tags/Xerces-J_%{cvs_version}/tools/src/InternalTaglet.java
25
26Source7:       %{name}-pom.xml
27
28# Patch the build so that it doesn't try to use bundled xml-commons source
29Patch0:        %{name}-build.patch
30
31# Patch the manifest so that it includes OSGi stuff
32Patch1:        %{name}-manifest.patch
33
34# Backported fix from upstream http://svn.apache.org/viewvc?view=revision&revision=1499506
35# See https://bugzilla.redhat.com/show_bug.cgi?id=1140031
36Patch2:        xerces-j2-CVE-2013-4002.patch
37
38
39BuildRoot:     %{_tmppath}/%{name}-%{version}-root
40BuildArch:     noarch
41BuildRequires: java-devel >= 1.6.0
42BuildRequires: javapackages-tools >= 3.4.1-7vl7
43BuildRequires: xalan-j2 >= 2.7.1
44BuildRequires: xml-commons-apis >= 1.4.01
45BuildRequires: xml-commons-resolver >= 1.2
46BuildRequires: ant
47BuildRequires: jaxp_parser_impl
48#BuildRequires: dejavu-sans-fonts
49Requires:      java-headless
50Requires:      javapackages-tools
51Requires:      xalan-j2 >= 2.7.1
52Requires:      xml-commons-apis >= 1.4.01
53Requires:      xml-commons-resolver >= 1.2
54
55Provides:      jaxp_parser_impl = 1.4
56Provides:      %{name}-scripts = %{version}-%{release}
57Obsoletes:     %{name}-scripts < 2.9.0-5
58
59Requires(post):  alternatives jaxp_parser_impl
60Requires(preun): alternatives jaxp_parser_impl
61
62# This documentation is provided by xml-commons-apis
63Obsoletes:     %{name}-javadoc-apis < %{version}-%{release}
64# http://mail-archives.apache.org/mod_mbox/xerces-j-dev/201008.mbox/%3COF8D7E2F83.0271A181-ON8525777F.00528302-8525777F.0054BBE0@ca.ibm.com%3E
65Obsoletes:     %{name}-manual < %{version}-%{release}
66
67%description
68Welcome to the future! Xerces2 is the next generation of high performance,
69fully compliant XML parsers in the Apache Xerces family. This new version of
70Xerces introduces the Xerces Native Interface (XNI), a complete framework for
71building parser components and configurations that is extremely modular and
72easy to program.
73
74The Apache Xerces2 parser is the reference implementation of XNI but other
75parser components, configurations, and parsers can be written using the Xerces
76Native Interface. For complete design and implementation documents, refer to
77the XNI Manual.
78
79Xerces2 is a fully conforming XML Schema processor. For more information,
80refer to the XML Schema page.
81
82Xerces2 also provides a complete implementation of the Document Object Model
83Level 3 Core and Load/Save W3C Recommendations and provides a complete
84implementation of the XML Inclusions (XInclude) W3C Recommendation. It also
85provides support for OASIS XML Catalogs v1.1.
86
87Xerces2 is able to parse documents written according to the XML 1.1
88Recommendation, except that it does not yet provide an option to enable
89normalization checking as described in section 2.13 of this specification. It
90also handles namespaces according to the XML Namespaces 1.1 Recommendation,
91and will correctly serialize XML 1.1 documents if the DOM level 3 load/save
92APIs are in use.
93
94%package        javadoc
95Summary:        Javadocs for %{name}
96Group:          Documentation
97Requires:       javapackages-tools
98
99# Consolidating all javadocs into one package
100Obsoletes:      %{name}-javadoc-impl < %{version}-%{release}
101Obsoletes:      %{name}-javadoc-xs < %{version}-%{release}
102Obsoletes:      %{name}-javadoc-xni < %{version}-%{release}
103Obsoletes:      %{name}-javadoc-other < %{version}-%{release}
104
105%description    javadoc
106This package contains the API documentation for %{name}.
107
108%package        demo
109Summary:        Demonstrations and samples for %{name}
110Group:          Development/Libraries
111Requires:       %{name} = %{version}-%{release}
112
113%description    demo
114%{summary}.
115
116
117%prep
118%setup -q -n xerces-%{cvs_version}
119%patch0 -p0 -b .orig
120%patch1 -p0 -b .orig
121%patch2 -p0 -b .orig
122
123# Copy the custom ant tasks into place
124mkdir -p tools/org/apache/xerces/util
125mkdir -p tools/bin
126cp -a %{SOURCE3} %{SOURCE5} %{SOURCE6} tools/org/apache/xerces/util
127
128# Make sure upstream hasn't sneaked in any jars we don't know about
129find -name '*.class' -exec rm -f '{}' \;
130find -name '*.jar' -exec rm -f '{}' \;
131
132sed -i 's/\r//' LICENSE README NOTICE
133
134%build
135pushd tools
136
137# Build custom ant tasks
138javac -classpath $(build-classpath ant) org/apache/xerces/util/XJavac.java
139jar cf bin/xjavac.jar org/apache/xerces/util/XJavac.class
140
141# Build custom doc taglets
142javac -classpath /usr/lib/jvm/java/lib/tools.jar org/apache/xerces/util/*Taglet.java
143jar cf bin/xerces2taglets.jar org/apache/xerces/util/*Taglet.class
144
145ln -sf $(build-classpath xalan-j2-serializer) serializer.jar
146ln -sf $(build-classpath xml-commons-apis) xml-apis.jar
147ln -sf $(build-classpath xml-commons-resolver) resolver.jar
148ln -sf $(build-classpath xerces-j2) x.jar
149popd
150
151# Build everything
152export ANT_OPTS="-Xmx256m -Djava.endorsed.dirs=$(pwd)/tools -Djava.awt.headless=true -Dbuild.sysclasspath=first -Ddisconnected=true"
153ant -Djavac.source=1.5 -Djavac.target=1.5 \
154    -Dbuild.compiler=modern \
155    clean jars javadocs
156
157%install
158rm -rf $RPM_BUILD_ROOT
159
160# jars
161install -pD -T build/xercesImpl.jar $RPM_BUILD_ROOT%{_javadir}/%{name}.jar
162
163# javadoc
164mkdir -p $RPM_BUILD_ROOT%{_javadocdir}/%{name}
165mkdir -p $RPM_BUILD_ROOT%{_javadocdir}/%{name}/impl
166mkdir -p $RPM_BUILD_ROOT%{_javadocdir}/%{name}/xs
167mkdir -p $RPM_BUILD_ROOT%{_javadocdir}/%{name}/xni
168mkdir -p $RPM_BUILD_ROOT%{_javadocdir}/%{name}/other
169
170cp -pr build/docs/javadocs/xerces2/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}/impl
171cp -pr build/docs/javadocs/api/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}/xs
172cp -pr build/docs/javadocs/xni/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}/xni
173cp -pr build/docs/javadocs/other/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}/other
174
175# scripts
176install -pD -m755 -T %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/%{name}-version
177install -pD -m755 -T %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}-constants
178
179# manual pages
180install -d -m 755 $RPM_BUILD_ROOT%{_mandir}/man1
181install -p -m 644 %{SOURCE11} $RPM_BUILD_ROOT%{_mandir}/man1
182install -p -m 644 %{SOURCE12} $RPM_BUILD_ROOT%{_mandir}/man1
183
184# demo
185install -pD -T build/xercesSamples.jar $RPM_BUILD_ROOT%{_datadir}/%{name}/%{name}-samples.jar
186cp -pr data $RPM_BUILD_ROOT%{_datadir}/%{name}
187
188# Pom
189#install -pD -T -m 644 %{SOURCE7} %{buildroot}%{_mavenpomdir}/JPP-%{name}.pom
190
191# Depmap with legacy depmaps for compatability
192#add_maven_depmap JPP-%{name}.pom %{name}.jar -a "xerces:xerces,xerces:xmlParserAPIs,apache:xerces-j2"
193
194# jaxp_parser_impl ghost symlink
195ln -s %{_sysconfdir}/alternatives \
196   $RPM_BUILD_ROOT%{_javadir}/jaxp_parser_impl.jar
197
198%clean
199rm -rf $RPM_BUILD_ROOT
200
201%post
202/sbin/update-alternatives --install %{_javadir}/jaxp_parser_impl.jar \
203    jaxp_parser_impl %{_javadir}/%{name}.jar 40
204
205%preun
206if [ $1 = 0 ]; then
207    /sbin/update-alternatives --remove jaxp_parser_impl \
208        %{_javadir}/%{name}.jar
209fi
210
211%files
212%defattr(-,root,root,-)
213%doc LICENSE NOTICE README
214%{_javadir}/%{name}*
215%{_bindir}/*
216%{_mandir}/*/*
217%ghost %{_javadir}/jaxp_parser_impl.jar
218
219%files javadoc
220%defattr(-,root,root,-)
221%{_javadocdir}/%{name}
222
223%files demo
224%defattr(-,root,root,-)
225%{_datadir}/%{name}
226
227
228%changelog
229* Sat Jan 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.11.0-1
230- updated to 2.11.0
231
232* Sat Feb 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.9.0-6
233- rebuild with Vine6 environment
234
235* Fri Aug 27 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.9.0-5
236- Initial build for Vine Linux
237
238* Sat Jun 12 2010 Mat Booth <fedora@matbooth.co.uk> - 2.9.0-4
239- Fix broken links in manual and fix javadoc requires.
240- Build 1.5 bytecode instead of 1.6, for compatibility.
241
242* Fri Jan 22 2010 Andrew Overholt <overholt@redhat.com> - 2.9.0-3
243- Fix unversioned Provides for jaxp_parser_impl (make it 1.3).
244
245* Thu Jan 14 2010 Mat Booth <fedora@matbooth.co.uk> - 2.9.0-2
246- Add a build dep on a font package because the JDK is missing a dependency
247  to function correctly in headless mode. See RHBZ #478480 and #521523.
248- Fix groups.
249
250* Tue Jan 5 2010 Mat Booth <fedora@matbooth.co.uk> - 2.9.0-1
251- Update to 2.9.0: This is the version Eclipse expects, previously the OSGi
252  manifest was lying about its version :-o
253- Enable manual sub-package now xml-stylebook is in Fedora.
254- Drop GCJ support.
255- Minor changes to spec to make it more conforming to the guidelines.
256- Drop the libgcj patch, we don't seem to need it anymore.
257- Add the OSGi manifest as part of the build instead of the install.
258- Fix packaging bug RHBZ #472646.
259
260* Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:2.7.1-12.3
261- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
262
263* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:2.7.1-11.3
264- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
265
266* Fri Jan 30 2009 Alexander Kurtakov <akurtako@redhat.com> 0:2.7.1-10.3
267- Add osgi manifest.
268
269* Thu Jul 10 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0:2.7.1-10.2
270- drop repotag
271- fix license tag
272
273* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0:2.7.1-10jpp.1
274- Autorebuild for GCC 4.3
275
276* Wed Mar 28 2007 Matt Wringe <mwringe@redhat.com> 0:2.7.1-9jpp.1
277- Update with newest jpp version
278- Clean up spec file for Fedora Review
279
280* Sun Aug 13 2006 Warren Togami <wtogami@redhat.com> 0:2.7.1-7jpp.2
281- fix typo in preun req
282
283* Sat Aug 12 2006 Matt Wringe <mwringe at redhat.com> 0:2.7.1-7jpp.1
284- Merge with upstream version
285
286* Sat Aug 12 2006 Matt Wringe <mwringe at redhat.com> 0:2.7.1-7jpp
287- Add conditional native compiling
288- Add missing requires for javadocs
289- Add missing requires for post and preun
290- Update version to 7jpp at Fedora's request
291
292* Sat Jul 22 2006 Jakub Jelinek <jakub@redhat.com> - 0:2.7.1-6jpp_9fc
293- Rebuilt
294
295* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0:2.7.1-6jpp_8fc
296- rebuild
297
298* Thu Mar 30 2006 Fernando Nasser <fnasser@redhat.com> 0:2.7.1-3jpp
299- Add missing BR for xml-stylebook
300
301* Wed Mar 22 2006 Ralph Apel <r.apel at r-apel.de> 0:2.7.1-2jpp
302- First JPP-1.7 release
303- use tools subdir and give it as java.endorsed.dirs (for java-1.4.2-bea e.g.)
304
305* Mon Mar  6 2006 Jeremy Katz <katzj@redhat.com> - 0:2.7.1-6jpp_7fc
306- stop scriptlet spew
307
308* Wed Feb 22 2006 Rafael Schloming <rafaels@redhat.com> - 0:2.7.1-6jpp_6fc
309- Updated to 2.7.1
310
311* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0:2.6.2-6jpp_5fc
312- bump again for double-long bug on ppc(64)
313
314* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0:2.6.2-6jpp_4fc
315- rebuilt for new gcc4.1 snapshot and glibc changes
316
317* Thu Feb  2 2006 Archit Shah <ashah@redhat.com> 0:2.6.2-6jpp_3fc
318- build xerces without using native code
319
320* Mon Jan  9 2006 Archit Shah <ashah@redhat.com> 0:2.6.2-6jpp_2fc
321- rebuilt for new gcj
322
323* Wed Dec 21 2005 Jesse Keating <jkeating@redhat.com> 0:2.6.2-6jpp_1fc
324- rebuilt for new gcj
325
326* Tue Dec 13 2005 Jesse Keating <jkeating@redhat.com>
327- rebuilt for new gcj
328
329* Fri Oct 07 2005 Ralph Apel <r.apel at r-apel.de> 0:2.7.1-1jpp
330- Upgrade to 2.7.1
331
332* Thu Jul 21 2005 Ralph Apel <r.apel at r-apel.de> 0:2.6.2-7jpp
333- Include target jars-dom3
334- Create new subpackage dom3
335
336* Mon Jul 18 2005 Gary Benson <gbenson at redhat.com> 0:2.6.2-5jpp_2fc
337- Build on ia64, ppc64, s390 and s390x.
338- Switch to aot-compile-rpm (also BC-compiles samples).
339
340* Wed Jul 13 2005 Gary Benson <gbenson at redhat.com> 0:2.6.2-6jpp
341- Build with Sun JDK (from <gareth.armstrong at hp.com>).
342
343* Wed Jun 15 2005 Gary Benson <gbenson at redhat.com> 0:2.6.2-5jpp_1fc
344- Upgrade to 2.6.2-5jpp.
345
346* Tue Jun 14 2005 Gary Benson <gbenson at redhat.com> 0:2.6.2-5jpp
347- Remove the tools tarball, and build xjavac from source.
348- Patch xjavac to fix the classpath under libgcj too.
349
350* Fri Jun 10 2005 Gary Benson <gbenson@redhat.com> 0:2.6.2-4jpp_8fc
351- Remove the tools tarball, and build xjavac from source.
352- Replace classpath workaround to xjavac task and use
353  xml-commons classes again (#152255).
354
355* Thu May 26 2005 Gary Benson <gbenson@redhat.com> 0:2.6.2-4jpp_7fc
356- Rearrange how BC-compiled stuff is built and installed.
357
358* Mon May 23 2005 Gary Benson <gbenson@redhat.com> 0:2.6.2-4jpp_6fc
359- Add alpha to the list of build architectures (#157522).
360- Use absolute paths for rebuild-gcj-db.
361
362* Thu May  5 2005 Gary Benson <gbenson@redhat.com> 0:2.6.2-4jpp_5fc
363- Add dependencies for %%post and %%postun scriptlets (#156901).
364
365* Fri Apr 29 2005 Gary Benson <gbenson@redhat.com> 0:2.6.2-4jpp_4fc
366- BC-compile.
367
368* Thu Apr 28 2005 Gary Benson <gbenson@redhat.com> 0:2.6.2-4jpp_3fc
369- Revert xjavac classpath workaround, and patch to use libgcj's
370  classes instead of those in xml-commons (#152255).
371
372* Thu Apr 21 2005 Gary Benson <gbenson@redhat.com> 0:2.6.2-4jpp_2fc
373- Add classpath workaround to xjavac task (#152255).
374
375* Wed Jan 12 2005 Gary Benson <gbenson@redhat.com> 0:2.6.2-4jpp_1fc
376- Reenable building of classes that require javax.swing (#130006).
377- Sync with RHAPS.
378
379* Mon Nov 15 2004 Fernando Nasser <fnasser@redhat.com>  0:2.6.2-4jpp_1rh
380- Merge with upstream for 2.6.2 upgrade
381
382* Thu Nov  4 2004 Gary Benson <gbenson@redhat.com> 0:2.6.2-2jpp_5fc
383- Build into Fedora.
384
385* Thu Oct 28 2004 Gary Benson <gbenson@redhat.com> 0:2.6.2-2jpp_4fc
386- Bootstrap into Fedora.
387
388* Fri Oct 1 2004 Andrew Overholt <overholt@redhat.com> 0:2.6.2-2jpp_4rh
389- add coreutils BuildRequires
390
391* Thu Sep 30 2004 Andrew Overholt <overholt@redhat.com> 0:2.6.2-2jpp_3rh
392- Remove xml-commons-resolver as a Requires
393
394* Thu Aug 26 2004 Ralph Apel <r.apel at r-apel.de> 0:2.6.2-4jpp
395- Build with ant-1.6.2
396- Dropped jikes requirement, built for 1.4.2
397
398* Wed Jun 23 2004 Kaj J. Niemi <kajtzu@fi.basen.net> 0:2.6.2-3jpp
399- Updated Patch #0 to fix breakage using BEA 1.4.2 SDK, new patch
400  from <mwringe@redhat.com> and <vivekl@redhat.com>.
401
402* Mon Jun 21 2004 Vivek Lakshmanan <vivekl@redhat.com> 0:2.6.2-2jpp_2rh
403- Added new Source1 URL and added new %%setup to expand it under the
404  expanded result of Source0.
405- Updated Patch0 to fix version discrepancies.
406- Added build requirement for xml-commons-apis
407 
408* Mon Jun 14 2004 Matt Wringe <mwringe@redhat.com> 0:2.6.2-2jpp_1rh
409- Update to 2.6.2
410- made patch names comformant
411
412* Mon Mar 29 2004 Kaj J. Niemi <kajtzu@fi.basen.net> 0:2.6.2-2jpp
413- Rebuilt with jikes 1.18 for java 1.3.1_11
414
415* Fri Mar 26 2004 Frank Ch. Eigler <fche@redhat.com> 0:2.6.1-1jpp_2rh
416- add RHUG upgrade cleanup
417
418* Tue Mar 23 2004 Kaj J. Niemi <kajtzu@fi.basen.net> 0:2.6.2-1jpp
419- 2.6.2
420
421* Thu Mar 11 2004 Frank Ch. Eigler <fche@redhat.com> 0:2.6.1-1jpp_1rh
422- RH vacuuming
423- remove jikes dependency
424- add nonjikes-cast.patch
425
426* Sun Feb 08 2004 David Walluck <david@anti-microsoft.org> 0:2.6.1-1jpp
427- 2.6.1
428- update Source0 URL
429- now requires xml-commons-resolver
430
431* Fri Jan  9 2004 Kaj J. Niemi <kajtzu@fi.basen.net> - 0:2.6.0-1jpp
432- Update to 2.6.0
433- Patch #1 (xerces-j2-manifest.patch) is unnecessary (upstream)
434
435* Tue Oct 21 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:2.5.0-1jpp
436- Update to 2.5.0.
437- Clean up versionless javadoc dir symlinking, own (ghost) the symlinks.
438- Mark javadocs as %%doc.
439
440* Wed Jun  4 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:2.4.0-3jpp
441- Own (ghost) %%{_javadir}/jaxp_parser_impl.jar.
442- Remove alternatives in preun instead of postun.
443
444* Mon May 12 2003 David Walluck <david@anti-microsoft.org> 0:2.4.0-2jpp
445- bug #17325 fixed upstream
446
447* Mon May 12 2003 David Walluck <david@anti-microsoft.org> 0:2.4.0-1jpp
448- 2.4.0
449- BuildRequires: jikes
450- update for JPackage 1.5
451- re-diff'ed build patch for 2.4.0
452- bug #17325 handled by perl now
453- scripts: s|find-jar|build-classpath| and don't test for java-functions
454
455* Wed Mar 26 2003 Nicolas Mailhot <Nicolas.Mailhot (at) JPackage.org> - 2.3.0-2jpp
456- For jpackage-utils 1.5
457- zapped manual, since it doesn't want to build
458- as a consequence, removed uneeded dependencies
459
460* Mon Feb 24 2003 Ville Skyttä <ville.skytta at iki.fi> - 2.3.0-1jpp
461- Update to 2.3.0.
462- Add a crude patch to work around invalid XML in doc sources, see
463  <http://nagoya.apache.org/bugzilla/show_bug.cgi?id=17325>.
464- Built with IBM's 1.3.1 SR3.
465
466* Sat Dec 28 2002 Ville Skyttä <ville.skytta at iki.fi> - 2.2.1-2jpp
467- Add upstream patch which fixes problems with Tomcat's webapps.
468  <http://nagoya.apache.org/bugzilla/show_bug.cgi?id=13282>
469  <http://marc.theaimsgroup.com/?l=xerces-cvs&m=103791990130308>
470- Separate scripts subpackage.
471
472* Fri Nov 15 2002 Ville Skyttä <ville.skytta at iki.fi> - 2.2.1-1jpp
473- Update to 2.2.1.
474- Change alternative to point to non-versioned jar.
475- Don't remove alternative on upgrade.
476- Fix Group tag for demo, javadoc and manual subpackages.
477- Add version and constants scripts.
478- Some spec file cleanup.
479
480* Sun Oct  6 2002 Ville Skyttä <ville.skytta at iki.fi> 2.2.0-2jpp
481- Fix bad permissions for main jar.
482
483* Sun Sep 29 2002 Ville Skyttä <ville.skytta at iki.fi> 2.1.0-1jpp
484- Update to 2.2.0.
485
486* Tue Sep 10 2002 Ville Skyttä <ville.skytta at iki.fi> 2.1.0-2jpp
487- Rebuild with -Dcompiler=modern, not a Jikes bug this time, but sloppy code
488  that is tolerated by javac.  See <http://www-124.ibm.com/developerworks/bugs/?func=detailbug&bug_id=3218&group_id=10> for details.
489
490* Tue Sep 10 2002 Ville Skyttä <ville.skytta at iki.fi> 2.1.0-1jpp
491- 2.1.0.
492- Updated description.
493- Changed javadoc and manual group to Documentation.
494- Spec file cleanups.
495
496* Fri Jul 12 2002 Henri Gomez <hgomez@users.sourceforge.net> 2.0.2-4jpp
497- add BuildRequires xerces-j1 and xalan-j2
498- removed BuildRequires xml-commons-api since ant require jaxp_parser_impl
499  which in turn require xml-commons-api ;)
500
501* Mon Jul 01 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.0.2-3jpp
502- vendor, distribution, group tags
503- provides jaxp_parser_impl
504- dropped api jar
505- renamed lone jar to %%{name}.jar
506- priority bumped to 40
507- fixed stylebook build (add xerces-j1 in classpath)
508
509* Wed Jun 26 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.0.2-2jpp
510- rebuild for missing symlinks
511- use sed instead of bash 2.x extension in link area to make spec compatible with distro using bash 1.1x
512
513* Mon Jun 24 2002 Henri Gomez <hgomez@users.sourceforge.net> 2.0.2-1jpp
514- 2.0.2
515
516* Sun Mar 10 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.0.1-1jpp
517- 2.0.1
518- provides jaxp_parser2 virtual resource
519- drop wrapper
520
521* Sun Feb 03 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.0.0-1jpp
522- first JPackage release
Note: See TracBrowser for help on using the repository browser.