source: projects/specs/trunk/x/xerces-c/xerces-c-vl.spec @ 521

Revision 521, 5.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:        Validating XML Parser
2Name:           xerces-c
3Version:        2.8.0
4Release: 2%{?_dist_release}
5License:        ASL 2.0
6Group:          System Environment/Libraries
7URL:            http://xml.apache.org/xerces-c/
8Source:         http://www.apache.org/dist/xerces/c/sources/xerces-c-src_2_8_0.tar.gz
9BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
10
11%description
12Xerces-C is a validating XML parser written in a portable subset of
13C++. Xerces-C makes it easy to give your application the ability to
14read and write XML data. A shared library is provided for parsing,
15generating, manipulating, and validating XML documents. Xerces-C is
16faithful to the XML 1.0 recommendation and associated standards ( DOM
171.0, DOM 2.0. SAX 1.0, SAX 2.0, Namespaces).
18
19%package        devel
20Summary:        Header files, libraries and development documentation for %{name}
21Group:          Development/Libraries
22Requires:       %{name} = %{version}-%{release}
23
24%description devel
25This package contains the header files, static libraries and development
26documentation for %{name}. If you like to develop programs using %{name},
27you will need to install %{name}-devel.
28
29%package doc
30Group:          Documentation
31Summary:        Documentation for Xerces-C++ validating XML parser
32
33%description doc
34Documentation for Xerces-C++.
35
36Xerces-C++ is a validating XML parser written in a portable subset of C++.
37Xerces-C++ makes it easy to give your application the ability to read and
38write XML data. A shared library is provided for parsing, generating,
39manipulating, and validating XML documents.
40
41%prep
42%setup -q -n xerces-c-src_2_8_0
43rm -rf doc/html/resources/.svn
44find ./doc -type f -perm 755 -exec chmod 644 {} \;
45find ./samples -type f -perm 755 -exec chmod 644 {} \;
46%{__perl} -pi.orig -e 's|(PREFIX.)/lib\b|$1/%{_lib}|g' src/xercesc/configure */Makefile.in
47rm doc/html/apiDocs/XMLRegisterCleanup_8hpp__incl.map
48rm doc/html/apiDocs/XSConstants_8hpp__incl.map
49
50# make rpmlint happy
51sed -i 's/\r//' doc/charter.xml
52iconv -f iso8859-1 -t utf-8 credits.txt > credits.utf8 && mv -f credits.{utf8,txt}
53iconv -f iso8859-1 -t utf-8 doc/feedback.xml > doc/feedback.utf8 && mv -f doc/feedback.{utf8,xml}
54iconv -f iso8859-1 -t utf-8 doc/migration.xml > doc/migration.utf8 && mv -f doc/migration.{utf8,xml}
55iconv -f iso8859-1 -t utf-8 doc/releases_archive.xml > doc/releases_archive.utf8 && mv -f doc/releases_archive.{utf8,xml}
56
57%build
58export XERCESCROOT="$PWD"
59
60# Let Makefiles be verbose
61find -name 'Makefile.*' | while read f; do
62        sed -i -e 's/$Q//g' \
63        -e 's/{MAKE} -s/(MAKE)/g' \
64        -e '/echo \"  (/d' \
65        $f
66done
67
68# Remove conflicting flags from runConfigure
69find -name runConfigure | while read f; do
70        sed -i -e 's/-w -O -DNDEBUG/-DNDEBUG/g' $f
71done
72
73cd $XERCESCROOT/src/xercesc
74%ifarch alpha ppc64 s390x sparc64 x86_64
75CXXFLAGS="${RPM_OPT_FLAGS}" CFLAGS="${RPM_OPT_FLAGS}" ./runConfigure -plinux -cgcc -xg++ -minmem -nsocket -tnative -rpthreads -b64 -P %{_prefix} -C --libdir="%{_libdir}"
76%else
77CXXFLAGS="${RPM_OPT_FLAGS}" CFLAGS="${RPM_OPT_FLAGS}" ./runConfigure -plinux -cgcc -xg++ -minmem -nsocket -tnative -rpthreads -b32 -P %{_prefix} -C --libdir="%{_libdir}"
78%endif
79# not smp safe
80%{__make}
81#cd $XERCESCROOT/samples
82#CXXFLAGS="${RPM_OPT_FLAGS}" CFLAGS="${RPM_OPT_FLAGS}" ./runConfigure -plinux -cgcc -xg++
83#%{__make}
84
85%install
86%{__rm} -rf $RPM_BUILD_ROOT
87export XERCESCROOT="$PWD"
88%{__make} install -C src/xercesc DESTDIR="$RPM_BUILD_ROOT"
89#mkdir -p $RPM_BUILD_ROOT%{_datadir}/%{name}
90#rm -rf $XERCESCROOT/samples/Projects
91#cp -a $XERCESCROOT/samples $RPM_BUILD_ROOT%{_datadir}/%{name}
92
93%post -p /sbin/ldconfig
94%postun -p /sbin/ldconfig
95
96%clean
97%{__rm} -rf $RPM_BUILD_ROOT
98
99%files
100%defattr(-,root,root,-)
101%doc LICENSE.txt
102%{_libdir}/libxerces*.so.*
103
104%files devel
105%defattr(-,root,root,-)
106%{_libdir}/libxerces*.so
107%{_includedir}/xercesc/
108
109%files doc
110%defattr(-,root,root,-)
111%doc Readme.html LICENSE NOTICE STATUS credits.txt doc samples
112
113#%files samples
114#%defattr(-,root,root,-)
115#%{_datadir}/%{name}/samples
116
117%changelog
118* Tue Mar 02 2010 Shu KONNO <owa@bg.wakwak.com> 2.8.0-2
119- rebuilt with new toolchain
120
121* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp>  2.8.0-1
122- initial build for Vine Linux
123
124* Mon Jun 30 2008 Peter Lemenkov <lemenkov@gmail.com> 2.8.0-2
125- Spec cleanups ( https://bugzilla.redhat.com/show_bug.cgi?id=435132 )
126
127* Sun Feb 10 2008 Peter Lemenkov <lemenkov@gmail.com> 2.8.0-1
128- Ver. 2.8.0
129
130* Sat Nov 25 2006 Peter Lemenkov <lemenkov@gmail.com> 2.7.0-6
131- typo fix
132
133* Sat Nov 25 2006 Peter Lemenkov <lemenkov@gmail.com> 2.7.0-5
134- fixed some rpmlint warnings
135
136* Fri Nov 24 2006 Peter Lemenkov <lemenkov@gmail.com> 2.7.0-4
137- Added samples to docs-package
138
139* Sat Nov 18 2006 Peter Lemenkov <lemenkov@gmail.com> 2.7.0-3
140- improvements suggested by Aurelien Bompard
141
142* Sat Oct 14 2006 Peter Lemenkov <lemenkov@gmail.com> 2.7.0-2
143- Disabled package 'samples'
144
145* Fri Oct 13 2006 Peter Lemenkov <lemenkov@gmail.com> 2.7.0-1
146- initial build for FE
147
148* Fri Jan 06 2006 Dag Wieers <dag@wieers.com> - 2.7.0-1 - 3891/dag
149- Cleaned SPEC file.
150
151* Tue Jan 03 2006 Dries Verachtert <dries@ulyssis.org> - 2.7.0-1
152- Updated to release 2.7.0.
153
154* Thu Sep 22 2005 C.Lee Taylor <leet@leenx.co.za> 2.6.1-1
155- Update to 2.6.1
156- Build for FC4 32/64bit
157
158* Sat Aug 20 2005 Che
159- initial rpm release
Note: See TracBrowser for help on using the repository browser.