source: projects/specs/trunk/x/xerces-c/xerces-c-vl.spec @ 10537

Revision 10537, 4.7 KB checked in by tomop, 8 years ago (diff)

xerces-c-3.1.3-2

Line 
1Summary:        Validating XML Parser
2Name:           xerces-c
3Version:        3.1.3
4Release:        2%{?_dist_release}
5License:        ASL 2.0
6Group:          System Environment/Libraries
7URL:            http://xml.apache.org/xerces-c/
8
9Vendor:         Project Vine
10Distribution:   Vine Linux
11
12Source0:        http://www.apache.org/dist/xerces/c/3/sources/xerces-c-%{version}.tar.xz
13
14BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires:  dos2unix
16
17%description
18Xerces-C is a validating XML parser written in a portable subset of
19C++. Xerces-C makes it easy to give your application the ability to
20read and write XML data. A shared library is provided for parsing,
21generating, manipulating, and validating XML documents. Xerces-C is
22faithful to the XML 1.0 recommendation and associated standards:
23XML 1.0 (Third Edition), XML 1.1 (First Edition), DOM Level 1, 2, 3
24Core, DOM Level 2.0 Traversal and Range, DOM Level 3.0 Load and Save,
25SAX 1.0 and SAX 2.0, Namespaces in XML, Namespaces in XML 1.1, XML
26Schema, XML Inclusions).
27
28%package        devel
29Summary:        Header files, libraries and development documentation for %{name}
30Summary(ja):    %{name} のヘッダファイル、ライブラリ、開発用ドキュメント
31Group:          Development/Libraries
32Requires:       %{name} = %{version}-%{release}
33
34%description devel
35This package contains the header files, static libraries and development
36documentation for %{name}. If you like to develop programs using %{name},
37you will need to install %{name}-devel.
38
39%package doc
40Summary:        Documentation for Xerces-C++ validating XML parser
41Group:          Documentation
42BuildArch:      noarch
43
44%description doc
45Documentation for Xerces-C++.
46
47Xerces-C++ is a validating XML parser written in a portable subset of C++.
48Xerces-C++ makes it easy to give your application the ability to read and
49write XML data. A shared library is provided for parsing, generating,
50manipulating, and validating XML documents.
51
52%prep
53%setup -q
54# Copy samples before build to avoid including built binaries in -doc package
55mkdir -p _docs
56cp -a samples/ _docs/
57
58%build
59# --disable-sse2 makes sure explicit -msse2 isn't passed to gcc so
60# the binaries would be compatible with non-SSE2 i686 hardware.
61# This only affects i686, as on x86_64 the compiler uses SSE2 by default.
62export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
63export CXXFLAGS="$CFLAGS"
64%configure --disable-static \
65  --disable-pretty-make \
66  --disable-sse2
67make %{?_smp_mflags}
68
69%install
70rm -rf $RPM_BUILD_ROOT
71make install DESTDIR="$RPM_BUILD_ROOT"
72# Correct errors in encoding
73iconv -f iso8859-1 -t utf-8 CREDITS > CREDITS.tmp && mv -f CREDITS.tmp CREDITS
74# Correct errors in line endings
75pushd doc; dos2unix -k *.xml; popd
76# Remove unwanted binaries
77rm -rf $RPM_BUILD_ROOT%{_bindir}
78# Remove .la files
79rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
80
81%post -p /sbin/ldconfig
82
83%postun -p /sbin/ldconfig
84
85%clean
86rm -rf $RPM_BUILD_ROOT
87
88%files
89%defattr(-,root,root,-)
90%doc LICENSE
91%{_libdir}/libxerces-c-3.*.so
92
93%files devel
94%defattr(-,root,root,-)
95%{_libdir}/libxerces-c.so
96%{_libdir}/pkgconfig/xerces-c.pc
97%{_includedir}/xercesc/
98
99%files doc
100%defattr(-,root,root,-)
101%doc README LICENSE NOTICE CREDITS doc _docs/*
102
103
104%changelog
105* Tue Jul  5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.1.3-2
106- rebuilt with new toolchain.
107
108* Tue Apr 12 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.1.3-1
109- updated to 3.1.3.
110
111* Sat Jan 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.1.1-1
112- updated to 3.1.1
113
114* Sat Feb 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.0-3
115- rebuild with Vine6 environment
116
117* Tue Mar 02 2010 Shu KONNO <owa@bg.wakwak.com> 2.8.0-2
118- rebuilt with new toolchain
119
120* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp>  2.8.0-1
121- initial build for Vine Linux
122
123* Mon Jun 30 2008 Peter Lemenkov <lemenkov@gmail.com> 2.8.0-2
124- Spec cleanups ( https://bugzilla.redhat.com/show_bug.cgi?id=435132 )
125
126* Sun Feb 10 2008 Peter Lemenkov <lemenkov@gmail.com> 2.8.0-1
127- Ver. 2.8.0
128
129* Sat Nov 25 2006 Peter Lemenkov <lemenkov@gmail.com> 2.7.0-6
130- typo fix
131
132* Sat Nov 25 2006 Peter Lemenkov <lemenkov@gmail.com> 2.7.0-5
133- fixed some rpmlint warnings
134
135* Fri Nov 24 2006 Peter Lemenkov <lemenkov@gmail.com> 2.7.0-4
136- Added samples to docs-package
137
138* Sat Nov 18 2006 Peter Lemenkov <lemenkov@gmail.com> 2.7.0-3
139- improvements suggested by Aurelien Bompard
140
141* Sat Oct 14 2006 Peter Lemenkov <lemenkov@gmail.com> 2.7.0-2
142- Disabled package 'samples'
143
144* Fri Oct 13 2006 Peter Lemenkov <lemenkov@gmail.com> 2.7.0-1
145- initial build for FE
146
147* Fri Jan 06 2006 Dag Wieers <dag@wieers.com> - 2.7.0-1 - 3891/dag
148- Cleaned SPEC file.
149
150* Tue Jan 03 2006 Dries Verachtert <dries@ulyssis.org> - 2.7.0-1
151- Updated to release 2.7.0.
152
153* Thu Sep 22 2005 C.Lee Taylor <leet@leenx.co.za> 2.6.1-1
154- Update to 2.6.1
155- Build for FC4 32/64bit
156
157* Sat Aug 20 2005 Che
158- initial rpm release
Note: See TracBrowser for help on using the repository browser.