source: projects/specs/trunk/x/xerces-c/xerces-c-vl.spec @ 10183

Revision 10183, 4.5 KB checked in by tomop, 8 years ago (diff)

xerces-c-3.1.3-1

Line 
1Summary:        Validating XML Parser
2Name:           xerces-c
3Version:        3.1.3
4Release:        1%{?_dist_release}
5License:        ASL 2.0
6Group:          System Environment/Libraries
7URL:            http://xml.apache.org/xerces-c/
8
9Source0:        http://www.apache.org/dist/xerces/c/3/sources/xerces-c-%{version}.tar.xz
10
11BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
12BuildRequires:  dos2unix
13
14%description
15Xerces-C is a validating XML parser written in a portable subset of
16C++. Xerces-C makes it easy to give your application the ability to
17read and write XML data. A shared library is provided for parsing,
18generating, manipulating, and validating XML documents. Xerces-C is
19faithful to the XML 1.0 recommendation and associated standards:
20XML 1.0 (Third Edition), XML 1.1 (First Edition), DOM Level 1, 2, 3
21Core, DOM Level 2.0 Traversal and Range, DOM Level 3.0 Load and Save,
22SAX 1.0 and SAX 2.0, Namespaces in XML, Namespaces in XML 1.1, XML
23Schema, XML Inclusions).
24
25%package        devel
26Summary:        Header files, libraries and development documentation for %{name}
27Summary(ja):    %{name} のヘッダファイル、ライブラリ、開発用ドキュメント
28Group:          Development/Libraries
29Requires:       %{name} = %{version}-%{release}
30
31%description devel
32This package contains the header files, static libraries and development
33documentation for %{name}. If you like to develop programs using %{name},
34you will need to install %{name}-devel.
35
36%package doc
37Summary:        Documentation for Xerces-C++ validating XML parser
38Group:          Documentation
39BuildArch:      noarch
40
41%description doc
42Documentation for Xerces-C++.
43
44Xerces-C++ is a validating XML parser written in a portable subset of C++.
45Xerces-C++ makes it easy to give your application the ability to read and
46write XML data. A shared library is provided for parsing, generating,
47manipulating, and validating XML documents.
48
49%prep
50%setup -q
51# Copy samples before build to avoid including built binaries in -doc package
52mkdir -p _docs
53cp -a samples/ _docs/
54
55%build
56# --disable-sse2 makes sure explicit -msse2 isn't passed to gcc so
57# the binaries would be compatible with non-SSE2 i686 hardware.
58# This only affects i686, as on x86_64 the compiler uses SSE2 by default.
59export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
60export CXXFLAGS="$CFLAGS"
61%configure --disable-static \
62  --disable-pretty-make \
63  --disable-sse2
64make %{?_smp_mflags}
65
66%install
67rm -rf $RPM_BUILD_ROOT
68make install DESTDIR="$RPM_BUILD_ROOT"
69# Correct errors in encoding
70iconv -f iso8859-1 -t utf-8 CREDITS > CREDITS.tmp && mv -f CREDITS.tmp CREDITS
71# Correct errors in line endings
72pushd doc; dos2unix -k *.xml; popd
73# Remove unwanted binaries
74rm -rf $RPM_BUILD_ROOT%{_bindir}
75# Remove .la files
76rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
77
78%post -p /sbin/ldconfig
79
80%postun -p /sbin/ldconfig
81
82%clean
83rm -rf $RPM_BUILD_ROOT
84
85%files
86%defattr(-,root,root,-)
87%doc LICENSE
88%{_libdir}/libxerces-c-3.*.so
89
90%files devel
91%defattr(-,root,root,-)
92%{_libdir}/libxerces-c.so
93%{_libdir}/pkgconfig/xerces-c.pc
94%{_includedir}/xercesc/
95
96%files doc
97%defattr(-,root,root,-)
98%doc README LICENSE NOTICE CREDITS doc _docs/*
99
100
101%changelog
102* Tue Apr 12 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.1.3-1
103- updated to 3.1.3.
104
105* Sat Jan 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.1.1-1
106- updated to 3.1.1
107
108* Sat Feb 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.0-3
109- rebuild with Vine6 environment
110
111* Tue Mar 02 2010 Shu KONNO <owa@bg.wakwak.com> 2.8.0-2
112- rebuilt with new toolchain
113
114* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp>  2.8.0-1
115- initial build for Vine Linux
116
117* Mon Jun 30 2008 Peter Lemenkov <lemenkov@gmail.com> 2.8.0-2
118- Spec cleanups ( https://bugzilla.redhat.com/show_bug.cgi?id=435132 )
119
120* Sun Feb 10 2008 Peter Lemenkov <lemenkov@gmail.com> 2.8.0-1
121- Ver. 2.8.0
122
123* Sat Nov 25 2006 Peter Lemenkov <lemenkov@gmail.com> 2.7.0-6
124- typo fix
125
126* Sat Nov 25 2006 Peter Lemenkov <lemenkov@gmail.com> 2.7.0-5
127- fixed some rpmlint warnings
128
129* Fri Nov 24 2006 Peter Lemenkov <lemenkov@gmail.com> 2.7.0-4
130- Added samples to docs-package
131
132* Sat Nov 18 2006 Peter Lemenkov <lemenkov@gmail.com> 2.7.0-3
133- improvements suggested by Aurelien Bompard
134
135* Sat Oct 14 2006 Peter Lemenkov <lemenkov@gmail.com> 2.7.0-2
136- Disabled package 'samples'
137
138* Fri Oct 13 2006 Peter Lemenkov <lemenkov@gmail.com> 2.7.0-1
139- initial build for FE
140
141* Fri Jan 06 2006 Dag Wieers <dag@wieers.com> - 2.7.0-1 - 3891/dag
142- Cleaned SPEC file.
143
144* Tue Jan 03 2006 Dries Verachtert <dries@ulyssis.org> - 2.7.0-1
145- Updated to release 2.7.0.
146
147* Thu Sep 22 2005 C.Lee Taylor <leet@leenx.co.za> 2.6.1-1
148- Update to 2.6.1
149- Build for FC4 32/64bit
150
151* Sat Aug 20 2005 Che
152- initial rpm release
Note: See TracBrowser for help on using the repository browser.