source: projects/specs/trunk/x/xchat/xchat-vl.spec @ 7938

Revision 7938, 21.5 KB checked in by Takemikaduchi, 11 years ago (diff)

GNOME-3.10.1

Line 
1# Nobody likely uses this so we disable it
2%define with_tclplugin 0
3
4%define name xchat
5%define version 2.8.8
6%define release 2%{?_dist_release}
7
8Summary:   GTK2 based graphical IRC client
9Summary(ja):   GTK2 ベースのグラフィカル IRC クライアント
10Name:      %{name}
11Version:   %{version}
12Release:   %{release}
13Group:     Applications/Internet
14License:   GPL
15URL:       http://www.xchat.org/
16
17Source0: http://www.xchat.org/files/source/2.8/xchat-%{version}.tar.xz
18
19
20# Patches 0-9 reserved for official xchat.org patches
21
22Patch12: xchat-1.8.7-use-sysconf-to-detect-cpus.patch
23# see #241923
24Patch35: xchat-2.8.4-disable-tray-icon-by-default.patch
25# Upstream XChat 2.8.6 defaults to Latin1 (what upstream calls the "IRC"
26# encoding). Default to UTF-8 instead (as previous versions did, at least when
27# running under a UTF-8 locale).
28# Both the "IRC" and "UTF-8" settings will try to accept both Latin1 and UTF-8
29# when it comes in, however "IRC" sends Latin1, "UTF-8" sends UTF-8.
30Patch41: xchat-2.8.6-default-utf8.patch
31# patch to add ability to change to tab with most recent activity
32# See http://sourceforge.net/tracker/?func=detail&aid=2022871&group_id=239&atid=350239
33Patch50: xchat-2.8.6-change-page-activity.patch
34# add port numbers for Freenode (Debarshi Ray)
35Patch51: xchat-2.8.6-freenode-ports.patch
36# work with libnotify 0.7
37# https://sourceforge.net/tracker/?func=detail&aid=3109838&group_id=239&atid=100239
38Patch52: xchat-2.8.8-libnotify07.patch
39
40# Vine
41#Source100: xchat-2.4.5-ja.po
42Patch100: http://takuo.jp/junk/xchat/99_plus.dpatch
43Patch110: http://takuo.jp/junk/xchat/99_x_dialog.dpatch
44Patch200: xchat-2.8.6_defaultserver-vine.patch
45
46Patch201: xchat-2.8.8-glib.patch
47
48# xchat MUST have the version of perl installed which was used to compile
49# it, or else the embeded perl interpreter will break.
50Requires: %(perl -le 'use Config; print $Config{archlibexp}')
51
52BuildRequires: glib2-devel >= 2.2.0
53BuildRequires: gtk2-devel >= 2.2.0
54BuildRequires: bison >= 1.35
55BuildRequires: gettext, sed
56BuildRequires: perl, python-devel, openssl-devel, pkgconfig
57BuildRequires: autoconf
58BuildRequires: GConf2-devel
59BuildRequires: dbus-glib-devel >= 0.60
60BuildRequires: tcl
61
62Requires(post): GConf2 >= 2.14
63Requires(preun): GConf2 >= 2.14
64
65Buildroot: %{_tmppath}/%{name}-%{version}-root
66
67
68%description
69X-Chat is an easy to use graphical IRC chat client for the X Window
70System.
71
72%description -l ja
73X-ChatはGTK2ベースのXウィンドウシステム用のIRCクライアントです。
74
75
76%prep
77%setup -q
78
79##%patch10 -p1
80
81%patch12 -p0 -b .use-sysconf-to-detect-cpus
82%patch35 -p1 -b .tray-icon
83%patch41 -p1 -b .default-utf8
84%patch50 -p1 -b .active-channel-switch
85%patch51 -p1 -b .freenode-ports
86%patch52 -p1 -b .libnotify07
87
88%patch100 -p1 -b .plus
89%patch110 -p1 -b .dialog
90
91%patch200 -p1 -b .servlist
92%patch201 -p1 -b .glib
93
94sed -i -e 's/#define GTK_DISABLE_DEPRECATED//g' src/fe-gtk/*.c
95sed -i -e 's/GETTEXT_MACRO_VERSION = 0\.17/GETTEXT_MACRO_VERSION = 0.18/g' po/Makefile.in.in
96
97
98%build
99touch NEWS ABOUT-NLS
100libtoolize --copy --force
101aclocal
102automake
103autoconf
104# Remove CVS files from source dirs so they're not installed into doc dirs.
105find . -name CVS -type d | xargs rm -rf
106
107export CFLAGS="$RPM_OPT_FLAGS $(perl -MExtUtils::Embed -e ccopts)"
108export LDFLAGS=$(perl -MExtUtils::Embed -e ldopts)
109
110if pkg-config openssl ; then
111        export CFLAGS="$CFLAGS `pkg-config --cflags openssl`"
112        export CPPFLAGS="$CPPFLAGS `pkg-config --cflags-only-I openssl`"
113        export LDFLAGS="$LDFLAGS `pkg-config --libs-only-L openssl`"
114fi
115
116%configure --disable-textfe \
117           --enable-openssl \
118           --enable-python \
119           --disable-spell \
120                   --enable-glibtest \
121%if %{with_tclplugin}
122i                  --enable-tcl \
123%endif     
124           --enable-ipv6
125
126make %{?_smp_mflags}
127
128
129%install
130rm -rf $RPM_BUILD_ROOT
131make DESTDIR=$RPM_BUILD_ROOT install
132
133# Remove unwanted stuff
134rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
135rm -f $RPM_BUILD_ROOT%{_libdir}/xchat/plugins/*.la
136#rm -f $RPM_BUILD_ROOT%{_datadir}/applications/xchat.desktop
137#rm -f $RPM_BUILD_ROOT/etc/X11/applnk/Internet/xchat.desktop
138
139%find_lang %name
140
141
142%files -f %{name}.lang
143%defattr(-,root,root)
144%doc README ChangeLog
145%{_sysconfdir}/gconf/schemas/*
146%{_bindir}/xchat
147%{_libdir}/xchat/plugins/*.so
148%{_datadir}/applications/xchat.desktop
149%{_datadir}/dbus-1/services/*
150%{_datadir}/pixmaps/*
151
152
153%clean
154rm -rf $RPM_BUILD_ROOT
155
156
157%post
158# Install schema
159export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
160gconftool-2 --makefile-install-rule /etc/gconf/schemas/apps_xchat_url_handler.schemas > /dev/null || :
161
162%pre
163if [ "$1" -gt 1 -a -f "/etc/gconf/schemas/apps_xchat_url_handler.schemas" ]; then
164  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
165  gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/apps_xchat_url_handler.schemas > /dev/null || :
166fi
167
168%preun
169if [ "$1" -eq 0 ]; then
170  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
171  gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/apps_xchat_url_handler.schemas > /dev/null || :
172fi
173
174
175%changelog
176* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.8-2
177- rebuild with tcl-8.5.15
178- add Patch201 (xchat-2.8.8-glib.patch)
179- change BuildRequires: dbus-glib-devel instead of dbus-devel
180
181* Sun Mar 27 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.8.8-1
182- new upstream release.
183- shipped some patches from Fedora development.
184
185* Sat Jan 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.6-5
186- rebuild with openssl-1.0.0c
187- add BuildRequires: tcl
188- add Patch201 (xchat-2.8.6-x86_64.patch)
189
190* Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.8.6-4
191- rebuilt with python-2.6.4-3
192
193* Tue Nov 03 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.8.6-3
194- updated Patch200 (Vine channel's default encoding to UTF-8)
195
196* Wed Apr 08 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.8.6-2
197- rebuilt with gtk2-2.16.0
198- don't #define GTK_DISABLE_DEPRECATED (fixes build against current GTK+)
199- add Patch200 (set default server connection for Vine people)
200- TODO: update ja.po
201
202* Mon Sep 01 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.8.6-1
203- updated to 2.8.6
204- drop/add patches
205
206* Sun May 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.8.4-1
207- new versioning policy
208- rebuilt with perl-5.10.0
209- spec in UTF-8
210
211* Tue Jan 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.8.4-0vl1
212- updated to 2.8.4 with updated plus patch and upstream patches (14-16)
213
214* Tue Jun 19 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.8.2-0vl1
215- updated to 2.8.2 with plus patch
216
217* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.8-0vl4
218- rebuild with dbus-1.0
219
220* Wed Nov 29 2006 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.6.8-0vl3
221- build without libsexy.
222
223* Thu Nov 23 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.8-0vl2
224- added Patch10 and Patch20 for possible crashes under certain environments
225
226* Thu Oct 26 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.8-0vl1
227- updated to 2.6.8 with plus patch
228
229* Sun Sep 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.5-0vl1
230- new upstream release
231- updated ja.po
232- added Patch1 from http://www.xchat.org/files/source/2.4/patches/
233- added Patches from Fedora
234  * Sun May 15 2005 Warren Togami <wtogami@redhat.com> 1:2.4.3-3
235  - Prevent interception of down arrow during Input Method (#144588 tagoh)
236  * Thu Apr 14 2005 Warren Togami <wtogami@redhat.com> 1:2.4.3-2
237  - fix plugins on lib64 (#113188 Ville Skytta)
238  * Tue Jan  4 2005 Christopher Aillon <caillon@redhat.com> 1:2.4.1-2
239  - Add Dan Reed's CTCP patch to support multiline messages (#136545)
240  * Tue Aug 17 2004 Daniel Reed <djr@redhat.com> 1:2.4.0-2
241  - #125846 Change xchat.desktop names to "IRC"
242
243* Sun Jan 09 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.9-0vl4
244- rebuild with perl-5.8.6-0vl2
245
246* Tue Jul  6 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.9-0vl3
247- rebuild with perl-5.8.2-0vl2
248- updated ja.po
249
250* Mon Jun 21 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.9-0vl2
251- resume othersview patch (Patch21)
252
253* Sun Jun 20 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.9-0vl1
254- new upstream release
255- updated Patch10
256- dropped unneeded patches
257- updated ja.po
258
259* Fri Nov  7 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.2-0vl5
260- build with perl-5.8.2
261
262* Fri Sep 26 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.2-0vl4
263- build with perl-5.8.1
264- change spec file's encoding: shift_jis -> euc-jp
265
266* Thu Jun 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.2-0vl3
267- add ja.po
268
269* Thu Jun 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.2-0vl2
270- add patch21 from debian to support othersview.
271
272* Thu Jun 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.2-0vl1
273- build for Vine Linux based on rawhide
274- some parts is merged with Vine Linux 1.8.10-0vl2
275  * Wed Jan 15 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.10-0vl2
276  - rebuilt against gnome-libs-1.4.2-0vl2 (for db1/db4 matters)
277  - add BuildRequires: automake14, autoconf213
278  - modified source10 (openprojects has been renamed to freenode)
279  * Tue Aug 13 2002 IWAI Masaharu <iwai@alib.jp> 1.8.10-0vl1
280  - upstream update
281  - updated plus patch
282  - moved xchat.desktop to %%{_sysconfdir}/X11/applnk/Internet by upstream
283  * Thu Jul 25 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.8-0vl3
284  - use source10 instead of patch10 for server list
285  - default server for #VineUsers changed to OpenProjects Network's
286  * Wed Mar 20 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.8-0vl2
287  - now with 1.8.8 plus patch
288  * Sat Mar 16 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.8.8-0vl1
289  - upstream release
290  - updated vine-serverlist.patch
291  - stop to apply plus patch
292    ( xchat-1.8.4 has the security hole... )
293  * Tue Oct  2 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.8.4-0vl3
294  - removed backup files for %%patch0 in Document Directory
295  * Sun Sep 30 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.4-0vl2
296  - updated to 1.8.4 release with plus patch :-)
297  * Sun Sep 30 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.8.4-0vl1
298  - upstream release
299  * Mon Sep  3 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp>
300  - 1.8.3-0vl1
301  - upstream release
302  - add xchat-text
303  - add docs: COPYING FAQ plugins/* scripts-perl/* scripts-python/*
304  * Fri Aug  3 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp>
305  - 1.8.2-0vl1
306  - upstream release
307  * Sat Jul 21 2001 <iwaim@cc.mbn.or.jp>
308  - 1.8.1-0vl1
309  - upstream release
310  - modified server.vine patch
311  * Sun Jul 15 2001 <sagami@vinelinux.org>
312  - 1.6.4.1-0vl3: prefix -> _prefix
313  - OLD_PO_FILE_INPUT=yes to build with new gettext
314  - use %%{find_lang}
315  * Wed Apr 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
316  - 1.6.4.1-0vl2
317  - fix CFLAGS for e-paned
318  * Tue Feb  6 2001 Takuo KITAME <kitame@northeye.org>
319  - 1.6.3.1-0vl1
320  - New upstream release
321  * Tue Oct 31 2000 Jun Nishii <jun@vinelinux.org>
322  - 1.5.9.4-0vl1
323  - This is the first release of xchat-plus.
324  * Mon Jul  3 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
325  - added w3m patch
326  * Wed Apr  12 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
327  - updated to 1.4.2
328  * Thu Mar  14 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
329  - updated to 1.4.1
330  - separated ja_nls patch to more_ja_nls and libjcode patches.
331  * Sat Mar  04 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
332  - modified mb_fix patch for cut & paste.
333  * Fri Feb  11 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
334  - updated to 1.4.0
335  * Wed Feb  2 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
336  - updated to 1.3.13
337  * Mon Jan 10 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
338  - modified mb_fix patch
339  * Wed Jan  5 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
340  - updated to 1.3.10
341  * Wed Dec  8 1999 Yasuyuki Furukawa <furukawa@vinelinux.org>
342  - updated to 1.3.8
343  - added mb_fix patch
344  * Tue Nov  9 1999 Yasuyuki Furukawa <furukawa@vinelinux.org>
345  - update to 1.3.6
346  * Sun Oct 17 1999 Jun NISHII <jun@flatout.org>
347  - merge ja-patch
348
349* Thu May 29 2003 Mike A. Harris <mharris@redhat.com> 2.0.2-7
350- Added back BuildRequires autoconf, and call autoconf prior to ./configure
351  as it seems to make xchat build successfully.  Have not bothered to figure
352  out why calling autoconf is needed.  Something for a rainy day.
353
354* Thu May 29 2003 Mike A. Harris <mharris@redhat.com> 2.0.2-6
355- Removed gnome-libs BuildRequires as it is bogus now
356- Removed autoconf BuildRequires and usage, as it should be unneeded
357- Added new BuildRequires on gettext, bison >= 1.35, glib2-devel >= 2.0.3,
358  gtk2-devel >= 2.0.3, /bin/sed  (#91676 - Warren Togami)
359- Removed dead patches: xchat-1.8.9-perlcrypt.patch, xchat-1.8.9-korean-fontset.patch
360
361* Wed May 21 2003 Mike A. Harris <mharris@redhat.com> 2.0.2-5
362- Removed xchat.desktop file, as it was earlier replacedwith a patch
363- Converted xchat-2.0.2-redhat-desktop-file.patch to be UTF-8 clean now,
364  instead of the various random legacy mix of encodings it was, updating
365  the following: es, ko, uk, zh_TW
366
367* Tue May 20 2003 Mike A. Harris <mharris@redhat.com> 2.0.2-4
368- Replace explicit perl package name-epoch-version Requires added in 2.0.2-3
369  with a more robust and generic solution of querying perl for the archlibexp
370  dir during building, and requiring it instead
371
372* Tue May 20 2003 Bill Nottingham <notting@redhat.com> 2.0.2-3
373- rebuild against new (old?) perl, add epoch to dependency
374
375* Sat May 17 2003 Mike A. Harris <mharris@redhat.com> 2.0.2-1
376- Updated to new xchat 2.0.2 based on GTK2
377- Dropped unneeded patches xchat-1.8.1-konqueror.patch,
378  xchat-1.8.4-fix-USE_GNOME.patch
379- Updated xchat-2.0.2-freenode.patch to refer to Openprojects.net
380- Removed doc/xchat.sgml doc/*.html scripts-python scripts-perl from %%doc
381- Added xchat-2.0.2-redhat-desktop-file.patch to patch the supplied xchat
382  desktop file, instead of replacing it and trying to stay in sync
383- Added xchat-2.0.2-lib64-cleanup-for-python.patch which fixes build problems
384  on lib64 archs, and replaces xchat-multilib.patch
385- Added with_tclplugin macro and default it to disabled
386
387* Mon Mar 17 2003 Mike A. Harris <mharris@redhat.com> 1.8.11-8
388- Added xchat-1.8.11-nickall.patch which was written by Fabio Olive Leite,
389  sent to me by Rik van Riel
390
391* Wed Feb 19 2003 Bill Nottingham <notting@redhat.com> 1.8.11-7
392- ship single desktop in %{_datadir}/applications, not /etc/X11/applnk
393
394* Fri Jan 31 2003 Mike A. Harris <mharris@redhat.com> 1.8.11-6
395- Added xchat-1.8.11-freenode.patch to rename all openprojects.net entries
396  to freenode.net in the default server list.  Patch courtesy of Dan Burcaw
397  from bug (#81704)
398
399* Wed Jan 22 2003 Mike A. Harris <mharris@redhat.com> 1.8.11-5
400- Removed double .desktop file (#81874,82315)
401
402* Wed Jan 22 2003 Tim Powers <timp@redhat.com> 1.8.11-4
403- rebuilt
404
405* Tue Jan  7 2003 Mike A. Harris <mharris@redhat.com> 1.8.11-3
406- Add bugfix from xchat.org xc1811fixststint.diff
407
408* Tue Jan  7 2003 Mike A. Harris <mharris@redhat.com> 1.8.11-2
409- Remove CVS files from source dirs so they're not installed into doc dirs.
410
411* Tue Jan  7 2003 Mike A. Harris <mharris@redhat.com> 1.8.11-1
412- Update to xchat 1.8.11 bugfix release, fixes various runtime crashes
413- Remove now included patches: xchat-1.8.10-urlhandler-open-in-new-tab.patch,
414  xchat-1.8.10-beep-beep-beep.patch
415
416* Tue Jan  7 2003 Nalin Dahyabhai <nalin@redhat.com> 1.8.10-13
417- Pick up OpenSSL configuration from pkgconfig, if available
418- Add openssl-devel and pkgconfig as buildreqs
419
420* Wed Dec 11 2002 Elliot Lee <sopwith@redhat.com> 1.8.10-12
421- Fix broken libpython path on multilibbed systems (patch13)
422- _smp_mflags
423
424* Tue Nov 26 2002 Mike A. Harris <mharris@redhat.com> 1.8.10-11
425- Added xchat-1.8.10-urlhandler-open-in-new-tab.patch to offer the option of
426  opening a URL in a new tab of an existing browser window rather than a new
427  window
428
429* Sat Nov 23 2002 Mike A. Harris <mharris@redhat.com> 1.8.10-10
430- Added BuildRequires: python-devel to hopefully pick up a missing dep
431  causing package build failure in timp's nightly builds.
432- Removed dead patches
433- Updated package summary and description to be more user friendly by
434  rewording, and removing scary words like GNOME, GTK and other irrelevance
435
436* Wed Nov 13 2002 Mike A. Harris <mharris@redhat.com> 1.8.10-9
437- Made sure {_sysconfdir}/X11/applnk/Internet/xchat.desktop gets packaged
438- Removed some conditional weirdness in %%files list.  This may break xchat
439  erratum releases on Red Hat Linux 7.x.  May need to be fixed in future.
440
441* Fri Aug 23 2002 Mike A. Harris <mharris@redhat.com> 1.8.10-7
442- Added Requires line so that xchat requires the exact version of perl
443  be installed, that was used to compile it, since the embedded perl
444  interpreter will break, if you upgrade perl
445
446* Thu Aug 15 2002 Mike A. Harris <mharris@redhat.com> 1.8.10-6
447- Fix Bill's beep beep beep bug (#71651)
448
449* Wed Aug 14 2002 Jonathan Blandford <jrb@redhat.com> 1.8.10-5
450- actually install the desktop file.
451
452* Fri Aug  9 2002 Mike A. Harris <mharris@redhat.com> 1.8.10-3
453- Added http://xchat.org/files/source/1.8/patches/xc1810fixme.diff to fix
454  bug with using /ME in a /QUERY window.  (#71179)
455
456* Wed Aug  7 2002 Mike A. Harris <mharris@redhat.com> 1.8.10-2
457- Updated to xchat 1.8.10 to fix a few bugs where a remote ircd could cause
458  the xchat client to crash.  This is a bugfix only release.
459
460* Tue Aug  6 2002 Mike A. Harris <mharris@redhat.com> 1.8.9-10
461- Added Korean fontset support to fix bug (#69771)
462
463* Mon Aug  5 2002 Mike A. Harris <mharris@redhat.com> 1.8.9-9
464- Enabled python scripting which was somehow disabled somewhere along the
465  line by default in upstream sources, and we missed catching it. (#70816)
466
467* Sun Aug  4 2002 Mike A. Harris <mharris@redhat.com> 1.8.9-8
468- Created new-style net-xchat.desktop file (#69541)
469
470* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 1.8.9-7
471- automated rebuild
472
473* Tue Jun 18 2002 Mike A. Harris <mharris@redhat.com> 1.8.9-6
474- updated the package description
475- Added CFLAGS and LDFLAGS export vars before configure to fix rpath problem
476
477* Sun May 26 2002 Tim Powers <timp@redhat.com>
478- automated rebuild
479
480* Mon May 20 2002 Mike A. Harris <mharris@redhat.com> 1.8.9-2
481- Updated to xchat 1.8.9
482
483* Mon Apr  8 2002 Mike A. Harris <mharris@redhat.com> 1.8.8-5
484- Re-enabled GNOME support due to user complaints of pixmaps missing, key
485  bindings, and other fairly important features no longer working.
486
487* Wed Mar 27 2002 Mike A. Harris <mharris@redhat.com> 1.8.8-4
488- Disabled GNOME support since it doesn't seem too useful anyways, and forces
489  all xchat users to install GNOME libs even if they use KDE. (#59626)
490- Updated URL and source lines in spec.
491
492* Wed Mar  6 2002 Mike A. Harris <mharris@redhat.com> 1.8.8-1
493- Updated to xchat 1.8.8
494
495* Tue Feb 26 2002 Mike A. Harris <mharris@redhat.com> 1.8.7-6
496- Built in new buildroot
497
498* Tue Feb  5 2002 Mike A. Harris <mharris@redhat.com> 1.8.7-5
499- Added xchat-1.8.7-use-sysconf-to-detect-cpus.patch to use glibc's sysconf()
500  to detect the number of processors available.
501
502* Mon Feb  4 2002 Mike A. Harris <mharris@redhat.com> 1.8.7-4
503- Enabled IPv6 support as per the request for enhancement (#52124)
504
505* Thu Jan 24 2002 Mike A. Harris <mharris@redhat.com> 1.8.7-3
506- Rebuilt in new build environment
507
508* Thu Jan 10 2002 Mike A. Harris <mharris@redhat.com> 1.8.7-2
509- Updated to xchat 1.8.7
510- New release fixes security vulnerability in CTCP reply
511- Built erratum for all supported releases (1.8.7-1.62.0, 1.8.7-1.70.0,
512  1.8.7-1.71.0, 1.8.7-1.72.0)
513- Removed konqueror patch as it is integrated now.
514
515* Sat Jan  5 2002 Mike A. Harris <mharris@redhat.com> 1.8.6-2
516- Enabled ssl support with --enable-openssl
517- Also built releases 1.72.0, 1.71.0, 1.70.0, 1.62.0 for erratum release
518
519* Mon Dec 10 2001 Mike A. Harris <mharris@redhat.com> 1.8.6-1
520- Updated to xchat 1.8.6
521
522* Tue Nov 13 2001 Mike A. Harris <mharris@redhat.com> 1.8.5-1
523- Updated to xchat 1.8.5
524- Added f to rm -r in install and clean sections
525
526* Sun Oct  7 2001 Mike A. Harris <mharris@redhat.com> 1.8.4-1
527- Updated to 1.8.4, now using tar.bz2
528- Removed kanjiconv-fix patch as it is integrated now
529- Added xchat-1.8.4-fix-USE_GNOME.patch to fix simple ifdef USE_GNOME typo
530
531* Fri Jul 13 2001 Akira TAGOH <tagoh@redhat.com> 1.8.1-2
532- fixed check locale.
533- don't save kanji_conv.
534  always check locale. however anyone can change the option from
535  the settings menu.
536
537* Thu Jul 12 2001 Havoc Pennington <hp@redhat.com>
538- upgrade to 1.8.1
539- remove autoconnect patch since it's upstream
540- remove japanese patch, upstream seems to have applied
541  parts of it and changelog says there's upstream support.
542  (this patch was pretty huge to maintain in an SRPM anyway...)
543- put scripts-python scripts-perl in docs bug #28521
544- remove patch to include locale.h, gone upstream
545- upgrade konqueror patch
546
547* Thu Jul 12 2001 Havoc Pennington <hp@redhat.com>
548- nevermind, BuildRequires gnome-libs, that should
549  close #48923
550
551* Thu Jul 12 2001 Havoc Pennington <hp@redhat.com>
552- fix file list to not include absolute path "/usr/share/..."
553  no idea how that ever worked at all. closes #48923
554
555* Mon Jun 25 2001 Karsten Hopp <karsten@redhat.de>
556- use konqueror, not kfmclient on URLs
557
558* Fri Feb 23 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
559- langify
560- use %%{_tmppath}
561- make it compile
562
563* Tue Feb 13 2001 Akira TAGOH <tagoh@redhat.com>
564- Added Japanese patch.
565
566* Tue Feb 13 2001 Havoc Pennington <hp@redhat.com>
567- patch that may fix autoconnections (bug 27093)
568
569* Mon Jan 22 2001 Havoc Pennington <hp@redhat.com>
570- 1.6.3
571- remove patch to desktop file (Internet->Application), seems to
572  have gone upstream
573
574* Sat Dec 9 2000 Havoc Pennington <hp@redhat.com>
575- Remove security fix which has been merged upstream
576- upgrade to 1.6.1
577
578* Sat Aug 19 2000 Havoc Pennington <hp@redhat.com>
579- Don't use /bin/sh to interpret URLs from the net
580
581* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
582- Updated Epoch
583
584* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
585- automatic rebuild
586
587* Mon Jun 19 2000 Havoc Pennington <hp@redhat.com>
588- Install HTML docs
589
590* Fri Jun 16 2000 Preston Brown <pbrown@redhat.com>
591- fix desktop entry
592
593* Fri May 19 2000 Havoc Pennington <hp@redhat.com>
594- rebuild for the Winston tree, update to 1.4.2
Note: See TracBrowser for help on using the repository browser.