source: projects/specs/trunk/x/xcb-util/xcb-util-vl.spec @ 8064

Revision 8064, 5.2 KB checked in by Takemikaduchi, 10 years ago (diff)

freetype2: fix pkgconfig
xserver: update to 1.14.5
others: new upstream release or rebuild

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name:           xcb-util
4Version:        0.3.9
5Release:        2%{?_dist_release}
6Summary:        Convenience libraries sitting on top of libxcb
7
8Group:          System Environment/Libraries
9License:        MIT
10URL:            http://xcb.freedesktop.org
11Source0:        http://xcb.freedesktop.org/dist/%{name}-%{version}.tar.bz2
12BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
13BuildRequires:  gperf, pkgconfig, libxcb-devel >= 1.4, m4, xorg-x11-proto-devel
14BuildRequires:  xorg-x11-util-macros
15BuildRequires:  chrpath
16
17Vendor: Project Vine
18Distribution: Vine Linux
19Packager: Takemikaduchi
20
21%description
22The xcb-util module provides a number of libraries which sit on top of
23libxcb, the core X protocol library, and some of the extension
24libraries. These experimental libraries provide convenience functions
25and interfaces which make the raw X protocol more usable. Some of the
26libraries also provide client-side code which is not strictly part of
27the X protocol but which have traditionally been provided by Xlib.
28
29
30%package        devel
31Summary:        Development and header files for xcb-util
32Group:          System Environment/Libraries
33Requires:       %{name} = %{version}-%{release}, pkgconfig
34
35%description    devel
36Development files for xcb-util.
37
38
39# compat32
40%package -n compat32-%{name}
41Summary: Convenience libraries sitting on top of libxcb
42Group: System Environment/Libraries
43Requires: %{name} = %{version}-%{release}
44
45%description -n compat32-%{name}
46The xcb-util module provides a number of libraries which sit on top of
47libxcb, the core X protocol library, and some of the extension
48libraries. These experimental libraries provide convenience functions
49and interfaces which make the raw X protocol more usable. Some of the
50libraries also provide client-side code which is not strictly part of
51the X protocol but which have traditionally been provided by Xlib.
52
53
54%package -n compat32-%{name}-devel
55Summary:        Development and header files for xcb-util
56Group:          System Environment/Libraries
57Requires:       %{name}-devel = %{version}-%{release}
58
59%description -n compat32-%{name}-devel
60Development files for xcb-util.
61
62
63%prep
64%setup -q
65
66
67%build
68%configure --with-pic --disable-static
69
70make %{?_smp_mflags}
71
72
73%check
74
75make check
76
77
78%install
79rm -rf %{buildroot}
80
81make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
82
83# remove RPATH
84chrpath --delete $RPM_BUILD_ROOT%{_prefix}/%{_lib}/libxcb-*.so.*
85
86rm %{buildroot}%{_libdir}/*.la
87
88
89%post -p /sbin/ldconfig
90
91
92%postun -p /sbin/ldconfig
93
94
95%post -n compat32-%{name} -p /sbin/ldconfig
96%postun -n compat32-%{name} -p /sbin/ldconfig
97
98
99%clean
100rm -rf %{buildroot}
101
102
103%files
104%defattr(-,root,root,-)
105%doc README
106%{_libdir}/libxcb-util.so.*
107
108%files devel
109%defattr(-,root,root,-)
110%{_libdir}/pkgconfig/*.pc
111%{_libdir}/libxcb-util.so
112%{_includedir}/xcb/*.h
113
114# compat32
115%if %{build_compat32}
116%files -n compat32-%{name}
117%defattr(-,root,root,-)
118%{_libdir}/libxcb-util.so.*
119
120%files -n compat32-%{name}-devel
121%defattr(-,root,root,-)
122%{_libdir}/libxcb-util.so
123%endif
124
125
126%changelog
127* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.9-2
128- rebuild with VineSeed environment
129
130* Wed Jun 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.9-1
131- new upstream release
132
133* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.8-1
134- new upstream release
135- add BuildRequires: xorg-x11-util-macros
136
137* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.6-2
138- rebuild with rpm-4.8.1 for pkg-config file
139
140* Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp>  0.3.6-1
141- initial build for Vine Linux
142
143* Fri Aug 28 2009 Michal Nowak <mnowak@redhat.com> - 0.3.6-1
144- 0.3.6
145
146* Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.5-2
147- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
148
149* Mon Jul 13 2009 Adam Jackson <ajax@redhat.com> 0.3.5-1
150- xcb-util 0.3.5
151
152* Mon Jul 06 2009 Adam Jackson <ajax@redhat.com> 0.3.4-2
153- Explicitly list DSOs so we're notified of version changes.
154
155* Sat Jun 13 2009 Michal Nowak <mnowak@redhat.com> - 0.3.4-1
156- 0.3.4; needed for Awesome 3.3
157
158* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.3-2
159- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
160
161* Fri Feb 20 2009 Michal Nowak <mnowak@redhat.com> - 0.3.3-1
162- 0.3.3
163- removed patches already in git (and 0.3.3)
164
165* Fri Dec 19 2008 Michal Nowak <mnowak@redhat.com> - 0.3.2-2
166- hack the sed lines after %%configure out and hack chrpath in
167- make check is running again
168
169* Thu Dec 18 2008 Michal Nowak <mnowak@redhat.com> - 0.3.2-1
170- 0.3.2
171- remove rpath (x86-64)
172- xcb_keysyms: remove xcb_lookup_t
173- Revert "keysyms: use xcb_key_lookup_t type for col paramter"
174- temporary disabled %%check due to RPATH regression
175
176* Thu Dec  4 2008 Michal Nowak <mnowak@redhat.com> - 0.3.1-2
177- patch for exit() in aux library (Peter Harris)
178- slight changes in spec file
179
180* Mon Nov 24 2008 Michal Nowak <mnowak@redhat.com> - 0.3.1-1
181- 0.3.1
182- fix license issue (Jonathan Landis)
183
184* Fri Sep 19 2008 Michal Nowak <mnowak@redhat.com> - 0.3.0-1
185- bump to 0.3.0
186
187* Sun Aug 17 2008 Michal Nowak <mnowak@redhat.com> - 0.2.1-2
188- new build deps: gperf, pkgconfig, libxcb, m4, xorg-x11-proto-devel
189- not installing *.a files anymore
190- configure with --with-pic
191
192* Mon Aug 04 2008 Michal Nowak <mnowak@redhat.com> - 0.2.1-1
193- initial package
194
Note: See TracBrowser for help on using the repository browser.