source: projects/specs/trunk/x/xawtv/xawtv-vl.spec @ 521

Revision 521, 9.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# How to build xawtv-fonts
2# rpm -bb --target noarch  xawtv.spec
3#
4Name: xawtv
5Summary: A TV application for video4linux compliant devices.
6Summary(ja): video4linux ¸ß´¹¥Ç¥Ð¥¤¥¹ÍѤΠTV ¥¢¥×¥ê¥±¡¼¥·¥ç¥ó
7Version: 3.95
8Release: 0vl1
9%define fontsver 1.1
10%define fontsrel 0vl1
11%define withalsa $([ -f /usr/include/linux/asound.h ] && echo enable || echo disable)
12%define alsa %([ "%{withalsa}" = "enable" ] && echo 1 || echo 0)
13%define applnkdir %([ -d %{_datadir}/applications ] && echo %{_datadir}/applications || echo /etc/X11/applnk/Multimedia )
14# for RedHat-6.x/Vine-2.x
15%define _sysconfdir /etc
16%define fontsdir /usr/X11R6/lib/X11/fonts/misc
17%define pixmapsdir %{_datadir}/pixmaps
18
19Source: http://bytesex.org/xawtv/%{name}-%{version}.tar.gz
20Source1: http://bytesex.org/xawtv/tv-fonts-%{fontsver}.tar.bz2
21Source2: v4l-conf.pam
22Source10: xawtvrc.JP
23Source11: bttv-tuneUp.sh
24#Patch: http://telia.dl.sourceforge.net/sourceforge/xaw-deinterlace/xaw-deinterlace-%{subver}.diff.bz2
25Group: Applications/Multimedia
26License: GPL
27URL: http://bytesex.org/xawtv/
28BuildPrereq: XFree86-devel, ncurses-devel libjpeg-devel
29BuildPrereq: make >= 3.80
30BuildPrereq: openMotif-devel >= 2.2.2
31PreReq: XFree86 , XFree86-xfs
32Requires: usermode
33Requires: %{name}-fonts
34
35%if %alsa
36Requires: alsa-driver
37%endif
38BuildRoot: %{_tmppath}/%{name}-root
39Excludearch: sparc s390 s390x
40%{?nosrc:NoSource:     0}
41%{?nosrc:NoSource:     1}
42
43Vendor: Project Vine
44Distribution: Vine Linux
45
46%description
47Xawtv is a simple xaw-based TV program which uses the bttv driver or
48video4linux. Xawtv contains various command-line utilities for
49grabbing images and .avi movies, for tuning in to TV stations, etc.
50Xawtv also includes a grabber driver for vic.
51
52%package motv
53Summary: Motif TV application
54Summary(ja): MOTIF ÈǤΠTV ¥¢¥×¥ê¥±¡¼¥·¥ç¥ó
55Requires: openMotif >= 2.2.2
56Requires: xawtv = %{version}-%{release}
57Group: Applications/Multimedia
58
59%description motv
60motv is a TV application which is build on Motif library.
61
62%package fonts
63Summary: Fonts for Xawtv
64Summary(ja): Xawtv ÍÑ¥Õ¥©¥ó¥È
65Group: Applications/Multimedia
66Version: %{fontsver}
67Release: %{fontsrel}
68PreReq: /usr/X11R6/bin/xset
69
70%description fonts
71Fonts collection for Xawtv
72
73
74%prep
75%setup -q -a 1
76#patch -p1
77%__cp %{SOURCE10} ./
78%__cp %{SOURCE11} ./tuneUp.sh
79
80%build
81
82%ifarch noarch
83
84# make fonts
85cd tv-fonts-%{fontsver}
86PATH=$PATH:/usr/X11R6/bin ; export PATH
87DISPLAY=   make
88
89%else
90
91PATH=$PATH:/usr/X11R6/bin ; export PATH
92#configure --%{withalsa}-alsa --enable-motif --enable-xfree-ext --enable-xvideo --enable-xft
93%configure --enable-motif --enable-xfree-ext --enable-xvideo --enable-xft
94%__make
95
96%endif
97
98%install
99
100%ifarch noarch
101
102# install fonts
103%__mkdir -p %{buildroot}%{fontsdir}
104%__install tv-fonts-%{fontsver}/*.gz  %{buildroot}%{fontsdir}
105
106%else
107
108%__rm -rf %{buildroot}
109#PATH=$PATH:/usr/X11R6/bin ; export PATH
110#makeinstall DESTDIR="%{buildroot}" SUID_ROOT="" install
111make DESTDIR="%{buildroot}" SUID_ROOT="" install
112
113%__install -d %{buildroot}%{_sbindir} \
114         %{buildroot}%{_libdir}/%{name} \
115         %{buildroot}%{_sysconfdir}/pam.d \
116         %{buildroot}%{_sysconfdir}/security/console.apps \
117         %{buildroot}%{pixmapsdir}
118 
119%__install -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/pam.d/v4l-conf
120echo "SESSION=true" > %{buildroot}%{_sysconfdir}/security/console.apps/v4l-conf
121echo "USER=root"   >> %{buildroot}%{_sysconfdir}/security/console.apps/v4l-conf
122echo "PROGRAM=%{_sbindir}/v4l-conf" >> %{buildroot}%{_sysconfdir}/security/console.apps/v4l-conf
123%__mv %{buildroot}%{_bindir}/v4l-conf %{buildroot}%{_sbindir}/
124ln -s consolehelper %{buildroot}%{_bindir}/v4l-conf
125%__install -d %{buildroot}%{_bindir}/X11
126ln -s %{_bindir}/xawtv %{buildroot}%{_bindir}/X11/xawtv
127%__install contrib/xawtv32x32.xpm %{buildroot}%{pixmapsdir}/%{name}.xpm
128#__mv %{buildroot}%{_libdir}/*.so %{buildroot}%{_libdir}/%{name}
129%__install -d %{buildroot}/etc/X11
130%__install xawtvrc.JP %{buildroot}/etc/X11/xawtvrc
131
132# prepare applnk
133%__install -d %{buildroot}%{applnkdir}
134cat > $RPM_BUILD_ROOT%{applnkdir}/%{name}.desktop <<EOF
135[Desktop Entry]
136Name=TV
137Comment=television
138Exec=xawtv
139Icon=%{pixmapsdir}/%{name}.xpm
140Terminal=false
141MultipleArgs=false
142Type=Application
143Categories=GNOME;Application;AudioVideo;Video
144EOF
145
146%endif
147
148%post
149%{_sbindir}/v4l-conf -q || :
150
151%post fonts
152{
153  cd %{fontsdir}
154  mkfontdir > /dev/null 2>&1
155  cd -
156}
157if [ ".$DISPLAY" != "." ]; then
158  xset fp rehash > /dev/null 2>&1
159  true
160fi
161
162%postun fonts
163if [ $1 = 0 ]; then
164  {
165    cd  %{fontsdir}
166    /usr/X11R6/bin/mkfontdir > /dev/null 2>&1
167    cd -
168  }
169  if [ ".$DISPLAY" != "." ]; then
170    /usr/X11R6/bin/xset fp rehash > /dev/null 2>&1
171    true
172  fi
173fi
174
175%clean
176rm -fr $RPM_BUILD_ROOT
177
178
179%ifarch noarch
180
181%files fonts
182%defattr(-,root,root)
183%{fontsdir}
184
185%else
186
187%files
188%defattr(-,root,root)
189%config /usr/X11R6/lib/X11/app-defaults/Xawtv
190%config(noreplace) %{_sysconfdir}/pam.d/v4l-conf
191%config(noreplace) %{_sysconfdir}/security/console.apps/v4l-conf
192%{_bindir}/[^Xm]*
193%attr(0711,root,root) %{_sbindir}/v4l-conf
194%{_bindir}/X11/xawtv
195/usr/X11R6/lib/X11/app-defaults/mtt
196%{_libdir}/%{name}
197%{_datadir}/%{name}
198%{_mandir}/man?/[^m]*
199%{_mandir}/*/man?/[^m]*
200%{_mandir}/man1/mtt.1*
201%config(missingok) %{applnkdir}/*
202%config(noreplace) /etc/X11/xawtvrc
203%doc COPYING README* TODO Changes MAKEDEV.v4l
204%doc contrib
205%doc xawtvrc* tuneUp.sh
206%{pixmapsdir}/*
207
208%files motv
209%defattr(-,root,root)
210%{_bindir}/motv
211/usr/X11R6/lib/X11/app-defaults/MoTV
212/usr/X11R6/lib/X11/*/app-defaults/MoTV
213
214%{_mandir}/man1/motv.1*
215
216%endif
217
218
219%changelog
220* Wed Nov 22 2006 Masaki Shinomiya <shino@pos.to> 3.95-0vl1
221- new upstream release, desktop launcher, buildprereq libjpeg-devel
222- files (motv was both in xawtv and in xawtv-motv package before)
223
224* Wed Aug 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.93-0vl1
225- new upstream release
226
227* Thu Apr 15 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.91-0vl2
228- rebuild with libdv-0.102
229
230* Sun Feb 15 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.91-0vl1
231- new upstream release
232- add motv subpackage, requires openMotif
233- build with openMotif for motv
234
235* Thu Dec 18 2003 Masaki Shinomiya <shino@pos.to> -3.90-0vl1
236- source update, xawtv-fonts, remove deinterlace.patch
237- 'rpm -bb --target noarch xawtv.spec'
238- will make xawtv-fonts package.
239- buildrequire make version 3.80 or later
240- use %%{buildroot} and some rewrite
241
242* Fri Dec 12 2003 Masaki Shinomiya <shino@pos.to> -3.74-0vl3
243- some mannual pages missing even in 0vl2, alsa detecting
244
245* Wed Dec 10 2003 Masaki Shinomiya <shino@pos.to> -3.74-0vl2
246- xawtvrc, tuneUp.sh,  MAKEDEV.v4l in doc
247- some mannual pages used to be missing
248- v4l-conf in post install script
249- bugfix in rebuild with alsa
250
251* Sun Jan 19 2003 Masaki Shinomiya <shino@pos.to>
252-3.74-0vl1: update source, doc, deinterlace patch, Japan.xawtv, URL
253- auto detect alsa 0.5x/0.9x, prereq
254
255* Fri Apr 5 2002 Masaki Shinomiya <shino@pos.to>
256- 3.73-0vl1: for Vine Linux-2.5
257* Sun Mar 31 2002 <shino@pos.to>
258- 3.73-0: install libraries in %{_libdir}/xawtv
259
260* Sat Mar 23 2002 <shino@pos.to>
261- 3.60-0.1: make symlink, .destop, correct file list
262
263* Fri Aug 17 2001 <sagami@vinelinux.org>
264- 3.60-0vl1: initial release for VineSeedPlus
265
266* Sun Aug  5 2001 Nalin Dahyabhai <nalin@redhat.com> 3.54-3
267- tweak PAM setup so that v4l-conf can access the display properly
268
269* Tue Jul 10 2001 Elliot Lee <sopwith@redhat.com> 3.54-2
270- Rebuild to remove libXv/libXxf86dga deps
271
272* Mon Jul 02 2001 Than Ngo <than@redhat.com>
273- update to 3.54
274
275* Fri Jun 22 2001 Than Ngo <than@redhat.com>
276- update to 3.53
277- add buildprereq
278- remove some uneeeded patches
279
280* Tue Jun 19 2001 Karsten Hopp <karsten@redhat.de>
281- excludearch s390 s390x
282
283* Wed Jun 13 2001 Than Ngo <than@redhat.com>
284- update to 3.51
285
286* Thu Jun 07 2001 Than Ngo <than@redhat.com>
287- update to 3.50
288
289* Thu May 31 2001 Than Ngo <than@redhat.com>
290- udate to 3.49
291
292* Tue May 22 2001 Than Ngo <than@redhat.com>
293- update to 3.48
294
295* Mon May 21 2001 Tim Powers <timp@redhat.com>
296- built for the distro
297
298* Wed May 18 2001 Karsten Hopp <karsten@redhat.de>
299- make xawtv work with kernel-2.4
300
301* Wed May 16 2001 Than Ngo <than@redhat.com>
302- update to 3.47
303
304* Mon May 07 2001 Than Ngo <than@redhat.com>
305- update to 3.45
306- add missing fonts
307
308* Tue Feb 13 2001 Than Ngo <than@redhat.com>
309- update to 3.34
310- use consolehelper for v4l-conf
311- add excludearch sparc, bdftopcf is broken on sparc
312
313* Wed Jan 24 2001 Than Ngo <than@redhat.com>
314- updated to 3.30
315- use /dev/video0 instead /dev/video (bug #24871)
316- fixed dependencies (Bug #24881)
317 
318* Sun Nov 19 2000 Than Ngo <than@redhat.com>
319- update to 3.24
320- add missing tools (rootv,scantv)
321- add missing prereq on xset and mkfontdir
322
323* Fri Nov 3 2000 Than Ngo <than@redhat.com>
324- update to 3.23
325
326* Wed Aug 23 2000 Tim Powers <timp@redhat.com>
327- rebuilt against new XFree86 to fix DGA problems
328
329* Mon Aug 21 2000 Than Ngo <than@redhat.com>
330- update to 3.18 (Bugfix release)
331- option -nodga to disable DGA (Bug #16577, #15702)
332- compress fonts with gzip
333
334* Mon Aug 07 2000 Tim Powers <timp@redhat.com>
335- fixed bug #15435
336
337* Mon Aug 07 2000 Than Ngo <than@redhat.de>
338- rebuilt against the new DGA
339- fixed in post and postun, so that it does not
340  emits to console (Bug #15436)
341
342
343* Sat Jul 29 2000 Than Ngo <than@redhat.de>
344- update to 3.17
345
346* Mon Jul 24 2000 Prospector <prospector@redhat.com>
347- rebuilt
348
349* Wed Jul 12 2000 Than Ngo <than@redhat.de>
350- FHS fixes
351
352* Mon Jul 03 2000 Prospector <bugzilla@redhat.com>
353- automatic rebuild
354
355* Sun May 28 2000 Ngo Than <than@redhat.de>
356- update to 3.14 for 7.0
357- put man page in correct place
358- add webcam
359- bzip2 source
360- cleanup specfile
361
362* Wed Jan 19 2000 Preston Brown <pbrown@redhat.com>
363- font fix (#8610) in post and postun
364- add missing files in bin
365
366* Sun Jan 16 2000 Preston Brown <pbrown@redhat.com>
367- whoops! 3.07 already bugfix release
368
369* Fri Jan 14 2000 Ngo Than <than@redhat.de>
370- updated to 3.06
371
372* Mon Jul 26 1999 Tim Powers <timp@redhat.com>
373- updated to 2.46
374- built for 6.1
375
376* Wed Apr 28 1999 Preston Brown <pbrown@redhat.com>
377- initial build for Powertools 6.0
Note: See TracBrowser for help on using the repository browser.