source: projects/specs/trunk/x/xanim/xanim-vl.spec @ 521

Revision 521, 4.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# if you want to make xanim_plus version,
2# uncomment below line, or rpm --with plus
3# % define plus 1
4%define plus 0
5%{?_with_plus:%define plus      1}
6
7%if %{plus}
8%define name xanim_plus
9%else
10%define name xanim
11%endif
12
13Summary: An X based viewer for many animation/video/audio file formats.
14Summary(ja): アニメーション/ビデオ/オーディオ・ビューア
15Name: %{name}
16Version: 2.80.1
17Release: 4%{?_dist_release}
18#Serial: 2
19License: MIT
20Group: Applications/Multimedia
21Url: http://xanim.va.pubnix.com/
22Source: ftp://xanim.va.pubnix.com/xanim2801.tar.gz
23%if %{plus}
24Source1: ftp://xanim.va.pubnix.com/modules/xa2.0_cvid_linuxELFg21.o.gz
25Source2: ftp://xanim.va.pubnix.com/modules/xa2.1_iv32_linuxELFg21.o.gz
26Source3: ftp://xanim.va.pubnix.com/modules/xa1.0_cyuv_linuxELFg21.o.gz
27%endif
28Patch0: xanim-libpath.patch
29Patch1: http://radar.sci.hokudai.ac.jp/~kato/computer/Util/xanim/xanim_wheelmouse.diff
30Patch2: xanim.Imakefile.mod.patch
31
32#BuildRequires: XOrg-devel zlib-devel
33BuildRequires: xorg-x11-devel zlib-devel
34
35Vendor: Project Vine
36Distribution: Vine Linux
37
38BuildRoot: %{_tmppath}/%{name}-%{version}-root
39
40%if %{plus}
41Provides: xanim
42Obsoletes: xanim
43%endif
44
45%description
46The XAnim program is an animation/video/audio viewer for the X Window
47System.  XAnim can display a large variety of animation, audio and
48video formats.
49
50Install the xanim package if you need a viewer for an animation, video
51or audio file.
52
53%description -l ja
54XAnim は,Xウィンドウシステム上で動作する,アニメーション/ビデオ/オーデ
55ィオ・ビューアです.XAnim はさまざまなアニメーション/ビデオ/オーディオの
56フォーマットに対応しています.
57
58一部著作権の問題で配布ソースに含まれていないデコーダ(Radius Cinepak,
59Intel Indeo 3.2,Creative Technology's CYUV)があります.これも,xanim
60の web ページから取得し,make し直すこと によって対応することができま
61す.(specファイルを参照してください.)
62
63#'
64%prep
65%setup -q -n xanim2801
66%patch0 -p1 -b .orig
67%patch1 -p0 -b .wheel
68#mv *.readme docs || :
69
70%if %{plus}
71mkdir -p mods
72cp %SOURCE1 %SOURCE2 %SOURCE3 mods
73gunzip mods/*
74%patch2 -p0
75%endif
76
77%build
78xmkmf
79#make xanim INCDIR=/usr/X11R6/include/X11
80make xanim INCDIR=/usr/include/X11
81
82%install
83rm -rf $RPM_BUILD_ROOT
84
85make DESTDIR=$RPM_BUILD_ROOT install
86cp -pr docs/xanim.man .
87#make DESTDIR=$RPM_BUILD_ROOT install.man
88make DESTDIR=$RPM_BUILD_ROOT MANPATH=%{_mandir} install.man
89mkdir -p $RPM_BUILD_ROOT%{_libdir}/xanim
90%if %{plus}
91for codec in *.xa; do
92  install -m755 $codec $RPM_BUILD_ROOT%{_libdir}/xanim || :
93done
94%endif
95
96%clean
97rm -rf $RPM_BUILD_ROOT
98
99%files
100%defattr(-,root,root)
101%doc docs/*
102#/usr/X11R6/bin/xanim
103#/usr/X11R6/man/man1/xanim.1x*
104%{_bindir}/xanim
105%{_mandir}/man1/xanim.1x*
106%dir %{_libdir}/xanim
107%if %{plus}
108%{_libdir}/xanim/*
109%endif
110
111%changelog
112* Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 2.80.1-4vl5
113- applied new versioning policy, spec in utf-8
114- changed path of x11
115- added value of MANPATH in make-install
116
117* Fri Jun 17 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.80.1-3vl15
118- rebuild with new toolchains
119- s/Copyright/License/
120
121* Fri Apr 20 2001 Jun Nishii <jun@vinelinux.org>
122- 2.80.1-3vl14
123- added macro:plus
124
125* Thu Jul 13 2000 Masato Bito <masato@nets.ce.hiroshima-cu.ac.jp>
126- 2.80.1-3vl13
127- modified %patch1 -p1 -> %patch1 -p0
128- fix %prep section
129- modified %files section to handle compressed man pages
130- modified BuildRoot:
131
132* Thu Dec  2 1999 Jun NISHII <jun@flatout.org>
133- fix defattr
134
135* Thu Nov 18 1999 Jun NISHII <jun@flatout.org>
136- added Japanese summary and description
137- added wheel mouse patch
138
139* Tue Jun 22 1999 Matt Wilson <msw@redhat.com>
140- removed proprietary codecs
141
142* Fri May 14 1999 Bill Nottingham <notting@redhat.com>
143- add alpha codecs.
144
145* Mon May 10 1999 Bill Nottingham <notting@redhat.com>
146- update to 2.80.1
147
148* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
149- auto rebuild in the new build environment (release 4)
150
151* Mon Mar 15 1999 Michael Maher <mike@redhat.com>
152- built new codecs for glibc2.1
153
154* Thu Nov 05 1998 Michael Maher <mike@redhat.com>
155- added binary codecs to read other formats.
156
157* Wed Sep 02 1998 Michael Maher <mike@redhat.com>
158- updated package
159
160* Fri Aug  7 1998 Jeff Johnson <jbj@redhat.com>
161- build root
162
163* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
164- translations modified for de, fr, tr
165
166* Fri Aug 22 1997 Erik Troan <ewt@redhat.com>
167- built against glibc
Note: See TracBrowser for help on using the repository browser.