source: projects/specs/trunk/x/xalan-j2/xalan-j2-vl.spec @ 1737

Revision 1737, 16.8 KB checked in by inagaki, 14 years ago (diff)

NEW: junit, jline, rhino, xalan-j2

Line 
1# Copyright (c) 2000-2005, JPackage Project
2# All rights reserved.
3#
4# Redistribution and use in source and binary forms, with or without
5# modification, are permitted provided that the following conditions
6# are met:
7#
8# 1. Redistributions of source code must retain the above copyright
9#    notice, this list of conditions and the following disclaimer.
10# 2. Redistributions in binary form must reproduce the above copyright
11#    notice, this list of conditions and the following disclaimer in the
12#    documentation and/or other materials provided with the
13#    distribution.
14# 3. Neither the name of the JPackage Project nor the names of its
15#    contributors may be used to endorse or promote products derived
16#    from this software without specific prior written permission.
17#
18# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
19# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
20# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
21# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
22# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
23# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
24# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
25# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
26# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
27# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
28# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
29#
30
31%define section free
32%define cvs_version 2_7_1
33
34Name:           xalan-j2
35Summary:        Java XSLT processor
36Summary(ja):    Java XSLT プロセッサ
37Version:        2.7.1
38Release:        2%{?_dist_release}
39
40Group:          Development/Libraries
41# samples/servlet/ApplyXSLTException.java is ASL 1.1
42# src/org/apache/xpath/domapi/XPathStylesheetDOM3Exception.java is W3C
43License:        ASL 1.1 and ASL 2.0 and W3C
44URL:            http://xalan.apache.org/
45
46# using binary for bootstrap
47#Source0:        http://www.apache.org/dist/xml/xalan-j/xalan-j_2_7_1-src.tar.gz
48Source0:        http://www.apache.org/dist/xml/xalan-j/xalan-j_2_7_1-bin-2jars.tar.gz
49#Source1:        %{name}-serializer-MANIFEST.MF
50#Patch0:         %{name}-noxsltcdeps.patch
51#Patch1:         %{name}-manifest.patch
52#Patch2:         %{name}-crosslink.patch
53#This patch uses xalan-j2-serializer.jar in the MANIFEST files instead of serializer
54#Patch3:                %{name}-src-MANIFEST-MF.patch
55
56BuildRoot:      %{_tmppath}/%{name}-%{version}-root
57
58BuildArch:      noarch
59Provides:       jaxp_transform_impl
60Requires:       jaxp_parser_impl
61Requires(post):  alternatives
62Requires(preun): alternatives
63#BuildRequires:  jpackage-utils >= 0:1.6
64#BuildRequires: java-devel
65#BuildRequires:  ant
66#BuildRequires:  bcel
67#BuildRequires: jlex
68#BuildRequires: java_cup
69#BuildRequires: regexp
70#BuildRequires: sed
71#BuildRequires: servlet25
72#BuildRequires:  xerces-j2 >= 0:2.7.1
73#BuildRequires:  xml-commons-apis >= 0:1.3
74#BuildRequires:  xml-stylebook
75
76%description
77Xalan is an XSLT processor for transforming XML documents into HTML,
78text, or other XML document types. It implements the W3C Recommendations
79for XSL Transformations (XSLT) and the XML Path Language (XPath). It can
80be used from the command line, in an applet or a servlet, or as a module
81in other program.
82
83#%package        xsltc
84#Summary:        XSLT compiler
85#Group:          Text Processing/Markup/XML
86#Requires:       java_cup
87#Requires:      bcel
88#Requires:      jlex
89#Requires:      regexp
90#Requires:      jaxp_parser_impl
91#
92#%description    xsltc
93#The XSLT Compiler is a Java-based tool for compiling XSLT stylesheets into
94#lightweight and portable Java byte codes called translets.
95
96%package        manual
97Summary:        Manual for %{name}
98Group:          Documentation
99
100%description    manual
101Documentation for %{name}.
102
103#%package        javadoc
104#Summary:        Javadoc for %{name}
105#Group:          Development/Documentation
106#BuildRequires:  java-javadoc
107## for /bin/rm and /bin/ln
108#Requires(post):                coreutils
109#Requires(postun):      coreutils
110#
111#%description    javadoc
112#Javadoc for %{name}.
113
114#%package        demo
115#Summary:        Demo for %{name}
116#Group:          Text Processing/Markup/XML
117#Requires:       %{name} = %{epoch}:%{version}-%{release}, servlet25
118#
119#%description    demo
120#Demonstrations and samples for %{name}.
121
122%prep
123%setup -q -n xalan-j_%{cvs_version}
124
125%build
126
127%install
128rm -rf $RPM_BUILD_ROOT
129
130# jars
131install -d -m 755 $RPM_BUILD_ROOT%{_javadir}
132install -p -m 644 xalan.jar \
133  $RPM_BUILD_ROOT%{_javadir}/%{name}-%{version}.jar
134install -p -m 644 xsltc.jar \
135  $RPM_BUILD_ROOT%{_javadir}/xsltc-%{version}.jar
136install -p -m 644 serializer.jar \
137  $RPM_BUILD_ROOT%{_javadir}/%{name}-serializer-%{version}.jar
138(cd $RPM_BUILD_ROOT%{_javadir} && for jar in *-%{version}.jar; do ln -sf ${jar} `echo $jar| sed "s|-%{version}||g"`; done)
139
140# javadoc
141#install -d -m 755 $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
142#cp -pr build/docs/apidocs/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
143#ln -s %{name}-%{version} $RPM_BUILD_ROOT%{_javadocdir}/%{name}
144#rm -rf build/docs/apidocs
145
146# demo
147#install -d -m 755 $RPM_BUILD_ROOT%{_datadir}/%{name}
148#install -p -m 644 build/xalansamples.jar \
149#  $RPM_BUILD_ROOT%{_datadir}/%{name}/%{name}-samples.jar
150#install -p -m 644 build/xalanservlet.war \
151#  $RPM_BUILD_ROOT%{_datadir}/%{name}/%{name}-servlet.war
152#cp -pr samples $RPM_BUILD_ROOT%{_datadir}/%{name}
153
154# fix link between manual and javadoc
155#(cd build/docs; ln -sf %{_javadocdir}/%{name}-%{version} apidocs)
156
157# jaxp_transform_impl ghost symlink
158ln -s %{_sysconfdir}/alternatives \
159  $RPM_BUILD_ROOT%{_javadir}/jaxp_transform_impl.jar
160
161
162%clean
163rm -rf $RPM_BUILD_ROOT
164
165
166%post
167/sbin/update-alternatives --install %{_javadir}/jaxp_transform_impl.jar \
168  jaxp_transform_impl %{_javadir}/%{name}.jar 30
169
170%preun
171{
172  [ $1 = 0 ] || exit 0
173  /sbin/update-alternatives --remove jaxp_transform_impl %{_javadir}/%{name}.jar
174} >/dev/null 2>&1 || :
175
176#%post javadoc
177#rm -f %{_javadocdir}/%{name}
178#ln -s %{name}-%{version} %{_javadocdir}/%{name}
179
180#%postun javadoc
181#if [ "$1" = "0" ]; then
182#    rm -f %{_javadocdir}/%{name}
183#fi
184
185%files
186%defattr(0644,root,root,0755)
187%doc LICENSE.txt NOTICE.txt readme.html
188%{_javadir}/%{name}-%{version}.jar
189%{_javadir}/%{name}.jar
190%{_javadir}/%{name}-serializer-%{version}.jar
191%{_javadir}/%{name}-serializer.jar
192%ghost %{_javadir}/jaxp_transform_impl.jar
193
194#%files xsltc
195#%defattr(0644,root,root,0755)
196%{_javadir}/xsltc-%{version}.jar
197%{_javadir}/xsltc.jar
198#%ghost %{_javadir}/jaxp_transform_impl.jar
199
200%files manual
201%defattr(0644,root,root,0755)
202%doc docs/*
203
204#%files javadoc
205#%defattr(0644,root,root,0755)
206#%doc %{_javadocdir}/%{name}-%{version}
207#%ghost %doc %{_javadocdir}/%{name}
208
209#%files demo
210#%defattr(0644,root,root,0755)
211#%{_datadir}/%{name}
212
213%changelog
214* Mon Aug 30 2010 Ryoichic INAGAKI <ryo1@bc.wakwak.com> 2.7.1-2
215- Initial build for VineLinux
216- using binary package for bootstrap
217
218* Wed Apr 7 2010 Alexander Kurtakov <akurtako@redhat.com> 0:2.7.1-1
219- Update to 2.7.1.
220- Drop gcj_support.
221
222* Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:2.7.0-9.5
223- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
224
225* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:2.7.0-8.5
226- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
227
228* Tue Feb 3 2009 Alexander Kurtakov <akurtako@redhat.com> 0:2.7.0-7.5
229- Add osgi manifest.
230
231* Sat Sep  6 2008 Tom "spot" Callaway <tcallawa@redhat.com> 0:2.7.0-7.4
232- fix license tag
233
234* Thu Jul 10 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0:2.7.0-7.3
235- drop repotag
236- fix license tag
237
238* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0:2.7.0-7jpp.2
239- Autorebuild for GCC 4.3
240
241* Fri Apr 20 2007 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-6jpp.2.fc7
242- Rebuild to fix incomplete .db/so files due to broken aot-compile-rpm
243
244* Fri Aug 18 2006 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-6jpp.1
245- Resync with latest from JPP.
246
247* Fri Aug 11 2006 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-5jpp.3
248- Rebuild.
249
250* Thu Aug 10 2006 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-5jpp.2
251- Rebuild.
252
253* Thu Aug 10 2006 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-5jpp.1
254- Resync with latest from JPP.
255- Partially adopt new naming convention (.1 suffix).
256- Use ln and rm explicitly instead of core-utils in Requires(x).
257
258* Thu Aug 10 2006 Karsten Hopp <karsten@redhat.de> 2.7.0-4jpp_5fc
259- Requires(post):     coreutils
260
261* Wed Jul 26 2006 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-4jpp_4fc
262- Extend patch to cover all applicable MANIFEST files in src directory.
263
264* Wed Jul 26 2006 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-4jpp_3fc
265- Apply patch to replace serializer.jar in MANIFEST file with
266  xalan-j2-serializer.jar.
267
268* Sat Jul 22 2006 Jakub Jelinek <jakub@redhat.com> - 0:2.7.0-4jpp_2fc
269- Rebuilt
270
271* Fri Jul 21 2006 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-4jpp_1fc
272- Resync with latest JPP version.
273
274* Wed Jul 19 2006 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-3jpp_1fc
275- Merge with latest version from jpp.
276- Undo ExcludeArch since eclipse available for all arch-es.
277- Remove jars from sources for new upstream version.
278- Purge unused patches from previous release.
279- Conditional native compilation with GCJ.
280- Use NVR macros wherever possible.
281
282* Wed Mar  8 2006 Rafael Schloming <rafaels@redhat.com> - 0:2.6.0-3jpp_10fc
283- excluded s390[x] and ppc64 due to eclipse
284
285* Mon Mar  6 2006 Jeremy Katz <katzj@redhat.com> - 0:2.6.0-3jpp_9fc
286- stop scriptlet spew
287
288* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0:2.6.0-3jpp_8fc
289- bump again for double-long bug on ppc(64)
290
291* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0:2.6.0-3jpp_7fc
292- rebuilt for new gcc4.1 snapshot and glibc changes
293
294* Wed Dec 21 2005 Jesse Keating <jkeating@redhat.com> 0:2.6.0-3jpp_6fc
295- rebuild again
296
297* Tue Dec 13 2005 Jesse Keating <jkeating@redhat.com> 0:2.6.0-3jpp_5fc.3
298- patch to not use target= in build.xml
299
300* Tue Dec 13 2005 Jesse Keating <jkeating@redhat.com> 0:2.6.0-3jpp_5fc.1
301- rebuild again with gcc-4.1
302
303* Fri Dec 09 2005 Warren Togami <wtogami@redhat.com> 0:2.6.0-3jpp_5fc
304- rebuild with gcc-4.1
305
306* Tue Nov  1 2005 Archit Shah <ashah at redhat.com> 0:2.6.0-3jpp_4fc
307- Exclude war which blocks aot compilation of main jar (#171005).
308
309* Tue Jul 19 2005 Gary Benson <gbenson at redhat.com> 0:2.6.0-3jpp_3fc
310- Build on ia64, ppc64, s390 and s390x.
311- Switch to aot-compile-rpm (also BC-compiles xsltc and samples).
312
313* Tue Jun 28 2005 Gary Benson <gbenson at redhat.com> 0:2.6.0-3jpp_2fc
314- Remove a tarball from the tarball too.
315- Fix demo subpackage's dependencies.
316
317* Wed Jun 15 2005 Gary Benson <gbenson at redhat.com> 0:2.6.0-3jpp_1fc
318- Remove jarfiles from the tarball.
319
320* Fri May 27 2005 Gary Benson <gbenson at redhat.com> 0:2.6.0-3jpp
321- Add NOTICE file as per Apache License version 2.0.
322- Build with servletapi5.
323
324* Fri May 27 2005 Gary Benson <gbenson@redhat.com> 0:2.6.0-2jpp_3fc
325- Remove now-unnecessary workaround for #130162.
326- Rearrange how BC-compiled stuff is built and installed.
327
328* Tue May 24 2005 Gary Benson <gbenson@redhat.com> 0:2.6.0-2jpp_2fc
329- Add DOM3 stubs to classes that need them (#152255).
330- BC-compile the main jarfile.
331
332* Fri Apr  1 2005 Gary Benson <gbenson@redhat.com>
333- Add NOTICE file as per Apache License version 2.0.
334
335* Wed Jan 12 2005 Gary Benson <gbenson@redhat.com> 0:2.6.0-2jpp_1fc
336- Sync with RHAPS.
337
338* Mon Nov 15 2004 Fernando Nasser <fnasser@redhat.com> 0:2.6.0-2jpp_1rh
339- Merge with latest community release
340
341* Thu Nov  4 2004 Gary Benson <gbenson@redhat.com> 0:2.6.0-1jpp_2fc
342- Build into Fedora.
343
344* Thu Aug 26 2004 Ralph Apel <r.ape at r-apel.de> 0:2.6.0-2jpp
345- Build with ant-1.6.2
346- Try with -Djava.awt.headless=true
347
348* Mon Jul 26 2004 Fernando Nasser <fnasser@redhat.com> 0:2.6.0-1jpp_1rh
349- Merge with latest community version
350
351* Fri Mar 26 2004 Frank Ch. Eigler <fche@redhat.com> 0:2.5.2-1jpp_2rh
352- add RHUG upgrade cleanup
353
354* Tue Mar 23 2004 Kaj J. Niemi <kajtzu@fi.basen.net> 0:2.6.0-1jpp
355- Updated to 2.6.0
356- Patches supplied by <aleksander.adamowski@altkom.pl>
357
358* Thu Mar  4 2004 Frank Ch. Eigler <fche@redhat.com> - 0:2.5.2-1jpp_1rh
359- RH vacuuming
360
361* Sat Nov 15 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:2.5.2-1jpp
362- Update to 2.5.2.
363- Re-enable javadocs, new style versionless symlink handling, crosslink
364  with local J2SE javadocs.
365- Spec cleanups.
366
367* Sat Jun  7 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:2.5.1-1jpp
368- Update to 2.5.1.
369- Fix jpackage-utils version in BuildRequires, add xerces-j2.
370- Non-versioned javadoc symlinking.
371- Add one missing epoch.
372- Clean up manifests from Class-Path's and other stuff we don't include.
373- xsltc no longer provides a jaxp_transform_impl because of huge classpath
374  and general unsuitablity for production-use, system-installed transformer.
375- Own (ghost) %%{_javadir}/jaxp_transform_impl.jar.
376- Remove alternatives in preun instead of postun.
377- Disable javadoc subpackage for now:
378  <http://issues.apache.org/bugzilla/show_bug.cgi?id=20572>
379
380* Thu Mar 27 2003 Nicolas Mailhot <Nicolas.Mailhot@One2team.com> 0:2.5.0.d1-1jpp
381- For jpackage-utils 1.5
382
383* Wed Jan 22 2003 Ville Skyttä <ville.skytta at iki.fi> - 2.4.1-2jpp
384- bsf -> oldbsf.
385- Use non-versioned jar in alternative, don't remove it on upgrade.
386- Remove hardcoded packager tag.
387
388* Mon Nov 04 2002 Henri Gomez <hgomez@users.sourceforge.net> 2.4.1-1jpp
389- 2.4.1
390
391* Tue Sep 10 2002 Ville Skyttä <ville.skytta at iki.fi> 2.4.0-1jpp
392- 2.4.0.
393
394* Thu Aug 22 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.4-0.D1.3jpp
395- corrected case for Group tag
396- fixed servlet classpath
397
398* Tue Aug 20 2002 Ville Skyttä <ville.skytta at iki.fi> 2.4-0.D1.2jpp
399- Remove xerces-j1 runtime dependency.
400- Add bcel, jlex, regexp to xsltc runtime requirements:
401  <http://xml.apache.org/xalan-j/xsltc_usage.html>
402- Build with -Dbuild.compiler=modern (IBM 1.3.1) to avoid stylebook errors.
403- XSLTC now provides jaxp_transform_impl too.
404- Earlier changes by Henri, from unreleased 2.4-D1.1jpp:
405    Mon Jul 15 2002 Henri Gomez <hgomez@users.sourceforge.net> 2.4-D1.1jpp
406  - 2.4D1
407  - use the jlex 1.2.5-5jpp (patched by Xalan/XSLTC team) rpm
408  - use the stylebook-1.0-b3_xalan-2.jar included in source file till it will
409    be packaged in jpackage
410  - use jaxp_parser_impl (possibly xerces-j2) instead of xerces-j1 for docs
411    generation, since it's tuned for stylebook-1.0-b3_xalan-2.jar
412  - build and provide xsltc in a separate rpm
413
414* Mon Jul 01 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.3.1-2jpp
415- provides jaxp_transform_impl
416- requires jaxp_parser_impl
417- stylebook already requires xml-commons-apis
418- jaxp_parser_impl already requires xml-commons-apis
419- use sed instead of bash 2.x extension in link area to make spec compatible with distro using bash 1.1x
420
421* Wed Jun 26 2002 Henri Gomez <hgomez@users.sourceforge.net> 2.3.1-2jpp
422- fix built classpath (bsf, bcel are existing jpackage rpms),
423- add buildrequires for javacup and JLex
424
425* Wed May 08 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.3.1-1jpp
426- 2.3.1
427- vendor, distribution, group tags
428
429* Mon Mar 18 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.3.0-2jpp
430- generic servlet support
431
432* Wed Feb 20 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.3.0-1jpp
433- 2.3.0
434- no more compat jar
435
436* Sun Jan 27 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.2.0-2jpp
437- adaptation to new stylebook1.0b3 package
438- used source tarball
439- section macro
440
441* Fri Jan 18 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.2.0-1jpp
442- 2.2.0 final
443- versioned dir for javadoc
444- no dependencies for manual and javadoc packages
445- stricter dependency for compat and demo packages
446- fixed package confusion
447- adaptation for new servlet3 package
448- requires xerces-j1 instead of jaxp_parser
449- xml-apis jar now in required xml-commons-apis external package
450
451* Wed Dec 5 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.2.D14-1jpp
452- 2.2.D14
453- javadoc into javadoc package
454- compat.jar into compat package
455- compat javadoc into compat-javadoc package
456
457* Wed Nov 21 2001 Christian Zoffoli <czoffoli@littlepenguin.org> 2.2.D13-2jpp
458- changed extension to jpp
459- prefixed xml-apis
460
461* Tue Nov 20 2001 Christian Zoffoli <czoffoli@littlepenguin.org> 2.2.D13-1jpp
462- 2.2.D13
463- removed packager tag
464
465* Sat Oct 6 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.2.D11-1jpp
466- 2.2.D11
467
468* Sun Sep 30 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.2.D10-2jpp
469- first unified release
470- s/jPackage/JPackage
471
472* Fri Sep 14 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.2.D10-1mdk
473- cvs references
474- splitted demo package
475- moved demo files to %{_datadir}/%{name}
476- only manual package requires stylebook-1.0b3
477- only demo package requires servletapi3
478
479* Wed Aug 22 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.2.D9-1mdk
480- 2.2.9
481- used new source packaging policy
482- added samples data
483
484* Wed Aug 08 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.2.D6-1mdk
485- first Mandrake release
Note: See TracBrowser for help on using the repository browser.