source: projects/specs/trunk/x/xalan-j2/xalan-j2-vl.spec @ 9447

Revision 9447, 18.7 KB checked in by inagaki, 9 years ago (diff)

2015-03-21 Ryoichi INAGAKi <ryo1@…>

  • antlr, junit, xalan-j2: updated
  • bcel, xml-stylebook: new


Line 
1# Copyright (c) 2000-2005, JPackage Project
2# All rights reserved.
3#
4# Redistribution and use in source and binary forms, with or without
5# modification, are permitted provided that the following conditions
6# are met:
7#
8# 1. Redistributions of source code must retain the above copyright
9#    notice, this list of conditions and the following disclaimer.
10# 2. Redistributions in binary form must reproduce the above copyright
11#    notice, this list of conditions and the following disclaimer in the
12#    documentation and/or other materials provided with the
13#    distribution.
14# 3. Neither the name of the JPackage Project nor the names of its
15#    contributors may be used to endorse or promote products derived
16#    from this software without specific prior written permission.
17#
18# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
19# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
20# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
21# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
22# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
23# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
24# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
25# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
26# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
27# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
28# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
29#
30
31%define section free
32%define cvs_version 2_7_1
33
34Name:           xalan-j2
35Summary:        Java XSLT processor
36Summary(ja):    Java XSLT プロセッサ
37Version:        2.7.1
38Release:        4%{?_dist_release}
39
40Group:          Development/Libraries
41# src/org/apache/xpath/domapi/XPathStylesheetDOM3Exception.java is W3C
42License:        ASL 2.0 and W3C
43URL:            http://xalan.apache.org/
44
45# using binary for bootstrap
46Source0:        http://archive.apache.org/dist/xml/xalan-j/xalan-j_2_7_1-src.tar.gz
47Source1:        %{name}-serializer-MANIFEST.MF
48Source2:        http://repo1.maven.org/maven2/xalan/xalan/2.7.1/xalan-2.7.1.pom
49Source3:        http://repo1.maven.org/maven2/xalan/serializer/2.7.1/serializer-2.7.1.pom
50Source4:        xsltc-%{version}.pom
51Source5:        %{name}-MANIFEST.MF
52Patch0:         %{name}-noxsltcdeps.patch
53# Fix CVE-2014-0107: insufficient constraints in secure processing
54# feature (oCERT-2014-002).  Generated form upstream revisions 1581058
55# and 1581426.
56Patch2:         %{name}-CVE-2014-0107.patch
57
58BuildRoot:      %{_tmppath}/%{name}-%{version}-root
59BuildArch:      noarch
60BuildRequires:  javapackages-tools
61BuildRequires:  java-devel
62BuildRequires:  ant
63BuildRequires:  bcel
64BuildRequires:  java_cup
65BuildRequires:  regexp
66BuildRequires:  sed
67#BuildRequires:  tomcat-servlet-3.1-api
68BuildRequires:  xerces-j2 >= 2.7.1
69BuildRequires:  xml-commons-apis >= 1.3
70BuildRequires:  xml-stylebook
71BuildRequires:  zip
72Requires:       xerces-j2
73Requires(post): /sbin/update-alternatives
74Requires(preun): /sbin/update-alternatives
75Provides:       jaxp_transform_impl
76
77%description
78Xalan is an XSLT processor for transforming XML documents into HTML,
79text, or other XML document types. It implements the W3C Recommendations
80for XSL Transformations (XSLT) and the XML Path Language (XPath). It can
81be used from the command line, in an applet or a servlet, or as a module
82in other program.
83
84%package        xsltc
85Summary:        XSLT compiler
86Summary(ja):    XSLT コンパイラ
87Group:          Development/Libraries
88Requires:       java_cup
89Requires:       bcel
90Requires:       regexp
91Requires:       xerces-j2
92
93%description    xsltc
94The XSLT Compiler is a Java-based tool for compiling XSLT stylesheets into
95lightweight and portable Java byte codes called translets.
96
97%package        manual
98Summary:        Manual for %{name}
99Group:          Documentation
100
101%description    manual
102Documentation for %{name}.
103
104%package        javadoc
105Summary:        Javadoc for %{name}
106Group:          Documentation
107BuildRequires:  java-javadoc
108
109%description    javadoc
110Javadoc for %{name}.
111
112%package        demo
113Summary:        Demo for %{name}
114Requires:       %{name} = %{epoch}:%{version}-%{release}
115#Requires:       tomcat-servlet-3.1-api
116
117%description    demo
118Demonstrations and samples for %{name}.
119
120%prep
121%setup -q -n xalan-j_%{cvs_version}
122%patch0 -p0
123%patch2 -p1
124
125find . -name '*.jar' -delete
126find . -name '*.class' -delete
127
128# this tar.gz contains bundled software, some of which has unclear
129# licensing terms (W3C Software/Document license) . We could probably
130# replicate this with our jars but it's too much work so just generate
131# non-interlinked documentation
132rm src/*tar.gz
133sed -i '/<!-- Expand jaxp sources/,/<delete file="${xml-commons-srcs.tar}"/{d}' build.xml
134
135# Remove classpaths from manifests
136sed -i '/class-path/I d' $(find -iname '*manifest*')
137
138# Convert CR-LF to LF-only
139sed -i s/
140// KEYS LICENSE.txt NOTICE.txt xdocs/style/resources/script.js \
141    xdocs/sources/xsltc/README* `find -name '*.sh'`
142
143%build
144if [ ! -e "$JAVA_HOME" ] ; then export JAVA_HOME="%{java_home}" ; fi
145pushd lib
146ln -sf $(build-classpath java_cup-runtime) runtime.jar
147ln -sf $(build-classpath bcel) BCEL.jar
148ln -sf $(build-classpath regexp) regexp.jar
149ln -sf $(build-classpath xerces-j2) xercesImpl.jar
150ln -sf $(build-classpath xml-commons-apis) xml-apis.jar
151popd
152pushd tools
153ln -sf $(build-classpath java_cup) java_cup.jar
154ln -sf $(build-classpath ant) ant.jar
155ln -sf $(build-classpath xml-stylebook) stylebook-1.0-b3_xalan-2.jar
156popd
157export CLASSPATH=$(build-classpath servlet)
158
159ant \
160  -Djava.awt.headless=true \
161  -Dapi.j2se=%{_javadocdir}/java \
162  -Dbuild.xalan-interpretive.jar=build/xalan-interpretive.jar \
163  xalan-interpretive.jar\
164  xsltc.unbundledjar \
165  samples \
166  docs
167#  javadocs \
168#  servlet
169
170%install
171rm -rf $RPM_BUILD_ROOT
172
173# inject OSGi manifests
174mkdir -p META-INF
175cp -p %{SOURCE1} META-INF/MANIFEST.MF
176touch META-INF/MANIFEST.MF
177zip -u build/serializer.jar META-INF/MANIFEST.MF
178cp -p %{SOURCE5} META-INF/MANIFEST.MF
179touch META-INF/MANIFEST.MF
180zip -u build/xalan-interpretive.jar META-INF/MANIFEST.MF
181
182# jars
183install -d -m 755 $RPM_BUILD_ROOT%{_javadir}
184install -p -m 644 build/xalan-interpretive.jar \
185  $RPM_BUILD_ROOT%{_javadir}/%{name}.jar
186install -p -m 644 build/xsltc.jar \
187  $RPM_BUILD_ROOT%{_javadir}/xsltc.jar
188install -p -m 644 build/serializer.jar \
189  $RPM_BUILD_ROOT%{_javadir}/%{name}-serializer.jar
190
191# POMs
192#install -d -m 755 $RPM_BUILD_ROOT%{_mavenpomdir}
193#install -p -m 644 %{SOURCE2} $RPM_BUILD_ROOT%{_mavenpomdir}/JPP-%{name}.pom
194#install -p -m 644 %{SOURCE3} $RPM_BUILD_ROOT%{_mavenpomdir}/JPP-%{name}-serializer.pom
195#install -p -m 644 %{SOURCE4} $RPM_BUILD_ROOT%{_mavenpomdir}/JPP-xsltc.pom
196#add_maven_depmap JPP-%{name}.pom %{name}.jar
197#add_maven_depmap JPP-%{name}-serializer.pom %{name}-serializer.jar
198#add_maven_depmap -f xsltc JPP-xsltc.pom xsltc.jar
199
200# javadoc
201#install -d -m 755 $RPM_BUILD_ROOT%{_javadocdir}/%{name}
202#cp -pr build/docs/apidocs/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}
203#rm -rf build/docs/apidocs
204
205# demo
206install -d -m 755 $RPM_BUILD_ROOT%{_datadir}/%{name}
207install -p -m 644 build/xalansamples.jar \
208        $RPM_BUILD_ROOT%{_datadir}/%{name}/%{name}-samples.jar
209#install -p -m 644 build/xalanservlet.war \
210#       $RPM_BUILD_ROOT%{_datadir}/%{name}/%{name}-servlet.war
211cp -pr samples $RPM_BUILD_ROOT%{_datadir}/%{name}
212
213# fix link between manual and javadoc
214(cd build/docs; ln -sf %{_javadocdir}/%{name} apidocs)
215
216# jaxp_transform_impl ghost symlink
217ln -s %{_sysconfdir}/alternatives \
218   $RPM_BUILD_ROOT%{_javadir}/jaxp_transform_impl.jar
219
220
221%clean
222rm -rf $RPM_BUILD_ROOT
223
224
225%post
226/sbin/update-alternatives \
227    --install %{_javadir}/jaxp_transform_impl.jar \
228    jaxp_transform_impl %{_javadir}/%{name}.jar 30
229
230%preun
231if [ $1 -eq 0 ] ; then
232    /sbin/update-alternatives --remove jaxp_transform_impl %{_javadir}/%{name}.jar
233fi
234
235%post javadoc
236rm -f %{_javadocdir}/%{name}
237ln -s %{name}-%{version} %{_javadocdir}/%{name}
238
239%postun javadoc
240if [ "$1" = "0" ]; then
241    rm -f %{_javadocdir}/%{name}
242fi
243
244%files
245%defattr(-,root,root,-)
246%doc KEYS readme.html
247%doc LICENSE.txt NOTICE.txt
248%{_javadir}/%{name}.jar
249%{_javadir}/%{name}-serializer.jar
250%ghost %{_javadir}/jaxp_transform_impl.jar
251
252%files xsltc
253%defattr(-,root,root,-)
254%doc LICENSE.txt NOTICE.txt
255%{_javadir}/xsltc.jar
256
257%files manual
258%defattr(-,root,root,-)
259%doc LICENSE.txt NOTICE.txt
260%doc build/docs/*
261
262#files javadoc
263#defattr(-,root,root,-)
264#doc LICENSE.txt NOTICE.txt
265#doc %{_javadocdir}/%{name}
266
267%files demo
268%defattr(-,root,root,-)
269%{_datadir}/%{name}
270
271%changelog
272* Fri Mar 20 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.7.1-4
273- rebuilt with current VineSeed
274
275* Sat Feb 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.7.1-3
276- rebuild with Vine6 environment
277
278* Mon Aug 30 2010 Ryoichic INAGAKI <ryo1@bc.wakwak.com> 2.7.1-2
279- Initial build for VineLinux
280- using binary package for bootstrap
281
282* Wed Apr 7 2010 Alexander Kurtakov <akurtako@redhat.com> 0:2.7.1-1
283- Update to 2.7.1.
284- Drop gcj_support.
285
286* Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:2.7.0-9.5
287- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
288
289* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:2.7.0-8.5
290- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
291
292* Tue Feb 3 2009 Alexander Kurtakov <akurtako@redhat.com> 0:2.7.0-7.5
293- Add osgi manifest.
294
295* Sat Sep  6 2008 Tom "spot" Callaway <tcallawa@redhat.com> 0:2.7.0-7.4
296- fix license tag
297
298* Thu Jul 10 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0:2.7.0-7.3
299- drop repotag
300- fix license tag
301
302* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0:2.7.0-7jpp.2
303- Autorebuild for GCC 4.3
304
305* Fri Apr 20 2007 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-6jpp.2.fc7
306- Rebuild to fix incomplete .db/so files due to broken aot-compile-rpm
307
308* Fri Aug 18 2006 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-6jpp.1
309- Resync with latest from JPP.
310
311* Fri Aug 11 2006 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-5jpp.3
312- Rebuild.
313
314* Thu Aug 10 2006 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-5jpp.2
315- Rebuild.
316
317* Thu Aug 10 2006 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-5jpp.1
318- Resync with latest from JPP.
319- Partially adopt new naming convention (.1 suffix).
320- Use ln and rm explicitly instead of core-utils in Requires(x).
321
322* Thu Aug 10 2006 Karsten Hopp <karsten@redhat.de> 2.7.0-4jpp_5fc
323- Requires(post):     coreutils
324
325* Wed Jul 26 2006 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-4jpp_4fc
326- Extend patch to cover all applicable MANIFEST files in src directory.
327
328* Wed Jul 26 2006 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-4jpp_3fc
329- Apply patch to replace serializer.jar in MANIFEST file with
330  xalan-j2-serializer.jar.
331
332* Sat Jul 22 2006 Jakub Jelinek <jakub@redhat.com> - 0:2.7.0-4jpp_2fc
333- Rebuilt
334
335* Fri Jul 21 2006 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-4jpp_1fc
336- Resync with latest JPP version.
337
338* Wed Jul 19 2006 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-3jpp_1fc
339- Merge with latest version from jpp.
340- Undo ExcludeArch since eclipse available for all arch-es.
341- Remove jars from sources for new upstream version.
342- Purge unused patches from previous release.
343- Conditional native compilation with GCJ.
344- Use NVR macros wherever possible.
345
346* Wed Mar  8 2006 Rafael Schloming <rafaels@redhat.com> - 0:2.6.0-3jpp_10fc
347- excluded s390[x] and ppc64 due to eclipse
348
349* Mon Mar  6 2006 Jeremy Katz <katzj@redhat.com> - 0:2.6.0-3jpp_9fc
350- stop scriptlet spew
351
352* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0:2.6.0-3jpp_8fc
353- bump again for double-long bug on ppc(64)
354
355* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0:2.6.0-3jpp_7fc
356- rebuilt for new gcc4.1 snapshot and glibc changes
357
358* Wed Dec 21 2005 Jesse Keating <jkeating@redhat.com> 0:2.6.0-3jpp_6fc
359- rebuild again
360
361* Tue Dec 13 2005 Jesse Keating <jkeating@redhat.com> 0:2.6.0-3jpp_5fc.3
362- patch to not use target= in build.xml
363
364* Tue Dec 13 2005 Jesse Keating <jkeating@redhat.com> 0:2.6.0-3jpp_5fc.1
365- rebuild again with gcc-4.1
366
367* Fri Dec 09 2005 Warren Togami <wtogami@redhat.com> 0:2.6.0-3jpp_5fc
368- rebuild with gcc-4.1
369
370* Tue Nov  1 2005 Archit Shah <ashah at redhat.com> 0:2.6.0-3jpp_4fc
371- Exclude war which blocks aot compilation of main jar (#171005).
372
373* Tue Jul 19 2005 Gary Benson <gbenson at redhat.com> 0:2.6.0-3jpp_3fc
374- Build on ia64, ppc64, s390 and s390x.
375- Switch to aot-compile-rpm (also BC-compiles xsltc and samples).
376
377* Tue Jun 28 2005 Gary Benson <gbenson at redhat.com> 0:2.6.0-3jpp_2fc
378- Remove a tarball from the tarball too.
379- Fix demo subpackage's dependencies.
380
381* Wed Jun 15 2005 Gary Benson <gbenson at redhat.com> 0:2.6.0-3jpp_1fc
382- Remove jarfiles from the tarball.
383
384* Fri May 27 2005 Gary Benson <gbenson at redhat.com> 0:2.6.0-3jpp
385- Add NOTICE file as per Apache License version 2.0.
386- Build with servletapi5.
387
388* Fri May 27 2005 Gary Benson <gbenson@redhat.com> 0:2.6.0-2jpp_3fc
389- Remove now-unnecessary workaround for #130162.
390- Rearrange how BC-compiled stuff is built and installed.
391
392* Tue May 24 2005 Gary Benson <gbenson@redhat.com> 0:2.6.0-2jpp_2fc
393- Add DOM3 stubs to classes that need them (#152255).
394- BC-compile the main jarfile.
395
396* Fri Apr  1 2005 Gary Benson <gbenson@redhat.com>
397- Add NOTICE file as per Apache License version 2.0.
398
399* Wed Jan 12 2005 Gary Benson <gbenson@redhat.com> 0:2.6.0-2jpp_1fc
400- Sync with RHAPS.
401
402* Mon Nov 15 2004 Fernando Nasser <fnasser@redhat.com> 0:2.6.0-2jpp_1rh
403- Merge with latest community release
404
405* Thu Nov  4 2004 Gary Benson <gbenson@redhat.com> 0:2.6.0-1jpp_2fc
406- Build into Fedora.
407
408* Thu Aug 26 2004 Ralph Apel <r.ape at r-apel.de> 0:2.6.0-2jpp
409- Build with ant-1.6.2
410- Try with -Djava.awt.headless=true
411
412* Mon Jul 26 2004 Fernando Nasser <fnasser@redhat.com> 0:2.6.0-1jpp_1rh
413- Merge with latest community version
414
415* Fri Mar 26 2004 Frank Ch. Eigler <fche@redhat.com> 0:2.5.2-1jpp_2rh
416- add RHUG upgrade cleanup
417
418* Tue Mar 23 2004 Kaj J. Niemi <kajtzu@fi.basen.net> 0:2.6.0-1jpp
419- Updated to 2.6.0
420- Patches supplied by <aleksander.adamowski@altkom.pl>
421
422* Thu Mar  4 2004 Frank Ch. Eigler <fche@redhat.com> - 0:2.5.2-1jpp_1rh
423- RH vacuuming
424
425* Sat Nov 15 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:2.5.2-1jpp
426- Update to 2.5.2.
427- Re-enable javadocs, new style versionless symlink handling, crosslink
428  with local J2SE javadocs.
429- Spec cleanups.
430
431* Sat Jun  7 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:2.5.1-1jpp
432- Update to 2.5.1.
433- Fix jpackage-utils version in BuildRequires, add xerces-j2.
434- Non-versioned javadoc symlinking.
435- Add one missing epoch.
436- Clean up manifests from Class-Path's and other stuff we don't include.
437- xsltc no longer provides a jaxp_transform_impl because of huge classpath
438  and general unsuitablity for production-use, system-installed transformer.
439- Own (ghost) %%{_javadir}/jaxp_transform_impl.jar.
440- Remove alternatives in preun instead of postun.
441- Disable javadoc subpackage for now:
442  <http://issues.apache.org/bugzilla/show_bug.cgi?id=20572>
443
444* Thu Mar 27 2003 Nicolas Mailhot <Nicolas.Mailhot@One2team.com> 0:2.5.0.d1-1jpp
445- For jpackage-utils 1.5
446
447* Wed Jan 22 2003 Ville Skyttä <ville.skytta at iki.fi> - 2.4.1-2jpp
448- bsf -> oldbsf.
449- Use non-versioned jar in alternative, don't remove it on upgrade.
450- Remove hardcoded packager tag.
451
452* Mon Nov 04 2002 Henri Gomez <hgomez@users.sourceforge.net> 2.4.1-1jpp
453- 2.4.1
454
455* Tue Sep 10 2002 Ville Skyttä <ville.skytta at iki.fi> 2.4.0-1jpp
456- 2.4.0.
457
458* Thu Aug 22 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.4-0.D1.3jpp
459- corrected case for Group tag
460- fixed servlet classpath
461
462* Tue Aug 20 2002 Ville Skyttä <ville.skytta at iki.fi> 2.4-0.D1.2jpp
463- Remove xerces-j1 runtime dependency.
464- Add bcel, jlex, regexp to xsltc runtime requirements:
465  <http://xml.apache.org/xalan-j/xsltc_usage.html>
466- Build with -Dbuild.compiler=modern (IBM 1.3.1) to avoid stylebook errors.
467- XSLTC now provides jaxp_transform_impl too.
468- Earlier changes by Henri, from unreleased 2.4-D1.1jpp:
469    Mon Jul 15 2002 Henri Gomez <hgomez@users.sourceforge.net> 2.4-D1.1jpp
470  - 2.4D1
471  - use the jlex 1.2.5-5jpp (patched by Xalan/XSLTC team) rpm
472  - use the stylebook-1.0-b3_xalan-2.jar included in source file till it will
473    be packaged in jpackage
474  - use jaxp_parser_impl (possibly xerces-j2) instead of xerces-j1 for docs
475    generation, since it's tuned for stylebook-1.0-b3_xalan-2.jar
476  - build and provide xsltc in a separate rpm
477
478* Mon Jul 01 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.3.1-2jpp
479- provides jaxp_transform_impl
480- requires jaxp_parser_impl
481- stylebook already requires xml-commons-apis
482- jaxp_parser_impl already requires xml-commons-apis
483- use sed instead of bash 2.x extension in link area to make spec compatible with distro using bash 1.1x
484
485* Wed Jun 26 2002 Henri Gomez <hgomez@users.sourceforge.net> 2.3.1-2jpp
486- fix built classpath (bsf, bcel are existing jpackage rpms),
487- add buildrequires for javacup and JLex
488
489* Wed May 08 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.3.1-1jpp
490- 2.3.1
491- vendor, distribution, group tags
492
493* Mon Mar 18 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.3.0-2jpp
494- generic servlet support
495
496* Wed Feb 20 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.3.0-1jpp
497- 2.3.0
498- no more compat jar
499
500* Sun Jan 27 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.2.0-2jpp
501- adaptation to new stylebook1.0b3 package
502- used source tarball
503- section macro
504
505* Fri Jan 18 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.2.0-1jpp
506- 2.2.0 final
507- versioned dir for javadoc
508- no dependencies for manual and javadoc packages
509- stricter dependency for compat and demo packages
510- fixed package confusion
511- adaptation for new servlet3 package
512- requires xerces-j1 instead of jaxp_parser
513- xml-apis jar now in required xml-commons-apis external package
514
515* Wed Dec 5 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.2.D14-1jpp
516- 2.2.D14
517- javadoc into javadoc package
518- compat.jar into compat package
519- compat javadoc into compat-javadoc package
520
521* Wed Nov 21 2001 Christian Zoffoli <czoffoli@littlepenguin.org> 2.2.D13-2jpp
522- changed extension to jpp
523- prefixed xml-apis
524
525* Tue Nov 20 2001 Christian Zoffoli <czoffoli@littlepenguin.org> 2.2.D13-1jpp
526- 2.2.D13
527- removed packager tag
528
529* Sat Oct 6 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.2.D11-1jpp
530- 2.2.D11
531
532* Sun Sep 30 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.2.D10-2jpp
533- first unified release
534- s/jPackage/JPackage
535
536* Fri Sep 14 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.2.D10-1mdk
537- cvs references
538- splitted demo package
539- moved demo files to %{_datadir}/%{name}
540- only manual package requires stylebook-1.0b3
541- only demo package requires servletapi3
542
543* Wed Aug 22 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.2.D9-1mdk
544- 2.2.9
545- used new source packaging policy
546- added samples data
547
548* Wed Aug 08 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.2.D6-1mdk
549- first Mandrake release
Note: See TracBrowser for help on using the repository browser.