source: projects/specs/trunk/x/xalan-c/xalan-c-vl.spec @ 521

Revision 521, 2.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:        Xalan XSLT processor for C
2
3Name:           xalan-c
4Version:        1.10.0
5Release:        1%{?_dist_release}
6
7Group:          System Environment/Libraries
8License:        ASL 2.0
9URL:            http://xml.apache.org/xalan-c/
10Source0:        http://www.apache.org/dist/xml/xalan-c/Xalan-C_1_10_0-src.tar.gz
11Patch0:         xalan-c-1.10.0-escaping.patch
12Patch1:         xalan-c-1.10.0-gcc43.patch
13BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
14
15BuildRequires:  xerces-c-devel
16Requires(post): /sbin/ldconfig
17Requires(postun): /sbin/ldconfig
18
19%description
20Xalan is an XSLT processor for transforming XML documents into HTML, text, or
21other XML document types.
22
23
24%package        devel
25Summary:        Header files, libraries and development documentation for %{name}
26Group:          Development/Libraries
27Requires:       %{name} = %{version}-%{release}
28
29
30%description devel
31This package contains the header files, static libraries and development
32documentation for %{name}. If you like to develop programs using %{name},
33you will need to install %{name}-devel.
34
35
36%package doc
37Group:          Documentation
38Summary:        Documentation for Xerces-C++ validating XML parser
39
40
41%description doc
42Documentation for %{name}.
43
44
45%prep
46%setup -q -n xml-xalan/c
47%patch0 -p2 -b .escaping
48%patch1 -p2 -b .gcc43
49find -type d -name CVS -print0 | xargs -0 rm -rf
50chmod 644 NOTICE
51
52
53%build
54export XALANCROOT="${PWD}"
55export XERCESROOT=%{_includedir}/xercesc/
56COMMONARGS="-plinux -cgcc -xg++ -minmem -rpthreads"
57%ifarch alpha ppc64 s390x sparc64 x86_64
58./runConfigure ${COMMONARGS} -b64 -P %{_prefix} -C --libdir="%{_libdir}" -z '%{optflags}'
59%else
60./runConfigure ${COMMONARGS} -b32 -P %{_prefix} -C --libdir="%{_libdir}" -z '%{optflags}'
61%endif
62# _smp_mflags do not work
63make
64
65
66%install
67rm -rf $RPM_BUILD_ROOT
68export XALANCROOT="${PWD}"
69export XERCESROOT=%{_includedir}/xercesc/
70make install DESTDIR=$RPM_BUILD_ROOT
71
72
73%post -p /sbin/ldconfig
74%postun -p /sbin/ldconfig
75
76
77%clean
78rm -rf $RPM_BUILD_ROOT
79
80
81%files
82%defattr(-,root,root,-)
83%doc LICENSE KEYS NOTICE
84%{_bindir}/Xalan
85%{_libdir}/libxalan*.so.*
86
87
88%files devel
89%defattr(-,root,root,-)
90%{_libdir}/libxalan*.so
91%{_includedir}/xalanc/
92
93
94%files doc
95%defattr(-,root,root,-)
96%doc readme.html xdocs samples
97
98
99%changelog
100* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.0-1
101- initial build for Vine Linux
102
103* Mon Feb 11 2008 Lubomir Kundrak <lkundrak@redhat.com> 1.10.0-4
104- Rebuild for newer xerces-c
105
106* Thu Jan 03 2008 Lubomir Kundrak <lkundrak@redhat.com> 1.10.0-3
107- Adding missing includes to fix build with gcc-4.3
108
109* Mon Nov 19 2007 Lubomir Kundrak <lkundrak@redhat.com> - 1.10.0-2
110- Fix passing of compiler flags
111- Bump to stable source instead of CVS snapshot
112- Fixed License tag
113
114* Thu Feb 15 2007 Till Maas <opensource till name> - 1.10.0-1
115- Initial spec for fedora extras
Note: See TracBrowser for help on using the repository browser.