source: projects/specs/trunk/x/x11vnc/x11vnc-vl.spec @ 521

Revision 521, 9.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:        VNC server for the current X11 session
2Summary(ja):    実行中の X セッションにリモートアクセスできる VNC サーバ
3Name:           x11vnc
4Version:        0.9.8
5Release:        2%{?_dist_release}
6License:        GPLv2
7Group:          User Interface/X
8URL:            http://www.karlrunge.com/x11vnc/
9Source0:        http://downloads.sourceforge.net/libvncserver/%{name}-%{version}.tar.gz
10# Don't want hardcoded rpaths.
11Patch1:         x11vnc-0.9.8-disableRpath.patch
12# According to new paths add new include to build. I think it is Fedora-related.
13Patch2:         x11vnc-0.9.8-XShm-explicit-include.patch
14
15BuildRequires:  libjpeg-devel, zlib-devel, openssl-devel
16BuildRequires:  xorg-x11-proto-devel, libXext-devel, libXtst-devel
17BuildRequires:  libXfixes-devel, avahi-devel
18#BuildRequires: libvncserver-devel
19### drop java stuff for vine
20#BuildRequires: java-1.6.0-openjdk-devel
21Requires:               Xvfb
22
23BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
24
25Packager:       kazutaka
26
27%description
28x11vnc allows one to view remotely and interact with real X displays
29(i.e. a display corresponding to a physical monitor, keyboard, and
30mouse) with any VNC viewer.
31
32It has built-in SSL/TLS encryption and RSA authentication, UNIX account
33and password login support, server-side scaling, single port HTTPS/HTTP
34and VNC, and Zeroconf service advertising.
35
36%description -l ja
37x11vnc により、VNC ビューアを使って実行中の X セッションに
38リモートアクセスできるようになります。アクセス中はモニターの
39表示だけでなく、キーボードやマウスのの操作も可能になります。
40
41また組込みの SSL/TLS 暗号化や RSA 認証、UNIX アカウントとパス
42ワードによるログイン、サーバーサイド・スケーリング、シングル
43ポート HTTPS/HTTP 及び VNC 接続、Zeroconf サービスへの通知など
44をサポートしています。
45
46
47### drop java stuff for vine
48#%package               javaviewers
49#Version:               %{version}
50#Summary:               VNC clients (browser java applets)
51#Requires:              %{name} = %{version}-%{release}
52#License:               GPLv2+
53#Group:         User Interface/X
54#BuildArch:     noarch
55#BuildRequires: java-devel >= 1:1.6.0
56#BuildRequires: jpackage-utils
57#
58#
59#%description   javaviewers
60#The package contains the corresponding java clients for %{name}. They
61#can be used with any java-enabled browser and provide an easy access to
62#the server without the need to install software on the client machine.
63
64
65%prep
66%setup -q
67%patch1 -p0 -b .rpath
68%if %{?_dist_release} == "vl6"
69%patch2 -p0 -b .XShm
70%endif
71
72# fix source perms for the -debuginfo package rpmlint warnings
73find -name "*.c" -o -name "*.h" -exec %{__chmod} 0644 {} \;
74
75for file in README AUTHORS; do
76        # ISO-8859-1 is my assumption.
77        iconv -f ISO-8859-1 -t UTF-8 "$file" > "$file.new"
78        touch --reference "$file" "$file.new"
79        %{__mv} "$file.new" "$file"
80done
81
82### drop java stuff for vine
83## Delete prebuilt binaries
84#find -name '*.jar' -exec rm {} \;
85
86%build
87%configure --without-tightvnc-filetransfer
88#          --with-system-libvncserver
89
90### drop java stuff for vine
91# First rebuild jars, what have been removed in %%prep.
92#pushd classes/ssl/src
93#%{__make} %{?_smp_mflags}
94#       # Alternative to patch Makefiles.
95#       for jarfile in *.jar; do
96#       %{__ln_s} src/$jarfile ../;
97#       %{__ln_s} ssl/src/$jarfile ../../;
98#       done
99#popd
100
101%{__make} %{?_smp_mflags}
102
103%install
104%{__rm} -rf %{buildroot}
105%{__make} install DESTDIR="%{buildroot}"
106
107### drop java stuff for vine
108## And Java viewers
109#pushd classes/ssl
110#%{__make} install DESTDIR="%{buildroot}"
111#popd
112#
113# Rename README file to avoid name bump
114#%{__mv} classes/ssl/src/tight/README classes/ssl/src/tight/README.tight
115#%{__mv} classes/ssl/src/ultra/README classes/ssl/src/ultra/README.ultra
116
117### Remove Java viewers for vine
118%{__rm} -rf $RPM_BUILD_ROOT/%{_datadir}/%{name}/classes
119
120
121%clean
122%{__rm} -rf %{buildroot}
123
124
125%files
126%defattr(-,root,root,-)
127%doc AUTHORS ChangeLog COPYING NEWS README TODO
128%{_mandir}/man1/x11vnc.1*
129%{_bindir}/x11vnc
130%{_datadir}/applications/x11vnc.desktop
131
132### drop java stuff for vine
133#%files javaviewers
134#%defattr(-,root,root,-)
135#%doc classes/ssl/README classes/ssl/src/tight/README.tight classes/ssl/src/ultra/README.ultra
136#%{_datadir}/%{name}
137#%exclude %{_datadir}/%{name}/classes/ssl/README
138
139%changelog
140* Sat Nov 21 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.9.8-2
141- apply Patch2 on VineSeed
142
143* Thu Nov 05 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.9.8-1
144- initial build for Vine Linux based on fedora development
145- remove java related stuff to avoid to depend java
146- drop dependency for libvncserver (also drop configure option)
147- add japanese description and summary
148
149* Tue Oct 6 2009 Pavel Alexeev <Pahan@Hubbitus.info> - 0.9.8-14
150- Make -javaviewers subpackage noarch.
151
152* Sun Oct 4 2009 Pavel Alexeev <Pahan@Hubbitus.info> - 0.9.8-13
153- Small fis requires release.
154- Rename README file to avoid name bump
155
156* Fri Sep 25 2009 Pavel Alexeev <Pahan@Hubbitus.info> - 0.9.8-12
157- Own %%{_datadir}/%%{name} instead of %%{_datadir}/%%{name}/classes
158- Add Requires: %%{name} = %%{version}-%%{release} in subpackage.
159- Change summary and description for javaviewers subpackage.
160- Remove %%doc marker from man-page.
161- %%defattr(-,root,root,0755) -> %%defattr(-,root,root,-)
162- Add classes/ssl/src/tight/README classes/ssl/src/ultra/README files into
163        javaviewers subpackage %%doc (thank you Orcan Ogetbil)
164- ln -s replaced by %%{__ln_s}
165- Set License: GPLv2+ for javaviewers subpackage (Thanks Spot)
166
167* Mon Aug 31 2009 Pavel Alexeev <Pahan@Hubbitus.info> - 0.9.8-11
168- Remove all prebuilt *.jar-files in %%prep section and try build it from source.
169- Add BR java-1.6.0-openjdk-devel
170- Introduce new subpackage x11vnc-javaviewers.
171- Add separate build java-viewers.
172- Add Russian localized versions of Summary and descrioptions.
173
174* Wed Aug 26 2009 Pavel Alexeev <Pahan@Hubbitus.info> - 0.9.8-10
175- Fix some spelling, change some cosmetic things.
176- Delete Patch0 and hacks to link with system lzo package - it is not needed
177        anymore as we link it with systel libvncserver instead.
178- Delete BR lzo-devel
179- Remiove empty directory %%{_datadir}/%%{name}/
180
181* Sun Aug 9 2009 Pavel Alexeev <Pahan@Hubbitus.info> - 0.9.8-9
182- Add Requires: Xvfb
183
184* Fri Aug 7 2009 Pavel Alexeev <Pahan@Hubbitus.info> - 0.9.8-8
185- Link to shared lzo instead of minilzo for all (not only EL-5).
186- Add BuildRequires: /usr/include/X11/extensions/XShm.h
187- Patch2: x11vnc-0.9.8-XShm-explicit-include.patch
188- Step to conditional BR for Fedora 12, add
189        Patch2: x11vnc-0.9.8-XShm-explicit-include.patch to build on it.
190
191* Tue Aug 4 2009 Pavel Alexeev <Pahan@Hubbitus.info> - 0.9.8-7
192- Change license to GPLv2 without plus according to x11vnc.c
193        source (thanks to Christian Krause).
194- For consistency macros usage replace "ln -s" by %%{__ln_s},
195        mv by %%{__mv} and similar (chmod, sed).
196- Change find call to avoid using xargs in chmod sources command.
197
198* Wed Jul 29 2009 Pavel Alexeev <Pahan@Hubbitus.info> - 0.9.8-6
199- Build with openssl unconditionally.
200- Add Patch1: x11vnc-0.9.8-disableRpath.patch
201- fix source perms for the -debuginfo package rpmlint warnings
202
203* Tue Jul 21 2009 Pavel Alexeev <Pahan@Hubbitus.info> - 0.9.8-5
204- Try use lzo instead of minilzo in EL-5 (minilzo is not bundled in it).
205- Try use system libvncserver library (--with-system-libvncserver
206        configure option) instead of bundled one.
207- System libvncserver built without tightvnc-filetransfer support.
208        Now disable it there (--without-filetransfer)
209        And according to it change License to only GPLv2+
210        ./configure --help misleading, using --without-tightvnc-filetransfer
211
212* Tue Jul 21 2009 Pavel Alexeev <Pahan@Hubbitus.info> - 0.9.8-4
213- All changes inspired by started Fedora Review (thank you to Christian Krause).
214- README and AUTHORS files converted into UTF-8.
215- Explicit mention previous author in changelog and delet old entries of it.
216- Source renamed to Source0.
217- Source0 URL changed to long (correct) variant:
218        http://downloads.sourceforge.net/libvncserver/%%{name}-%%{version}.tar.gz
219        was http://dl.sf.net/libvncserver/x11vnc-%%{version}.tar.gz
220- Add BR: /usr/include/X11/extensions/XInput.h; In F12 it is located in
221        libXi-devel but in previous versions in xorg-x11-proto-devel
222        so, to do not make conditional requires, require explicit file.
223- Remove prebuild binaries clients.
224- Remove Requires: minilzo it will be automatically propogated.
225- Add BR: libvncserver-devel
226
227* Fri Jul 10 2009 Pavel Alexeev <Pahan@Hubbitus.info> - 0.9.8-3
228- Add BR openssl-devel to provide SSL capability (thanks Manuel Wolfshant).
229- Requires: minilzo, BR lzo-devel and Patch0:
230        11vnc-0.9.8-use-system-minilzo.patch to use system version of library.
231- Add "and GPLv2" to License. See comment above why.
232- Add BuildRequires: libXfixes-devel
233
234* Fri Jul 10 2009 Pavel Alexeev <Pahan@Hubbitus.info> - 0.9.8-2
235- Import http://packages.sw.be/x11vnc/x11vnc-0.9.7-1.rf.src.rpm to maintain it in fedora:
236        Packager: Dag Wieers <dag@wieers.com>
237        Vendor: Dag Apt Repository, http://dag.wieers.com/apt/
238- Step to version 0.9.8
239- Reformat spec with tabs.
240- Comment out (leave for history) Packager and Vendor tags
241- Remove defines of several macros like dtag, conditional _without_modxorg
242- Remove all stuff around conditional build _without_modxorg
243- Add -%%(%%{__id_u} -n) part into buildroot.
244- Make setup quiet.
245- Remove "rf" Release suffix and replace it by %%{?dist}
246- License from GPL changed to GPLv2+
Note: See TracBrowser for help on using the repository browser.