source: projects/specs/trunk/x/x-face/x-face-vl.spec @ 521

Revision 521, 8.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define _noVersionedDependencies        1
2%define prereq_ge()     %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1 | grep -v "is not")
3
4%define origver         1.3.6.24
5%define origname        x-face
6
7Name:         %{origname}
8Version:      %{origver}
9Release:      0vl3
10License:      GPL2
11
12URL:          http://www.jpl.org/elips/
13Source0:      ftp://ftp.jpl.org/pub/elisp/x-face-%{version}.tar.gz
14Source1:      ftp://ftp.jpl.org/pub/elisp/make-gray-x-face.el
15Source2:      ftp://ftp.jpl.org/pub/elisp/x-face-e21.el.gz
16Source10:     %{origname}-install.sh
17Source11:     %{origname}-remove.sh
18
19Group:        Applications/Editors/Emacs
20BuildRoot:    %{_tmppath}/%{name}-%{version}-root
21BuildArch:    noarch
22Summary:      X-Face Utilities for XEmacs & Emacs-21,22
23Summary(ja):  XEmacs µÚ¤Ó Emacs-21,22 ¾å¤Ë¤Æ X-Face ¤òɽ¼¨¤¹¤ë¥é¥¤¥Ö¥é¥ê
24#Requires:    xemacs
25Requires:     faces faces-xface
26
27# for make-gray-x-face.el
28Requires:     netpbm-progs
29
30Obsoletes:    x-face-xemacs
31
32PreReq:       emacsen
33%prereq_ge   emacsen-common
34
35Vendor:       Project Vine
36Distribution: Vine Linux
37Packager:     MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
38
39
40%description
41X-Face enables to display 48x48 X11 bitmap "Face" in-line
42for various MUAs on XEmacs.
43
44After installation, add below lines to your ~/.emacs file:
45
46        (when (and window-system (module-installed-p 'x-face))
47           (autoload 'x-face-xmas-mew-display-x-face "x-face" nil t)
48           (setq wl-highlight-x-face-function
49              'x-face-xmas-mew-display-x-face)
50        )
51 
52
53%description -l ja
54X-Face ¤ò»È¤¦¤È¡¢XEmacs ¾å¤ÇÆ°¤¯Â¿¤¯¤Î MUA ¾å¤Ç
5548x48 ¤Î¥Ó¥Ã¥È¥Þ¥Ã¥×¡ÖFace¡×¤ò¥¤¥ó¥é¥¤¥óɽ¼¨¤¹¤ë¤³¤È¤¬¤Ç¤­¤Þ¤¹¡£
56
57(Åö¥Ñ¥Ã¥±¡¼¥¸¤ËƱº­¤·¤Æ¤¤¤ë)
58x-face-e21.el ¤ò»È¤¦¤È¡¢emacs21 ¾å¤ÇƱÍͤʤ³¤È¤¬¤Ç¤­¤Þ¤¹¡£
59(emacs21 ¤Ç¤Ï bitmap-mule ¤ò»È¤¦¤³¤È¤â¤Ç¤­¤Þ¤¹¤¬¡¢~/.x-face-cache
60¤ò¤°¤º¤°¤º¤ËÊø¤·¤Æ¤·¤Þ¤¦¤Î¤Ç¡¢bitmap-mule ¤ò»È¤ï¤º¤Ëɬ¤º
61Åö¥Ñ¥Ã¥±¡¼¥¸¤ò»È¤Ã¤Æ¤¯¤À¤µ¤¤)
62
63XEmacs ¤ÎÀßÄêÎã ~/.xemacs.el(~/.xemacs/init.el)
64
65        ;;; XEmacs + Wanderlust ¤ÎÀßÄê
66        (when (and window-system (module-installed-p 'x-face))
67           (autoload 'x-face-xmas-mew-display-x-face "x-face" nil t)
68           (setq wl-highlight-x-face-function
69              'x-face-xmas-mew-display-x-face)
70        )
71
72        ;;; XEmacs + Mew ¤ÎÀßÄê
73        (autoload 'x-face-xmas-mew-display-x-face "x-face")
74        (setq mew-use-highlight-x-face-function 'x-face-xmas-mew-display-x-face)
75
76¾å¼ê¤¯É½¼¨¤Ç¤­¤Ê¤¤¾ì¹ç¤Ï¡¢ÉÕ°¤Î¥É¥­¥å¥á¥ó¥È¤ò»²¾È¤·¤Æ¤ß¤Æ¤¯¤À¤µ¤¤¡£
77(%{_defaultdocdir}/%{name}-%{version}/README.ja)
78
79Emacs-21.x ¤ÎÀßÄêÎã(~/.emacs.el)
80
81        ;;; Emacs-21.x + Wanderlust
82        (autoload 'x-face-decode-message-header "x-face-e21")
83        (setq wl-highlight-x-face-function 'x-face-decode-message-header)
84
85        ;;; Emacs-21.x + Mew
86        (cond ((featurep 'xemacs)
87          ;;
88              )
89          ((= 21 emacs-major-version)
90           (setq mew-use-highlight-x-face t
91              mew-use-highlight-x-face-function 'x-face-decode-message-header)
92              (define-key mew-summary-mode-map "\C-x4s" 'x-face-save)
93              (define-key mew-draft-mode-map "\C-x4i" 'x-face-insert)
94              (define-key mew-draft-header-map "\C-x4i" 'x-face-insert)
95              (define-key mew-draft-mode-map "\M-t" 'x-face-show)
96              (define-key mew-draft-header-map "\M-t" 'x-face-show)
97          )
98        )
99
100¾å¼ê¤¯É½¼¨¤Ç¤­¤Ê¤¤¾ì¹ç¤Ï¡¢¥½¡¼¥¹¤ò»²¾È¤·¤Æ¤ß¤Æ¤¯¤À¤µ¤¤¡£
101(%{_sharedstatedir}/emacs/site-lisp/%{name}/x-face-e21.el)
102
103
104Version.1.3.6.14 °Ê¹ß¤Ç¤Ï¿³¬Ä´ ¤Î X-Face ¤òɽ¼¨¤¹¤ë¤³¤È¤¬²Äǽ¤Ç¤¹¡£
105
106make-gray-x-face ¤ò»ÈÍѤ¹¤ë¤³¤È¤Ë¤è¤ê¡¢Â¿³¬Ä´ X-Face ¤òºîÀ®¤¹¤ë¤³¤È
107¤¬¤Ç¤­¤Þ¤¹¡£(xemacs21.4 µÚ¤Ó emacs21 ¤Î¤ß)
108
109make-gray-x-face ¤ò»ÈÍѤ¹¤ë¤Ë¤Ï¡¢~/.emacs.el(~/.xemacs/init.el)¤Ë
110°Ê²¼¤òÄɲ䷤Ƥ¯¤À¤µ¤¤¡£
111
112(autoload 'convert-image-to-gray-x-face "make-gray-x-face" nil t)
113
114M-x convert-image-to-gray-x-face ¤Ç¤â¤Ã¤Æ gif ¤« png ¤Î³¨¤ò
115X-Face ¤Ë¤·¤¿¤â¤Î¤ò¸½ºß°ÌÃÖ¤ËÁÞÆþ¤·¤Þ¤¹¡£
116(Depth: ¤Ï 2 ¤«¤é 8 ¤Þ¤Ç¤ÎÃͤò»ØÄꤹ¤ë¤Î¤Ç¤¹¤¬¡¢¤Þ¤¡ 3 °Ì¤ÇÎɤ¤¤Î¤Ç¤Ï¤Ê¤¤¤Ç¤·¤ç¤¦¤«)
117̾Á°(~/.xface)¤òÉÕ¤±¤ÆÊݸ¤·¤Æ¤ª¤±¤Ð¥á¡¼¥ëÁ÷¿®»þ¤Ë¼«Æ°Åª¤ËźÉÕ¤µ¤ì¤Þ¤¹¡£
118
119¤Þ¤¿¡¢Ê£¿ô¤Î X-Face ¤ò»È¤¤Ê¬¤±¤¿¤¤¾ì¹ç¤Ï¡¢select-xface ¤ò»È¤¦¤ÈÊØÍø¤Ç¤¹¡£
120(¿³¬Ä´ X-Face ¤ò wl ¤Ç»È¤¤¤¿¤¤¾ì¹ç¤Ïɬ¤º select-xface ¤ò»È¤Ã¤Æ¤¯¤À¤µ¤¤¡£
121wl ¤Ë http://lists.airs.net/wl/archive/200203/msg00064.html
122¤¬Åö¤¿¤Ã¤Æ¤Ê¤¤°Ù)
123
124
125%prep
126[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
127
128%setup -n x-face-%{version}
129cp %{SOURCE2} .
130gunzip x-face-e21.el.gz
131
132
133%install
134[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
135[ "${RPM_BUILD_ROOT}" != "/" ] && mkdir -p ${RPM_BUILD_ROOT}
136
137mkdir -p ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{origname}
138mkdir -p ${RPM_BUILD_ROOT}/%{_libdir}/emacsen-common/packages/install
139mkdir -p ${RPM_BUILD_ROOT}/%{_libdir}/emacsen-common/packages/remove
140
141cp -a Makefile *.el* *.xpm *.xbm %{SOURCE1} \
142        ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{origname}
143
144%_installemacsenscript %{origname} %{SOURCE10}
145
146%_removeemacsenscript  %{origname} %{SOURCE11}
147
148
149%post
150
151## bytecompile el and install elc
152
153if [ "$1" = 2 ] ; then
154
155%_emacsenPackageRemove %{origname}
156
157fi
158
159%_addemacsenlist %{origname}
160
161%_emacsenPackageInstall %{origname}
162
163
164%preun
165
166if [ "$1" = 0 ] ; then
167
168%_emacsenPackageRemove %{origname}
169
170%_removeemacsenlist %{origname}
171
172fi
173
174
175%clean
176[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
177
178
179%files
180%defattr(-,root,root)
181%doc ChangeLog.ja METHOD.ja README-Anim.ja README-Makefile.ja README.ja TODO.ja
182%doc x-face-beta-logo.xbm x-face-beta-logo.xpm x-face-logo.xbm x-face-logo.xpm
183%{_datadir}/emacs/site-lisp/%{origname}
184%{_libdir}/emacsen-common/packages/install/%{origname}
185%{_libdir}/emacsen-common/packages/remove/%{origname}
186
187
188%changelog
189* Mon Jun 18 2007 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.3.6.24-0vl3
190- update x-face-e21(Revised:2007/03/06)
191- Modded x-face-install.sh, x-face-remove.sh(for emacs-22)
192
193* Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.6.24-0vl2
194- changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
195
196* Fri Jul  9 2004 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.3.6.24-0vl1
197- update
198- update x-face-e21(Revised:2004/05/10)
199
200* Mon Jun 30 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.3.6.23-0vl1
201- update
202
203* Wed May 21 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.3.6.20-0vl5
204- update x-face-e21(Revised:2003/03/24)
205- Copyright -> License
206
207* Sat May 11 2002 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.3.6.20-0vl4
208- add Requires: netpbm-progs(for make-gray-x-face.elc)
209
210* Sat May  4 2002 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.3.6.20-0vl3
211- mv x-face-xemacs x-face
212- Modified %description
213
214* Thu Mar 28 2002 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.3.6.20-0vl2
215- Add x-face-e21.el.gz for Emacs-21.1
216- Byte Compiled make-gray-x-face.el for Emacs-21.1
217
218* Mon Mar 18 2002 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.3.6.20-0vl1
219- update to 1.3.6.20
220- included make-gray-x-face.el
221
222* Mon Feb 25 2002 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.3.6.19-0vl1
223- update to 1.3.6.19
224- Delete %Patch0(from Elips X-Mail-Count: 0004572)
225
226* Thu Feb 21 2002 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.3.6.16-0vl2
227- Add %Patch0(from Elips X-Mail-Count: 0004572)
228
229* Wed Feb 20 2002 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.3.6.16-0vl1
230- update to 1.3.6.16
231- Delete Requires: netpbm
232
233* Thu Feb 15 2002 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.3.6.15-0vl1
234- update to 1.3.6.15
235- add Requires: netpbm
236
237* Sat Jan 26 2002 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.3.6.13-0vl3
238- Commentout(Requires: xemacs) because name changed xemacs21.1,xemacs21.4
239
240* Sat Jan 12 2002 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.3.6.13-0vl2
241- x-face-xemacs-install.sh fix(VERSION=)
242
243* Sun Dec 23 2001 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.3.6.13-0vl1
244- updated to 1.3.6.13
245
246* Sat Dec 15 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.6.12-0vl1
247- updated to 1.3.6.12 release
248- now emacsen-common aware
249
250* Sat Jan 08 2000 MATSUBAYASHI 'Shaolin' Kohji
251- 1.3.6.9-1
252- updated in sync with 1.3.6.9 release
253
254* Tue Dec 21 1999 MATSUBAYASHI 'Shaolin' Kohji
255- 1.3.6.8-1
256- updated in sync with 1.3.6.8 release
257
258* Sat Dec 18 1999 MATSUBAYASHI 'Shaolin' Kohji
259- 1.3.6.7-1
260- updated in sync with 1.3.6.7 release
261
262* Thu Nov 18 1999 MATSUBAYASHI 'Shaolin' Kohji
263- 1.3.6.6-1
264- updated in sync with 1.3.6.6 release
265- change Group to Applications/Editors/EmacsLisp
266
267* Thu Nov 18 1999 MATSUBAYASHI 'Shaolin' Kohji
268- 1.3.6.4-1
269- updated in sync with 1.3.6.4 release
270
271* Thu Sep 30 1999 MATSUBAYASHI 'Shaolin' Kohji
272- 1.3.6-1
273- updated to 1.3.6 release
274- fixed Copyright: tag
275
276* Wed Sep 29 1999 MATSUBAYASHI 'Shaolin' Kohji
277- 1.3.5.5-3
278- in sync with downgraded xemacs release (21.1.4-1)
279
280* Thu Sep 23 1999 MATSUBAYASHI 'Shaolin' Kohji
281- 1.3.5.5-2
282- Requires: faces, faces-xface added
283  (compface is replaced with faces rpms from Red Hat Rawhide)
284
285* Fri Sep 10 1999 MATSUBAYASHI 'Shaolin' Kohji
286- 1.3.5.5-1
287- updated to 1.3.5.5 release
288
289* Thu Sep  2 1999 MATSUBAYASHI 'Shaolin' Kohji
290- 1.3.5.3-5
291- spec has been splitted into mule / xemacs packages
292
293* Sun Aug 29 1999 MATSUBAYASHI 'Shaolin' Kohji
294- 1.3.5.3-3
295- slight modifications for the %prep & %clean section
296
297* Thu Aug 26 1999 MATSUBAYASHI 'Shaolin' Kohji
298- 1.3.5.3-2
299- updated for XEmacs 21.1.6
300
301* Mon Jul 12 1999 MATSUBAYASHI 'Shaolin' Kohji
302- 1.3.5.3-1
303- first RPM release
Note: See TracBrowser for help on using the repository browser.