source: projects/specs/trunk/w/wxPython/wxPython-vl.spec @ 10575

Revision 10575, 10.6 KB checked in by tomop, 8 years ago (diff)

wxPython-3.0.2.0-1

Line 
1%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
3
4#%define buildflags WXPORT=gtk2 UNICODE=1
5%global py_setup_args WX_CONFIG=/usr/bin/wx-config-3.0 WXPORT=gtk3
6
7Name:           wxPython
8Version:        3.0.2.0
9Release:        1%{?dist}
10
11Summary:        GUI toolkit for the Python programming language
12
13Group:          Development/Languages
14License:        LGPLv2+ and wxWidgets
15URL:            http://www.wxpython.org/
16Source0:        http://downloads.sourceforge.net/wxpython/%{name}-src-%{version}.tar.bz2
17# Remove Editra - it doesn't work and is technically a bundle.  Thanks to
18# Debian for the patch.
19Patch0:         fix-editra-removal.patch
20Patch1:         wxPython-3.0.0.0-format.patch
21# http://trac.wxwidgets.org/ticket/16765
22Patch2:         wxPython-3.0.2.0-getxwindowcrash.patch
23# http://trac.wxwidgets.org/ticket/16767
24Patch3:         wxPython-3.0.2.0-plot.patch
25# http://trac.wxwidgets.org/ticket/17160
26Patch4:         wxPython-3.0.2.0-listctrl-mixin-edit.patch
27BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
28# make sure to keep this updated as appropriate
29BuildRequires:  wxGTK3-devel
30BuildRequires:  python-devel
31BuildRequires:  gtk3-devel
32#BuildRequires:  mesa-libGL-devel mesa-libGLU-devel
33
34Vendor: Project Vine
35Distribution: Vine Linux
36
37%description
38wxPython is a GUI toolkit for the Python programming language. It allows
39Python programmers to create programs with a robust, highly functional
40graphical user interface, simply and easily. It is implemented as a Python
41extension module (native code) that wraps the popular wxWindows cross
42platform GUI library, which is written in C++.
43
44%package        devel
45Group:          Development/Libraries
46Summary:        Development files for wxPython add-on modules
47Requires:       %{name} = %{version}-%{release}
48Requires:       wxGTK3-devel
49
50%description devel
51This package includes C++ header files and SWIG files needed for developing
52add-on modules for wxPython. It is NOT needed for development of most
53programs which use the wxPython toolkit.
54
55%package        docs
56Group:          Documentation
57Summary:        Documentation and samples for wxPython
58Requires:       %{name} = %{version}-%{release}
59BuildArch:      noarch
60
61%description docs
62Documentation, samples and demo application for wxPython.
63
64
65%prep
66%autosetup -p1 -n wxPython-src-%{version}
67
68# fix libdir otherwise additional wx libs cannot be found, fix default optimization flags
69sed -i -e 's|/usr/lib|%{_libdir}|' -e 's|-O3|-O2|' wxPython/config.py
70
71
72%build
73# Just build the wxPython part, not all of wxWindows which we already have
74# in Fedora
75cd wxPython
76# included distutils is not multilib aware; use normal
77%__rm -rf distutils
78python setup.py %{py_setup_args} build
79
80
81%install
82%__rm -rf $RPM_BUILD_ROOT
83cd wxPython
84python setup.py %{py_setup_args} install --root=$RPM_BUILD_ROOT
85
86# this is a kludge....
87%if "%{python_sitelib}" != "%{python_sitearch}"
88%__mv $RPM_BUILD_ROOT%{python_sitelib}/wx.pth  $RPM_BUILD_ROOT%{python_sitearch}
89%__mv $RPM_BUILD_ROOT%{python_sitelib}/wxversion.py* $RPM_BUILD_ROOT%{python_sitearch}
90%endif
91
92%clean
93%__rm -rf $RPM_BUILD_ROOT
94
95
96%files
97%defattr(-,root,root,-)
98%license wxPython/licence/*
99%{_bindir}/*
100%{python_sitearch}/*
101%{python_sitelib}/*
102
103%files devel
104%defattr(-,root,root,-)
105%dir %{_includedir}/wx-3.0/wx/wxPython
106%{_includedir}/wx-3.0/wx/wxPython/*.h
107%dir %{_includedir}/wx-3.0/wx/wxPython/i_files
108%{_includedir}/wx-3.0/wx/wxPython/i_files/*.i
109%{_includedir}/wx-3.0/wx/wxPython/i_files/*.py*
110%{_includedir}/wx-3.0/wx/wxPython/i_files/*.swg
111
112%files docs
113%defattr(-,root,root,-)
114%doc wxPython/docs wxPython/demo wxPython/samples
115
116
117%changelog
118* Sat Jul  9 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.2.0-1
119- new upstream release.
120
121* Fri Aug 10 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.8.12.1-3
122- s/wx-gtk2/wxGTK/g
123
124* Sun Jul 29 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.8.12.1-2
125- rebuilt with wx-gtk2-devel-2.8.12-2
126
127* Fri Apr  6 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.8.12.1-1
128- updated to 2.8.12.1
129
130* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.12.0-2
131- rebuild with python-2.7.2
132
133* Sun May 15 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.8.12.0-1
134- initial build based on Fedora rawhide
135
136* Tue Apr 26 2011 Dan Horák <dan[at]danny.cz> - 2.8.12.0-1
137- update to 2.8.12.0 (#699207)
138
139* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.8.11.0-5
140- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
141
142* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 2.8.11.0-4
143- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
144
145* Mon Jul 12 2010 Dan Horák <dan@danny.cz> - 2.8.11.0-3
146- rebuilt against wxGTK-2.8.11-2
147
148* Sun Jul 11 2010 Lubomir Rintel <lkundrak@v3.sk> - 2.8.11.0-2
149- Include egg-info when build on recent RHEL
150
151* Mon May 31 2010 Dan Horák <dan[at]danny.cz> - 2.8.11.0-1
152- update to 2.8.11.0 (#593837, #595936, #597639)
153
154* Sun May  2 2010 Dan Horák <dan[at]danny.cz> - 2.8.10.1-3
155- rebuilt with wxGTK 2.8.11
156
157* Wed Mar 17 2010 Dan Horák <dan[at]danny.cz> - 2.8.10.1-2
158- add missing module (#573961)
159
160* Sat Jan 16 2010 Dan Horák <dan[at]danny.cz> - 2.8.10.1-1
161- update to 2.8.10.1
162- backport to wxGTK 2.8.10 API
163- cleaned up BRs
164
165* Thu Jan  7 2010 Hans de Goede <hdegoede@redhat.com> - 2.8.9.2-4
166- Change python_foo macros to use %%global as the new rpm will break
167  using %%define here, see:
168  https://www.redhat.com/archives/fedora-devel-list/2010-January/msg00093.html
169
170* Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.8.9.2-3
171- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
172
173* Fri Apr 10 2009 Dan Horák <dan[at]danny.cz> - 2.8.9.2-2
174- add patch to fix compile failure for contrib/gizmos/_treelist.i
175
176* Fri Apr 10 2009 Dan Horák <dan[at]danny.cz> - 2.8.9.2-1
177- update to 2.8.9.2
178- create noarch docs subpackage
179
180* Thu Mar  5 2009 Lubomir Rintel <lkundrak@v3.sk> - 2.8.9.1-4
181- Rebuilt for newer wxgtk package
182
183* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.8.9.1-3
184- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
185
186* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.8.9.1-2
187- Rebuild for Python 2.6
188
189* Tue Sep 30 2008 Dan Horak <dan[at]danny.cz> - 2.8.9.1-1
190- update to 2.8.9.1
191- fix libdir for additional wx libraries (#306761)
192
193* Mon Sep 29 2008 Dan Horak <dan[at]danny.cz> - 2.8.9.0-1
194- update to 2.8.9.0
195
196* Sat Sep  6 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.8.8.0-2
197- fix license tag
198
199* Thu Jul 31 2008 Matthew Miller <mattdm@mattdm.org> - 2.8.8.0-1
200- update to 2.8.8.0 (bug #457408)
201- a fix for bug #450073 is included in the upstream release, so
202  dropping that patch.
203
204* Thu Jun 12 2008 Hans de Goede <j.w.r.degoede@hhs.nl> - 2.8.7.1-5
205- Fix an attribute error when importing wxPython (compat) module
206  (redhat bugzilla 450073, 450074)
207
208* Fri Jun  6 2008 Matthew Miller <mattdm@mattdm.org> - 2.8.7.1-4
209- gratuitously bump package release number to work around build system
210  glitch. again, but it will work this time.
211
212* Wed Jun  4 2008 Matthew Miller <mattdm@mattdm.org> - 2.8.7.1-3
213- gratuitously bump package release number to work around build system
214  glitch
215
216* Thu Feb 21 2008 Matthew Miller <mattdm@mattdm.org> - 2.8.7.1-2
217- include egg-info files for fedora 9 or greater
218
219* Wed Feb 20 2008 Matthew Miller <mattdm@mattdm.org> - 2.8.7.1-1
220- update to 2.8.7.1
221
222* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.8.4.0-3
223- Autorebuild for GCC 4.3
224
225* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 2.8.4.0-2
226- Rebuild for selinux ppc32 issue.
227
228* Wed Jul 11 2007 Matthew Miller <mattdm@mattdm.org> - 2.8.4.0-1
229- update to 2.8.4.0
230- obsolete compat-wxPythonGTK
231
232* Sun Apr 15 2007 Matthew Miller <mattdm@mattdm.org> - 2.8.3.0-1
233- update to 2.8.3.0
234
235* Fri Dec 15 2006 Matthew Miller <mattdm@mattdm.org> - 2.8.0.1-1
236- update to 2.8.0.1
237- make buildrequire wxGTK of version-wxpythonsubrelease
238- add wxaddons to filelist
239
240* Mon Dec 11 2006 Matthew Miller <mattdm@mattdm.org> - 2.6.3.2-3
241- bump release for rebuild against python 2.5.
242
243* Mon Aug 28 2006 Matthew Miller <mattdm@mattdm.org> - 2.6.3.2-2
244- bump release for FC6 rebuild
245
246* Thu Apr 13 2006 Matthew Miller <mattdm@mattdm.org> - 2.6.3.2-1
247- version 2.6.3.2
248- move wxversion.py _into_ lib64. Apparently that's the right thing to do. :)
249- upstream tarball no longer includes embedded.o (since I finally got around
250  to pointing that out to the developers instead of just kludging it away.)
251- buildrequires to just libGLU-devel instead of mesa-libGL-devel
252
253* Fri Mar 31 2006 Matthew Miller <mattdm@mattdm.org> - 2.6.3.0-4
254- grr. bump relnumber.
255
256* Fri Mar 31 2006 Matthew Miller <mattdm@mattdm.org> - 2.6.3.0-3
257- oh yeah -- wxversion.py not lib64.
258
259* Fri Mar 31 2006 Matthew Miller <mattdm@mattdm.org> - 2.6.3.0-2
260- buildrequires mesa-libGLU-devel
261
262* Thu Mar 30 2006 Matthew Miller <mattdm@mattdm.org> - 2.6.3.0-1
263- update to 2.6.3.0
264- wxGTK and wxPython versions are inexorably linked; make BuildRequires
265  be exact, rather than >=.
266- make devel subpackage as per comment #7 in bug #163440.
267
268* Thu Nov 24 2005 Matthew Miller <mattdm@mattdm.org> - 2.6.1.0-1
269- update to 2.6.0.0
270- merge in changes from current extras 2.4.x package
271- Happy Thanksgiving
272- build animate extention again -- works now.
273
274* Thu Apr 28 2005 Matthew Miller <mattdm@bu.edu> - 2.6.0.0-bu45.1
275- get rid of accidental binaries in source tarball -- they generates
276  spurious dependencies and serve no purpose
277- update to 2.6.0.0 and build for Velouria
278- switch to Fedora Extras base spec file
279- enable gtk2 and unicode and all the code stuff (as FE does)
280- disable BUILD_ANIMATE extension from contrib -- doesn't build
281- files are in a different location now -- adjust to that
282- zap include files (needed only for building wxPython 3rd-party modules),
283  because I don't think this is likely to be very useful. Other option
284  would be to create a -devel package, but I think that'd be confusing.
285
286* Tue Feb 08 2005 Thorsten Leemhuis <fedora at leemhuis dot info> 0:2.4.2.4-4
287- remove included disutils - it is not multilib aware; this
288  fixes build on x86_64
289
290* Tue Jan 06 2004 Panu Matilainen <pmatilai@welho.com> 0:2.4.2.4-0.fdr.3
291- rename package to wxPythonGTK2, provide wxPython (see bug 927)
292- dont ship binaries in /usr/share
293
294* Thu Nov 20 2003 Panu Matilainen <pmatilai@welho.com> 0:2.4.2.4-0.fdr.2
295- add missing buildrequires: python-devel, wxGTK2-gl
296
297* Sun Nov 02 2003 Panu Matilainen <pmatilai@welho.com> 0:2.4.2.4-0.fdr.1
298- Initial RPM release.
299~
Note: See TracBrowser for help on using the repository browser.