source: projects/specs/trunk/w/wxGlade/wxGlade-vl.spec @ 3887

Revision 3887, 5.9 KB checked in by munepi, 13 years ago (diff)

NEW: added two spec files of wxPython and wxGlade

Line 
1%define tipversion 20110516
2%define hgnode 96ff5a770485
3
4Summary:        A wxWidgets/wxPython/wxPerl GUI designer
5Name:           wxGlade
6Version:        0.6.3
7Release:        1%{?tipversion:.tip%tipversion}%{?_dist_release}
8#Source0:       http://downloads.sourceforge.net/wxglade/%{name}-%{version}.tar.gz
9## renamed https://bitbucket.org/agriggio/wxglade/get/tip.tar.bz2 to Source0:
10Source0:        wxGlade-0.6.3%{?tipversion:.tip%tipversion}.tar.bz2
11Source1:    wxglade.desktop
12Source2:    wxglade.png
13License:        MIT
14URL:        http://wxglade.sourceforge.net/
15Group:          Development/Tools
16BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
17BuildArch:      noarch
18BuildRequires: desktop-file-utils
19Requires:       python >= 2.2
20Requires:       wxPython >= 2.6
21
22Distribution:   Vine
23Vendor:         Project Vine
24
25%description
26wxGlade is a GUI designer written in Python with the popular GUI
27toolkit wxPython, that helps you create wxWidgets/wxPython user
28interfaces. At the moment it can generate Python, C++, Perl and XRC
29(wxWidgets' XML resources) code.
30
31%prep
32%setup -q -n agriggio-wxglade-%{hgnode}
33
34
35%build
36# nothing to do
37
38
39%install
40# cleanup
41%__rm -rf $RPM_BUILD_ROOT
42
43# make dirs
44%__install -m 755 -d $RPM_BUILD_ROOT%{_bindir}
45%__install -m 755 -d $RPM_BUILD_ROOT%{_datadir}/%{name}
46%__install -m 755 -d $RPM_BUILD_ROOT%{_datadir}/%{name}/codegen
47%__install -m 755 -d $RPM_BUILD_ROOT%{_datadir}/%{name}/edit_sizers
48%__install -m 755 -d $RPM_BUILD_ROOT%{_datadir}/%{name}/res
49%__install -m 755 -d $RPM_BUILD_ROOT%{_datadir}/%{name}/icons
50%__install -m 755 -d $RPM_BUILD_ROOT%{_datadir}/%{name}/icons/gtk
51
52# copy files needed at runtime
53%__install -m644 -p *.py $RPM_BUILD_ROOT%{_datadir}/%{name}
54%__install -m644 -p codegen/*  $RPM_BUILD_ROOT%{_datadir}/%{name}/codegen
55%__install -m644 -p edit_sizers/*  $RPM_BUILD_ROOT%{_datadir}/%{name}/edit_sizers
56%__install -m644 -p res/* $RPM_BUILD_ROOT%{_datadir}/%{name}/res
57%__install -m644 -p icons/*.ico icons/*.png icons/*.xpm  $RPM_BUILD_ROOT%{_datadir}/%{name}/icons
58%__install -m644 -p icons/gtk/*.xpm  $RPM_BUILD_ROOT%{_datadir}/%{name}/icons/gtk
59%__cp -Rp widgets  $RPM_BUILD_ROOT%{_datadir}/%{name}/widgets
60find docs -type f -exec chmod 644 {} \;
61
62# make a launcher script
63cat > $RPM_BUILD_ROOT%{_bindir}/wxglade <<EOF
64#!/bin/bash
65exec python %{_datadir}/%{name}/wxglade.py "\$@"
66EOF
67chmod +x $RPM_BUILD_ROOT%{_bindir}/wxglade
68
69# install desktop entry
70desktop-file-install --vendor=vine \
71  --dir=$RPM_BUILD_ROOT%{_datadir}/applications         \
72  %{SOURCE1}
73%__install -m 755 -d $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
74%__install -m 644 -p %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
75
76# docs symlink
77%__ln_s %{_docdir}/%{name}-%{version}/docs $RPM_BUILD_ROOT%{_datadir}/%{name}/docs
78
79%post
80touch --no-create %{_datadir}/icons/hicolor || :
81%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
82update-desktop-database %{_datadir}/applications &>/dev/null || :
83
84%postun
85touch --no-create %{_datadir}/icons/hicolor || :
86%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
87update-desktop-database %{_datadir}/applications &>/dev/null || :
88
89%clean
90%__rm -rf $RPM_BUILD_ROOT
91
92%files
93%defattr(-,root,root,-)
94%doc docs CHANGES.txt README.txt TODO.txt credits.txt license.txt
95%{_bindir}/wxglade
96%{_datadir}/%{name}
97%{_datadir}/icons/hicolor/32x32/apps/*
98%{_datadir}/applications/*
99
100
101%changelog
102* Mon May 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-1.tip20110516
103- initial build
104
105* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.3tip20100625-3
106- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
107
108* Wed Aug 11 2010 David Malcolm <dmalcolm@redhat.com> - 0.6.3tip20100625-2
109- recompiling .py files against Python 2.7 (rhbz#623417)
110
111* Fri Jun  25 2010 ZC Miao <hellwolf.misty@gmail.com> - 0.6.3tip20100625-1
112- update to tip20100625
113
114* Sun Jun  6 2010 ZC Miao <hellwolf.misty@gmail.com> - 0.6.3tip20091130-2
115- update source
116
117* Mon Nov 30 2009 ZC Miao <hellwolf.misty@gmail.com> - 0.6.3tip20091130-1
118- update to tip version
119
120* Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.3-4
121- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
122
123* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.3-3
124- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
125
126* Sat May 24 2008 ZC Miao <hellwolf.misty@gmail.com> - 0.6.3-2
127- update to 0.6.3
128
129* Sat Nov 24 2007 ZC Miao <hellwolf.misty@gmail.com> - 0.6.1-1
130- update to 0.6.1
131- remove docs path patch, add a docs symlink instead
132
133* Thu Jul 19 2007 ZC Miao <hellwolf.misty@gmail.com> - 0.5-6
134- 248795 , patch for launch help docs correctly
135
136* Mon Apr 16 2007 ZC Miao <hellwolf.misty@gmail.com> - 0.5-5
137- update to fix EVR problem
138
139* Sun Apr 15 2007 ZC Miao <hellwolf.misty@gmail.com> - 0.5-2
140- file permissions with install command
141
142* Sun Apr 15 2007 ZC Miao <hellwolf.misty@gmail.com> - 0.5-1
143- update to 0.5
144- launch script with quoted $@
145- name to wxGlade
146
147* Tue Feb 27 2007 ZC Miao <hellwolf.misty@gmail.com> - 0.4.1-3
148- Desktop entry do not need version number
149- remove some comments
150
151* Sun Feb 25 2007 ZC Miao <hellwolf.misty@gmail.com> - 0.4.1-2
152- install icon to hicolor directory
153- change name to wxglade
154- BuildRequires desktop-file-utils
155- remove Application category in desktop file
156- remove some macro redefination
157
158* Fri Feb 16 2007 ZC Miao <hellwolf.misty@gmail.com> - 0.4.1-2
159- Add missing icons
160
161* Fri Feb 16 2007 ZC Miao <hellwolf.misty@gmail.com> - 0.4.1-1
162- update to 0.4.1
163
164* Wed Oct 27 2004 Alberto Griggio <agriggio@users.sf.net> 0.3.5-1
165- Updated to version 0.3.5
166
167* Wed Mar 10 2004 Alberto Griggio <agriggio@users.sf.net> 0.3.4-1
168- Updated to version 0.3.4
169
170* Wed Mar 10 2004 Alberto Griggio <albgrig@tiscalinet.it> 0.3.2-1
171- Updated to version 0.3.2
172
173* Tue Sep 02 2003 Alberto Griggio <albgrig@tiscalinet.it> 0.3.1-1
174- Updated to version 0.3.1
175
176* Fri Aug 29 2003 Robin Dunn <robind@alldunn.com> 0.3-5
177- Initial version
Note: See TracBrowser for help on using the repository browser.