source: projects/specs/trunk/w/wxGTK/wxGTK-vl.spec @ 6493

Revision 6493, 6.5 KB checked in by kudoh, 12 years ago (diff)

wxGTK-vl.spec

Line 
1%define name wxGTK
2%define wxconfig gtk2-unicode-release-2.8
3%define wx_ver 2.8
4
5Summary: The GTK+ 2 port of the wxWidgets library
6Summary(ja): wxWidgets ライブラリーの GTK+ 2 ポート
7Name: %{name}
8Version: %{wx_ver}.12
9Release: 1%{?_dist_release}
10
11License: wxWindows License
12Group: System Environment/Libraries
13URL: http://www.wxwidgets.org/
14Source0: wxGTK-%{version}.tar.bz2
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16
17BuildRequires: cppunit-devel
18#BuildRequires: gstreamer-devel >= 0.10
19#BuildRequires: gstreamer-plugins-base-devel >= 0.10
20BuildRequires: gtk2-devel
21BuildRequires: expat-devel
22BuildRequires: libgnomeprintui-devel
23BuildRequires: libjpeg-turbo-devel
24BuildRequires: libpng-devel
25BuildRequires: libSM-devel
26BuildRequires: libtiff-devel
27BuildRequires: mesa-libGL-devel
28BuildRequires: mesa-libGLU-devel
29BuildRequires: pkgconfig
30BuildRequires: SDL-devel
31BuildRequires: zlib-devel
32
33Obsoletes: wx-gtk2
34
35Vendor: Project Vine
36Distribution: Vine Linux
37
38%description
39wxWidgets is a free C++ library for cross-platform GUI development.
40With wxWidgets, you can create applications for different GUIs (GTK+,
41Motif, MS Windows, MacOS X, Windows CE, GPE) from the same source code.
42
43%package devel
44Summary: The GTK+ 2 port of the wxWidgets library
45Summary(ja): wxWidgets ライブラリーの開発用ファイル
46Group: Development/Libraries
47Requires: %{name} = %{version}-%{release}
48Requires: wxBase = %{version}-%{release}
49Requires: gtk2-devel
50Requires: mesa-libGL-devel, mesa-libGLU-devel
51Obsoletes: wx-gtk2-devel
52
53%description devel
54The GTK+ 2 port of the wxWidgets library, header files.
55
56%package -n wxBase
57Summary: Non-GUI support classes from the wxWidgets library
58Group: System Environment/Libraries
59
60%description -n wxBase
61Every wxWidgets application must link against this library. It contains
62mandatory classes that any wxWidgets code depends on (like wxString) and
63portability classes that abstract differences between platforms. wxBase can
64be used to develop console mode applications -- it does not require any GUI
65libraries or the X Window System.
66
67
68%prep
69%setup -qn wxGTK-%{version}
70
71sed -i -e 's|/usr/lib\b|%{_libdir}|' wx-config.in configure
72
73# fix plugin dir for 64-bit
74sed -i -e 's|/lib|/%{_lib}|' src/unix/stdpaths.cpp
75
76# fix permissions for sources
77chmod a-x include/wx/{msgout.h,dcgraph.h,graphics.h}
78chmod a-x src/common/msgout.cpp
79
80%build
81%configure --enable-shared \
82           --enable-unicode \
83           --enable-sound \
84           --enable-intl \
85           --enable-display \
86           --enable-geometry \
87           --enable-graphics_ctx \
88           --disable-rpath \
89           --with-expat \
90           --with-gtk \
91           --with-libpng \
92           --with-libjpeg \
93           --with-libtiff \
94           --with-libxpm \
95           --with-opengl \
96           --with-regex \
97           --with-sdl \
98           --with-zlib
99
100%{__make} %{?_smp_mflags}
101
102%install
103%__rm -rf %{buildroot}
104
105%makeinstall
106ln -sf %{_libdir}/wx/config/%{wxconfig} %{buildroot}%{_bindir}/wx-config
107
108%makeinstall -C contrib
109
110%clean
111%__rm -rf %{buildroot}
112
113%post -p /sbin/ldconfig
114%postun -p /sbin/ldconfig
115
116%post -n wxBase -p /sbin/ldconfig
117%postun -n wxBase -p /sbin/ldconfig
118
119%files
120%defattr(-,root,root,-)
121%doc docs/changes.txt docs/gpl.txt docs/lgpl.txt docs/licence.txt
122%doc docs/licendoc.txt docs/preamble.txt docs/readme.txt
123%{_libdir}/libwx_gtk2u_adv-*.so.*
124%{_libdir}/libwx_gtk2u_aui-*.so.*
125%{_libdir}/libwx_gtk2u_core-*.so.*
126%{_libdir}/libwx_gtk2u_fl-*.so.*
127%{_libdir}/libwx_gtk2u_gizmos-*.so.*
128%{_libdir}/libwx_gtk2u_gizmos_xrc*.so.*
129%{_libdir}/libwx_gtk2u_gl-*.so.*
130%{_libdir}/libwx_gtk2u_html-*.so.*
131%{_libdir}/libwx_gtk2u_ogl-*.so.*
132%{_libdir}/libwx_gtk2u_plot-*.so.*
133%{_libdir}/libwx_gtk2u_qa-*.so.*
134%{_libdir}/libwx_gtk2u_richtext-*.so.*
135%{_libdir}/libwx_gtk2u_stc-*.so.*
136%{_libdir}/libwx_gtk2u_svg-*.so.*
137%{_libdir}/libwx_gtk2u_xrc-*.so.*
138
139%files devel
140%defattr(-,root,root,-)
141%{_bindir}/wx-config
142%{_bindir}/wxrc*
143%{_includedir}/wx-2.8
144%{_libdir}/libwx_*.so
145%dir %{_libdir}/wx
146%dir %{_libdir}/wx/include
147%{_libdir}/wx/include/gtk2*
148%dir %{_libdir}/wx/config
149%{_libdir}/wx/config/gtk2*
150%{_datadir}/aclocal/*
151%{_datadir}/bakefile/presets/*
152
153%files -n wxBase
154%defattr(-,root,root,-)
155%doc docs/changes.txt docs/gpl.txt docs/lgpl.txt docs/licence.txt
156%doc docs/licendoc.txt docs/preamble.txt docs/readme.txt
157%{_libdir}/libwx_baseu-*.so.*
158%{_libdir}/libwx_baseu_net-*.so.*
159%{_libdir}/libwx_baseu_xml-*.so.*
160
161%changelog
162* Sun Jul 01 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.12-1
163- redefined name, package structure and configure
164
165* Wed May 4 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.12-1
166- new upstream version
167
168* Thu Sep 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.11-2
169- built with rpm-4.8.1-1 for pkg-config file
170- changed libjpeg-devel to libjpeg-turbo-devel
171- added BuildRequires: libSM-devel, cppunit-devel, libgnomeprintui-devel
172
173* Tue Jun 8 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.11-1
174- new upstream version
175- dropt all patches
176
177* Tue Feb 23 2010 Shu KONNO <owa@bg.wakwak.com> 2.8.10-4
178- added Patch10: wxGTK-2.8.10-gsockgtk.patch
179- added conrib libraries
180- rebuilt with new toolchain
181
182* Tue Jul 28 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.8.10-3
183- add patch100 for fix CVE-2009-2369 (Interger OF) from fc10
184
185* Mon Jun 22 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.10-2vl5
186- spec in UTF-8
187
188* Thu Mar 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.10-1vl5
189- new upstream version
190- built with gtk2-2.16.0
191
192* Wed Jan 21 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.9-1vl5
193- new upstream version
194- modified BuildPreReq: mesa-libGL-devel mesa-libGLU-devel (instead of XOrg-gl-devel)
195
196* Tue Feb 26 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.8.7-0vl5
197- rebuild with expat-2.0.1
198- add BuildPreReq: expat-devel pkgconfig
199
200* Sun Jan 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.7-0vl4
201- rebuilt with gtk2-2.12.5
202
203* Sun Dec 30 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.8.7-0vl3
204- rebuilt for VineSeed
205
206* Sun Dec 30 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.8.7-0vl2
207- add --enable-unicode configure option
208
209* Sat Dec 29 2007 Shu KONNO  <owa@bg.wakwak.com> - 2.8.7-0vl1
210- new upstream version
211
212* Fri Jun  1 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.6.3-0vl2
213- rebuilt with new toolchain
214
215* Thu May 18 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.6.3-0vl1
216- new upstream version
217- fixed Obsoletes tag
218
219* Fri Oct 21 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.6.2-0vl1
220- new upstream version
221- added Obsoletes: %{name}-gl %{name}-samples
222
223* Sun Jul 10 2005 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 2.6.1-0vl1
224- new upstream version
225- remove private symbol patch
226- remove wx-gtk2-gl, wx-gtk2-samples subpackage
227
228* Tue May 25 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 2.4.2-0vl1
229- Initial build.
Note: See TracBrowser for help on using the repository browser.