source: projects/specs/trunk/w/wxGTK/wxGTK-vl.spec @ 12279

Revision 12279, 7.8 KB checked in by ara_t, 4 years ago (diff)

wxGTK: rebuild with new toolchain

Line 
1%define name wxGTK
2%define wxconfig gtk2-unicode-release-2.8
3%define wx_ver 2.8
4
5Summary: The GTK+ 2 port of the wxWidgets library
6Summary(ja): wxWidgets ライブラリーの GTK+ 2 ポート
7Name: %{name}
8Version: %{wx_ver}.12
9Release: 8%{?_dist_release}
10
11License: wxWindows License
12Group: System Environment/Libraries
13URL: http://www.wxwidgets.org/
14
15Source0: wxGTK-%{version}.tar.bz2
16
17# https://bugzilla.redhat.com/show_bug.cgi?id=1308243
18# backported from https://github.com/wxWidgets/wxWidgets/commit/1780a38b7bc9a9c04d33775a3176fe8516465f50
19Patch1: %{name}-%{version}-char.patch
20
21
22BuildRoot: %{_tmppath}/%{name}-%{version}-root
23
24BuildRequires: cppunit-devel
25#BuildRequires: gstreamer-devel >= 0.10
26#BuildRequires: gstreamer-plugins-base-devel >= 0.10
27BuildRequires: gtk2-devel
28BuildRequires: expat-devel
29BuildRequires: libgnomeprintui-devel
30BuildRequires: libjpeg-turbo-devel
31BuildRequires: libpng-devel
32BuildRequires: libSM-devel
33BuildRequires: libtiff-devel
34BuildRequires: mesa-libGL-devel
35BuildRequires: mesa-libGLU-devel
36BuildRequires: pkgconfig
37BuildRequires: SDL-devel
38BuildRequires: zlib-devel
39
40Obsoletes: wx-gtk2 < %{version}-%{release}
41
42Vendor: Project Vine
43Distribution: Vine Linux
44Packager: toshi_kd
45
46%description
47wxWidgets is a free C++ library for cross-platform GUI development.
48With wxWidgets, you can create applications for different GUIs (GTK+,
49Motif, MS Windows, MacOS X, Windows CE, GPE) from the same source code.
50
51%package devel
52Summary: The GTK+ 2 port of the wxWidgets library
53Summary(ja): wxWidgets ライブラリーの開発用ファイル
54Group: Development/Libraries
55Requires: %{name} = %{version}-%{release}
56Requires: wxBase = %{version}-%{release}
57Requires: gtk2-devel
58Requires: mesa-libGL-devel, mesa-libGLU-devel
59Obsoletes: wx-gtk2-devel < %{version}-%{release}
60
61%description devel
62The GTK+ 2 port of the wxWidgets library, header files.
63
64%package -n wxBase
65Summary: Non-GUI support classes from the wxWidgets library
66Group: System Environment/Libraries
67
68%description -n wxBase
69Every wxWidgets application must link against this library. It contains
70mandatory classes that any wxWidgets code depends on (like wxString) and
71portability classes that abstract differences between platforms. wxBase can
72be used to develop console mode applications -- it does not require any GUI
73libraries or the X Window System.
74
75
76%prep
77%setup -qn wxGTK-%{version}
78%patch1 -p1 -b .char
79
80sed -i -e 's|/usr/lib\b|%{_libdir}|' wx-config.in configure
81
82# fix plugin dir for 64-bit
83sed -i -e 's|/lib|/%{_lib}|' src/unix/stdpaths.cpp
84
85# fix permissions for sources
86chmod a-x include/wx/{msgout.h,dcgraph.h,graphics.h}
87chmod a-x src/common/msgout.cpp
88
89%build
90%configure --enable-accel \
91           --enable-controls \
92           --enable-shared \
93           --enable-unicode \
94           --enable-sound \
95           --enable-intl \
96           --enable-display \
97           --enable-geometry \
98           --enable-graphics_ctx \
99           --disable-rpath \
100           --with-expat \
101           --with-gtk \
102           --with-libpng \
103           --with-libjpeg \
104           --with-libtiff \
105           --with-libxpm \
106           --with-opengl \
107           --with-regex \
108           --with-sdl \
109           --with-zlib
110
111%{__make} %{?_smp_mflags}
112
113%install
114%__rm -rf %{buildroot}
115
116%makeinstall
117ln -sf %{_libdir}/wx/config/%{wxconfig} %{buildroot}%{_bindir}/wx-config
118
119%makeinstall -C contrib
120
121%clean
122%__rm -rf %{buildroot}
123
124%post -p /sbin/ldconfig
125%postun -p /sbin/ldconfig
126
127%post -n wxBase -p /sbin/ldconfig
128%postun -n wxBase -p /sbin/ldconfig
129
130%files
131%defattr(-,root,root,-)
132%doc docs/changes.txt docs/gpl.txt docs/lgpl.txt docs/licence.txt
133%doc docs/licendoc.txt docs/preamble.txt docs/readme.txt
134%{_libdir}/libwx_gtk2u_adv-*.so.*
135%{_libdir}/libwx_gtk2u_aui-*.so.*
136%{_libdir}/libwx_gtk2u_core-*.so.*
137%{_libdir}/libwx_gtk2u_fl-*.so.*
138%{_libdir}/libwx_gtk2u_gizmos-*.so.*
139%{_libdir}/libwx_gtk2u_gizmos_xrc*.so.*
140%{_libdir}/libwx_gtk2u_gl-*.so.*
141%{_libdir}/libwx_gtk2u_html-*.so.*
142%{_libdir}/libwx_gtk2u_ogl-*.so.*
143%{_libdir}/libwx_gtk2u_plot-*.so.*
144%{_libdir}/libwx_gtk2u_qa-*.so.*
145%{_libdir}/libwx_gtk2u_richtext-*.so.*
146%{_libdir}/libwx_gtk2u_stc-*.so.*
147%{_libdir}/libwx_gtk2u_svg-*.so.*
148%{_libdir}/libwx_gtk2u_xrc-*.so.*
149
150%files devel
151%defattr(-,root,root,-)
152%{_bindir}/wx-config
153%{_bindir}/wxrc*
154%{_includedir}/wx-2.8
155%{_libdir}/libwx_*.so
156%dir %{_libdir}/wx
157%dir %{_libdir}/wx/include
158%{_libdir}/wx/include/gtk2*
159%dir %{_libdir}/wx/config
160%{_libdir}/wx/config/gtk2*
161%{_datadir}/aclocal/*
162%{_datadir}/bakefile/presets/*
163
164%files -n wxBase
165%defattr(-,root,root,-)
166%doc docs/changes.txt docs/gpl.txt docs/lgpl.txt docs/licence.txt
167%doc docs/licendoc.txt docs/preamble.txt docs/readme.txt
168%{_libdir}/libwx_baseu-*.so.*
169%{_libdir}/libwx_baseu_net-*.so.*
170%{_libdir}/libwx_baseu_xml-*.so.*
171
172
173%changelog
174* Mon Oct 21 2019 Toshiaki Ara <ara_t@384.jp> 2.8.12-8
175- rebuilt with new toolchain.
176- add Patch1 from fedora
177
178* Fri Jul  1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.8.12-7
179- rebuilt with new toolchain.
180
181* Fri Jul 18 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.12-6
182- rebuilt with libpng-1.6.12
183
184* Mon Jan 13 2014 NAKAMURA Kenta <kenta@vinelinux.org> 2.8.12-5
185- rebuilt with the current environment
186
187* Sat Jan 26 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.12-4
188- added configure option: --enable-accel, --enable-controls
189
190* Thu Aug 09 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.12-3
191- increment release number (+2)
192- add version-release to Obsoletes tag
193  - O: wx-gtk2 < %{version}-%{release}
194  - O: wx-gtk2-devel < %{version}-%{release}
195- remove wx-gtk2* package from repository
196
197* Sun Jul 01 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.12-1
198- redefined name, package structure and configure
199
200* Wed May 4 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.12-1
201- new upstream version
202
203* Thu Sep 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.11-2
204- built with rpm-4.8.1-1 for pkg-config file
205- changed libjpeg-devel to libjpeg-turbo-devel
206- added BuildRequires: libSM-devel, cppunit-devel, libgnomeprintui-devel
207
208* Tue Jun 8 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.11-1
209- new upstream version
210- dropt all patches
211
212* Tue Feb 23 2010 Shu KONNO <owa@bg.wakwak.com> 2.8.10-4
213- added Patch10: wxGTK-2.8.10-gsockgtk.patch
214- added conrib libraries
215- rebuilt with new toolchain
216
217* Tue Jul 28 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.8.10-3
218- add patch100 for fix CVE-2009-2369 (Interger OF) from fc10
219
220* Mon Jun 22 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.10-2vl5
221- spec in UTF-8
222
223* Thu Mar 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.10-1vl5
224- new upstream version
225- built with gtk2-2.16.0
226
227* Wed Jan 21 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.9-1vl5
228- new upstream version
229- modified BuildPreReq: mesa-libGL-devel mesa-libGLU-devel (instead of XOrg-gl-devel)
230
231* Tue Feb 26 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.8.7-0vl5
232- rebuild with expat-2.0.1
233- add BuildPreReq: expat-devel pkgconfig
234
235* Sun Jan 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.7-0vl4
236- rebuilt with gtk2-2.12.5
237
238* Sun Dec 30 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.8.7-0vl3
239- rebuilt for VineSeed
240
241* Sun Dec 30 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.8.7-0vl2
242- add --enable-unicode configure option
243
244* Sat Dec 29 2007 Shu KONNO  <owa@bg.wakwak.com> - 2.8.7-0vl1
245- new upstream version
246
247* Fri Jun  1 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.6.3-0vl2
248- rebuilt with new toolchain
249
250* Thu May 18 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.6.3-0vl1
251- new upstream version
252- fixed Obsoletes tag
253
254* Fri Oct 21 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.6.2-0vl1
255- new upstream version
256- added Obsoletes: %{name}-gl %{name}-samples
257
258* Sun Jul 10 2005 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 2.6.1-0vl1
259- new upstream version
260- remove private symbol patch
261- remove wx-gtk2-gl, wx-gtk2-samples subpackage
262
263* Tue May 25 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 2.4.2-0vl1
264- Initial build.
Note: See TracBrowser for help on using the repository browser.