source: projects/specs/trunk/w/wx-gtk2/wx-gtk2-vl.spec @ 521

Revision 521, 4.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define name wx-gtk2
2%define wxconfig gtk2-unicode-release-2.8
3%define wx_ver 2.8
4
5Summary: The GTK+ 2 port of the wxWidgets library
6Summary(ja): GTK+ バージョン 2 を使用した wxWidgets ライブラリ
7Name: %{name}
8Version: %{wx_ver}.10
9Release: 4%{?_dist_release}
10License: wxWindows License
11Group: System Environment/Libraries
12URL: http://www.wxwidgets.org/
13Source0: wxGTK-%{version}.tar.gz
14Patch10: wxGTK-2.8.10-gsockgtk.patch
15Patch100: wxGTK-2.8.10-CVE-2009-2369.patch
16
17#BuildPreReq: gtk2-devel libpng-devel libjpeg-devel libtiff-devel
18#BuildPreReq: mesa-libGL-devel mesa-libGLU-devel zlib-devel expat-devel pkgconfig
19BuildRequires: gtk2-devel libpng-devel libjpeg-devel libtiff-devel
20BuildRequires: mesa-libGL-devel mesa-libGLU-devel zlib-devel expat-devel pkgconfig
21BuildRoot: %{_tmppath}/%{name}-%{version}-root
22
23Obsoletes: %{name}-gl <= 2.4.2-0vl1
24Obsoletes: %{name}-samples <= 2.4.2-0vl1
25Provides: wxwin wxBase wxGTK
26
27Vendor: Project Vine
28Distribution: Vine Linux
29
30%description
31wxWidgets is a free C++ library for cross-platform GUI development.
32With wxWidgets, you can create applications for different GUIs (GTK+,
33Motif, MS Windows, MacOS X, Windows CE, GPE) from the same source code.
34
35
36%package devel
37Summary: The GTK+ 2 port of the wxWidgets library
38Summary(ja): wxWidgets ライブラリの開発用ファイル
39Group: Development/Libraries
40Provides: wxBase-devel wxGTK-devel
41Requires: %{name} = %{version}-%{release}
42
43%description devel
44The GTK+ 2 port of the wxWidgets library, header files.
45
46
47%prep
48%setup -q -n wxGTK-%{version}
49%patch10 -p1 -b .gsockgtk
50%patch100 -p0 -b .CVE-2009-2369
51
52%build
53%configure --enable-shared --enable-unicode --with-gtk \
54        --with-libpng --with-libjpeg --with-libtiff --with-libxpm \
55        --with-opengl --with-regex --with-zlib
56
57%__make %{?_smp_mflags}
58
59%install
60%__rm -rf %{buildroot}
61%makeinstall
62ln -sf %{_libdir}/wx/config/%{wxconfig} %{buildroot}%{_bindir}/wx-config
63
64%makeinstall -C contrib
65
66%clean
67%__rm -rf %{buildroot}
68
69%post -p /sbin/ldconfig
70
71%postun -p /sbin/ldconfig
72
73%files
74%defattr(-,root,root)
75%doc *.txt demos docs
76%{_libdir}/libwx_base*.so.*
77%{_libdir}/libwx_gtk2*.so.*
78#%{_datadir}/locale/*/LC_MESSAGES/*
79
80%files devel
81%defattr(-,root,root)
82%{_includedir}/wx-%{wx_ver}/wx/*.h
83%{_includedir}/wx-%{wx_ver}/wx/*/*.h
84%{_includedir}/wx-%{wx_ver}/wx/*/*/*.h
85%{_includedir}/wx-%{wx_ver}/wx/*.cpp
86%{_includedir}/wx-%{wx_ver}/wx/plot/*.bmp
87%{_includedir}/wx-%{wx_ver}/wx/plot/*.rc
88%{_libdir}/wx
89%{_libdir}/libwx_base*.so
90%{_libdir}/libwx_gtk2*.so
91%{_bindir}/*
92%{_datadir}/aclocal/*.m4
93%{_datadir}/bakefile/*
94
95%changelog
96* Tue Feb 23 2010 Shu KONNO <owa@bg.wakwak.com> 2.8.10-4
97- added Patch10: wxGTK-2.8.10-gsockgtk.patch
98- added conrib libraries
99- rebuilt with new toolchain
100
101* Tue Jul 28 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.8.10-3
102- add patch100 for fix CVE-2009-2369 (Interger OF) from fc10
103
104* Mon Jun 22 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.10-2vl5
105- spec in UTF-8
106
107* Thu Mar 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.10-1vl5
108- new upstream version
109- built with gtk2-2.16.0
110
111* Wed Jan 21 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.9-1vl5
112- new upstream version
113- modified BuildPreReq: mesa-libGL-devel mesa-libGLU-devel (instead of XOrg-gl-devel)
114
115* Tue Feb 26 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.8.7-0vl5
116- rebuild with expat-2.0.1
117- add BuildPreReq: expat-devel pkgconfig
118
119* Sun Jan 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.7-0vl4
120- rebuilt with gtk2-2.12.5
121
122* Sun Dec 30 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.8.7-0vl3
123- rebuilt for VineSeed
124
125* Sun Dec 30 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.8.7-0vl2
126- add --enable-unicode configure option
127
128* Sat Dec 29 2007 Shu KONNO  <owa@bg.wakwak.com> - 2.8.7-0vl1
129- new upstream version
130
131* Fri Jun  1 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.6.3-0vl2
132- rebuilt with new toolchain
133
134* Thu May 18 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.6.3-0vl1
135- new upstream version
136- fixed Obsoletes tag
137
138* Fri Oct 21 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.6.2-0vl1
139- new upstream version
140- added Obsoletes: %{name}-gl %{name}-samples
141
142* Sun Jul 10 2005 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 2.6.1-0vl1
143- new upstream version
144- remove private symbol patch
145- remove wx-gtk2-gl, wx-gtk2-samples subpackage
146
147* Tue May 25 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 2.4.2-0vl1
148- Initial build.
149
Note: See TracBrowser for help on using the repository browser.